Προσθέστε μια σύνδεση δεδομένων σε υπηρεσία Web

ΣΗΜΑΝΤΙΚΟ: Αυτό το άρθρο προέρχεται από μηχανική μετάφραση, δείτε την αποποίηση ευθυνών. Θα βρείτε την αγγλική έκδοση του παρόντος άρθρου εδώ για αναφορά.

Μπορείτε να προσθέσετε μία ή περισσότερες δευτερεύουσες συνδέσεις δεδομένων στο πρότυπο φόρμας με τις οποίες να εκτελείται ερώτημα ή υποβολή δεδομένων σε μια υπηρεσία Web.

Σε αυτό το άρθρο

Επισκόπηση

Προβλέψεις συμβατότητας

Πριν ξεκινήσετε

Προσθήκη σύνδεσης δεδομένων ερωτήματος

Προσθήκη σύνδεσης δεδομένων υποβολής

Επισκόπηση

Μια δευτερεύουσα σύνδεση δεδομένων είναι οποιαδήποτε σύνδεση δεδομένων σε μια εξωτερική προέλευση δεδομένων που προσθέτετε σε ένα πρότυπο φόρμας. Αυτή η σύνδεση δεδομένων είναι διαφορετική από την κύρια σύνδεση δεδομένων που δημιουργείται όταν σχεδιάζετε ένα πρότυπο φόρμας που βασίζεται σε μια βάση δεδομένων, υπηρεσία Web ή ρυθμίσεις σε μια βιβλιοθήκη συνδέσεων. Προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων μόνο αν δεν μπορείτε να υποβάλετε ερώτημα ή αποστολή δεδομένων μέσω της κύριας σύνδεσης δεδομένων.

Κατά την προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων στο πρότυπο φόρμας που εκτελεί ερωτήματα δεδομένων, το Microsoft Office InfoPath δημιουργεί μια δευτερεύουσα προέλευση δεδομένων με πεδία δεδομένων και ομάδες που αντιστοιχεί το Σχήμα XML της υπηρεσίας Web. Επειδή η δομή δεδομένων στο δευτερεύον αρχείο προέλευσης δεδομένων πρέπει να συμφωνεί με το σχήμα XML, δεν μπορείτε να τροποποιήσετε υπάρχοντα πεδία ή ομάδες στο δευτερεύον αρχείο προέλευσης δεδομένων. Όταν προσθέτετε μια σύνδεση δεδομένων υποβολής στο πρότυπο φόρμας, ρυθμίζετε τις παραμέτρους του προτύπου φόρμας για να επιτρέψετε στους χρήστες να υποβάλουν τα δεδομένα φόρμας και ρυθμίζετε τις παραμέτρους των επιλογών υποβολής για τις φόρμες που βασίζονται στο πρότυπο φόρμας.

Αρχή της σελίδας

Προβλέψεις συμβατότητας

Δεν μπορείτε να ρυθμίσετε τις παραμέτρους της σύνδεσης δεδομένων υποβολής σε ένα πρότυπο φόρμας που είναι συμβατό με το πρόγραμμα περιήγησης για να επιτρέπεται σε χρήστες να υποβάλουν πληροφορίες αλλαγής μαζί με τα δεδομένα φόρμας σε μια υπηρεσία Web που αποδέχεται Microsoft ADO.NET DataSet. Οι πληροφορίες αλλαγής αποτελούνται από τις τροποποιήσεις που κάνει ένας χρήστης στα δεδομένα που είναι αποθηκευμένα σε μια βάση δεδομένων. Η βάση δεδομένων χρησιμοποιεί μια υπηρεσία Web για τη σύνδεση χρηστών στη βάση δεδομένων. Το ADO.NET είναι δυνατό να χρησιμοποιεί πληροφορίες αλλαγής για τον καθορισμό του τρόπου ενημέρωσης των δεδομένων στη βάση δεδομένων. Ρωτήστε τον διαχειριστή της υπηρεσίας Web αν απαιτούνται στην υπηρεσία Web πληροφορίες αλλαγής για την ενημέρωση της βάσης δεδομένων. Αν ναι, θα πρέπει να σχεδιάσετε ένα πρότυπο φόρμας του οποίου οι φόρμες να μπορούν να συμπληρωθούν μόνο με χρήση του InfoPath.

Αρχή της σελίδας

Πριν ξεκινήσετε

Πριν να προσθέσετε μια δευτερεύουσα σύνδεση δεδομένων στο πρότυπο φόρμας, χρειάζεστε τις παρακάτω πληροφορίες από τον διαχειριστή της υπηρεσίας Web:

  • Θέση της υπηρεσίας Web.

  • Επιβεβαίωση ότι στην υπηρεσία Web χρησιμοποιείται κωδικοποίηση στυλ εγγράφου/καθορισμένου στυλ. Στο InfoPath μπορούν να χρησιμοποιούνται μόνο υπηρεσίες Web με στυλ εγγράφου/καθορισμένο στυλ.

  • Όνομα της λειτουργίας της υπηρεσίας Web από την οποία θα στέλνονται ή θα λαμβάνονται δεδομένα από φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας.

Αρχή της σελίδας

Προσθήκη σύνδεσης δεδομένων ερωτήματος

Για να επιτρέπεται στους χρήστες να εκτελούν ερωτήματα δεδομένων από μια υπηρεσία Web με χρήση του προτύπου φόρμας, πρέπει να κάνετε τα εξής στο πρότυπο φόρμας:

  1. Προσθήκη δευτερεύουσας σύνδεσης δεδομένων.

  2. Ρύθμιση παραμέτρων του προτύπου φόρμας για χρήση της δευτερεύουσας σύνδεσης δεδομένων.

Βήμα 1: Προσθήκη δευτερεύουσας σύνδεσης δεδομένων

  1. Στο μενού Εργαλεία, κάντε κλικ στην εντολή Συνδέσεις δεδομένων.

  2. Στο παράθυρο διαλόγου Συνδέσεις δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  3. Στον "Οδηγό σύνδεσης δεδομένων", κάντε κλικ στην επιλογή Δημιουργία νέας σύνδεσης σε, κάντε κλικ στην επιλογή Λήψη δεδομένων και μετά κάντε κλικ στο κουμπί Επόμενο.

  4. Στην περιοχή Από πού θέλετε να λαμβάνετε τα δεδομένα, κάντε κλικ στην επιλογή Υπηρεσία Web και μετά κάντε κλικ στο κουμπί Επόμενο.

  5. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε τη θέση της υπηρεσίας Web και μετά κάντε κλικ στο κουμπί Επόμενο.

    ΣΗΜΕΙΩΣΗ : Εάν θέλετε να αναζητήσετε μια υπηρεσία Web με χρήση διακομιστή καθολικής περιγραφή εντοπισμού και Integration (UDDI), κάντε κλικ στην επιλογή Αναζήτηση UDDI, πληκτρολογήστε τη διεύθυνση URL του διακομιστή UDDI που θέλετε να πραγματοποιήσετε αναζήτηση, καθορίστε εάν θέλετε να κάνετε αναζήτηση από την υπηρεσία παροχής ή από μια υπηρεσία που παρέχεται, πληκτρολογήστε μια λέξη-κλειδί αναζήτησης και, στη συνέχεια, κάντε κλικ στο κουμπί Αναζήτηση. Υπηρεσίες Web που ταιριάζουν με τη λέξη-κλειδί αναζήτησης θα εμφανίζεται στη λίστα αποτελεσμάτων αναζήτησης. Επιλέξτε την υπηρεσία Web που θέλετε να χρησιμοποιήσετε και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

  6. Στη λίστα Επιλογή λειτουργίας στην επόμενη σελίδα του οδηγού, κάντε κλικ στη λειτουργία της υπηρεσίας Web που επιστρέφει δεδομένα στη φόρμα και μετά κάντε κλικ στο κουμπί Επόμενο.

  7. Εάν παρουσιαστεί ένα άγνωστο στοιχείο στον "Οδηγό σύνδεσης δεδομένων" στη διάταξη της υπηρεσίας Web, στην επόμενη σελίδα του οδηγού ενδέχεται να σας ζητηθεί να καθορίσετε τιμές δείγματος για κάθε παράμετρο, ώστε να καθορίσετε τα πεδία ή τις ομάδες που θα προστεθούν στο κύριο αρχείο προέλευσης δεδομένων.

    Πώς γίνεται;

    1. Επιλέξτε μια παράμετρο στον πίνακα παραμέτρους και, στη συνέχεια, κάντε κλικ στην επιλογή Ορισμός τιμής δείγματος.

    2. Στο πλαίσιο τιμή δείγματος, πληκτρολογήστε μια τιμή που μπορεί να χρησιμοποιήσετε για αυτό το πεδίο χρήστη σας και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

    3. Επαναλάβετε αυτά τα βήματα για κάθε παράμετρο στον πίνακα παραμέτρους και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

    Τεχνικές λεπτομέρειες

    Όταν ρυθμίζετε τις παραμέτρους σύνδεσης δεδομένων σε μια υπηρεσία Web στον Οδηγό σύνδεσης δεδομένων, το Microsoft Office InfoPath συνδέεται με την υπηρεσία Web και ζητά το αρχείο γλώσσας περιγραφής υπηρεσιών Web (WSDL). Το αρχείο WSDL περιέχει το σχήμα που χρησιμοποιείται από την υπηρεσία Web. Η υπηρεσία Web ανταποκρίνεται στην αίτηση με την αποστολή αυτού του αρχείου στο InfoPath. Το InfoPath χρησιμοποιεί τις πληροφορίες σε αυτό το αρχείο για να προσθέσετε τα κατάλληλα πεδία και ομάδες στο δευτερεύον αρχείο προέλευσης δεδομένων στο πρότυπο φόρμας. Αν το InfoPath βρει ένα τύπο άγνωστη στοιχείου στο αρχείο WSDL, το InfoPath χρησιμοποιεί το δείγμα δεδομένων για να καθορίσετε τον ορισμό του τύπου άγνωστο στοιχείο και, στη συνέχεια, προσθέτει τα κατάλληλα πεδία και ομάδες στο δευτερεύον αρχείο προέλευσης δεδομένων.

  8. Εάν θέλετε να είναι διαθέσιμα τα αποτελέσματα του ερωτήματος όταν η φόρμα δεν είναι συνδεδεμένη σε δίκτυο, ενεργοποιήστε το πλαίσιο ελέγχου Αποθήκευση αντιγράφου των δεδομένων στο πρότυπο φόρμας.

    Σημείωση ασφαλείας : Επιλογή του πλαισίου ελέγχου αποθηκεύει τα αποτελέσματα του ερωτήματος στο πρότυπο φόρμας. Επειδή τα δεδομένα αποθηκεύονται στο πρότυπο φόρμας, είναι διαθέσιμες σε φόρμες που συμπληρώνουν οι χρήστες, ακόμα και αν τους υπολογιστές δεν είναι συνδεδεμένοι σε δίκτυο. Εάν λαμβάνετε ευαίσθητα δεδομένα από αυτήν τη σύνδεση δεδομένων, μπορείτε να απενεργοποιήσετε αυτήν τη δυνατότητα για την προστασία των δεδομένων σε περίπτωση που ο υπολογιστής χαθεί ή κλοπής.

  9. Κάντε κλικ στο κουμπί Επόμενο.

  10. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε ένα περιγραφικό όνομα για τη σύνδεση δεδομένων ερωτήματος.

  11. Για να μπορούν οι φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας να ανακτούν δεδομένα αυτόματα αφού ανοιχτούν, ενεργοποιήστε το πλαίσιο ελέγχου Αυτόματη ανάκτηση δεδομένων, όταν ανοίγει η φόρμα.

  12. Βεβαιωθείτε ότι οι πληροφορίες στην ενότητα Σύνοψη είναι σωστά και, στη συνέχεια, κάντε κλικ στο κουμπί Τέλος.

  13. Κάντε κλικ στο κουμπί Κλείσιμο.

Βήμα 2: Ρύθμιση παραμέτρων του προτύπου φόρμας για χρήση της δευτερεύουσας σύνδεσης δεδομένων

Όταν προσθέτετε μια σύνδεση δεδομένων ερωτήματος σε ένα πρότυπο φόρμας, από προεπιλογή, οι φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας χρησιμοποιούν τη σύνδεση δεδομένων όταν ανοίγονται από ένα χρήστη. Μπορείτε, επίσης, να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας σας, ώστε να χρησιμοποιεί τη σύνδεση δεδομένων ερωτήματος με έναν από τους εξής τρόπους:

  • Προσθήκη κανόνα    Μπορείτε να ρυθμίσετε έναν κανόνα για να χρησιμοποιήσετε τη σύνδεση δεδομένων κάθε φορά που προκύπτει η συνθήκη του κανόνα.

  • Κουμπί "Προσθήκη"    Μπορείτε να προσθέσετε ένα κουμπί στο πρότυπο φόρμας που οι χρήστες μπορούν να κάνουν κλικ για τη λήψη δεδομένων με χρήση της σύνδεσης δεδομένων ερωτήματος.

  • Χρήση προσαρμοσμένου κώδικα    Εάν δεν μπορείτε να προσθέσετε έναν κανόνα ή ένα κουμπί, μπορείτε να χρησιμοποιήσετε προσαρμοσμένου κώδικα για τη λήψη δεδομένων με χρήση της σύνδεσης δεδομένων ερωτήματος. Χρήση προσαρμοσμένου κώδικα απαιτεί προγραμματιστή, για να δημιουργήσετε το προσαρμοσμένο κώδικα.

Προσθήκη ενός κανόνα

Μπορείτε να προσθέσετε έναν κανόνα στο πρότυπο φόρμας, για να λαμβάνετε δεδομένα από τη σύνδεση δεδομένων ερωτήματος, όποτε πληρείται η συνθήκη για τον κανόνα. Στην παρακάτω διαδικασία θεωρείται ότι έχετε δημιουργήσει μια σύνδεση δεδομένων ερωτήματος για το πρότυπο φόρμας και ότι έχετε ρυθμίσει τις παραμέτρους ενός στοιχείου ελέγχου στο πρότυπο φόρμας, ώστε να εμφανίζονται τα δεδομένα από αυτήν τη σύνδεση δεδομένων.

  1. Εάν το πρότυπο φόρμας έχει πολλές προβολές, κάντε κλικ στο όνομα της προβολής στο μενού " Προβολή " για να μεταβείτε στην προβολή με το στοιχείο ελέγχου όπου θέλετε να εμφανίσετε τα δεδομένα από το δευτερεύον αρχείο προέλευσης δεδομένων.

  2. Κάντε διπλό κλικ στο στοιχείο ελέγχου στο οποίο θέλετε να προσθέσετε έναν κανόνα.

  3. Κάντε κλικ στην καρτέλα Δεδομένα.

  4. Στην περιοχή Επικύρωση και Κανόνες, κάντε κλικ στο στοιχείο Κανόνες.

  5. Στο παράθυρο διαλόγου Κανόνες, κάντε κλικ στην επιλογή Προσθήκη.

  6. Στο πλαίσιο Όνομα, πληκτρολογήστε ένα όνομα για τον κανόνα.

  7. Για να καθορίσετε μια συνθήκη, όταν πρέπει να εκτελέσετε τον κανόνα, κάντε κλικ στην επιλογή Ορισμός συνθήκης και, στη συνέχεια, εισαγάγετε τη συνθήκη. Ο κανόνας θα εκτελεστεί όταν πραγματοποιείται η συνθήκη. Εάν δεν ορίσετε μια συνθήκη, ο κανόνας θα εκτελείται κάθε φορά που ο χρήστης αλλάζει την τιμή στο στοιχείο ελέγχου και, στη συνέχεια, πραγματοποιεί μετακίνηση του δρομέα μακριά από αυτό το στοιχείο ελέγχου.

  8. Κάντε κλικ στην επιλογή Προσθήκη ενέργειας.

  9. Στη λίστα Ενέργεια, κάντε κλικ στην επιλογή Ερώτημα με χρήση σύνδεσης δεδομένων.

  10. Στη λίστα Σύνδεση δεδομένων, κάντε κλικ στη σύνδεση δεδομένων ερωτήματος που θέλετε να χρησιμοποιήσετε και μετά κάντε κλικ στο κουμπί ΟΚ κάθε ανοιχτού παραθύρου διαλόγου για να κλείσει.

  11. Για να ελέγξετε τις αλλαγές σας, κάντε κλικ στην επιλογή Προεπισκόπηση στη Βασική γραμμή εργαλείων ή πατήστε το συνδυασμό πλήκτρων CTRL+SHIFT+B.

Προσθήκη κουμπιού

Μπορείτε να προσθέσετε ένα στοιχείο ελέγχου κουμπιού στο πρότυπο φόρμας, στο οποίο να μπορούν να κάνουν κλικ οι χρήστες για να λαμβάνουν δεδομένα από τη σύνδεση δεδομένων ερωτήματος. Στην παρακάτω διαδικασία θεωρείται ότι έχετε δημιουργήσει μια σύνδεση δεδομένων ερωτήματος για το πρότυπο φόρμας.

  1. Εάν το πρότυπο φόρμας έχει πολλές προβολές, κάντε κλικ στο όνομα της προβολής στο μενού " Προβολή " για να μεταβείτε στην προβολή με το στοιχείο ελέγχου όπου θέλετε να εμφανίσετε τα δεδομένα από το δευτερεύον αρχείο προέλευσης δεδομένων.

  2. Εάν το παράθυρο εργασιών Στοιχεία ελέγχου δεν είναι ορατό, κάντε κλικ στην επιλογή Περισσότερα στοιχεία ελέγχου στο μενού Εισαγωγή ή πατήστε το συνδυασμό πλήκτρων ALT+I, C.

  3. Σύρετε ένα στοιχείο ελέγχου κουμπιού στο πρότυπο φόρμας.

  4. Κάντε διπλό κλικ στο κουμπί που μόλις προσθέσατε στο πρότυπο φόρμας.

  5. Κάντε κλικ στην καρτέλα Γενικά.

  6. Στη λίστα Ενέργεια, κάντε κλικ στην επιλογή Ανανέωση.

  7. Στο πλαίσιο Ετικέτα, πληκτρολογήστε το όνομα που θέλετε να εμφανίζεται στο κουμπί του προτύπου φόρμας.

  8. Κάντε κλικ στην επιλογή Ρυθμίσεις.

  9. Στο παράθυρο διαλόγου Ανανέωση, κάντε κλικ στην επιλογή Ένα δευτερεύον αρχείο προέλευσης δεδομένων.

  10. Στη λίστα Επιλογή δευτερεύοντος αρχείου προέλευσης δεδομένων, κάντε κλικ στο δευτερεύον αρχείο προέλευσης δεδομένων που σχετίζεται με τη σύνδεση δεδομένων ερωτήματος και μετά κάντε κλικ στο κουμπί ΟΚ κάθε ανοιχτού παραθύρου διαλόγου για να κλείσει.

  11. Για να ελέγξετε τις αλλαγές σας, κάντε κλικ στην επιλογή Προεπισκόπηση στη Βασική γραμμή εργαλείων ή πατήστε το συνδυασμό πλήκτρων CTRL+SHIFT+B.

Αρχή της σελίδας

Προσθήκη σύνδεσης δεδομένων υποβολής

Για να επιτρέπεται στους χρήστες να υποβάλουν φόρμες οι οποίες βασίζονται στο πρότυπο φόρμας σε υπηρεσία Web, πρώτα πρέπει να προσθέσετε μια δευτερεύουσα σύνδεση δεδομένων στο πρότυπο φόρμας που εκτελεί την υποβολή δεδομένων και μετά να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας ώστε να επιτρέπεται στους χρήστες να υποβάλουν δεδομένα φόρμας.

Βήμα 1: Προσθήκη δευτερεύουσας σύνδεσης δεδομένων

  1. Στο μενού Εργαλεία, κάντε κλικ στην εντολή Συνδέσεις δεδομένων.

  2. Στο παράθυρο διαλόγου Συνδέσεις δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  3. Στον "Οδηγό σύνδεσης δεδομένων", κάντε κλικ στην επιλογή Δημιουργία νέας σύνδεσης σε, κάντε κλικ στην επιλογή Υποβολή δεδομένων και μετά κάντε κλικ στο κουμπί Επόμενο.

  4. Στην περιοχή Με ποιον τρόπο θέλετε να υποβάλετε τα δεδομένα, κάντε κλικ στην επιλογή Σε υπηρεσία Web και μετά κάντε κλικ στο κουμπί Επόμενο.

  5. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε τη θέση της υπηρεσίας Web στην οποία θα υποβάλουν τα δεδομένα οι χρήστες και μετά κάντε κλικ στο κουμπί Επόμενο.

    ΣΗΜΕΙΩΣΗ : Εάν θέλετε να αναζητήσετε μια υπηρεσία Web με χρήση διακομιστή καθολικής περιγραφή εντοπισμού και Integration (UDDI), κάντε κλικ στην επιλογή Αναζήτηση UDDI, πληκτρολογήστε τη διεύθυνση URL του διακομιστή UDDI που θέλετε να πραγματοποιήσετε αναζήτηση, καθορίστε εάν θέλετε να κάνετε αναζήτηση από την υπηρεσία παροχής ή από μια υπηρεσία που παρέχεται, πληκτρολογήστε μια λέξη-κλειδί αναζήτησης και, στη συνέχεια, κάντε κλικ στο κουμπί Αναζήτηση. Υπηρεσίες Web που ταιριάζουν με τη λέξη-κλειδί αναζήτησης θα εμφανίζεται στη λίστα αποτελεσμάτων αναζήτησης. Επιλέξτε την υπηρεσία Web που θέλετε να χρησιμοποιήσετε και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

  6. Στη λίστα Επιλογή λειτουργίας, κάντε κλικ στη λειτουργία της υπηρεσίας Web που θα λαμβάνει τα δεδομένα φόρμας και μετά κάντε κλικ στο κουμπί Επόμενο.

  7. Στην επόμενη σελίδα του οδηγού, για να επιλέξετε τα δεδομένα της φόρμας που θα υποβληθούν για κάθε παράμετρο στην υπηρεσία Web, κάντε ένα από τα εξής:

    Υποβολή των δεδομένων ενός πεδίου ή ομάδας.

    1. Στη λίστα Παράμετροι, κάντε κλικ στην παράμετρο της υπηρεσίας του Web που θα λάβει τα δεδομένα από τη φόρμα.

    2. Στην περιοχή Επιλογές παραμέτρων, κάντε κλικ στην επιλογή Πεδίο ή ομάδα.

    3. Κάντε κλικ στην επιλογή Τροποποίηση Εικόνα κουμπιού .

    4. Στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, κάντε κλικ στο πεδίο ή στην ομάδα της οποίας τα δεδομένα θέλετε να υποβάλετε και κατόπιν κάντε κλικ στο κουμπί OK.

    5. Στο πλαίσιο Συμπερίληψη κάντε κλικ στην εντολή Μόνο κείμενο και θυγατρικά στοιχεία για την υποβολή μόνο των δεδομένων σε αυτό το πεδίο και των θυγατρικών στοιχείων του πεδίου ή της ομάδας ή κάντε κλικ στην εντολή Δευτερεύον δέντρο XML, συμπεριλαμβανομένου του επιλεγμένου στοιχείου για την υποβολή του ονόματος του πεδίου, των δεδομένων του πεδίου και των θυγατρικών στοιχείων στην επιλεγμένη ομάδα ή πεδίο.

    Υποβολή όλων των δεδομένων της φόρμας

    1. Στη λίστα Παράμετροι, κάντε κλικ στην παράμετρο της υπηρεσίας του Web που θα λάβει τα δεδομένα από τη φόρμα.

    2. Στην περιοχή Επιλογές παραμέτρου, κάντε κλικ στην επιλογή όλη η φόρμα (έγγραφο XML, συμπεριλαμβανομένων των οδηγιών επεξεργασίας).

    Υποβολή των δεδομένων ως συμβολοσειράς

    1. Στη λίστα Παράμετροι, κάντε κλικ στην παράμετρο της υπηρεσίας του Web που θα λάβει τα δεδομένα από τη φόρμα.

    2. Στην περιοχή Επιλογές παραμέτρου, κάντε κλικ στην επιλογή όλη η φόρμα (έγγραφο XML, συμπεριλαμβανομένων των οδηγιών επεξεργασίας).

    3. Επιλέξτε το πλαίσιο ελέγχου Υποβολή δεδομένων ως συμβολοσειράς.

      ΣΗΜΕΙΩΣΗ : Συνήθως, επιλέγετε αυτό το πλαίσιο ελέγχου για την υποβολή δεδομένων με ψηφιακή υπογραφή. Στις περισσότερες περιπτώσεις, καταργήστε την επιλογή αυτού του πλαισίου ελέγχου.

    Τεχνική σημείωση σχετικά με αντικείμενα ADO.NET DataSet

    Εάν στην υπηρεσία Web απαιτείται ένα αντικείμενο ADO.NET DataSet, επιλέξτε έναν κόμβο συνόλου δεδομένων κατά τη ρύθμιση παραμέτρων αυτής της σύνδεσης δεδομένων. Εάν χρησιμοποιήσετε κάποιον άλλον τύπο κόμβου για μια σύνδεση δεδομένων σε υπηρεσία Web στην οποία απαιτείται ένα αντικείμενο ADO.NET DataSet, η ενέργεια υποβολής θα αποτύχει.

  8. Κάντε κλικ στο κουμπί Επόμενο.

  9. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε ένα όνομα για τη σύνδεση δεδομένων υποβολής.

  10. Βεβαιωθείτε ότι οι πληροφορίες στην ενότητα Σύνοψη είναι σωστά και, στη συνέχεια, κάντε κλικ στο κουμπί Τέλος.

  11. Κάντε κλικ στο κουμπί Κλείσιμο.

Αφού προσθέσετε τη δευτερεύουσα σύνδεση δεδομένων υποβολής, πρέπει να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας για να επιτρέπεται στους χρήστες να υποβάλουν τα δεδομένα φόρμας με χρήση αυτής της σύνδεσης δεδομένων υποβολής.

Βήμα 2: Ενεργοποίηση υποβολής στο πρότυπο φόρμας

Όταν ρυθμίζετε τις παραμέτρους του προτύπου φόρμας για να επιτρέπεται στους χρήστες να υποβάλουν τα δεδομένα φόρμας, το InfoPath προσθέτει ένα κουμπί Υποβολή στη γραμμή εργαλείων Βασική και μια εντολή Υποβολή στο μενού Αρχείο της φόρμας. Μπορείτε επίσης να προσαρμόσετε τις επιλογές υποβολής για το πρότυπο φόρμας με τους παρακάτω τρόπους:

  • Αλλαγή του κειμένου που εμφανίζεται στο κουμπί Υποβολή και στην εντολή Υποβολή.

  • Αλλαγή της συντόμευσης πληκτρολογίου για το κουμπί Υποβολή και την εντολή Υποβολή.

  • Δημιουργία προσαρμοσμένων μηνυμάτων εμφάνισης στους χρήστες κατά την υποβολή των φορμών τους.

  • Καθορίστε εάν θα αφήσετε τη φόρμα ανοιχτή, εάν θα την κλείσετε ή εάν θα ανοίξετε μια άλλη, κενή φόρμα μετά την υποβολή της φόρμας.

  • Στο μενού Εργαλεία, κάντε κλικ στο κουμπί Επιλογές για την υποβολή.

  • Στο παράθυρο διαλόγου Επιλογές υποβολής, ενεργοποιήστε το πλαίσιο ελέγχου Να επιτρέπεται στους χρήστες η υποβολή αυτής της φόρμας, κάντε κλικ στην επιλογή Αποστολή δεδομένων φόρμας σε μεμονωμένο προορισμό και, κατόπιν, στη λίστα, κάντε κλικ στην επιλογή Υπηρεσία Web.

  • Στη λίστα Επιλέξτε μια σύνδεση δεδομένων για υποβολή, κάντε κλικ στο όνομα της σύνδεσης δεδομένων υποβολής προς την υπηρεσία Web που δημιουργήσατε στα προηγούμενα βήματα.

    1. Για να αλλάξετε το όνομα του κουμπιού " Υποβολή " που εμφανίζεται στη Βασική γραμμή εργαλείων και την εντολή Υποβολή που εμφανίζεται στο μενού αρχείο, όταν οι χρήστες να συμπληρώνουν τη φόρμα, πληκτρολογήστε το νέο όνομα στο πλαίσιο Λεζάντα στο πλαίσιο διαλόγου " Επιλογές υποβολής ".

      Συμβουλή: Εάν θέλετε να αντιστοιχίσετε μια συντόμευση πληκτρολογίου σε αυτό το κουμπί και εντολών, πληκτρολογήστε ένα εμπορικό και (&) πριν από το χαρακτήρα που θέλετε να χρησιμοποιήσετε ως μια συντόμευση πληκτρολογίου. Για παράδειγμα, για να αντιστοιχίσετε συνδυασμό πλήκτρων ALT + B ως τη συντόμευση πληκτρολογίου για το κουμπί " Υποβολή " και την εντολή, πληκτρολογήστε Su & πί.

  • Εάν δεν θέλετε άτομα για να χρησιμοποιήσετε μια εντολή Υποβολή ή το κουμπί Υποβολή στη Βασική γραμμή εργαλείων κατά τη συμπλήρωση της φόρμας, καταργήστε το πλαίσιο ελέγχου Εμφάνιση στοιχείου μενού "Υποβολή" και το κουμπί γραμμής εργαλείων "Υποβολή".

    1. Από προεπιλογή, μετά την υποβολή μιας φόρμας, το InfoPath διατηρεί ανοιχτή τη φόρμα και εμφανίζει ένα μήνυμα για να υποδείξετε εάν η φόρμα υποβλήθηκε με επιτυχία. Για να αλλάξετε την προεπιλεγμένη συμπεριφορά, κάντε κλικ στην επιλογή για προχωρημένους και, στη συνέχεια, κάντε ένα από τα εξής:

      • Για να κλείσετε τη φόρμα ή να δημιουργήσετε μια νέα κενή φόρμα αφού ο χρήστης υποβάλλει μια συμπληρωμένη φόρμα, κάντε κλικ στην επιλογή που θέλετε στη λίστα μετά την υποβολή.

      • Για να δημιουργήσετε ένα προσαρμοσμένο μήνυμα για να υποδείξετε εάν η φόρμα υποβλήθηκε με επιτυχία, επιλέξτε το πλαίσιο ελέγχου Χρήση προσαρμοσμένων μηνυμάτων και, στη συνέχεια, πληκτρολογήστε τα μηνύματά σας στα πλαίσια στην επιτυχίας και σε περίπτωση αποτυχίας.

        Συμβουλή: Χρησιμοποιήστε ένα μήνυμα στο πλαίσιο σε περίπτωση αποτυχίας για να πείτε στους χρήστες τι να κάνετε εάν δεν είναι δυνατό να υποβάλουν τους φόρμα. Για παράδειγμα, που μπορεί να προτείνει ότι οι χρήστες αποθηκεύουν τη φόρμα τους και επικοινωνήστε με κάποιον για περαιτέρω οδηγίες.

      • Εάν δεν θέλετε να εμφανίζεται ένα μήνυμα αφού ο χρήστης υποβάλλει μια φόρμα, καταργήστε την επιλογή από το πλαίσιο ελέγχου Εμφάνιση επιτυχίας και αποτυχίας μηνύματα.

Αρχή της σελίδας

ΣΗΜΕΙΩΣΗ : Αποποίηση ευθυνών αυτόματης μετάφρασης: Αυτό το άρθρο έχει μεταφραστεί από ένα σύστημα υπολογιστή χωρίς ανθρώπινη παρέμβαση. Η Microsoft προσφέρει αυτές τις αυτόματες μεταφράσεις για να βοηθά τους μη αγγλόφωνους χρήστες να απολαμβάνουν περιεχόμενο σχετικά με προϊόντα, υπηρεσίες και τεχνολογίες της Microsoft. Το άρθρο προέρχεται από μηχανική μετάφραση, συνεπώς ενδέχεται να περιέχει λάθη λεξιλογίου, σύνταξης ή γραμματικής.

Αναπτύξτε τις δεξιότητές σας
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×