Μετακίνηση ενός δημοσιευμένου προτύπου φόρμας σε μια νέα βιβλιοθήκη του SharePoint

ΣΗΜΑΝΤΙΚΟ: Αυτό το άρθρο προέρχεται από μηχανική μετάφραση, δείτε την αποποίηση ευθυνών. Θα βρείτε την αγγλική έκδοση του παρόντος άρθρου εδώ για αναφορά.

Σε αυτό το άρθρο

Επισκόπηση

Πριν ξεκινήσετε

Λήψη αντιγράφου εργασίας του προτύπου φόρμας

Βήμα 1: Δημοσίευση του προτύπου φόρμας στη νέα βιβλιοθήκη εγγράφων

Βήμα 2: Αντιγραφή και επανασύνδεση των υπαρχουσών φορμών

Επισκόπηση

Μετά τη δημοσίευση ενός προτύπου φόρμας σε μια βιβλιοθήκη εγγράφων για συμπλήρωση από τους χρήστες, ίσως χρειάζεται να μετακινήσετε αυτό το πρότυπο φόρμας σε μια άλλη βιβλιοθήκη εγγράφων. Για παράδειγμα, ίσως πρέπει να μετακινήσετε το πρότυπο φόρμας σε ένα διακομιστή με μεγαλύτερη χωρητικότητα, ώστε να μπορούν περισσότεροι χρήστες να συμπληρώνουν φόρμες ταυτόχρονα. Ορισμένοι χρήστες ίσως έχουν ήδη συμπληρώσει φόρμες που βασίζονται στο πρότυπο φόρμας που ήταν αποθηκευμένο στην αρχική βιβλιοθήκη εγγράφων. Όταν μετακινείτε το πρότυπο φόρμας σε μια νέα βιβλιοθήκη εγγράφων, θέλετε να μετακινηθούν και αυτές οι φόρμες. Επίσης, θέλετε να εξασφαλίσετε ότι αυτές οι φόρμες θα λειτουργούν στη νέα βιβλιοθήκη εγγράφων, πριν να αρχειοθετήσετε ή να διαγράψετε την παλιά βιβλιοθήκη εγγράφων.

Συμβουλή: Πριν να μετακινήσετε δημοσιευμένα πρότυπα φόρμας σε μια νέα βιβλιοθήκη εγγράφων, δημιουργήστε ένα σχέδιο που να περιλαμβάνει την ενημέρωση των χρηστών σχετικά με τη μετακίνηση των φορμών τους σε μια νέα βιβλιοθήκη εγγράφων. Θέλετε οι χρήστες να χρησιμοποιούν τη νέα βιβλιοθήκη εγγράφων για να αποθηκεύουν νέες φόρμες ή για να τροποποιούν υπάρχουσες φόρμες. Το σχέδιο πρέπει επίσης να περιλαμβάνει μια διαδικασία αρχειοθέτησης ή διαγραφής της αρχικής βιβλιοθήκης εγγράφων.

Για να μετακινήσετε ένα πρότυπο φόρμας και τις υπάρχουσες φόρμες του σε μια νέα βιβλιοθήκη εγγράφων, χρειάζεται πρώτα να δημοσιεύσετε το αντίγραφο εργασίας του προτύπου φόρμας στη νέα βιβλιοθήκη εγγράφων. Το αντίγραφο εργασίας είναι η έκδοση που αποθηκεύεται στον υπολογιστή σας ή σε ένα πρόγραμμα ελέγχου εκδόσεων, όπως το Microsoft Visual SourceSafe.

Συμβουλή: Εάν δεν διαθέτετε αντίγραφο εργασίας του προτύπου φόρμας, μπορείτε να αποθηκεύσετε ένα αντίγραφο αυτού του προτύπου από την αρχική βιβλιοθήκη εγγράφων στον υπολογιστή σας, για να το χρησιμοποιήσετε ως αντίγραφο εργασίας.

Μετά τη δημοσίευση του αντιγράφου εργασίας σε μια νέα βιβλιοθήκη εγγράφων, χρειάζεται να αντιγράψετε τις υπάρχουσες φόρμες από την παλιά βιβλιοθήκη εγγράφων στη νέα και, κατόπιν, να επανασυνδέσετε τις φόρμες που βρίσκονται στη νέα βιβλιοθήκη εγγράφων στο πρόσφατα δημοσιευμένο πρότυπο φόρμας.

Εάν χρειάζεται να κάνετε κάποιες αλλαγές ως αποτέλεσμα της μετακίνησης του προτύπου φόρμας, πραγματοποιήστε τις πριν από τη δημοσίευση του προτύπου φόρμας. Για παράδειγμα, η θέση των εξωτερικών αρχείων προέλευσης δεδομένων που χρησιμοποιούνται από τις φόρμες οι οποίες βασίζονται σε αυτό το πρότυπο φόρμας, ενδέχεται να αλλάζει επίσης, ως αποτέλεσμα της μετακίνησης του προτύπου φόρμας. Σε αυτή την περίπτωση, χρειάζεται να αλλάξετε τη σύνδεση των δεδομένων του προτύπου φόρμας στη νέα θέση των εξωτερικών αρχείων προέλευσης δεδομένων, πριν από τη δημοσίευση του προτύπου φόρμας. Συνδέσεις για περισσότερες πληροφορίες σχετικά με την αλλαγή των συνδέσεων δεδομένων, θα βρείτε στην ενότητα Δείτε επίσης.

ΣΗΜΕΙΩΣΗ : Δημοσίευση προτύπου φόρμας δεν είναι ίδια με την αποθήκευση ενός προτύπου φόρμας. Όταν δημοσιεύετε ένα πρότυπο φόρμας, τον Οδηγό δημοσίευσης προσθέτει τη θέση δημοσίευσης και τις οδηγίες στο πρότυπο φόρμας επεξεργασίας, έτσι ώστε οι χρήστες μπορούν να ανοίξουν φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας. Όταν αποθηκεύετε ένα πρότυπο φόρμας, αποθηκεύετε ένα αντίγραφο του προτύπου φόρμας, όπως ακριβώς κάνετε όταν αποθηκεύετε ένα αρχείο στον υπολογιστή σας. Πρέπει πάντα να χρησιμοποιείτε τον Οδηγό δημοσίευσης όταν θέλετε να είναι διαθέσιμες για τους χρήστες σας να συμπληρώνουν του προτύπου φόρμας.

Αρχή της σελίδας

Πριν ξεκινήσετε

Πριν από τη μετακίνηση του προτύπου φόρμας και των υπαρχουσών φορμών που βασίζονται σε αυτό το πρότυπο φόρμας σε μια νέα βιβλιοθήκη εγγράφων, θα χρειαστείτε τα εξής:

  • Το αντίγραφο εργασίας του προτύπου φόρμας    Πρόκειται για ένα αντίγραφο του προτύπου φόρμας, το οποίο θα τροποποιήσετε και στη συνέχεια θα αναδημοσιεύσετε στη νέα βιβλιοθήκη εγγράφων. Το αντίγραφο εργασίας ενδέχεται να είναι αποθηκευμένο στον υπολογιστή σας ή σε ένα πρόγραμμα ελέγχου εκδόσεων, όπως είναι το Visual SourceSafe.

  • Τις θέσεις των νέων εξωτερικών αρχείων προέλευσης δεδομένων    Εάν οι φόρμες που βασίζονται στο πρότυπο φόρμας χρησιμοποιούν εξωτερικά αρχεία προέλευσης δεδομένων τα οποία έχουν αλλάξει, θα χρειαστείτε τις νέες θέσεις των εξωτερικών αρχείων προέλευσης δεδομένων. Επιβεβαιώστε με το διαχειριστή σας ότι εσείς και οι χρήστες σας διαθέτετε τα απαραίτητα δικαιώματα χρήσης των εξωτερικών αρχείων προέλευσης δεδομένων. Εάν στο πρότυπο φόρμας χρησιμοποιούνται ρυθμίσεις σε ένα αρχείο σύνδεσης δεδομένων για τη σύνδεση σε ένα εξωτερικό αρχείο προέλευσης δεδομένων, επιβεβαιώστε ότι το αρχείο σύνδεσης δεδομένων έχει ενημερωθεί με τη νέα θέση του εξωτερικού αρχείου προέλευσης δεδομένων.

  • Τα απαραίτητα δικαιώματα στο διακομιστή που εκτελεί το Windows SharePoint Services 3.0    Για να δημοσιεύσετε ένα πρότυπο φόρμας και για να αντιγράψετε τις υπάρχουσες φόρμες από την παλιά βιβλιοθήκη εγγράφων στη νέα, θα χρειαστείτε τα απαραίτητα δικαιώματα στο διακομιστή. Επικοινωνήστε με το διαχειριστή του διακομιστή, για να επιβεβαιώστε ότι διαθέτετε αυτά τα δικαιώματα.

Αρχή της σελίδας

Λήψη αντιγράφου εργασίας του προτύπου φόρμας

Εάν θέλετε να τροποποιήσετε ένα πρότυπο φόρμας που είναι δημοσιευμένο σε μια βιβλιοθήκη εγγράφων ή σε μια κοινόχρηστη θέση δικτύου, και δεν διαθέτετε αντίγραφο εργασίας του προτύπου φόρμας, μπορείτε να αποθηκεύσετε ένα αντίγραφο εργασίας του προτύπου φόρμας από τη θέση δημοσίευσης στον υπολογιστή σας.

Συμβουλή: Σκεφτείτε τη χρήση ενός προγράμματος ελέγχου εκδόσεων, όπως το Microsoft Visual SourceSafe, για τη διαχείριση των αντιγράφων εργασίας των προτύπων φόρμας.

Αποθήκευση αντιγράφου του προτύπου φόρμας από μια βιβλιοθήκη εγγράφων στον υπολογιστή σας

  1. Σε ένα πρόγραμμα περιήγησης Web, ανοίξτε τη βιβλιοθήκη εγγράφων όπου δημοσιεύτηκε το πρότυπο φόρμας.

  2. Στο μενού Ρυθμίσεις, κάντε κλικ στην επιλογή Ρυθμίσεις και, στη συνέχεια, κάντε κλικ στην επιλογή Ρυθμίσεις βιβλιοθήκης φορμών.

  3. Στην ενότητα Γενικές ρυθμίσεις, κάντε κλικ στην επιλογή Ρυθμίσεις για προχωρημένους.

  4. Στην ενότητα Πρότυπο εγγράφου, κάντε κλικ στην εντολή Επεξεργασία προτύπου.

    Το πρότυπο φόρμας θα ανοίξει στο Microsoft Office InfoPath.

  5. Στο παράθυρο διαλόγου Microsoft Office InfoPath, κάντε κλικ στο κουμπί Ναι.

  6. Από το μενού Αρχείο, κάντε κλικ στην επιλογή Αποθήκευση ως.

  7. Στο παράθυρο διαλόγου Microsoft Office InfoPath, κάντε κλικ στο κουμπί OK.

  8. Στο παράθυρο διαλόγου Αποθήκευση ως, μεταβείτε στη θέση στην οποία θέλετε να αποθηκεύσετε ένα αντίγραφο του προτύπου φόρμας και στη συνέχεια πατήστε το κουμπί Αποθήκευση.

Αποθήκευση αντιγράφου του προτύπου φόρμας από τον κοινόχρηστο φάκελο δικτύου στον υπολογιστή σας

  1. Στο μενού αρχείο, κάντε κλικ στην επιλογή Σχεδίαση προτύπου φόρμας.

  2. Στην περιοχή Άνοιγμα προτύπου φόρμας, κάντε κλικ στην εντολή Στον υπολογιστή μου.

  3. Μεταβείτε στον κοινόχρηστο φάκελο δικτύου του προτύπου δημοσιευμένη φόρμα, κάντε κλικ στο πρότυπο φόρμας και, στη συνέχεια, κάντε κλικ στην επιλογή Άνοιγμα.

  4. Από το μενού Αρχείο, κάντε κλικ στην επιλογή Αποθήκευση ως.

  5. Στο παράθυρο διαλόγου Microsoft Office InfoPath, κάντε κλικ στο κουμπί OK.

  6. Στο παράθυρο διαλόγου Αποθήκευση ως, επιλέξτε μια θέση, εκτός από την αρχική δημοσίευση θέση όπου θέλετε να αποθηκεύσετε ένα αντίγραφο εργασίας του προτύπου φόρμας και, στη συνέχεια, κάντε κλικ στην επιλογή Αποθήκευση.

Αρχή της σελίδας

Βήμα 1: Δημοσίευση του προτύπου φόρμας στη νέα βιβλιοθήκη εγγράφων

  1. Ανοίξτε το αντίγραφο εργασίας του προτύπου φόρμας σε κατάσταση σχεδίασης.

  2. Στο μενού Αρχείο, κάντε κλικ στην εντολή Δημοσίευση.

  3. Στον "Οδηγό δημοσίευσης", κάντε κλικ στην επιλογή Σε ένα διακομιστή του SharePoint με ή χωρίς υπηρεσίες φορμών InfoPath Forms Services και κατόπιν κάντε κλικ στο κουμπί Επόμενο.

  4. Στο πλαίσιο Πληκτρολογήστε τη θέση της τοποθεσίας του SharePoint ή των υπηρεσιών InfoPath Forms Services, πληκτρολογήστε τη θέση της τοποθεσίας του SharePoint που περιέχει τη νέα βιβλιοθήκη εγγράφων στην οποία θέλετε να μετακινήσετε το πρότυπο φόρμας και, κατόπιν, κάντε κλικ στο κουμπί Επόμενο.

  5. Στην επόμενη σελίδα του οδηγού, κάντε κλικ στην επιλογή Βιβλιοθήκη εγγράφων και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  6. Κάντε κλικ στην επιλογή Δημιουργία νέας βιβλιοθήκης εγγράφων και κατόπιν κάντε κλικ στο κουμπί Επόμενο.

  7. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε όνομα και περιγραφή για τη νέα βιβλιοθήκη εγγράφων και, κατόπιν, κάντε κλικ στο κουμπί Επόμενο.

  8. Στο πρότυπο φόρμας, επιλέξτε τα πεδία που θέλετε να εμφανίζονται ως στήλες στην προεπιλεγμένη προβολή της βιβλιοθήκης εγγράφων.

    Πώς γίνεται;

    1. Κάντε κλικ στο κουμπί Προσθήκη.

    2. Επιλέξτε το πεδίο που θέλετε να προσθέσετε ως στήλη στη βιβλιοθήκη εγγράφων και, στη συνέχεια, κάντε ένα από τα εξής:

      • Πληκτρολογήστε ένα όνομα για τη στήλη στο πλαίσιο όνομα στήλης.

      • Επιλέξτε τη στήλη στη λίστα ομάδα στηλών τοποθεσίας, επιλέξτε ένα όνομα στη λίστα όνομα στήλης και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

        ΣΗΜΕΙΩΣΗ : Εάν έχετε επιλέξει ένα επαναλαμβανόμενο πεδίο για να εμφανίσετε δεδομένα στη βιβλιοθήκη εγγράφων, μπορείτε να ορίσετε τον τρόπο που θέλετε να εμφανίζεται το πεδίο στη βιβλιοθήκη εγγράφων, κάνοντας κλικ σε μια τιμή από τη λίστα συνάρτηση. Μπορείτε να επιλέξετε εάν θέλετε να εμφανίσετε την πρώτη τιμή στο πεδίο, η τελευταία τιμή στο πεδίο ή μια καταμέτρηση του όλες τις εμφανίσεις του πεδίου ή εάν θέλετε να συγχωνεύσετε όλες τις τιμές.

    3. Κάντε κλικ στο κουμπί OK.

    Συνδέσεις για περισσότερες πληροφορίες σχετικά με την εμφάνιση δεδομένων σε στήλες σε μια βιβλιοθήκη εγγράφων θα βρείτε στην ενότητα Δείτε επίσης.

  9. Κάντε κλικ στο κουμπί Επόμενο.

  10. Στην επόμενη σελίδα του οδηγού, επιβεβαιώστε ότι οι πληροφορίες που εμφανίζονται είναι σωστές και κατόπιν κάντε κλικ στην εντολή Δημοσίευση.

  11. Για να ανοίξετε τη βιβλιοθήκη εγγράφων και να ελέγξετε τη διαδικασία συμπλήρωσης φόρμας που βασίζεται σε αυτό το πρότυπο φόρμας, επιλέξτε το πλαίσιο ελέγχου Άνοιγμα αυτής της βιβλιοθήκης εγγράφων και, κατόπιν, κάντε κλικ στο κουμπί Κλείσιμο.

    Η βιβλιοθήκη εγγράφων θα ανοίξει σε ένα πρόγραμμα περιήγησης. Όταν κάνετε κλικ στην εντολή Δημιουργία στη γραμμή εργαλείων λίστας, μια φόρμα που βασίζεται σε αυτό το πρότυπο φόρμας ανοίγει στο Microsoft Office InfoPath.

Μετά τη δημοσίευση του προτύπου φόρμας σε μια νέα βιβλιοθήκη εγγράφων, μπορείτε να αντιγράψετε τις υπάρχουσες φόρμες που βασίζονται στην παλιά έκδοση του προτύπου φορμών, από την παλιά βιβλιοθήκη εγγράφων στη νέα. Μετά την αντιγραφή των υπαρχουσών φορμών, μπορείτε να επανασυνδέσετε τις υπάρχουσες φόρμες στη νέα έκδοση του προτύπου φόρμας. Εάν δεν τις συνδέσετε, οι χρήστες ενδέχεται να μην έχουν τη δυνατότητα να ανοίξουν αυτές τις φόρμες.

Αρχή της σελίδας

Βήμα 2: Αντιγραφή και επανασύνδεση των υπαρχουσών φορμών

Αυτή η διαδικασία προϋποθέτει ότι και οι δύο βιβλιοθήκες εγγράφων βρίσκονται σε ένα διακομιστή που εκτελεί Windows SharePoint Services 3.0.

  1. Ανοίξτε την παλιά βιβλιοθήκη εγγράφων με ένα πρόγραμμα περιήγησης στο Web.

  2. Στο μενού Προβολή, κάντε κλικ στην εντολή Προβολή Εξερεύνησης.

  3. Κρατήστε πατημένο το πλήκτρο CTRL, επιλέξτε κάθε φόρμα που θέλετε να μετακινήσετε και, κατόπιν, κάντε δεξιό κλικ σε μία από τις φόρμες.

  4. Στο παράθυρο διαλόγου Internet Explorer, κάντε κλικ στο κουμπί Ναι και, κατόπιν, κάντε κλικ στην εντολή Αντιγραφή από το μενού συντόμευσης.

  5. Ανοίξτε τη νέα βιβλιοθήκη εγγράφων.

  6. Στην περιοχή Επιλογή προβολής, κάντε κλικ στην επιλογή Προβολή Εξερεύνησης.

  7. Κάντε δεξιό κλικ στον κενό χώρο στο παράθυρο φακέλου.

  8. Στο παράθυρο διαλόγου Internet Explorer, κάντε κλικ στο κουμπί Ναι και, κατόπιν, κάντε κλικ στην εντολή Επικόλληση από το μενού συντόμευσης.

  9. Στο μενού Προβολή, κάντε κλικ στην εντολή Επανάληψη σύνδεσης εγγράφων.

  10. Στη στήλη Επανάληψη σύνδεσης, επιλέξτε το πλαίσιο ελέγχου για κάθε φόρμα που θέλετε να συνδέσετε στο νέο πρότυπο φόρμας.

  11. Στη γραμμή εργαλείων λίστας, κάντε κλικ στην εντολή Επανασύνδεση επιλεγμένων εγγράφων.

Μετά την επανασύνδεση των υπαρχουσών φορμών στο νέο πρότυπο φόρμας, οι χρήστες μπορούν να αλλάξουν τις υπάρχουσες φόρμες που έχουν αντιγραφεί στη νέα βιβλιοθήκη εγγράφων ή να συμπληρώσουν νέες φόρμες που βασίζονται στο πρόσφατα δημοσιευμένο πρότυπο φόρμας.

Αρχή της σελίδας

ΣΗΜΕΙΩΣΗ : Αποποίηση ευθυνών αυτόματης μετάφρασης: Αυτό το άρθρο έχει μεταφραστεί από ένα σύστημα υπολογιστή χωρίς ανθρώπινη παρέμβαση. Η Microsoft προσφέρει αυτές τις αυτόματες μεταφράσεις για να βοηθά τους μη αγγλόφωνους χρήστες να απολαμβάνουν περιεχόμενο σχετικά με προϊόντα, υπηρεσίες και τεχνολογίες της Microsoft. Το άρθρο προέρχεται από μηχανική μετάφραση, συνεπώς ενδέχεται να περιέχει λάθη λεξιλογίου, σύνταξης ή γραμματικής.

Αναπτύξτε τις δεξιότητές σας
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×