Επιδιόρθωση ενός κατεστραμμένου βιβλίου εργασίας

ΣΗΜΑΝΤΙΚΟ: Αυτό το άρθρο προέρχεται από μηχανική μετάφραση, δείτε την αποποίηση ευθυνών. Θα βρείτε την αγγλική έκδοση του παρόντος άρθρου εδώ για αναφορά.

Όταν το Microsoft Excel εντοπίζει ένα κατεστραμμένο βιβλίο εργασίας κατά το άνοιγμα του αρχείου, ξεκινά αυτόματα τη λειτουργία ανάκτησης αρχείων και προσπαθεί να επιδιορθώσει το βιβλίο εργασίας. Αν η λειτουργία ανάκτησης αρχείων δεν ξεκινά, δοκιμάστε να χρησιμοποιήσετε αυτήν τη μη αυτόματη διαδικασία για να ανακτήσετε το βιβλίο εργασίας:

  1. Επιλέξτε Αρχείο > Άνοιγμα.

  2. Κάντε κλικ στη θέση και στο φάκελο που περιέχει το κατεστραμμένο βιβλίο εργασίας.

  3. Στο παράθυρο διαλόγου Άνοιγμα, επιλέξτε το κατεστραμμένο βιβλίο εργασίας.

  4. Κάντε κλικ στο βέλος δίπλα στο κουμπί Άνοιγμα και επιλέξτε Άνοιγμα και επιδιόρθωση.

    Εντολή "Άνοιγμα και επιδιόρθωση"

  5. Για να ανακτήσετε όσο περισσότερα δεδομένα του βιβλίου εργασίας γίνεται, επιλέξτε Επιδιόρθωση.

    Εάν δεν μπορείτε να ανακτήσετε τα δεδομένα σας με την επιλογή Επιδιόρθωση, επιλέξτε Εξαγωγή δεδομένων για να εξαγάγετε τιμές και τύπους από το βιβλίο εργασίας.

Εάν δεν λειτουργήσει ούτε η αυτόματη ούτε η μη αυτόματη επιδιόρθωση, υπάρχουν ορισμένες μέθοδοι ανάκτησης που μπορεί να σας βοηθήσουν να αποκαταστήσετε τα δεδομένα σας. Μπορείτε επίσης να πάρετε ορισμένα προληπτικά μέτρα για να αποφύγετε την απώλεια της εργασίας σας, με αυτόματη αποθήκευση ενός αντιγράφου ασφαλείας του βιβλίου εργασίας ή τη δημιουργία ενός αρχείου ανάκτησης κατά καιρούς.

Επαναφορά δεδομένων από ένα κατεστραμμένο βιβλίο εργασίας

Αυτόματη αποθήκευση αντιγράφου ασφαλείας ενός βιβλίου εργασίας

Αυτόματη δημιουργία ενός αρχείου ανάκτησης σε καθορισμένα χρονικά διαστήματα

Επαναφορά δεδομένων από ένα κατεστραμμένο βιβλίο εργασίας

Επιλέξτε μία από τις ακόλουθες μεθόδους για να ανακτήσετε τα δεδομένα σας. Εάν δεν είναι επιτυχής, δοκιμάστε μια άλλη μέθοδο. Μπορείτε επίσης να δοκιμάσετε λύσεις λογισμικού τρίτου κατασκευαστή για να ανακτήσετε ένα βιβλίο εργασίας.

ΣΗΜΑΝΤΙΚΟ: Εάν ένα σφάλμα στο δίσκο ή στο δίκτυο δεν σας επιτρέπει να ανοίξετε ένα βιβλίο εργασίας, μετακινήστε το βιβλίο εργασίας σε διαφορετική μονάδα σκληρού δίσκου ή ένα τοπικό δίσκο πριν δοκιμάσετε κάποια από τις παρακάτω επιλογές ανάκτησης.

Ανάκτηση δεδομένων, όταν το βιβλίο εργασίας είναι ανοιχτό στο Excel

  • Επαναφορά του βιβλίου εργασίας στην τελευταία αποθηκευμένη έκδοση    Εάν ένα βιβλίο εργασίας καταστραφεί ενώ εργάζεστε αλλά πριν να αποθηκεύσετε τις αλλαγές σας, μπορείτε να επαναφέρετε το βιβλίο εργασίας στην τελευταία αποθηκευμένη έκδοση:

    1. Επιλέξτε Αρχείο > Άνοιγμα.

    2. Κάντε διπλό κλικ στο όνομα του βιβλίου εργασίας που έχετε ανοιχτό στο Excel.

    3. Κάντε κλικ στο κουμπί Ναι για να ανοίξετε ξανά το βιβλίο εργασίας.

      Το βιβλίο εργασίας ανοίγει χωρίς τις αλλαγές που κάνατε και οι οποίες ενδεχομένως να προκάλεσαν την καταστροφή του.

Ανάκτηση δεδομένων, όταν δεν είναι δυνατό το άνοιγμα του βιβλίου εργασίας στο Excel

  • Ορισμός της επιλογής υπολογισμού στο Excel σε μη αυτόματος    Δοκιμάστε να αλλάξετε τη ρύθμιση υπολογισμού από αυτόματη σε μη αυτόματη. Επειδή δεν θα γίνει νέος υπολογισμός του βιβλίου εργασίας, ενδέχεται να ανοίξει.

    1. Επιλέξτε Αρχείο > Δημιουργία.

    2. Στην περιοχή Δημιουργία, επιλέξτε Κενό βιβλίο εργασίας.

    3. Κάντε κλικ στα στοιχεία Αρχείο > Επιλογές.

    4. Στην κατηγορία Τύποι, στην περιοχή Επιλογές υπολογισμού, επιλέξτε Μη αυτόματα, και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

    5. Επιλέξτε Αρχείο > Άνοιγμα.

    6. Εντοπίστε και, στη συνέχεια, κάντε διπλό κλικ στο κατεστραμμένο βιβλίο εργασίας για να το ανοίξετε.

  • Χρήση εξωτερικών αναφορών για σύνδεση στο κατεστραμμένο βιβλίο εργασίας    Για να ανακτήσετε μόνο δεδομένα και όχι τους τύπους ή τις υπολογισμένες τιμές από το βιβλίο εργασίας, δοκιμάστε να χρησιμοποιήσετε εξωτερικές αναφορές για σύνδεση στο κατεστραμμένο βιβλίο εργασίας.

    1. Επιλέξτε Αρχείο > Άνοιγμα.

    2. Μεταβείτε στο φάκελο που περιέχει το κατεστραμμένο βιβλίο εργασίας.

    3. Κάντε δεξί κλικ στο όνομα αρχείου του κατεστραμμένου βιβλίου εργασίας, επιλέξτε Αντιγραφή και, στη συνέχεια, κάντε κλικ στην επιλογή Άκυρο.

    4. Επιλέξτε Αρχείο > Δημιουργία.

    5. Στην περιοχή Δημιουργία, επιλέξτε Κενό βιβλίο εργασίας.

    6. Στο κελί A1 του νέου βιβλίου εργασίας, πληκτρολογήστε = όνομα αρχείου! A1, όπου όνομα του αρχείου είναι το όνομα του κατεστραμμένου βιβλίου εργασίας που αντιγράψατε στο βήμα 3 και, στη συνέχεια, πατήστε το πλήκτρο Enter.

      ΣΗΜΕΙΩΣΗ : Πρέπει να εισαγάγετε μόνο το όνομα του βιβλίου εργασίας — δεν χρειάζεται να πληκτρολογήσετε την επέκταση του ονόματος αρχείου.

    7. Εάν εμφανιστεί το πλαίσιο διαλόγου Ενημέρωση τιμών, επιλέξτε το κατεστραμμένο βιβλίο εργασίας και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

    8. Αν εμφανιστεί το παράθυρο διαλόγου Επιλογή φύλλου, επιλέξτε το κατάλληλο φύλλο και μετά κάντε κλικ στο κουμπί OK.

    9. Επιλέξτε το κελί A1.

    10. Επιλέξτε Κεντρική > Αντιγραφή ή πατήστε το συνδυασμό πλήκτρων Ctrl+C.

    11. Επιλέξτε μια περιοχή, ξεκινώντας από το κελί A1, που έχει σχεδόν το ίδιο μέγεθος με την περιοχή των κελιών που περιέχουν δεδομένα στο κατεστραμμένο βιβλίο εργασίας.

    12. Επιλέξτε Κεντρική > Επικόλληση ή πατήστε το συνδυασμό πλήκτρων Ctrl+V.

    13. Διατηρώντας την περιοχή των κελιών επιλεγμένη, επιλέξτε Κεντρική > Αντιγραφή ξανά ή πατήστε το συνδυασμό πλήκτρων Ctrl+C.

    14. Επιλέξτε Κεντρική > βέλος κάτω από την επιλογή Επικόλληση και, στη συνέχεια, στην περιοχή Επικόλληση τιμών, πατήστε Τιμές.

      Με την επικόλληση τιμών καταργούνται οι συνδέσεις προς το κατεστραμμένο βιβλίο εργασίας και απομένουν μόνο τα δεδομένα.

  • Χρήση μακροεντολής για εξαγωγή δεδομένων από ένα κατεστραμμένο βιβλίο εργασίας    Εάν ένα γράφημα είναι συνδεδεμένο με το κατεστραμμένο βιβλίο εργασίας, δοκιμάστε να χρησιμοποιήσετε μια μακροεντολή για να εξαγάγετε τα δεδομένα προέλευσης του γραφήματος.

    1. Αντιγράψτε τον παρακάτω κώδικα μακροεντολής και επικολλήστε τον σε ένα φύλλο λειτουργικής μονάδας:

      Sub GetChartValues()

      DIM NumberOfRows ως ακέραιος αριθμός

      DIM X ως αντικείμενο

      Μετρητής = 2

      ' Υπολογισμός του αριθμού των γραμμών δεδομένων.

      NumberOfRows = UBound(ActiveChart.SeriesCollection(1). Τιμές)

      Worksheets("ChartData"). Κελιά (1, 1) = "Τιμές X"

      ' Εγγραφή άξονα x τιμές στο φύλλο εργασίας.

      Με Worksheets("ChartData")

      . Περιοχή (. Κελιά (2, 1) _

      . Κελιά (NumberOfRows + 1; 1)) = _

      Application.Transpose(ActiveChart.SeriesCollection(1). Τιμές x)

      Τελειώνει με

      ' Επανάληψη μέσω όλες τις σειρές στο γράφημα και τις τιμές τους για να γράψετε

      ' στο φύλλο εργασίας.

      Για κάθε X στο ActiveChart.SeriesCollection

      Worksheets("ChartData"). Κελιά (1, μετρητής) = X.Name

      Με Worksheets("ChartData")

      . Περιοχή (. Κελιά (2, μετρητής) _

      . Κελιά (NumberOfRows + 1, μετρητής)) = _

      Application.Transpose(X.Values)

      Τελειώνει με

      Μετρητής = μετρητή + 1

      Επόμενο

      End Sub

    2. Εισαγάγετε ή διαγράψτε ένα φύλλο εργασίας στο βιβλίο εργασίας σας, κάντε δεξί κλικ στην καρτέλα του φύλλου και, στη συνέχεια, μετονομάστε το σε ChartData.

    3. Επιλέξτε το γράφημα από το οποίο θέλετε να εξαγάγετε τις υποκείμενες τιμές δεδομένων.

      ΣΗΜΕΙΩΣΗ : Ο πίνακας μπορεί να ενσωματωθεί σε ένα φύλλο εργασίας ή σε ένα ξεχωριστό φύλλο γραφήματος.

    4. Εκτελέστε τη μακροεντολή GetChartValues.

    5. Τα δεδομένα από το γράφημα τοποθετούνται στο φύλλο εργασίας ChartData.

Αρχή της σελίδας

Αυτόματη αποθήκευση αντιγράφου ασφαλείας ενός βιβλίου εργασίας

Δημιουργώντας ένα αντίγραφο ασφαλείας του βιβλίου εργασίας σας, θα έχετε πάντα πρόσβαση στα δεδομένα σας εάν το βιβλίο εργασίας διαγραφεί κατά λάθος ή καταστραφεί.

  1. Επιλέξτε Αρχείο > Αποθήκευση ως.

  2. Κάντε κλικ στην επιλογή Υπολογιστής και, στη συνέχεια, πατήστε το κουμπί Αναζήτηση.

    Κουμπί "Αναζήτηση"

  3. Στο παράθυρο διαλόγου Αποθήκευση ως, κάντε κλικ στο βέλος δίπλα στην επιλογή Εργαλεία και, στη συνέχεια, πατήστε Γενικές επιλογές.

    "Γενικές επιλογές" στο μενού "Εργαλεία"

  4. Στο παράθυρο διαλόγου Γενικές επιλογές, επιλέξτε το πλαίσιο Να δημιουργείται πάντα αντίγραφο ασφαλείας.

    Επιλογή "Να δημιουργείται πάντα αντίγραφο ασφαλείας" στο παράθυρο διαλόγου "Γενικές επιλογές"

Αρχή της σελίδας

Αυτόματη δημιουργία ενός αρχείου ανάκτησης σε καθορισμένα χρονικά διαστήματα

Ένα αρχείο ανάκτησης του βιβλίου εργασίας βοηθά, επίσης, να εξασφαλίσετε την πρόσβαση στα δεδομένα σας εάν το βιβλίο εργασίας διαγραφεί κατά λάθος ή καταστραφεί.

  1. Κάντε κλικ στα στοιχεία Αρχείο > Επιλογές.

  2. Στην κατηγορία Αποθήκευση, στην περιοχή Αποθήκευση βιβλίων εργασίας, επιλέξτε το πλαίσιο ελέγχου Αποθήκευση πληροφοριών Αυτόματης Ανάκτησης κάθε και, στη συνέχεια, καταχωρήστε έναν αριθμό λεπτών. (Η προεπιλεγμένη τιμή είναι 10.)

    Επιλογή "Αυτόματη Ανάκτηση" στην καρτέλα "Αποθήκευση" στο παράθυρο διαλόγου "Επιλογές του Excel"

  3. Στο πλαίσιο Θέση αρχείου αυτόματης ανάκτησης, εισαγάγετε τη θέση στην οποία θέλετε να αποθηκεύεται το αρχείο ανάκτησης.

  4. Βεβαιωθείτε ότι δεν είναι επιλεγμένο το πλαίσιο ελέγχου Απενεργοποίηση της Αυτόματης Ανάκτησης για αυτό το βιβλίο εργασίας μόνο.

Αρχή της σελίδας

ΣΗΜΕΙΩΣΗ : Αποποίηση ευθυνών αυτόματης μετάφρασης: Αυτό το άρθρο έχει μεταφραστεί από ένα σύστημα υπολογιστή χωρίς ανθρώπινη παρέμβαση. Η Microsoft προσφέρει αυτές τις αυτόματες μεταφράσεις για να βοηθά τους μη αγγλόφωνους χρήστες να απολαμβάνουν περιεχόμενο σχετικά με προϊόντα, υπηρεσίες και τεχνολογίες της Microsoft. Το άρθρο προέρχεται από μηχανική μετάφραση, συνεπώς ενδέχεται να περιέχει λάθη λεξιλογίου, σύνταξης ή γραμματικής.

Αναπτύξτε τις δεξιότητές σας
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×