Εισαγωγή μιας Προβολής δεδομένων ως φόρμας

ΣΗΜΑΝΤΙΚΟ: Αυτό το άρθρο προέρχεται από μηχανική μετάφραση, δείτε την αποποίηση ευθυνών. Θα βρείτε την αγγλική έκδοση του παρόντος άρθρου εδώ για αναφορά.

Οι φόρμες είναι απαραίτητο μέρος οποιασδήποτε εφαρμογής Web του Microsoft SharePoint, στην οποία θέλετε να συλλέξετε δεδομένα από χρήστες. Οι Προβολές δεδομένων δημιουργούνται σε τεχνολογία φόρμας ASP.NET, ώστε να μπορείτε εύκολα να τις εισάγετε είτε ως προβολές δεδομένων μόνο για ανάγνωση είτε ως φόρμες στις οποίες οι χρήστες μπορούν να συντάξουν στο αρχείο προέλευσης δεδομένων μέσω του προγράμματος περιήγησης. Με το Microsoft Office SharePoint Designer 2007, μπορείτε εύκολα να εισάγετε μια Προβολή δεδομένων ως φόρμα, ώστε οι χρήστες να μπορούν να πραγματοποιήσουν και να αποθηκεύσουν αλλαγές σε αυτούς τους τύπους προελεύσεων δεδομένων: λίστες και βιβλιοθήκες, συνδέσεις βάσης δεδομένων και τοπικά αρχεία XML. Έχετε υπόψη ότι μια προβολή δεδομένων που εισάγεται ως φόρμα μπορεί να χρησιμοποιηθεί μόνο με αυτούς τους τύπους προελεύσεων δεδομένων.

Το άρθρο αυτό παρουσιάζει τον τρόπο εισαγωγής μιας Προβολής δεδομένων ως φόρμας. Επίσης, το άρθρο αυτό σας δείχνει τον τρόπο δημιουργίας ενός υποδείγματος αρχείου XML για χρήση ως αρχείο προέλευσης δεδομένων, ώστε να μπορείτε να ακολουθήσετε το παράδειγμα.

ΣΗΜΑΝΤΙΚΟ: Σε αυτό το άρθρο περιγράφει τη δημιουργία μιας προβολής δεδομένων σε μια τοποθεσία του SharePoint που βρίσκονται σε έναν διακομιστή όπου εκτελείται Windows SharePoint Services 3.0. Αυτή η λειτουργία δεν είναι διαθέσιμη εάν η τοποθεσία σας δεν βρίσκεται σε έναν διακομιστή με Windows SharePoint Services 3.0.

Σε αυτό το άρθρο

Πριν ξεκινήσετε

Γιατί εισαγωγή μιας προβολής δεδομένων ως φόρμα;

Δημιουργήστε ένα αρχείο .xml ως προέλευση δεδομένων δείγματος

Εισαγωγή μιας προβολής δεδομένων ως φόρμα

Επεξεργαστείτε τα δεδομένα χρησιμοποιώντας το πρόγραμμα περιήγησης

Προτεινόμενα επόμενα βήματα

Προτού ξεκινήσετε

Το Office SharePoint Designer 2007 διαθέτει δύο ξεχωριστές δυνατότητες που επιτρέπουν στους χρήστες να επεξεργάζονται τα δεδομένα σε μια Προβολή δεδομένων μέσω του προγράμματος περιήγησης:

  • Εισαγωγή μιας Προβολής δεδομένων ως φόρμας     Κατά τη δημιουργία μιας Προβολής δεδομένων, μπορείτε να επιλέξετε την εισαγωγή μιας φόρμας ενός στοιχείου ή μιας φόρμας πολλών στοιχείων. Η φόρμα είναι πάντα σε κατάσταση λειτουργίας επεξεργασίας και εμφανίζει είτε μία είτε πολλές εγγραφές. Οι χρήστες μπορούν να τροποποιήσουν δεδομένα και να εισάγουν νέες εγγραφές μέσω του προγράμματος περιήγησης,αλλά δεν μπορούν να διαγράψουν εγγραφές. Μπορεί να θέλετε μια φόρμα πολλών στοιχείων όταν οι χρήστες πρέπει να επεξεργάζονται γρήγορα τα δεδομένα σε πολλές εγγραφές ταυτόχρονα.

  • Προσθήκη συνδέσεων σε μια υπάρχουσα προβολή δεδομένων     Μπορείτε να προσθέσετε συνδέσεις σε μια υπάρχουσα προβολή δεδομένων έτσι ώστε οι χρήστες μπορούν να επεξεργαστούν, διαγραφή ή εισαγωγή εγγραφών στο αρχείο προέλευσης δεδομένων. Οι χρήστες κάνουν κλικ στη σύνδεση επεξεργασία για μια εγγραφή για να τοποθετήσετε αυτό το στοιχείο σε κατάσταση λειτουργίας επεξεργασίας. Εάν προσθέσετε συνδέσεις σε μια προβολή δεδομένων που έχει εισαχθεί ως φόρμα, οι συνδέσεις αντικαθιστούν τα κουμπιά φόρμας. Επιπλέον, εάν μπορείτε να προσθέσετε συνδέσεις σε μια προβολή δεδομένων που έχει εισαχθεί ως φόρμα, η προβολή δεδομένων δεν θα εμφανίζονται πλέον πεδία φόρμας από προεπιλογή. Αυτό θα εμφανίζουν μόνο τα δεδομένα σε μια προβολή. Για περισσότερες πληροφορίες, ανατρέξτε στο άρθρο Επεξεργασία, διαγραφή, ή εισαγωγή εγγραφών σε μια προβολή δεδομένων.

Εφόσον εισάγετε μια Προβολή δεδομένων ως φόρμα, μπορείτε να φιλτράρετε, τα ταξινομήσετε και να ομαδοποιήσετε τα δεδομένα, να εφαρμόσετε μορφοποίηση υπό όρους ή να δημιουργήσετε στήλες τύπου. Όταν οι χρήστες πραγματοποιούν αλλαγές στα δεδομένα και έπειτα αποθηκεύουν τις αλλαγές αυτές, οποιοδήποτε φίλτρο, σειρά ταξινόμησης, μορφοποίηση υπό όρους ή στήλη τύπου εφαρμόζονται, εμφανίζουν τα ενημερωμένα δεδομένα. Μπορείτε επίσης να προσθέσετε ενσωματωμένες ενέργειες φόρμας στα κουμπιά Αποθήκευση ή Άκυρο που εμφανίζονται στη φόρμα από προεπιλογή. Μπορείτε να βρείτε μια σύνδεση σε περισσότερες πληροφορίες σχετικά με τις ενσωματωμένες ενέργειες φόρμας στην ενότητα Δείτε επίσης.

Αρχή της σελίδας

Γιατί πραγματοποιείται η εισαγωγή μιας Προβολής δεδομένων ως φόρμας;

Η Προβολή δεδομένων είναι μια προβολή του αρχείου προέλευσης δεδομένων με δυνατότητα επεξεργασίας. Μπορείτε να εισάγετε μια Προβολή δεδομένων σε μια σελίδα ASPX είτε ως προβολή είτε ως φόρμα. Μια Προβολή δεδομένων που εισάγεται ως προβολή σας επιτρέπει τη μορφοποίηση της παρουσίασης δεδομένων αλλά όχι την επεξεργασία των ίδιων των δεδομένων.

Ωστόσο, αν εισάγετε την ίδια Προβολή δεδομένων ως φόρμα, μπορείτε να επεξεργαστείτε τα δεδομένων μέσω του προγράμματος περιήγησης και οι αλλαγές σας συντάσσονται και αποθηκεύονται στο αρχικό αρχείο προέλευσης δεδομένων. Με το Office SharePoint Designer 2007, μπορείτε γρήγορα να δημιουργήσετε έναν από τους τρεις τύπους φορμών από ένα υπάρχον αρχείο προέλευσης δεδομένων:

  • Μια Φόρμα ενός στοιχείου εμφανίζει μία εγγραφή ως φόρμας — με κάθε πεδίο στη δική του γραμμή και με το όνομα πεδίου ως επικεφαλίδα για τη συγκεκριμένη γραμμή — ώστε να μπορείτε να επεξεργαστείτε τα δεδομένα για μια εγγραφή κάθε φορά. Η φόρμα παρέχει συνδέσεις περιήγησης όπου μπορείτε να προβάλλετε γρήγορα την επόμενη και την προηγούμενη εγγραφή.

    Προβολή δεδομένων που έχει εισαχθεί ως φόρμα μίας εγγραφής

  • Μια Φόρμα πολλών στοιχείων εμφανίζει πολλές εγγραφές ως φόρμα — με κάθε πεδίο στη δική του στήλη και με το όνομα πεδίου ως επικεφαλίδα για τη συγκεκριμένη στήλη — ώστε να μπορείτε να επεξεργαστείτε γρήγορα τα δεδομένα για πολλές εγγραφές και στη συνέχεια να αποθηκεύσετε τις αλλαγές ταυτόχρονα.

    Προβολή δεδομένων που έχει εισαχθεί ως φόρμα πολλών εγγραφών

  • Μια Φόρμα δημιουργίας στοιχείου εμφανίζει κενά πεδία για μία εγγραφή — με κάθε πεδίο στη δική του γραμμή και με το όνομα πεδίου ως την επικεφαλίδα για τη γραμμή — ώστε να μπορείτε να προσθέσετε δεδομένα σε μια προέλευση δεδομένων, μία εγγραφή κάθε φορά. Μπορείτε να συμπεριλάβετε όλα τα σχετικά πεδία για την εγγραφή, ώστε όλα τα δεδομένα να μπορούν να αποθηκευτούν ταυτόχρονα.

    Φόρμα δημιουργίας στοιχείου για Προβολή δεδομένων εισηγμένη ως φόρμα

Οι Προβολές δεδομένων που εισάγονται ως φόρμες μπορούν να δημιουργηθούν για λίστες και βιβλιοθήκες του SharePoint, συνδέσεις βάσεων δεδομένων και τοπικά έγγραφα XML. Όταν εισάγετε μια Προβολή δεδομένων, το Office SharePoint Designer 2007 κάνει ανάκτηση δεδομένων από μια προέλευση δεδομένων με τη μορφή XML (Extensible Markup Language) και εμφανίζει αυτά τα δεδομένα χρησιμοποιώντας μετασχηματισμούς XSL T (Extensible Stylesheet Language Transformations). Όπως με κάθε Προβολή δεδομένων, μπορείτε να τροποποιήσετε μια φόρμα χρησιμοποιώντας το Office SharePoint Designer 2007.

Αφού κάνετε εισαγωγή της Προβολής δεδομένων στη σελίδα σας, μπορείτε να χρησιμοποιήσετε τα εργαλεία WYSIWYG στο Office SharePoint Designer 2007 για να προσθέσετε ή να καταργήσετε στήλες, να αλλάξετε τη μορφή της γραμματοσειράς ή να εφαρμόσετε χρώματα. Όταν μορφοποιείτε μια Προβολή δεδομένων χρησιμοποιώντας τα εργαλεία WYSIWYG που είναι διαθέσιμα στο Office SharePoint Designer 2007, η XSL (Extensible Stylesheet Language) εισάγεται κατευθείαν στο HTML. Ενώ μπορείτε να επεξεργαστείτε αμέσως την XSL σε προβολή Κώδικα, μπορείτε επίσης να χρησιμοποιήσετε τα εργαλεία μορφοποίησης του Office SharePoint Designer 2007 για να εφαρμόσετε εύκολα και γρήγορα την XSL χωρίς να γνωρίζετε XSL.

Αρχή της σελίδας

Δημιουργία αρχείου .xml ως δείγμα προέλευσης δεδομένων

Η Northwind Traders, μια εταιρεία διανομής τροφών gourmet, παρακολουθεί την απογραφή της σε ένα αρχείο XML. Όταν η απογραφή είναι χαμηλή, ένα μέλος της ομάδας καλεί τον προμηθευτή του συγκεκριμένου προϊόντος και κάνει μια παραγγελία. Συνιστάται να εισάγουν μια Προβολή δεδομένων ως φόρμα, ώστε το μέλος της ομάδας που κάνει την παραγγελία να μπορεί να ενημερώσει τις μονάδες που έχουν παραγγελθεί. Με τον τρόπο αυτό, η Northwind Traders θα έχει πάντα τις πιο ενημερωμένες πληροφορίες στην τρέχουσα απογραφή της.

Οι παρακάτω διαδικασίες απαιτούν τη χρήση ενός αρχείου .xml ως προέλευση δεδομένων. Εάν δεν διαθέτετε ένα αρχείο .xml στην τοποθεσία σας του SharePoint, τότε πρέπει πρώτα να δημιουργήσετε τη λίστα προϊόντων της Northwind Traders. Αφού δημιουργήσετε τη λίστα, μπορείτε να εισάγετε μια Προβολή των δεδομένων ως φόρμα για να ενημερώσετε τα δεδομένα που περιέχονται στη λίστα.

Δημιουργία του αρχείου Προϊόντα.xml

  1. Στο μενού Αρχείο, κάντε κλικ στην εντολή Άνοιγμα τοποθεσίας.

  2. Στο παράθυρο διαλόγου Άνοιγμα τοποθεσίας, αναζητήστε και επιλέξτε την τοποθεσία σας ου SharePoint και μετά κάντε κλικ στο κουμπί Άνοιγμα.

  3. Εάν σας ζητηθεί, στο παράθυρο διαλόγου Σύνδεση με, πληκτρολογήστε το όνομα χρήστη και τον κωδικό πρόσβασής σας και μετά κάντε κλικ στο κουμπί OK.

  4. Στο μενού Αρχείο, κάντε κλικ στην εντολή Δημιουργία.

  5. Στο παράθυρο διαλόγου Δημιουργία, στην καρτέλα Σελίδα, κάντε κλικ στην καρτέλα Γενικά στο πιο αριστερό παράθυρο και στη συνέχεια κάντε διπλό κλικ στην επιλογή Αρχείο κειμένου στο επόμενο παράθυρο στα δεξιά.

    Ένα νέο αρχείο κειμένου θα ανοίξει στην τοποθεσία Web σας.

  6. Αντιγράψτε τις παρακάτω γραμμές κώδικα, επιλέγοντάς τις και πατώντας τα πλήκτρα CTRL+C.

    <?xml version="1.0" encoding="utf-8"?>
    <ProductsRoot>
    <Products>
    <ProductID>1</ProductID>
    <ProductName>Chai</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>10 boxes x 20 bags</QuantityPerUnit>
    <UnitPrice>18</UnitPrice>
    <UnitsInStock>39</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>10</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>2</ProductID>
    <ProductName>Chang</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>24 - 12 oz bottles</QuantityPerUnit>
    <UnitPrice>19</UnitPrice>
    <UnitsInStock>17</UnitsInStock>
    <UnitsOnOrder>40</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>3</ProductID>
    <ProductName>Aniseed Syrup</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>12 - 550 ml bottles</QuantityPerUnit>
    <UnitPrice>10</UnitPrice>
    <UnitsInStock>13</UnitsInStock>
    <UnitsOnOrder>70</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>4</ProductID>
    <ProductName>Chef Anton's Cajun Seasoning</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>48 - 6 oz jars</QuantityPerUnit>
    <UnitPrice>22</UnitPrice>
    <UnitsInStock>53</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>5</ProductID>
    <ProductName>Chef Anton's Gumbo Mix</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>36 boxes</QuantityPerUnit>
    <UnitPrice>21.35</UnitPrice>
    <UnitsInStock>0</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>1</Discontinued>
    </Products>
    </ProductsRoot>
  7. Στο Office SharePoint Designer 2007, τοποθετήστε το σημείο εισαγωγής στο επάνω μέρος της σελίδας και μετά πατήστε τα πλήκτρα CTRL+V για να επικολλήσετε στη σελίδα τον κώδικα που μόλις αντιγράψατε.

  8. Από το μενού Αρχείο, κάντε κλικ στην επιλογή Αποθήκευση ως.

  9. Στο παράθυρο διαλόγου Αποθήκευση ως, στο πλαίσιο όνομα αρχείου, πληκτρολογήστε το αρχείο προϊόντα.XML.

  10. Στη λίστα Αποθήκευση ως τύπου, κάντε κλικ στην επιλογή XML και στη συνέχεια κάντε κλικ στο κουμπί Αποθήκευση.

Αρχή της σελίδας

Εισαγωγή μιας Προβολής δεδομένων ως φόρμας

Όταν εισάγετε την Προβολή δεδομένων, ως φόρμα, χρησιμοποιώντας το παράθυρο εργασιών Λεπτομέρειες προέλευσης δεδομένων, πρώτα πρέπει να εισάγετε την Προβολή δεδομένων στη σελίδα. Στη συνέχεια, επιλέξτε μια προέλευση δεδομένων στο παράθυρο εργασιών Βιβλιοθήκη προέλευσης δεδομένων, το οποίο διαχειρίζεται τις προελεύσεις δεδομένων που είναι διαθέσιμες για μια τοποθεσία SharePoint. Μόλις επιλέξτε την προέλευση των δεδομένων σας, θα ανοίξει το παράθυρο Λεπτομέρειες προέλευσης δεδομένων. στο παράθυρο εργασιών Λεπτομέρειες προέλευσης δεδομένων, επιλέξτε τα πεδία που θέλετε να εμφανίσετε και κατόπιν κάντε τα εισαγωγή στην Προβολή δεδομένων.

Οι Φόρμες δεδομένων βασίζονται στην τεχνολογία ASP.NET 2.0. Για να δημιουργήσετε μια Προβολή δεδομένων, πρέπει να ξεκινήσετε με μια σελίδα ASP.NET (αρχείο .aspx). Σε αυτό το παράδειγμα, θα δημιουργήσετε μια νέα σελίδα ASP.NET και, στη συνέχεια, θα εισάγετε μια Προβολή δεδομένων ως φόρμα, χρησιμοποιώντας το παράθυρο εργασιών Λεπτομέρειες προέλευσης δεδομένων.

  1. Στο μενού Αρχείο, κάντε κλικ στην εντολή Δημιουργία.

  2. Στο παράθυρο διαλόγου Δημιουργία, στην καρτέλα Σελίδα, κάντε κλικ στην επιλογή Γενικά και στη συνέχεια κάντε διπλό κλικ στην επιλογή ASPX.

    Θα ανοίξει μια νέα σελίδα με την ετικέτα ΜΟΡΦΗ.

    Ετικέτα μορφής ASP.NET

  3. Στο μενού Προβολή δεδομένων, κάντε κλικ στην εντολή Εισαγωγή Προβολής δεδομένων.

    Στη σελίδα σας θα εμφανιστεί μια κενή Προβολή δεδομένων και θα ανοίξει το παράθυρο εργασιών Βιβλιοθήκη προέλευσης δεδομένων.

    Κενή προβολή δεδομένων

    Αφού έχετε κάνει εισαγωγή της Προβολής δεδομένων, είστε έτοιμοι να προσθέσετε τα δεδομένα.

  4. Στο παράθυρο εργασιών Βιβλιοθήκη προέλευσης δεδομένων, εντοπίστε την προέλευση των δεδομένων, κάντε κλικ σε αυτή και μετά κάντε κλικ στο κουμπί Εμφάνιση δεδομένων.

    Στο παράδειγμα, στην περιοχή Αρχεία XML, κάντε κλικ στο προϊόντα.xml και μετά κάντε κλικ στο κουμπί Εμφάνιση δεδομένων. Εάν η επικεφαλίδα της περιοχής Αρχεία XML έχει συμπτυχθεί, κάντε κλικ στο σύμβολο συν (+) για να την αναπτύξετε.

  5. Στο παράθυρο εργασιών Λεπτομέρειες προέλευσης δεδομένων, κάντε κλικ στα πεδία που θέλετε να εισάγετε στην Προβολή δεδομένων.

    Συμβουλή: Για να επιλέξετε πολλά πεδία, κρατήστε πιεσμένο το πλήκτρο CTRL και κάντε κλικ σε κάθε ένα από αυτά.

    Στο παράδειγμα, στο φάκελο ProductsRoot, στην περιοχή Προϊόντα, κάντε κλικ στο στοιχείο Όνομα_Προϊόντος. Πατήστε και κρατήστε πατημένο το πλήκτρο CTRL, ενώ κάνετε κλικ στα στοιχεία Μονάδες_Σε_Απόθεμα, Μονάδες_Σε_Παραγγελία και Επίπεδο_Αναπαραγγελίας.

    Επιλεγμένα πεδία στο παράθυρο εργασιών Λεπτομέρειες προέλευσης δεδομένων

  6. Κάντε κλικ στην επιλογή Εισαγωγή επιλεγμένων πεδίων ως και μετά κάντε κλικ στην εντολή Φόρμα πολλών στοιχείων για να εισάγετε τα επιλεγμένα δεδομένα στην Προβολή δεδομένων ως φόρμα.

    ΣΗΜΕΙΩΣΗ : Η Φόρμα ενός στοιχείου εμφανίζει μια εγγραφή τη φορά ως φόρμα. Η προβολή Φόρμα πολλαπλών στοιχείων εμφανίζει πολλές εγγραφές, με κάθε πεδίο στη δική του στήλη και με το όνομα του αρχείου ως επικεφαλίδα για τη στήλη αυτή.

    Τα πεδία που επιλέξατε στο παράθυρο εργασιών Λεπτομέρειες προέλευσης δεδομένωνεμφανίζονται σε μια φόρμα.

    ΣΗΜΕΙΩΣΗ : Επειδή το παράδειγμα αυτό χρησιμοποιεί ένα αρχείο .xml, κάθε πεδίο της Προβολής δεδομένων έχει δυνατότητα επεξεργασίας. Ωστόσο, ανάλογα με τον τύπο του αρχείου προέλευσης δεδομένων, είναι πιθανό να μην είναι δυνατή η επεξεργασία κάποιων πεδίων. Για παράδειγμα, εάν το αρχείο προέλευσης δεδομένων είναι μια λίστα του SharePoint και επιλέξετε να συμπεριλάβετε στη φόρμα πεδία συστήματος όπως το "Δημιουργία από" ή "Τροποποίηση από", δεν είναι δυνατή η επεξεργασία των πεδίων αυτών.

    Επιλεγμένα δεδομένα που εμφανίζονται ως φόρμα

    Μόλις εισάγετε την Προβολή δεδομένων ως φόρμα, μπορείτε τα χρησιμοποιήσετε τα εργαλεία WYSIWYG, όπως είναι η γραμμή εργαλείων Μορφοποίηση για να τροποποιήσετε γραμματοσειρές, να στοιχίσετε κείμενο ή να εφαρμόσετε χρώματα. Όταν εφαρμόζετε νέα μορφοποίηση σε ένα σημείο δεδομένων στην Προβολή δεδομένων, το Office SharePoint Designer 2007 εφαρμόζει τη μορφοποίηση σε όλα τα δεδομένα του ίδιου επιπέδου στην XML τροποποιώντας το φύλλο στυλ XSLT που επισυνάπτεται στη σελίδα. Για παράδειγμα, στην προηγούμενη εικόνα, εάν επιλέξετε Chai και μετά κάνετε κλικ στην επιλογή Έντονη γραφή στη γραμμή εργαλείων Μορφοποίηση, τότε το Office SharePoint Designer 2007 εφαρμόζει την ίδια μορφοποίηση σε όλα τα περιεχόμενα που εμφανίζονται στο πεδίο Όνομα_Προϊόντος.

    Εφαρμογή της ίδιας μορφοποίηση σε όλα τα δεδομένα στο ίδιο επίπεδο

  7. Από το μενού Αρχείο, κάντε κλικ στην επιλογή Αποθήκευση ως. Στο παράθυρο διαλόγου Αποθήκευση ως, στο πλαίσιο Όνομα αρχείου, πληκτρολογήστε ένα όνομα για το αρχείο και, στη συνέχεια, κάντε κλικ στην εντολή Αποθήκευση.

Αρχή της σελίδας

Επεξεργασία δεδομένων μέσω του προγράμματος περιήγησης

Μετά από την αποθήκευση της σελίδας που περιέχει τη φόρμα, μπορείτε να κάνετε προεπισκόπησή της στο πρόγραμμα περιήγησης και να τροποποιήσετε τα δεδομένα στη φόρμα.

Τύποι πεδίου και εισαγωγή δεδομένων

Το παράδειγμα αυτό χρησιμοποιεί ένα αρχείο XML ως αρχείο προέλευσης δεδομένων. Επειδή ένα αρχείο XML είναι ένα απλό αρχείο κειμένου, δεν είναι δυνατός ο καθορισμός των τύπων τιμών που πρέπει να περιέχουν τα μεμονωμένα πεδία. Για παράδειγμα, δεν υπάρχει τίποτα που να σας εμποδίζει να εισάγετε και να αποθηκεύσετε κείμενο σε ένα πεδίο που θα έπρεπε να περιέχει αριθμούς, όπως το πεδίο ΜονάδεςΣεΠαραγγελία.

Ωστόσο, αν το αρχείο προέλευσης δεδομένων είναι ένα αρχείο προέλευσης δεδομένων SQL, όπως μια βάση δεδομένων SQL ή μια λίστα ή βιβλιοθήκη του SharePoint, οι τύποι πεδίου μπορεί να είναι καθορισμένοι στο ίδιο το αρχείο προέλευσης δεδομένων. Σε αυτήν την περίπτωση, εάν χρησιμοποιήσετε τη φόρμα για εισαγωγή κειμένου σε ένα πεδίο που απαιτεί αριθμούς και στη συνέχεια κάνετε κλικ στην εντολή Αποθήκευση, θα εμφανιστεί ένα μήνυμα σφάλματος στο πρόγραμμα περιήγησης που εξηγεί ότι το στοιχείο ελέγχου του αρχείου προέλευσης δεδομένων απέτυχε να εκτελέσει την εντολή ενημέρωσης. Εάν λάβετε αυτό το μήνυμα σφάλματος, κάντε κλικ στο κουμπί Πίσω στο πρόγραμμα περιήγησης και στη συνέχεια κάντε κλικ είτε στο κουμπί Ακύρωση στη φόρμα για να απορρίψετε τις αλλαγές σας ή εισάγετε τιμές στα πεδία φόρμας που μπορεί να αποδεχτεί το αρχείο προέλευσης δεδομένων.

Για το λόγο αυτό, όταν σχεδιάζετε τη φόρμα στο Office SharePoint Designer 2007, μπορεί να πρέπει να συμπεριλάβετε κείμενο στις κεφαλίδες στήλης, όταν ένα πεδίο απαιτεί την εισαγωγή συγκεκριμένου τύπου.

Χρήση της φόρμας στο πρόγραμμα περιήγησης

  1. Στο Office SharePoint Designer 2007, στο μενού Αρχείο, κάντε κλικ στην εντολή Προεπισκόπηση στο πρόγραμμα περιήγησης και, στη συνέχεια, κάντε κλικ στον τύπο και το μέγεθος του προγράμματος περιήγησης που θέλετε να χρησιμοποιήσετε.

    Συντόμευση πληκτρολογίου επιλέξτε τη σελίδα που θέλετε να κάνετε προεπισκόπηση στη λίστα φακέλων και, στη συνέχεια, πατήστε το πλήκτρο F12.

    Η σελίδα με τη φόρμα εμφανίζεται στο πρόγραμμα περιήγησης.

    Η εγγραφή πολλών στοιχείων όπως εμφανίζεται στο πρόγραμμα περιήγησης

  2. Μπορείτε να καθορίσετε οποιεσδήποτε πληροφορίες που εμφανίζονται σε ένα πεδίο φόρμας στην Προβολή δεδομένων. Μπορείτε επίσης να αλλάξετε τις πληροφορίες σε πολλά πεδία σε πολλές εγγραφές, ταυτόχρονα. Όταν ολοκληρώσετε την τροποποίηση των δεδομένων στη φόρμα, κάντε κλικ στο κουμπί Αποθήκευση για να υποβάλετε τις αλλαγές στην προέλευση δεδομένων ή κάντε κλικ στο κουμπί Άκυρο για να απορρίψετε τις αλλαγές σας.

    Για να ακολουθήσετε το παράδειγμα, στη στήλη ΌνομαΠροϊόντος , στο πεδίο που περιέχει τη λέξη Chai, τοποθετήστε το δρομέα στο τέλος της λέξης Chai, πατήστε το πλήκτρο ΔΙΑΣΤΉΜΑΤΟΣ μία φορά και, στη συνέχεια, πληκτρολογήστε Συγκεντρωθείτε τσάι. Στη στήλη προέλευσης , σε το Chai εγγραφή, πληκτρολογήστε 40. Στη στήλη προέλευσης , σε το του σεφ Cajun Seasoning εγγραφή, πληκτρολογήστε 35και, στη συνέχεια, κάντε κλικ στην επιλογή Αποθήκευση. Εμφανίζεται η φόρμα με ενημερωμένη την εγγραφή στο πρόγραμμα περιήγησης.

    Η φόρμα δεδομένων εμφανίζεται με ενημερωμένη την εγγραφή.

Αρχή της σελίδας

Προτεινόμενα βήματα συνέχειας

Οι Προβολές δεδομένων είναι πολύ ισχυρές, πλήρως προσαρμοζόμενες προβολές δεδομένων πραγματικού χρόνου. Τώρα που μάθατε πώς να εισάγετε μια προβολή δεδομένων ως φόρμα, ίσως να θέλετε να μάθετε πώς να κάνετε τα εξής:

  • Φιλτράρισμα δεδομένων σε μια προβολή δεδομένων    Μπορείτε εύκολα να φιλτράρετε τα δεδομένα σε μια προβολή δεδομένων, έτσι ώστε τα δεδομένα που εμφανίζονται είναι ακριβώς τα δεδομένα που θέλετε να προβάλετε. Για περισσότερες πληροφορίες, ανατρέξτε στο θέμα Φιλτράρισμα δεδομένων σε μια προβολή δεδομένων.

  • Ταξινόμηση και ομαδοποίηση δεδομένων σε μια προβολή δεδομένων    Μπορείτε γρήγορα να ταξινομήσετε ή να ομαδοποιήσετε τα δεδομένα σε μια προβολή δεδομένων. Για παράδειγμα, μπορείτε εύκολα να ταξινομήσετε τη λίστα με αλφαβητική σειρά. Για περισσότερες πληροφορίες, ανατρέξτε στο θέμα Ταξινόμηση και ομαδοποίηση δεδομένων σε μια προβολή δεδομένων.

  • Εφαρμογή μορφοποίησης σε μια προβολή δεδομένων υπό όρους    Μπορείτε να εφαρμόσετε τη συγκεκριμένη μορφοποίηση σε μια προβολή δεδομένων όταν τα δεδομένα στην προβολή δεδομένων πληρούν συγκεκριμένες συνθήκες. Για περισσότερες πληροφορίες, ανατρέξτε στο θέμα εφαρμογή μορφοποίηση υπό όρους σε μια προβολή δεδομένων.

  • Δημιουργία στήλης τύπου σε μια προβολή δεδομένων    Μπορείτε να δημιουργήσετε μια υπολογιζόμενη στήλη που εμφανίζει το αποτέλεσμα ενός υπολογισμού των δεδομένων σε μια προβολή δεδομένων. Για παράδειγμα, μπορείτε να πολλαπλασιάσετε την τιμή μονάδας από τον αριθμό των μονάδων σε απόθεμα και να εμφανίσετε τη συνολική τιμή των στοιχείων σε μια ξεχωριστή στήλη. Για περισσότερες πληροφορίες, ανατρέξτε στο θέμα Δημιουργία στήλης τύπου σε μια προβολή δεδομένων.

  • Τροποποίηση στηλών σε μια προβολή δεδομένων    Μπορείτε να γρήγορα και εύκολα Προσθήκη, κατάργηση ή να αναδιατάξετε στήλες σε μια προβολή δεδομένων. Για περισσότερες πληροφορίες, ανατρέξτε στο θέμα Τροποποίηση των στηλών σε μια προβολή δεδομένων.

  • Εμφάνιση δείγματος δεδομένων στην προβολή δεδομένων    Μπορείτε εύκολα να εμφανίσετε δείγμα δεδομένων σε μια προβολή δεδομένων.

Αρχή της σελίδας

ΣΗΜΕΙΩΣΗ : Αποποίηση ευθυνών αυτόματης μετάφρασης: Αυτό το άρθρο έχει μεταφραστεί από ένα σύστημα υπολογιστή χωρίς ανθρώπινη παρέμβαση. Η Microsoft προσφέρει αυτές τις αυτόματες μεταφράσεις για να βοηθά τους μη αγγλόφωνους χρήστες να απολαμβάνουν περιεχόμενο σχετικά με προϊόντα, υπηρεσίες και τεχνολογίες της Microsoft. Το άρθρο προέρχεται από μηχανική μετάφραση, συνεπώς ενδέχεται να περιέχει λάθη λεξιλογίου, σύνταξης ή γραμματικής.

Αναπτύξτε τις δεξιότητές σας
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×