Δημιουργία ενός επικαλυπτόμενου πλαισίου λίστας

Σημείωση:  Θέλουμε να σας παρέχουμε το πιο πρόσφατο περιεχόμενο βοήθειας στη γλώσσα σας όσο πιο σύντομα γίνεται. Αυτή η σελίδα έχω μεταφραστεί μέσω αυτοματοποιημένης διαδικασίας και ενδεχομένως να περιέχει γραμματικά λάθη και ανακρίβειες. Ο σκοπός μας είναι αυτό το περιεχόμενο να σας φανεί χρήσιμο. Μπορείτε να μας ενημερώσετε στο κάτω μέρος αυτής της σελίδας εάν οι πληροφορίες σάς φάνηκαν χρήσιμες; Εδώ θα βρείτε το άρθρο στα Αγγλικά , για να το συμβουλεύεστε εύκολα.

Επικαλυπτόμενα πλαίσια λίστας βοηθά τους χρήστες να συμπληρώνουν φόρμες πιο γρήγορα και να διασφαλίσετε ότι οι χρήστες καταχωρούν σωστά τα δεδομένα. Σε αυτό το άρθρο περιγράφει τον τρόπο για να δημιουργήσετε και να συμπληρώσετε επικαλυπτόμενου πλαίσια λίστας με τα δεδομένα. Στο Microsoft Office InfoPath, μπορείτε να συμπληρώσετε μια λίστα με τα δεδομένα που χρησιμοποιεί τιμές από τη φόρμα, τιμές από ένα εξωτερικό έγγραφο επεκτάσιμη γλώσσα σήμανσης (XML) ή τιμές από μια βάση δεδομένων της Microsoft Office Access.

Σε αυτό το άρθρο

Τι είναι μια επικαλυπτόμενου πλαισίου λίστας;

Βήμα 1: Εισαγωγή ενός επικαλυπτόμενου πλαισίου λίστας

Βήμα 2: Παρέχει τα δεδομένα

Τι είναι μια επικαλυπτόμενου πλαισίου λίστας;

Επικαλυπτόμενου πλαισίου λίστας είναι ένα πλαίσιο λίστας με επιλογές που αλλάζουν ανάλογα με την τιμή που ένας χρήστης επιλέγει σε ένα άλλο πλαίσιο λίστας. Για παράδειγμα, εάν ένας χρήστης κάνει κλικ καρυκεύματα στο πλαίσιο κατηγορίες που φαίνεται στην παρακάτω εικόνα, το πλαίσιο προϊόντα θα εμφανίσει μια λίστα καρυκευμάτων.

Παράδειγμα επικαλυπτόμενου πλαισίου λίστας

Οι ενότητες που ακολουθούν δείχνουν πώς μπορείτε να σχεδιάσετε ένα πρότυπο φόρμας με δύο πλαίσια λίστας, όπου το δεύτερο πλαίσιο λίστας φιλτράρεται με βάση την τιμή που κάποιος χρήστης επιλέξει από το πρώτο πλαίσιο λίστας. Όταν αλλάξει η τιμή στο πρώτο πλαίσιο λίστας, το φίλτρο εφαρμόζεται αυτόματα στο δεύτερο πλαίσιο λίστας, το οποίο αλλάζει τις τιμές.

Ζητήματα συμβατότητας

Φίλτρα μπορεί να χρησιμοποιηθεί μόνο σε πρότυπα φόρμας που έχουν σχεδιαστεί για συμπλήρωση στο InfoPath. Φίλτρα δεν είναι διαθέσιμα σε πρότυπα φόρμας με συμβατότητα προγράμματος περιήγησης.

Αρχή της σελίδας

Βήμα 1: Εισαγωγή ενός επικαλυπτόμενου πλαισίου λίστας

Για να δημιουργήσετε ένα επικαλυπτόμενο πλαίσιο λίστας, πρέπει να εισαγάγετε δύο πλαίσια λίστας στο πρότυπο φόρμας.

Σημείωση: Κατά την εισαγωγή ενός επικαλυπτόμενου πλαισίου λίστας στο πρότυπο φόρμας, βεβαιωθείτε ότι τα δύο πλαίσια λίστας δεν είναι σε επαναλαμβανόμενη ενότητα ή επαναλαμβανόμενος πίνακας.

  1. Εάν το παράθυρο εργασιών Στοιχεία ελέγχου δεν είναι ορατό, κάντε κλικ στην επιλογή Περισσότερα στοιχεία ελέγχου στο μενού Εισαγωγή ή πατήστε το συνδυασμό πλήκτρων ALT+I, C.

  2. Στην περιοχή Εισαγωγή στοιχείων ελέγχου στο παράθυρο εργασιών " στοιχεία ελέγχου ", κάντε κλικ στο Αναπτυσσόμενο πλαίσιο λίστας. Όταν ένας χρήστης συμπληρώνει μια φόρμα που βασίζεται στο πρότυπο φόρμας, η επιλογή σε αυτό το πλαίσιο αναπτυσσόμενης λίστας θα καθορίσει τις επιλογές που είναι διαθέσιμες στο δεύτερο πλαίσιο λίστας.

  3. Κάντε κλικ στο πλαίσιο λίστας. Πρότυπο φόρμας τώρα θα πρέπει να περιέχει ένα πλαίσιο αναπτυσσόμενης λίστας και ένα τυπικό πλαίσιο λίστας.

    Αναπτυσσόμενο πλαίσιο λίστας και πλαίσιο λίστας σε φόρμα

  4. Κάντε διπλό κλικ στο πλαίσιο αναπτυσσόμενης λίστας που έχετε εισαγάγει στο πρότυπο φόρμας στο βήμα 2.

  5. Στο παράθυρο διαλόγου Ιδιότητες πλαισίου αναπτυσσόμενης λίστας, κάντε κλικ στην καρτέλα δεδομένα.

  6. Στο πλαίσιο όνομα πεδίου, πληκτρολογήστε listBox1και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

  7. Κάντε διπλό κλικ στο πλαίσιο λίστας που έχετε εισαγάγει στο πρότυπο φόρμας στο βήμα 3.

  8. Στο παράθυρο διαλόγου Ιδιότητες πλαισίου λίστας, κάντε κλικ στην καρτέλα δεδομένα.

  9. Στο πλαίσιο όνομα πεδίου, πληκτρολογήστε listBox2Cascadeκαι, στη συνέχεια, κάντε κλικ στο κουμπί OK.

Αρχή της σελίδας

Βήμα 2: Παρέχει τα δεδομένα

Τώρα που έχετε εισαγάγει τα πλαίσια λίστας στο πρότυπο φόρμας, πρέπει να δώσετε τα δεδομένα που θα εμφανίζονται. Στη συνέχεια, πρέπει να εφαρμόσετε ένα φίλτρο έτσι ώστε οι επιλογές στο δεύτερο πλαίσιο λίστας να βασίζονται την επιλογή του χρήστη στο πρώτο πλαίσιο λίστας.

Η ενότητα αυτή εξηγεί τον τρόπο σύνδεσης τα πλαίσια λίστας με τα δεδομένα, χρησιμοποιώντας τρεις συνηθισμένες μεθόδους: Προσθήκη των δεδομένων στη φόρμα. σύνδεση της φόρμας σε ένα υπάρχον έγγραφο XML που περιέχει τα δεδομένα. ή τη σύνδεση της φόρμας σε μια βάση δεδομένων που περιέχει τα δεδομένα. Για να ολοκληρώσετε τη δημιουργία του επικαλυπτόμενου πλαισίου λίστας, κάντε κλικ στη μέθοδο που θέλετε να χρησιμοποιήσετε στη λίστα που ακολουθεί.

Σύνδεση με τα δεδομένα στη φόρμα

Σύνδεση σε ένα εξωτερικό έγγραφο XML

Σύνδεση με βάση δεδομένων

Σύνδεση με τα δεδομένα στη φόρμα

Σε αυτήν την ενότητα, θα μάθετε πώς μπορείτε να συμπληρώσετε τα πλαίσια λίστας με τα δεδομένα από τη φόρμα. Για να το κάνετε αυτό, πρέπει πρώτα να ρυθμίσετε τα πεδία στο πρότυπο φόρμας, έτσι ώστε να μπορείτε να εισαγάγετε τα ονόματα των κατηγοριών και ένα σύνολο προϊόντων για κάθε κατηγορία.

Ρύθμιση παραμέτρων πεδίων στο πρότυπο φόρμας

  1. Εάν το παράθυρο εργασιών Προέλευση δεδομένων δεν είναι ορατό, κάντε κλικ στο Αρχείο προέλευσης δεδομένων στο μενού Προβολή.

  2. Στο παράθυρο εργασιών " Προέλευση δεδομένων ", κάντε δεξί κλικ στην ομάδα myFields και, στη συνέχεια, κάντε κλικ στην επιλογή Προσθήκη.

  3. Στο πλαίσιο όνομα, στο παράθυρο διαλόγου Προσθήκη πεδίου ή ομάδας, πληκτρολογήστε CategoriesAndProducts.

  4. Στη λίστα Τύπος, κάντε κλικ στην ομάδα.

  5. Επιλέξτε το πλαίσιο ελέγχου Επανάληψη και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

  6. Στο παράθυρο εργασιών " Προέλευση δεδομένων ", κάντε δεξί κλικ στην ομάδα CategoriesAndProducts.

  7. Στο πλαίσιο όνομα, στο παράθυρο διαλόγου Προσθήκη πεδίου ή ομάδας, πληκτρολογήστε κατηγορίακαι, στη συνέχεια, κάντε κλικ στο κουμπί OK. Αυτό το πεδίο θα περιέχει τα ονόματα των κατηγοριών για το πρώτο πλαίσιο λίστας.

  8. Κάντε δεξί κλικ στην ομάδα CategoriesAndProducts και, στη συνέχεια, κάντε κλικ στην επιλογή Προσθήκη.

  9. Στο πλαίσιο όνομα, στο παράθυρο διαλόγου Προσθήκη πεδίου ή ομάδας, πληκτρολογήστε προϊόντος.

  10. Επιλέξτε το πλαίσιο ελέγχου Επανάληψη και, στη συνέχεια, κάντε κλικ στο κουμπί OK. Αυτό το πεδίο θα περιέχει τα ονόματα των προϊόντων για το δεύτερο πλαίσιο λίστας.

Επειδή αυτό το πλαίσιο λίστας συμπληρώνεται με δεδομένα από τη φόρμα, τα δεδομένα πρέπει να προστεθεί στη φόρμα. Για να το κάνετε αυτό, θα πρέπει να δημιουργήσετε προεπιλεγμένες τιμές για τα πεδία προϊόντων και κατηγορία.

Συμβουλή

Μπορείτε επίσης να δημιουργήσετε πλαίσια λίστας που εμφανίζουν τιμές που πληκτρολογούν οι χρήστες στη φόρμα τον εαυτό τους. Για να το κάνετε αυτό, συσχετίσετε το πλαίσιο λίστας με τα πεδία που είναι συνδεδεμένα με στοιχεία ελέγχου στη φόρμα. Όταν ένας χρήστης εισάγει τιμές στα στοιχεία ελέγχου, αλλάξτε τις επιλογές στο πλαίσιο λίστας.

Δημιουργία προεπιλεγμένων τιμών

  1. Στο μενού Εργαλεία, κάντε κλικ στην επιλογή Προεπιλεγμένων τιμών.

  2. Στο παράθυρο διαλόγου Επεξεργασία προεπιλεγμένων τιμών, στην ομάδα CategoriesAndProducts, επιλέξτε το πεδίο κατηγορία (μην καταργήσετε το πλαίσιο ελέγχου), και, στη συνέχεια, στο πλαίσιο προεπιλεγμένη τιμή, πληκτρολογήστε ψάρια.

  3. Επιλέξτε το πεδίο προϊόντος (μην καταργήσετε το πλαίσιο ελέγχου), και, στη συνέχεια, στο πλαίσιο προεπιλεγμένη τιμή, πληκτρολογήστε Καβούρια.

  4. Κάντε δεξιό κλικ στο πεδίο " προϊόν " και, στη συνέχεια, κάντε κλικ στην επιλογή Προσθήκη άλλου προϊόντος παραπάνω. Αυτό σας επιτρέπει να προσθέσετε ένα δεύτερο προϊόν για ψάρια ως προεπιλεγμένη τιμή.

  5. Κάντε δεξί κλικ στο δεύτερο στιγμιότυπο του πεδίου προϊόντος (μην καταργήσετε το πλαίσιο ελέγχου), και, στη συνέχεια, στο πλαίσιο προεπιλεγμένη τιμή, πληκτρολογήστε σολομού.

  6. Κάντε δεξί κλικ στην ομάδα CategoriesAndProducts και, στη συνέχεια, κάντε κλικ στην επιλογή Προσθήκη. Αυτό σας επιτρέπει να προσθέσετε μια δεύτερη κατηγορία ως προεπιλεγμένη τιμή.

  7. Χρησιμοποιήστε τα προηγούμενα βήματα για να καθορίσετε τις προεπιλεγμένες τιμές για τη δεύτερη εμφάνιση των πεδίων κατηγορίας και προϊόντοςΓαλακτοκομικά, τυρί τσένταρ και γάλακτος σοκολάτα, αντίστοιχα.

  8. Κάντε κλικ στο κουμπί OK.

Τώρα που έχετε εισαγάγει προεπιλεγμένες τιμές για τα πεδία προϊόντων και κατηγορία, μπορείτε να συνδεθείτε του πρώτου πλαισίου λίστας με τα δεδομένα που πληκτρολογήσατε.

Σύνδεση του πρώτου πλαισίου λίστας με τα δεδομένα

  1. Στο πρότυπο φόρμας, κάντε διπλό κλικ στο πλαίσιο αναπτυσσόμενης λίστας που έχετε εισαγάγει προηγουμένως.

  2. Κάντε κλικ στην καρτέλα Δεδομένα.

  3. Στο παράθυρο διαλόγου Ιδιότητες πλαισίου αναπτυσσόμενης λίστας, στην περιοχή καταχωρήσεις πλαισίου λίστας, κάντε κλικ στην επιλογή Αναζήτηση τιμών στο αρχείο προέλευσης δεδομένων στη φόρμα.

  4. Κάντε κλικ στο κουμπί Επιλογή XPath Εικόνα κουμπιού δίπλα στο πλαίσιο καταχωρήσεις.

  5. Στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, στην ομάδα CategoriesAndProducts, κάντε κλικ στο πεδίο " κατηγορία " και, στη συνέχεια, κάντε κλικ στο κουμπί OK δύο φορές.

Τώρα θα πρέπει να συνδεθείτε στο δεύτερο πλαίσιο λίστας με τα δεδομένα. Ενώ πραγματοποιείτε αυτήν σύνδεση δεδομένων, θα θέλετε να εφαρμόσετε ένα φίλτρο στο δεύτερο πλαίσιο λίστας. Αυτό το φίλτρο θα συμπληρώσετε το δεύτερο πλαίσιο λίστας με τα κατάλληλα προϊόντα, με βάση την επιλεγμένη κατηγορία στο πρώτο πλαίσιο λίστας. Το φίλτρο συγκρίνει την τιμή που έχει επιλεγεί στο πρώτο πλαίσιο λίστας (πεδίο listBox1) με τη λίστα κατηγοριών που αποθηκεύσατε στη φόρμα (πεδίο κατηγοριών).

Σύνδεση στο δεύτερο πλαίσιο λίστας με τα δεδομένα

  1. Στο πρότυπο φόρμας, κάντε διπλό κλικ το τυπικό πλαίσιο λίστας που έχετε εισαγάγει προηγουμένως.

  2. Κάντε κλικ στην καρτέλα Δεδομένα.

  3. Στο παράθυρο διαλόγου Ιδιότητες πλαισίου λίστας, στην περιοχή καταχωρήσεις πλαισίου λίστας, κάντε κλικ στην επιλογή Αναζήτηση τιμών στο αρχείο προέλευσης δεδομένων στη φόρμα.

  4. Κάντε κλικ στο κουμπί Επιλογή XPath Εικόνα κουμπιού δίπλα στο πλαίσιο καταχωρήσεις.

  5. Στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, στην ομάδα CategoriesAndProducts, κάντε κλικ στο πεδίο " προϊόν " και, στη συνέχεια, κάντε κλικ στην επιλογή Φιλτράρισμα δεδομένων.

  6. Στο παράθυρο διαλόγου Φιλτράρισμα δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  7. Στο παράθυρο διαλόγου Καθορισμός συνθηκών φίλτρου, κάντε κλικ στην επιλογή Επιλογή πεδίου ή ομάδας στο πρώτο πλαίσιο.

  8. Στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, κάντε κλικ στην επιλογή listBox1 και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

  9. Στο παράθυρο διαλόγου Καθορισμός συνθηκών φίλτρου, κάντε κλικ στην επιλογή Επιλογή πεδίου ή ομάδας στο τρίτο πλαίσιο.

  10. Στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, κάντε κλικ στο πεδίο " κατηγορία " και, στη συνέχεια, κάντε κλικ στο κουμπί OK για να κλείσετε όλα τα παράθυρα διαλόγου "Άνοιγμα".

Τώρα που έχετε συνδέσει το δεύτερο πλαίσιο λίστας με τα δεδομένα και έχετε εφαρμόσει το φίλτρο, είστε έτοιμοι να ελέγξετε τα πλαίσια λίστας για να βεβαιωθείτε ότι λειτουργούν σωστά.

Ελέγξετε τα πλαίσια λίστας

  1. Για να ελέγξετε τις αλλαγές σας, κάντε κλικ στην επιλογή Προεπισκόπηση στη Βασική γραμμή εργαλείων ή πατήστε το συνδυασμό πλήκτρων CTRL+SHIFT+B.

  2. Στο πλαίσιο αναπτυσσόμενης λίστας, κάντε κλικ στην επιλογή ψάρια. Το τυπικό πλαίσιο λίστας πρέπει να εμφανίσετε μια κενή γραμμή, Καβούρια και σολομού.

    Σημείωση: Στην κενή γραμμή επιτρέπει στους χρήστες, καταργήστε την επιλογή από το πλαίσιο λίστας.

Εάν τα πλαίσια λίστας δεν λειτουργούν σωστά, ελέγξτε το φίλτρο για το δεύτερο πλαίσιο λίστας για να βεβαιωθείτε ότι συγκρίνει το πεδίο listBox1 με το πεδίο κατηγορία.

Αρχή της ενότητας

Σύνδεση σε ένα εξωτερικό έγγραφο XML

Σε αυτήν την ενότητα, θα μάθετε πώς μπορείτε να δημιουργήσετε μια σύνδεση δεδομένων σε ένα έγγραφο XML που περιέχει τιμές προϊόντων και κατηγοριών. Το έγγραφο XML θα δευτερεύον αρχείο προέλευσης δεδομένων. Για να δημιουργήσετε αυτήν τη σύνδεση δεδομένων, θα πρέπει να δημιουργήσετε το έγγραφο XML, συσχετίσετε τα πλαίσια λίστας στο πρότυπο φόρμας με το έγγραφο XML και, στη συνέχεια, να εφαρμόσετε ένα φίλτρο στο δεύτερο πλαίσιο λίστας, έτσι ώστε η λίστα με τα προϊόντα αλλάζει σωστά.

Μπορείτε να συσχετίσετε τη φόρμα με ένα δευτερεύον αρχείο προέλευσης δεδομένων, πρέπει να δημιουργήσετε το έγγραφο XML.

Δημιουργήστε το έγγραφο XML

  1. Ξεκινήστε το Σημειωματάριο ή κάποιο άλλο πρόγραμμα επεξεργασίας κειμένου.

  2. Αντιγράψτε και επικολλήστε τα ακόλουθα δεδομένα XML στο πρόγραμμα επεξεργασίας κειμένου:

    <?xml version="1.0" encoding="UTF-8"?>
    <ListBoxData>
    <CategoriesAndProducts>
    <Categories>Seafood</Categories>
    <Products>
    <Product>Crab meat</Product>
    </Products>
    <Products>
    <Product>Salmon</Product>
    </Products>
    </CategoriesAndProducts>
    <CategoriesAndProducts>
    <Categories>Dairy</Categories>
    <Products>
    <Product>Chocolate milk</Product>
    </Products>
    <Products>
    <Product>Cheddar</Product>
    </Products>
    </CategoriesAndProducts>
    </ListBoxData>
  3. Αποθηκεύστε το αρχείο στον υπολογιστή σας ως listBoxData.xml.

Τώρα που έχετε δημιουργήσει ένα έγγραφο XML, μπορείτε να το συνδεθείτε στο πρότυπο φόρμας. Αυτό θα δημιουργήσει ένα δευτερεύον αρχείο προέλευσης δεδομένων.

Συνδέστε το έγγραφο XML στο πρότυπο φόρμας

  1. Στο μενού Εργαλεία, κάντε κλικ στην επιλογή Συνδέσεις δεδομένων.

  2. Στο παράθυρο διαλόγου Συνδέσεις δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  3. Στον Οδηγό σύνδεσης δεδομένων, κάντε κλικ στην επιλογή λήψη δεδομένων και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  4. Στην επόμενη σελίδα του οδηγού, κάντε κλικ στην επιλογή έγγραφο XML και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  5. Στην επόμενη σελίδα του οδηγού, κάντε κλικ στο κουμπί Αναζήτηση, επιλέξτε το αρχείο listBoxData.xml που έχετε αποθηκεύσει στον υπολογιστή σας και, στη συνέχεια, κάντε κλικ στην επιλογή Άνοιγμα.

  6. Στην επόμενη σελίδα του οδηγού, κάντε κλικ στην επιλογή Συμπερίληψη τα δεδομένα ως αρχείο πόρων στο πρότυπο φόρμας ή το τμήμα προτύπου και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  7. Στην επόμενη σελίδα του οδηγού, στο πλαίσιο Πληκτρολογήστε ένα όνομα για αυτήν τη σύνδεση δεδομένων, πληκτρολογήστε listBoxDataXMLFile.

  8. Επιλέξτε το πλαίσιο ελέγχου Αυτόματη Ανάκτηση δεδομένων κατά το άνοιγμα φόρμας. Αυτό εγγυάται ότι τα δεδομένα του πλαισίου λίστας θα είναι διαθέσιμη κάθε φορά που ανοίγει τη φόρμα, αντί να απαιτείται ένας χρήστης να ερωτήματος για αυτήν.

  9. Κάντε κλικ στο κουμπί Τέλος.

  10. Στο παράθυρο διαλόγου Συνδέσεις δεδομένων, κάντε κλικ στο κουμπί Κλείσιμο.

Τώρα είστε έτοιμοι να συνδέσετε το πρώτο πλαίσιο λίστας στο πρότυπο φόρμας με τα δεδομένα στο έγγραφο XML.

Σύνδεση του πρώτου πλαισίου λίστας με τα δεδομένα

  1. Στο πρότυπο φόρμας, κάντε διπλό κλικ στο πλαίσιο αναπτυσσόμενης λίστας που έχετε εισαγάγει προηγουμένως.

  2. Κάντε κλικ στην καρτέλα Δεδομένα.

  3. Στο παράθυρο διαλόγου Ιδιότητες πλαισίου αναπτυσσόμενης λίστας, στην περιοχή καταχωρήσεις πλαισίου λίστας, κάντε κλικ στην επιλογή Αναζήτηση τιμών από μια εξωτερική προέλευση δεδομένων.

  4. Στο πλαίσιο αρχείο προέλευσης δεδομένων, κάντε κλικ στην επιλογή listBoxDataXMLFile.

  5. Κάντε κλικ στο κουμπί Επιλογή XPath Εικόνα κουμπιού δίπλα στο πλαίσιο καταχωρήσεις.

  6. Στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, στην ομάδα CategoriesAndProducts, κάντε κλικ στο πεδίο κατηγοριών.

    Σημείωση: Το κίτρινο φόντο στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας υποδηλώνει ότι εργάζεστε με ένα δευτερεύον αρχείο προέλευσης δεδομένων.

  7. Κάντε διπλό κλικ στο στοιχείο ΟΚ.

Τώρα θα πρέπει να συνδέσετε το δεύτερο πλαίσιο λίστας στο έγγραφο XML. Ενώ πραγματοποιείτε αυτήν τη σύνδεση δεδομένων, θα θέλετε να εφαρμόσετε ένα φίλτρο στο δεύτερο πλαίσιο λίστας. Αυτό το φίλτρο θα συμπληρώσετε το δεύτερο πλαίσιο λίστας με τα κατάλληλα προϊόντα, με βάση την επιλεγμένη κατηγορία στο πρώτο πλαίσιο λίστας. Το φίλτρο συγκρίνει την τιμή που έχει επιλεγεί στο πρώτο πλαίσιο λίστας (πεδίο listBox1) με τη λίστα κατηγοριών που αποθηκεύσατε στη φόρμα (πεδίο κατηγοριών).

Σύνδεση στο δεύτερο πλαίσιο λίστας με τα δεδομένα

  1. Στο πρότυπο φόρμας, κάντε διπλό κλικ το τυπικό πλαίσιο λίστας που έχετε εισαγάγει προηγουμένως.

  2. Κάντε κλικ στην καρτέλα Δεδομένα.

  3. Στο παράθυρο διαλόγου Ιδιότητες πλαισίου λίστας, στην περιοχή καταχωρήσεις πλαισίου λίστας, κάντε κλικ στην επιλογή Αναζήτηση τιμών από μια εξωτερική προέλευση δεδομένων.

  4. Στο πλαίσιο αρχείο προέλευσης δεδομένων, κάντε κλικ στην επιλογή listBoxDataXMLFile.

  5. Κάντε κλικ στο κουμπί Επιλογή XPath Εικόνα κουμπιού δίπλα στο πλαίσιο καταχωρήσεις.

  6. Στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, στην ομάδα CategoriesAndProducts, αναπτύξτε την ομάδα προϊόντων και, στη συνέχεια, κάντε κλικ στο πεδίο " προϊόν ".

  7. Κάντε κλικ στην επιλογή Φιλτράρισμα δεδομένων.

  8. Στο παράθυρο διαλόγου Φιλτράρισμα δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  9. Στο παράθυρο διαλόγου Καθορισμός συνθηκών φίλτρου, κάντε κλικ στην επιλογή Επιλογή πεδίου ή ομάδας στο πρώτο πλαίσιο.

  10. Στο πλαίσιο αρχείο προέλευσης δεδομένων, στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, κάντε κλικ στην επιλογή κύριες.

  11. Κάντε κλικ στην επιλογή listBox1 και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

  12. Στο παράθυρο διαλόγου Καθορισμός συνθηκών φίλτρου, κάντε κλικ στην επιλογή Επιλογή πεδίου ή ομάδας στο τρίτο πλαίσιο.

  13. Στο πλαίσιο αρχείο προέλευσης δεδομένων, στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, κάντε κλικ στην επιλογή listBoxDataXMLFile (δευτερεύον) και, στη συνέχεια, κάντε κλικ στην επιλογή κατηγορίες.

  14. Κάντε κλικ στο κουμπί OK για να κλείσετε όλα τα ανοιχτά παράθυρα διαλόγου.

Τώρα που έχετε συνδέσει το δεύτερο πλαίσιο λίστας στο έγγραφο XML και έχετε εφαρμόσει το φίλτρο, είστε έτοιμοι να ελέγξετε τα πλαίσια λίστας για να βεβαιωθείτε ότι λειτουργούν σωστά.

Ελέγξετε τα πλαίσια λίστας

  1. Για να ελέγξετε τις αλλαγές σας, κάντε κλικ στην επιλογή Προεπισκόπηση στη Βασική γραμμή εργαλείων ή πατήστε το συνδυασμό πλήκτρων CTRL+SHIFT+B.

  2. Στο πλαίσιο αναπτυσσόμενης λίστας, κάντε κλικ στην επιλογή ψάρια. Το τυπικό πλαίσιο λίστας θα πρέπει να εμφανίζουν μόνο μια κενή γραμμή, Καβούρια και σολομού.

    Σημείωση: Στην κενή γραμμή επιτρέπει στους χρήστες, καταργήστε την επιλογή από το πλαίσιο λίστας.

Εάν τα πλαίσια λίστας δεν λειτουργούν σωστά, ελέγξτε το φίλτρο για το δεύτερο πλαίσιο λίστας για να βεβαιωθείτε ότι συγκρίνει το πεδίο listBox1 με το πεδίο κατηγορία.

Αρχή της ενότητας

Σύνδεση με βάση δεδομένων

Σε αυτήν την ενότητα, θα μάθετε πώς μπορείτε να δημιουργήσετε μια σύνδεση δεδομένων σε δύο πίνακες σε μια βάση δεδομένων της Access. Για να το κάνετε αυτό, συσχετίζετε τα πλαίσια λίστας στο πρότυπο φόρμας με τη βάση δεδομένων και, στη συνέχεια, να εφαρμόσετε ένα φίλτρο στο δεύτερο πλαίσιο λίστας, ώστε να στη λίστα εμφανίζονται σωστά στο το δεύτερο πλαίσιο Καταγραφή αλλαγών με βάση την τιμή που επιλέξατε στο πρώτο πλαίσιο λίστας. Για αυτό το παράδειγμα, θα υποθέσουμε ότι ότι η βάση δεδομένων της Access περιέχει δύο πίνακες που ονομάζεται κατηγορίες και προϊόντα και ότι οι δύο πίνακες σχετίζονται μεταξύ τους με το πεδίο ΚωδΚατηγορίας, η οποία χρησιμοποιείται σε κάθε πίνακα.

Πίνακα "Κατηγορίες"   

ΚωδΚατηγορίας

ΌνομαΚατηγορίας

1

Ψάρια

2

Γαλακτοκομικά

Πίνακας "προϊόντα"   

ProductID

ΚωδΚατηγορίας

Όνομα_προϊόντος

1

1

Καβούρια

2

1

Σολομός

3

2

Γάλακτος σοκολάτα

4

2

Τυρί τσένταρ

Σύνδεση του προτύπου φόρμας με το αρχείο προέλευσης δεδομένων

Αρχικά, πρέπει να μπορείτε να δημιουργήσετε μια σύνδεση δεδομένων μεταξύ του προτύπου φόρμας και των πινάκων στη βάση δεδομένων. Επειδή απλώς εμφανίζετε τα δεδομένα από τη βάση δεδομένων, αντί να τροποποιείτε απευθείας, βάση δεδομένων της Access θα είναι ένα δευτερεύον αρχείο προέλευσης δεδομένων για το πρότυπο φόρμας.

  1. Στο μενού Εργαλεία, κάντε κλικ στην επιλογή Συνδέσεις δεδομένων.

  2. Στο παράθυρο διαλόγου Συνδέσεις δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  3. Στον Οδηγό σύνδεσης δεδομένων, κάντε κλικ στην επιλογή λήψη δεδομένων και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  4. Στην επόμενη σελίδα του οδηγού, κάντε κλικ στην επιλογή βάση δεδομένων (Microsoft SQL Server ή Microsoft Office Access μόνο) και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  5. Στην επόμενη σελίδα του οδηγού, κάντε κλικ στην επιλογή Επιλογή βάσης δεδομένων, και, στη συνέχεια, αναζητήστε και κάντε διπλό κλικ σε βάση δεδομένων της Access στο σκληρό σας δίσκο.

  6. Στο παράθυρο διαλόγου Επιλογή πίνακα, κάντε κλικ στον πίνακα που περιέχει τα δεδομένα που θέλετε να εμφανίζονται στη λίστα πρώτη (σε αυτό το παράδειγμα, ο πίνακας κατηγορίες) και, στη συνέχεια, κάντε κλικ στο κουμπί OK. Καθορίζει τον πίνακα ως πρωτεύοντα πίνακα για τη σύνδεση δεδομένων.

  7. Στον οδηγό, κάντε κλικ στην επιλογή Προσθήκη πίνακα.

  8. Στο παράθυρο διαλόγου Προσθήκη πίνακα ή ερωτήματος, κάντε κλικ στον πίνακα που περιέχει τα δεδομένα που θέλετε να εμφανίζονται στη δεύτερη λίστα (σε αυτό το παράδειγμα, τον πίνακα Products) και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  9. Στο παράθυρο διαλόγου Επεξεργασία σχέσεων, βεβαιωθείτε ότι τα πεδία σύνδεσης είναι σωστές. Σε αυτό το παράδειγμα, οι πίνακες σχετίζονται μεταξύ τους με το πεδίο ΚωδΚατηγορίας.

    Συμβουλή: Εάν τα πεδία σύνδεσης δεν είναι σωστοί, επιλέξτε τα πεδία και, στη συνέχεια, κάντε κλικ στην επιλογή Κατάργηση σχέσης. Στη συνέχεια, κάντε κλικ στην επιλογή Προσθήκη σχέσης, επιλέξτε τα σωστά πεδία και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

  10. Κάντε κλικ στο κουμπί Τέλος.

    Σημείωση: Σε αυτό το παράδειγμα, ο πίνακας κατηγοριών έχει μια σχέση ένα-προς-πολλά με τον πίνακα προϊόντα, γεγονός που σημαίνει ότι για κάθε κατηγορία ενδέχεται να υπάρχουν πολλά προϊόντα. Σε μια βάση δεδομένων, αυτό το είδος της σχέσης συνήθως δημιουργείται χρησιμοποιώντας πεδία κλειδιού. Σε αυτήν την περίπτωση, το πεδίο κλειδιού CategoryID επιτρέπει την πρόσβαση για να συσχετίσετε το σωστό σύνολο προϊόντων με την κατάλληλη κατηγορία.

  11. Στον οδηγό, εξετάστε τη δομή αρχείου προέλευσης δεδομένων. Θα πρέπει να βλέπετε δύο πίνακες συνδεδεμένους μεταξύ τους: τον πρωτεύοντα πίνακα και το δευτερεύοντα πίνακα. Για να δείτε τα μεμονωμένα πεδία στον πίνακα, επιλέξτε το πλαίσιο ελέγχου Εμφάνιση στηλών πίνακα. Αφού ολοκληρώσετε την αναθεώρηση της δομής δεδομένων, κάντε κλικ στο κουμπί Επόμενο.

  12. Καταργήστε την επιλογή από το πλαίσιο ελέγχου Αποθήκευση αντιγράφου των δεδομένων στο πρότυπο φόρμας και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  13. Στο πλαίσιο Πληκτρολογήστε ένα όνομα για αυτήν τη σύνδεση δεδομένων, στην επόμενη σελίδα του οδηγού, πληκτρολογήστε ένα όνομα για τη σύνδεση δεδομένων.

  14. Επιλέξτε το πλαίσιο ελέγχου Αυτόματη Ανάκτηση δεδομένων κατά το άνοιγμα φόρμας.

  15. Κάντε κλικ στο κουμπί Τέλος και, στη συνέχεια, κάντε κλικ στο κουμπί Κλείσιμο στο παράθυρο διαλόγου Συνδέσεις δεδομένων.

Σύνδεση του πρώτου πλαισίου λίστας με τα δεδομένα

Τώρα που έχετε δημιουργήσει μια σύνδεση δεδομένων σε δευτερεύον αρχείο προέλευσης δεδομένων, μπορείτε να συνδεθείτε πρώτο πλαίσιο λίστας στο πρότυπο φόρμας με τους πίνακες της βάσης δεδομένων.

  1. Στο πρότυπο φόρμας, κάντε διπλό κλικ στο πλαίσιο αναπτυσσόμενης λίστας που έχετε εισαγάγει νωρίτερα.

  2. Κάντε κλικ στην καρτέλα Δεδομένα.

  3. Στο παράθυρο διαλόγου Ιδιότητες πλαισίου αναπτυσσόμενης λίστας, στην περιοχή καταχωρήσεις πλαισίου λίστας, κάντε κλικ στην επιλογή Αναζήτηση τιμών από μια εξωτερική προέλευση δεδομένων.

  4. Στο πλαίσιο αρχείο προέλευσης δεδομένων, βεβαιωθείτε ότι είναι ενεργοποιημένη η σύνδεση δεδομένων που δημιουργήσατε.

  5. Κάντε κλικ στο κουμπί Επιλογή XPath Εικόνα κουμπιού δίπλα στο πλαίσιο καταχωρήσεις.

  6. Στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, κάντε κλικ στο όνομα του πίνακα που περιέχει τα δεδομένα που θέλετε να εμφανίζονται στην αναπτυσσόμενη λίστα (σε αυτό το παράδειγμα, d: Categories ) και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

    Σημείωση: Το κίτρινο φόντο στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας υποδηλώνει ότι εργάζεστε με ένα δευτερεύον αρχείο προέλευσης δεδομένων.

  7. Κάντε κλικ στο κουμπί Επιλογή XPath Εικόνα κουμπιού δίπλα στο πλαίσιο τιμή.

  8. Στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, βεβαιωθείτε ότι το πεδίο σύνδεσης (σε αυτό το παράδειγμα, : CategoryID ) είναι επιλεγμένο και, στη συνέχεια, κάντε κλικ στο κουμπί OK. Αυτή είναι η τιμή που θα αποθηκευτεί όταν ο χρήστης κάνει μια επιλογή στο πλαίσιο λίστας.

  9. Κάντε κλικ στο κουμπί Επιλογή XPath Εικόνα κουμπιού δίπλα στο πλαίσιο εμφανιζόμενο όνομα.

  10. Στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, κάντε κλικ στο όνομα του πεδίου που θέλετε να εμφανίζονται στην αναπτυσσόμενη λίστα (σε αυτό το παράδειγμα, : ΌνομαΚατηγορίας ).

  11. Κάντε διπλό κλικ στο στοιχείο ΟΚ.

Σύνδεση στο δεύτερο πλαίσιο λίστας με τα δεδομένα

Τώρα θα πρέπει να συνδεθείτε στο δεύτερο πλαίσιο λίστας στη βάση δεδομένων. Ενώ πραγματοποιείτε αυτήν τη σύνδεση δεδομένων, θα θέλετε να εφαρμόσετε ένα φίλτρο στο δεύτερο πλαίσιο λίστας. Αυτό το φίλτρο θα συμπληρώσετε το δεύτερο πλαίσιο λίστας με τις κατάλληλες τιμές, με βάση την τιμή που είναι επιλεγμένη στο πρώτο πλαίσιο λίστας.

  1. Στο πρότυπο φόρμας, κάντε διπλό κλικ το τυπικό πλαίσιο λίστας.

  2. Κάντε κλικ στην καρτέλα Δεδομένα.

  3. Στο παράθυρο διαλόγου Ιδιότητες πλαισίου λίστας, στην περιοχή καταχωρήσεις πλαισίου λίστας, κάντε κλικ στην επιλογή Αναζήτηση τιμών από μια εξωτερική προέλευση δεδομένων.

  4. Στο πλαίσιο αρχείο προέλευσης δεδομένων, βεβαιωθείτε ότι είναι ενεργοποιημένη η σύνδεση δεδομένων που δημιουργήσατε.

  5. Κάντε κλικ στο κουμπί Επιλογή XPath Εικόνα κουμπιού δίπλα στο πλαίσιο καταχωρήσεις.

  6. Στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, αναπτύξτε την κύρια ομάδα (σε αυτό το παράδειγμα, d: Categories ) και, στη συνέχεια, κάντε κλικ στην επιλογή ομάδα δευτερεύον που αντιστοιχεί στον πίνακα που περιέχει τα δεδομένα που θέλετε να εμφανίζεται στο πλαίσιο λίστας επικαλυπτόμενου (σε αυτό παράδειγμα προϊόντα ).

  7. Κάντε κλικ στην επιλογή Φιλτράρισμα δεδομένων.

  8. Στο παράθυρο διαλόγου Φιλτράρισμα δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  9. Στο παράθυρο διαλόγου Καθορισμός συνθηκών φίλτρου, στο πρώτο πλαίσιο, βεβαιωθείτε ότι είναι επιλεγμένο το πεδίο σύνδεσης από το δευτερεύοντα πίνακα (σε αυτό το παράδειγμα, τα προϊόντα ).

    Σημαντικό: Εάν τα πεδία συνδετικές έχουν το ίδιο όνομα και στους δύο πίνακες, βεβαιωθείτε ότι έχετε επιλέξει το σωστό αρχείο. Τα πεδία από κάθε πίνακα ταξινομούνται μαζί με τη λίστα. Γι ' αυτό, μπορείτε να χρησιμοποιήσετε τα ονόματα των πεδίων περιβάλλοντος για να προσδιορίσετε ποιο είναι το σωστό αρχείο. Σε αυτό το παράδειγμα, θα σας επιλέξτε το πεδίο ΚωδΚατηγορίας που εμφανίζεται με τα άλλα πεδία από τον πίνακα Products.

  10. Στο τρίτο πλαίσιο, κάντε κλικ στην Επιλογή πεδίου ή ομάδας.

  11. Στο πλαίσιο αρχείο προέλευσης δεδομένων, στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, κάντε κλικ στην επιλογή κύριες, κάντε κλικ στο πεδίο listBox1 και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

    Τώρα έχετε ρυθμίσει ένα φίλτρο που συγκρίνει την τιμή που έχει επιλεγεί στο πλαίσιο αναπτυσσόμενης λίστας (πεδίο listBox1) με τη λίστα των τιμών σε τυπικό πλαίσιο λίστας.

  12. Κάντε κλικ στο κουμπί OK τρεις φορές για να επιστρέψετε στο παράθυρο διαλόγου Ιδιότητες πλαισίου λίστας.

  13. Κάντε κλικ στο κουμπί Επιλογή XPath Εικόνα κουμπιού δίπλα στο πλαίσιο τιμή.

  14. Στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, επιλέξτε την τιμή που θέλετε να τα αποθηκεύσετε όταν ο χρήστης κάνει μια επιλογή στο πλαίσιο λίστας. Σε αυτό το παράδειγμα, θέλουμε να αποθηκεύσετε το πεδίο ProductID για μελλοντική χρήση. Γι ' αυτό, θα σας επιλέξτε το : ProductID ομαδοποίηση και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

  15. Κάντε κλικ στο κουμπί Επιλογή XPath Εικόνα κουμπιού δίπλα στο πλαίσιο εμφανιζόμενο όνομα.

  16. Στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, κάντε κλικ στο όνομα του πεδίου που θέλετε να εμφανίζονται στο πλαίσιο λίστας (σε αυτό το παράδειγμα, : ProductName ).

  17. Κάντε διπλό κλικ στο στοιχείο ΟΚ.

Ελέγξετε τα πλαίσια λίστας

Τώρα που έχετε συνδέσει το δεύτερο πλαίσιο λίστας στη βάση δεδομένων και έχετε εφαρμόσει το φίλτρο, είστε έτοιμοι να ελέγξετε τα πλαίσια λίστας για να βεβαιωθείτε ότι λειτουργούν σωστά.

  1. Για να ελέγξετε τις αλλαγές σας, κάντε κλικ στην επιλογή Προεπισκόπηση στη Βασική γραμμή εργαλείων ή πατήστε το συνδυασμό πλήκτρων CTRL+SHIFT+B.

  2. Επιλέξτε μια τιμή στο πλαίσιο αναπτυσσόμενης λίστας. Το τυπικό πλαίσιο λίστας θα πρέπει να εμφανίζουν τις κατάλληλες τιμές από το δευτερεύοντα πίνακα, ανάλογα με το πεδίο σύνδεσης που επιλέξατε.

Συμβουλή: Εάν τα πλαίσια λίστας δεν λειτουργούν σωστά, ελέγξτε το φίλτρο για το δεύτερο πλαίσιο λίστας για να βεβαιωθείτε ότι συγκρίνει το πεδίο listBox1 με το πεδίο ΚωδΚατηγορίας.

Αρχή της ενότητας

Αρχή της σελίδας

Αναπτύξτε τις δεξιότητές σας στο Office
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×