Δημιουργία, εκτέλεση, επεξεργασία ή διαγραφή μιας μακροεντολής

ΣΗΜΑΝΤΙΚΟ: Αυτό το άρθρο προέρχεται από μηχανική μετάφραση, δείτε την αποποίηση ευθυνών. Θα βρείτε την αγγλική έκδοση του παρόντος άρθρου εδώ για αναφορά.

Για να εξοικονομήσετε χρόνο σε εργασίες που κάνετε συχνά, μπορείτε να καταγράψετε τα βήματα από αυτές τις εργασίες με μια μακροεντολή. Στη συνέχεια, όταν θέλετε να εκτελέσετε μία από αυτές τις εργασίες εγγραφής, μπορείτε να ενεργοποιήσετε τη μακροεντολή για να εκτελέσετε τα βήματα για εσάς.

Word

Στο Word 2016 για Mac, μπορείτε να δημιουργήσετε μια μακροεντολή που έχει μια συντόμευση πληκτρολογίου, να εκτελέσετε μια μακροεντολή και να διαγράψετε μια μακροεντολή που δεν χρειάζεστε πλέον.

  1. Κάντε κλικ στις επιλογές Προβολή > Μακροεντολές > Καταγραφή μακροεντολής.

    Στην καρτέλα προβολή, κάντε κλικ στο κουμπί μακροεντολής και, στη συνέχεια, κάντε κλικ στην επιλογή Καταγραφή μακροεντολής για να ξεκινήσετε τη δημιουργία μιας μακροεντολής.
  2. Πληκτρολογήστε ένα όνομα για τη μακροεντολή ή αποδεχτείτε την προεπιλεγμένη παρέχει που Word.

    Πληκτρολογήστε ένα όνομα για τη μακροεντολή σας στο πλαίσιο Όνομα μακροεντολής ή αποδεχθείτε το όνομα γενικής χρήσης που παρέχονται από το Word.
  3. Για να χρησιμοποιήσετε αυτήν τη μακροεντολή σε οποιαδήποτε νέα έγγραφα δημιουργήσετε, βεβαιωθείτε ότι Όλα τα έγγραφα (κανονική) είναι επιλεγμένο στη λίστα Αποθήκευση μακροεντολής σε.

  4. Κάντε κλικ στην επιλογή πληκτρολογίου για να εκχωρήσετε ένα συνδυασμό πλήκτρων για τη μακροεντολή σας.

    Word εμφανίζει το παράθυρο διαλόγου Προσαρμογή πληκτρολογίου.

  5. Πληκτρολογήστε ένα συνδυασμό πλήκτρων στο πλαίσιο πατήστε τη νέα συντόμευση πληκτρολογίου.

    Το Word εμφανίζει την εντολή ή τη μακροεντολή που έχουν ήδη ανατεθεί σε ένα συνδυασμό πλήκτρων, αν υπάρχουν, αφού πατήσετε το συνδυασμό.

    Όταν πατάτε το συνδυασμό πλήκτρων, Word εμφανίζει την εντολή ή ενέργεια που έχουν αντιστοιχιστεί σε αυτόν το συνδυασμό πλήκτρων, εάν υπάρχει.

  6. Εάν έχει ήδη αντιστοιχιστεί το συνδυασμό πλήκτρων που επιλέξατε, διαγράψτε το από το πλαίσιο πατήστε τη νέα συντόμευση πληκτρολογίου και, στη συνέχεια, επιλέξτε έναν νέο συνδυασμό πλήκτρων.

    Μεταβείτε στο επόμενο βήμα όταν βρείτε ένα συνδυασμό πλήκτρων που δεν έχουν αντιστοιχιστεί.

    Το Word προσδιορίζει όταν πατήσετε ένα συνδυασμό πλήκτρων που δεν έχουν ακόμα ανατεθεί σε μια εντολή ή μια μακροεντολή.
  7. Για να χρησιμοποιήσετε αυτήν τη συντόμευση πληκτρολογίου σε οποιαδήποτε νέα έγγραφα, είναι ότι Normal.dotm, στο καθολικό πρότυπο, είναι επιλεγμένο στη λίστα Αποθήκευση αλλαγών στο.

    Επιλέξτε Normal.dotm για να κάνετε μια μακροεντολή που είναι διαθέσιμη για χρήση σε νέα έγγραφα που δημιουργείτε.
  8. Κάντε κλικ στο κουμπί Αντιστοίχιση.

  9. Όταν είστε έτοιμοι για την καταγραφή της μακροεντολής, κάντε κλικ στο κουμπί OK.

  10. Κάντε κλικ στην επιλογή τις εντολές ή πατήστε τα πλήκτρα για κάθε βήμα στην εργασία.

    Word καταγράφει το κλικ και πατήματα πλήκτρων, αλλά δεν καταγράφει κείμενο που επιλέγετε με το ποντίκι. Για να επιλέξετε κείμενο κατά την καταγραφή μιας μακροεντολής, χρησιμοποιήστε το πληκτρολόγιο.

  11. Για να σταματήσετε την καταγραφή, κάντε κλικ στις επιλογές Προβολή > Μακροεντολές > Διακοπή καταγραφής.

    Στο μενού "μακροεντολές" για να διακόψετε την καταγραφή μιας μακροεντολής, κάντε κλικ στην επιλογή Διακοπή καταγραφής.

Για να εκτελέσετε μια μακροεντολή, πατήστε τη συντόμευση πληκτρολογίου που έχει εκχωρηθεί ή εκτελέσετε τη μακροεντολή από τη λίστα μακροεντολές.

  1. Κάντε κλικ στα στοιχεία Προβολή > Μακροεντολές > Προβολή μακροεντολών.

    Κάντε κλικ στην επιλογή Προβολή μακροεντολών για προβολή και επεξεργασία μακροεντολών που σχετίζεται με το τρέχον έγγραφο.
  2. Στη λίστα στην περιοχή όνομα μακροεντολής, επιλέξτε τη μακροεντολή που θέλετε να εκτελέσετε.

  3. Κάντε κλικ στο κουμπί Εκτέλεση.

    Αφού επιλέξετε μια μακροεντολή στην περιοχή όνομα μακροεντολής, κάντε κλικ στο κουμπί Εκτέλεση για να το εκτελέσετε.

  1. Κάντε κλικ στα στοιχεία Προβολή > Μακροεντολές > Προβολή μακροεντολών.

    Κάντε κλικ στην επιλογή Προβολή μακροεντολών για προβολή και επεξεργασία μακροεντολών που σχετίζεται με το τρέχον έγγραφο.
  2. Βεβαιωθείτε ότι στη θέση που καθορίζεται από μακροεντολές περιλαμβάνει τη θέση της μακροεντολής που θέλετε να διαγράψετε.

    Επιλέξτε τη θέση από τις μακροεντολές που θέλετε να προβάλετε από τις μακροεντολές στη λίστα.

    Η λίστα θα περιλαμβάνει το έγγραφο που είναι ανοιχτό στο τρέχον παράθυρο, καθώς και τις εντολές της καθολικού προτύπου και Word.

  3. Στην περιοχή όνομα μακροεντολής, επιλέξτε τη μακροεντολή που θέλετε να διαγράψετε και, στη συνέχεια, κάντε κλικ στο σύμβολο μείον κάτω από τη λίστα.

    Επιλέξτε τη μακροεντολή που θέλετε να διαγράψετε και, στη συνέχεια, κάντε κλικ στο σύμβολο πλην κάτω από τη λίστα.
  4. Όταν Word σας ζητάει να επιβεβαιώσετε ότι θέλετε να διαγράψετε τη μακροεντολή, κάντε κλικ στο κουμπί Ναι.

Excel

Στο Excel 2016 για Mac, μπορείτε να δημιουργήσετε μια μακροεντολή που έχει μια συντόμευση πληκτρολογίου, να εκτελέσετε μια μακροεντολή και να διαγράψετε μια μακροεντολή που δεν χρειάζεστε πλέον.

Κατά την καταγραφή μιας μακροεντολής, απαιτείται τις εγγραφές Καταγραφή μακροεντολής όλα τα βήματα για να ολοκληρώσετε τις ενέργειες που θέλετε να εκτελέσετε τη μακροεντολή σας. Αυτά τα βήματα μπορεί να περιλαμβάνει την πληκτρολόγηση κειμένου ή αριθμών, κάνοντας κλικ στην επιλογή κελιών ή εντολές στην κορδέλα ή στο μενού, μορφοποίηση, επιλογή κελιών, γραμμών ή στηλών και σύρετε το δείκτη του ποντικιού για να επιλέξετε τα κελιά σε υπολογιστικό φύλλο.

ΣΗΜΕΙΩΣΗ : Οι εντολές για την καταγραφή, τη δημιουργία και διαγραφή των μακροεντολών, καθώς και άλλες δυνατότητες για προχωρημένους, είναι επίσης διαθέσιμες στην καρτέλα " Προγραμματιστής " στην κορδέλα. Για περισσότερες πληροφορίες σχετικά με τη χρήση της καρτέλας προγραμματιστής, ανατρέξτε στο θέμα χρήση της καρτέλας "Προγραμματιστής" για να δημιουργήσετε ή να διαγράψετε μια μακροεντολή στο Excel 2016 για Mac.

  1. Επιλέξτε Εργαλεία > μακροεντολή > νέα εγγραφή.

    Επιλέξτε Εργαλεία, στη συνέχεια, μακροεντολή, στη συνέχεια, Καταγραφή νέας μακροεντολής

  2. Στο πλαίσιο Όνομα μακροεντολής, πληκτρολογήστε ένα όνομα για τη μακροεντολή.

    Εισαγάγετε ένα κλειδί όνομα, θέση και συντόμευση μακροεντολής

  3. Για να δημιουργήσετε μια συντόμευση πληκτρολογίου για τη μακροεντολή, πληκτρολογήστε ένα γράμμα στο πλαίσιο Option + Cmd.

  4. Επιλέξτε μια θέση για τη μακροεντολή από την αναπτυσσόμενη λίστα.

    Για να αποθηκεύσετε τη μακροεντολή

    Κάντε κλικ στην επιλογή

    Στο έγγραφο που θέλετε να δημιουργήσετε μακροεντολής σε

    Αυτό το βιβλίο εργασίας

    Σε όλα τα ανοιχτά έγγραφα

    Νέο βιβλίο εργασίας

    Για να είναι διαθέσιμη όταν χρησιμοποιείτε το Excel

    Βιβλίο προσωπικών μακροεντολών

  5. (Προαιρετικό) Προσθέστε μια περιγραφή για τη μακροεντολή σας.

  6. Όταν είστε έτοιμοι για την εγγραφή, κάντε κλικ στο κουμπί OK.

  7. Κάντε κλικ στην επιλογή τις εντολές ή πατήστε τα πλήκτρα για κάθε βήμα στην εργασία.

  8. Για να διακόψετε την καταγραφή, επιλέξτε Εργαλεία > μακροεντολή > Διακοπή καταγραφής. (Αυτό το βήμα δεν θα καταγραφεί στη μακροεντολή σας.)

    Επιλέξτε Διακοπή καταγραφής

Για να εκτελέσετε μια μακροεντολή, πατήστε τη συντόμευση πληκτρολογίου που έχει εκχωρηθεί ή εκτελέσετε τη μακροεντολή από το παράθυρο διαλόγου μακροεντολές.

  1. Στην καρτέλα Προβολή, επιλέξτε Προβολή μακροεντολών.

  2. Κάντε κλικ στην επιλογή μακροεντολές στο αναδυόμενο μενού και επιλέξτε Αυτό το βιβλίο εργασίας.

  3. Επιλέξτε τη μακροεντολή σας από τη λίστα και κάντε κλικ στην επιλογή Εκτέλεση.

    Το παράθυρο "Μακροεντολές" του Excel για Mac

  1. Επιλέξτε Εργαλεία > μακροεντολή > μακροεντολές.

    Επιλέξτε μακροεντολή και, στη συνέχεια, επιλέξτε μακροεντολές

  2. Επιλέξτε τη μακροεντολή για να διαγράψετε και, στη συνέχεια, πατήστε το σύμβολο πλην.

    Επιλέξτε όνομα μακροεντολής και, στη συνέχεια, επιλέξτε σύμβολο πλην

  3. Θα εμφανιστεί ένα μήνυμα επιβεβαίωσης. Κάντε κλικ στο κουμπί Ναι για να επιβεβαιώσετε τη διαγραφή.

    Επιβεβαίωση διαγραφής

Μπορείτε επίσης να διαγράψετε μια μακροεντολή από την καρτέλα Προγραμματιστής.

  1. Στην καρτέλα Προγραμματιστής, επιλέξτε Μακροεντολές.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να διαγράψετε και, στη συνέχεια, κάντε κλικ στο κουμπί διαγραφής.

    Επιλέξτε μια μακροεντολή και κάντε κλικ στο σύμβολο πλην για να τη διαγράψετε

Word

Για να αυτοματοποιήσετε μια επαναλαμβανόμενη εργασία, μπορείτε να δημιουργήσετε γρήγορα μια μακροεντολή στο Word. Μπορείτε επίσης να χρησιμοποιήσετε την Επεξεργασία Visual Basic στη Microsoft Visual Basic for Applications για να συντάξετε τη δική σας δέσμη ενεργειών μακροεντολής ή για να αντιγράψετε ολόκληρη ή μέρος μιας μακροεντολής σε μια νέα μακροεντολή.

Κατά την καταγραφή μιας μακροεντολής, καταγράφονται όλα τα βήματα που απαιτούνται για να ολοκληρώσετε τις ενέργειες που θέλετε να εκτελέσετε τη μακροεντολή σας. Ωστόσο, περιήγησης πίσω στην καρτέλα για να διακόψετε την καταγραφή δεν περιλαμβάνεται στα βήματα που καταγράφονται.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Καταγραφή.

    Καρτέλα "Προγραμματιστής" στο Word, ομάδα "Visual Basic"

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στο πλαίσιο Όνομα μακροεντολής, πληκτρολογήστε ένα όνομα για τη μακροεντολή.

  3. Στο αναδυόμενο μενού Αποθήκευση μακροεντολής σε, κάντε ένα από τα εξής:

    Για να αποθηκεύσετε τη μακροεντολή

    Κάντε κλικ στο στοιχείο

    Στο έγγραφο στο οποίο δημιουργείτε τη μακροεντολή

    [όνομα εγγράφου] (έγγραφο)

    Σε όλα τα ανοιχτά έγγραφα

    Όλα τα έγγραφα (Κανονικό)

  4. Επιλέξτε OK και, στη συνέχεια, εκτελέστε τις ενέργειες που θέλετε να καταγράψετε.

  5. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Διακοπή.

Μπορείτε να χρησιμοποιήσετε την ενσωματωμένη Επεξεργασία Visual Basic για να δημιουργήσετε μια μακροεντολή.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Πρόγραμμα επεξεργασίας.

    Καρτέλα "Προγραμματιστής" στο Word, ομάδα "Visual Basic"

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Εάν θέλετε να εισαγάγετε μια λειτουργική μονάδα, στην Επεξεργασία Visual Basic, στο μενού Εισαγωγή, κάντε κλικ στην επιλογή Λειτουργική μονάδα.

  3. Στο παράθυρο κώδικα της λειτουργικής μονάδας, πληκτρολογήστε ή αντιγράψτε τον κώδικα μακροεντολής που θέλετε να χρησιμοποιήσετε.

  4. Όταν τελειώσετε, στο μενού του Word, κάντε κλικ στην επιλογή Κλείσιμο και επιστροφή στο Microsoft Word.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο Word, ομάδα "Visual Basic"

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να εκτελέσετε και, στη συνέχεια, κάντε κλικ στην επιλογή Εκτέλεση.

Για να επεξεργαστείτε μια μακροεντολή, χρησιμοποιήστε την Επεξεργασία Visual Basic.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο Word, ομάδα "Visual Basic"

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να επεξεργαστείτε και, στη συνέχεια, κάντε κλικ στην επιλογή Επεξεργασία.

    Ανοίγει η Επεξεργασία Visual Basic.

  3. Κάντε τις αλλαγές που θέλετε.

  4. Όταν τελειώσετε, στο μενού του Word, κάντε κλικ στην επιλογή Κλείσιμο και επιστροφή στο Microsoft Word.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο Word, ομάδα "Visual Basic"

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να αντιγράψετε και, στη συνέχεια, κάντε κλικ στην επιλογή Επεξεργασία.

    Ανοίγει η Επεξεργασία Visual Basic.

  3. Στο παράθυρο κώδικα του προγράμματος επεξεργασίας Visual Basic, επιλέξτε τις γραμμές της μακροεντολής που επιθυμείτε να αντιγράψετε.

    Συμβουλή: Για να αντιγράψετε ολόκληρη τη μακροεντολή, συμπεριλάβετε στην επιλογή τις γραμμές Sub και End Sub.

  4. Από το μενού Edit, κάντε κλικ στην εντολή Copy.

  5. Στο πλαίσιο Έργο, του παραθύρου κώδικα, κάντε κλικ στη λειτουργική μονάδα όπου θέλετε να τοποθετηθεί ο κώδικας.

  6. Στο μενού Edit, κάντε κλικ στην εντολή Paste.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο Word, ομάδα "Visual Basic"

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να διαγράψετε και, στη συνέχεια, κάντε κλικ στην επιλογή Διαγραφή.

PowerPoint

Για την αυτοματοποίηση μιας επαναλαμβανόμενης εργασίας, μπορείτε να χρησιμοποιήσετε Visual Basic for Applications για να δημιουργήσετε ένα μακροεντολή στο PowerPoint.

Μπορείτε να χρησιμοποιήσετε την ενσωματωμένη Επεξεργασία Visual Basic για να δημιουργήσετε μια μακροεντολή.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Πρόγραμμα επεξεργασίας.

    Καρτέλα "Προγραμματιστής" στο PowerPoint, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Εάν θέλετε να εισαγάγετε μια λειτουργική μονάδα, στην Επεξεργασία Visual Basic, στο μενού Εισαγωγή, κάντε κλικ στην επιλογή Λειτουργική μονάδα.

  3. Στο παράθυρο κώδικα της λειτουργικής μονάδας, πληκτρολογήστε ή αντιγράψτε τον κώδικα μακροεντολής που θέλετε να χρησιμοποιήσετε.

  4. Όταν τελειώσετε, στο μενού του PowerPoint, κάντε κλικ στην επιλογή Κλείσιμο και επιστροφή στο Microsoft PowerPoint.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο PowerPoint, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να εκτελέσετε και, στη συνέχεια, κάντε κλικ στην επιλογή Εκτέλεση.

Για να επεξεργαστείτε μια μακροεντολή, χρησιμοποιήστε την Επεξεργασία Visual Basic.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο PowerPoint, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να επεξεργαστείτε και, στη συνέχεια, κάντε κλικ στην επιλογή Επεξεργασία.

    Ανοίγει η Επεξεργασία Visual Basic.

  3. Κάντε τις αλλαγές που θέλετε.

  4. Όταν τελειώσετε, στο μενού του PowerPoint, κάντε κλικ στην επιλογή Κλείσιμο και επιστροφή στο Microsoft PowerPoint.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο PowerPoint, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να αντιγράψετε και, στη συνέχεια, κάντε κλικ στην επιλογή Επεξεργασία.

    Ανοίγει η Επεξεργασία Visual Basic.

  3. Στο παράθυρο κώδικα του προγράμματος επεξεργασίας Visual Basic, επιλέξτε τις γραμμές της μακροεντολής που επιθυμείτε να αντιγράψετε.

    Συμβουλή: Για να αντιγράψετε ολόκληρη τη μακροεντολή, συμπεριλάβετε στην επιλογή τις γραμμές Sub και End Sub.

  4. Από το μενού Edit, κάντε κλικ στην εντολή Copy.

  5. Στο πλαίσιο Έργο, του παραθύρου κώδικα, κάντε κλικ στη λειτουργική μονάδα όπου θέλετε να τοποθετηθεί ο κώδικας.

  6. Στο μενού Edit, κάντε κλικ στην εντολή Paste.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο PowerPoint, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να διαγράψετε και, στη συνέχεια, κάντε κλικ στην επιλογή Διαγραφή.

Excel

Για να αυτοματοποιήσετε μια επαναλαμβανόμενη εργασία, μπορείτε να δημιουργήσετε γρήγορα μια μακροεντολή στο Excel. Μπορείτε επίσης να χρησιμοποιήσετε την Επεξεργασία Visual Basic στη Microsoft Visual Basic for Applications για να συντάξετε τη δική σας δέσμη ενεργειών μακροεντολής ή για να αντιγράψετε ολόκληρη ή μέρος μιας μακροεντολής σε μια νέα μακροεντολή.

Καταγράφονται όλα τα βήματα που απαιτούνται για να ολοκληρώσετε τις ενέργειες που θέλετε να εκτελεί η μακροεντολή σας. Ωστόσο, η επιστροφή στην καρτέλα για να σταματήσει η καταγραφή δεν περιλαμβάνεται στα βήματα που καταγράφονται.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Καταγραφή.

    Καρτέλα "Προγραμματιστής" στο Excel, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στο πλαίσιο Όνομα μακροεντολής, πληκτρολογήστε ένα όνομα για τη μακροεντολή.

    Συμβουλή: Για να δημιουργήσετε μια συντόμευση πληκτρολογίου για τη μακροεντολή, πληκτρολογήστε ένα γράμμα στο πλαίσιο Option+Cmd+.

  3. Στο αναδυόμενο μενού Αποθήκευση μακροεντολής σε, κάντε ένα από τα εξής:

    Για να αποθηκεύσετε τη μακροεντολή

    Κάντε κλικ στο στοιχείο

    Στο έγγραφο στο οποίο δημιουργείτε τη μακροεντολή

    Αυτό το βιβλίο εργασίας

    Σε όλα τα ανοιχτά έγγραφα

    Νέο βιβλίο εργασίας

    Για να είναι διαθέσιμη όταν χρησιμοποιείτε το Excel

    Βιβλίο προσωπικών μακροεντολών

    Βιβλίο προσωπικών μακροεντολών βρίσκεται στην χρήστες / όνομα_χρήστη/βιβλιοθήκη/εφαρμογή υποστηρίζει / Microsoft/Office Excel.

  4. Επιλέξτε OK και, στη συνέχεια, εκτελέστε τις ενέργειες που θέλετε να καταγράψετε.

  5. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ ξανά στην επιλογή Καταγραφή.

Μπορείτε να χρησιμοποιήσετε την ενσωματωμένη Επεξεργασία Visual Basic για να δημιουργήσετε μια μακροεντολή.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Πρόγραμμα επεξεργασίας.

    Καρτέλα "Προγραμματιστής" στο Excel, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Εάν θέλετε να εισαγάγετε μια λειτουργική μονάδα, στην Επεξεργασία Visual Basic, στο μενού Εισαγωγή, κάντε κλικ στην επιλογή Λειτουργική μονάδα.

  3. Στο παράθυρο κώδικα της λειτουργικής μονάδας, πληκτρολογήστε ή αντιγράψτε τον κώδικα μακροεντολής που θέλετε να χρησιμοποιήσετε.

  4. Όταν τελειώσετε, στο μενού του Excel, κάντε κλικ στην επιλογή Κλείσιμο και επιστροφή στο Microsoft Excel.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο Excel, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να εκτελέσετε και, στη συνέχεια, κάντε κλικ στην επιλογή Εκτέλεση.

    Συμβουλή: Για να εκτελέσετε μια μακροεντολή, χρησιμοποιώντας μια συντόμευση πληκτρολογίου, πατήστε OPTION + COMMAND +το γράμμα που πληκτρολογήσατε κατά τη δημιουργία της συντόμευσης πληκτρολογίου.

Για να επεξεργαστείτε μια μακροεντολή, χρησιμοποιήστε την Επεξεργασία Visual Basic.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο Excel, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να επεξεργαστείτε και, στη συνέχεια, κάντε κλικ στην επιλογή Επεξεργασία.

    Ανοίγει η Επεξεργασία Visual Basic.

  3. Κάντε τις αλλαγές που θέλετε.

  4. Όταν τελειώσετε, στο μενού του Excel, κάντε κλικ στην επιλογή Κλείσιμο και επιστροφή στο Microsoft Excel.

Αφού ολοκληρώσετε αυτή τη διαδικασία, η μακροεντολή θα εκτελείται κάθε φορά που ανοίγετε το βιβλίο εργασίας που περιέχει τη μακροεντολή.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Καταγραφή.

    Καρτέλα "Προγραμματιστής" στο Excel, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στο πλαίσιο Όνομα μακροεντολής, πληκτρολογήστε Auto_Open.

  3. Στο αναδυόμενο μενού Αποθήκευση μακροεντολής σε, κάντε ένα από τα εξής:

    Για να αποθηκεύσετε τη μακροεντολή

    Κάντε κλικ στο στοιχείο

    Στο έγγραφο στο οποίο δημιουργείτε τη μακροεντολή

    Αυτό το βιβλίο εργασίας

    Σε όλα τα ανοιχτά έγγραφα

    Νέο βιβλίο εργασίας

    Για να είναι διαθέσιμη όταν χρησιμοποιείτε το Excel

    Βιβλίο προσωπικών μακροεντολών

  4. Επιλέξτε OK και, στη συνέχεια, εκτελέστε τις ενέργειες που θέλετε να καταγράψετε.

  5. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ ξανά στην επιλογή Καταγραφή.

  6. Στο μενού Αρχείο, κάντε κλικ στην επιλογή Αποθήκευση ως.

  7. Στο αναδυόμενο μενού Μορφοποίηση, κάντε κλικ στην επιλογήΒιβλίο εργασίας του Excel με δυνατότητα μακροεντολών (.xlsm) και, στη συνέχεια, κάντε κλικ στην επιλογή Αποθήκευση.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο Excel, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να αντιγράψετε και, στη συνέχεια, κάντε κλικ στην επιλογή Επεξεργασία.

    Ανοίγει η Επεξεργασία Visual Basic.

  3. Στο παράθυρο κώδικα του προγράμματος επεξεργασίας Visual Basic, επιλέξτε τις γραμμές της μακροεντολής που επιθυμείτε να αντιγράψετε.

    Συμβουλή: Για να αντιγράψετε ολόκληρη τη μακροεντολή, συμπεριλάβετε στην επιλογή τις γραμμές Sub και End Sub.

  4. Από το μενού Edit, κάντε κλικ στην εντολή Copy.

  5. Στο πλαίσιο Έργο, του παραθύρου κώδικα, κάντε κλικ στη λειτουργική μονάδα όπου θέλετε να τοποθετηθεί ο κώδικας.

  6. Στο μενού Edit, κάντε κλικ στην εντολή Paste.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο Excel, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να διαγράψετε και, στη συνέχεια, κάντε κλικ στην επιλογή Διαγραφή.

ΣΗΜΕΙΩΣΗ : Αποποίηση ευθυνών αυτόματης μετάφρασης: Αυτό το άρθρο έχει μεταφραστεί από ένα σύστημα υπολογιστή χωρίς ανθρώπινη παρέμβαση. Η Microsoft προσφέρει αυτές τις αυτόματες μεταφράσεις για να βοηθά τους μη αγγλόφωνους χρήστες να απολαμβάνουν περιεχόμενο σχετικά με προϊόντα, υπηρεσίες και τεχνολογίες της Microsoft. Το άρθρο προέρχεται από μηχανική μετάφραση, συνεπώς ενδέχεται να περιέχει λάθη λεξιλογίου, σύνταξης ή γραμματικής.

Αναπτύξτε τις δεξιότητές σας
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×