Βήμα 4 - Μοιραστείτε τη μακροεντολή σας με άλλους

Το σημαντικό στοιχείο που πρέπει να κατανοήσετε για την κοινή χρήση μακροεντολών είναι ότι αποθηκεύονται στο αρχείο του Office, επομένως θα πρέπει να θέσετε σε κοινή χρήση αυτό το αρχείο με τους άλλους χρήστες. Εάν δημιουργήσατε μια μακροεντολή στο Word, θα πρέπει να θέσετε σε κοινή χρήση το αρχείο ως "Πρότυπο του Word με δυνατότητα μακροεντολών (.dotm)" ή "Έγγραφο του Word με δυνατότητα μακροεντολών (.docm)". Εάν δημιουργήσατε τη μακροεντολή στο Excel, θα πρέπει να θέσετε σε κοινή χρήση το αρχείο ως "Βιβλίο εργασίας του Excel με δυνατότητα μακροεντολών (.xlsm)" ή "Πρότυπο του Excel με δυνατότητα μακροεντολών (.xltm)".

Εάν δημιουργήσατε μια μακροεντολή στο Word, υπάρχουν μερικά επιπλέον βήματα που θα πρέπει να κάνετε για να θέσετε σε κοινή χρήση τη μακροεντολή σας:

Δημιουργία κενού προτύπου του Word

  1. Ανοίξτε ένα νέο έγγραφο του Word.

  2. Από το μενού Αρχείο, κάντε κλικ στην εντολή Αποθήκευση ως.

  3. Ονομάστε το αρχείο global_macros.dotm.

  4. Από την αναπτυσσόμενη λίστα Μορφοποίηση, επιλέξτε "Πρότυπο του Word με δυνατότητα μακροεντολών (*.docm)" ως Μορφή.

  5. Επιλέξτε το σημείο όπου θέλετε να αποθηκεύσετε το αρχείο στο δίκτυό σας.

  6. Κάντε κλικ στην επιλογή Αποθήκευση και, στη συνέχεια, κλείστε το πρότυπο.

Εξαγωγή της μακροεντολής του Word από το έγγραφό σας

Με τη μακροεντολή που καταγράψατε στο βήμα 1, ακολουθήστε τα επόμενα βήματα για να εξαγάγετε τη μακροεντολή:

  1. Ανοίξτε το έγγραφο ή το πρότυπο που περιέχει τη μακροεντολή που θέλετε να εξαγάγετε.

  2. Στο μενού Εργαλεία, τοποθετήστε το δείκτη του ποντικιού στην επιλογή Μακροεντολή και, στη συνέχεια, κάντε κλικ στην επιλογή Μακροεντολές.

  3. Επιλέξτε τη μακροεντολή που θέλετε να εξαγάγετε και, στη συνέχεια, κάντε κλικ στην επιλογή Επεξεργασία. Επιλέξτε μακροεντολή για εξαγωγή

  4. Στην Επεξεργασία Visual Basic, κάντε κλικ στις επιλογές Αρχείο > Εξαγωγή αρχείου.

  5. Αποθηκεύστε τη μακροεντολή στον ίδιο φάκελο με το πρότυπο με δυνατότητα μακροεντολών global_macros.dotm.

Εισαγωγή της μακροεντολής του Word στο νέο κενό πρότυπο

  1. Ανοίξτε το global_macros.dotm και, στη συνέχεια, κάντε κλικ στις επιλογές Εργαλεία > Μακροεντολής > Επεξεργασία Visual Basic.

  2. Για να εισαγάγετε τη μακροεντολή, κάντε κλικ στις επιλογές Αρχείο > Εισαγωγή αρχείου, μεταβείτε στο φάκελο όπου έχετε εξαγάγει τη μακροεντολή σας, επιλέξτε το αρχείο και, στη συνέχεια, κάντε κλικ στο κουμπί Άνοιγμα.

  3. Αποθηκεύστε τη λειτουργική μονάδα, κλείστε την Επεξεργασία Visual Basic και, στη συνέχεια, κλείστε το Word.

Τώρα μπορείτε να θέσετε σε κοινή χρήση τη μακροεντολή σας με άλλους χρήστες και να τους πείτε να ακολουθήσουν τα παρακάτω βήματα για να εγκαταστήσουν τη μακροεντολή στον υπολογιστή τους.

Εγκατάσταση του προτύπου: ρύθμιση του Word για χρήση της μακροεντολής σας

  1. Τοποθετήστε το αρχείο global_macro.dotm σε αυτή τη θέση:

    • Word για Mac 2011: Macintosh HD: Χρήστες: Όνομα χρήστη: Βιβλιοθήκη: Υποστήριξη εφαρμογών: Microsoft: Office: Πρότυπα χρήστη: Τα πρότυπά μου

    • Word 2003 για Windows ή νεότερη έκδοση: C:\Έγγραφα και ρυθμίσεις\Όνομα_χρήστη\Δεδομένα εφαρμογών\Microsoft\Word\ΕΚΚΙΝΗΣΗ

      ΣΗΜΕΙΩΣΗ :  Το Όνομα_χρήστη είναι το όνομα σύνδεσης του χρήστη.

  2. Στο Word, κάντε κλικ στις επιλογές Word > Προτιμήσεις....

Προτιμήσεις του Word

  1. Στην ενότητα Προσωπικές ρυθμίσεις, κάντε κλικ στην επιλογή Θέσεις αρχείων

  2. Επιλέξτε Εκκίνηση από τη λίστα Θέσεις αρχείων και, στη συνέχεια, κάντε κλικ στην επιλογή Τροποποίηση....

Θέση αρχείου

  1. Επιβεβαιώστε ότι το Word χρησιμοποιεί τον ίδιο φάκελο όπου τοποθετήσατε το αρχείο global_macro.dotm ως φάκελο εκκίνησης.

  2. Κάντε κλικ στο στοιχείο Επιλογή για να κλείσετε το παράθυρο διαλόγου Επιλογή φακέλου και, στη συνέχεια, στο κουμπί OK για να κλείσετε το παράθυρο διαλόγου "Θέσεις αρχείων".

Το τελευταίο βήμα είναι να πείτε στο Word να χρησιμοποιεί το αρχείο global_macros.dotm κατά την εκκίνησή.

  1. Στο Word, κάντε κλικ στις επιλογές Εργαλεία > Πρότυπα και πρόσθετα.

  2. Επιλέξτε το αρχείο global_macros.dotm από τη λίστα και κάντε κλικ στο κουμπί OK.

    Συμβουλή:  Εάν δεν βλέπετε το πρότυπο στη λίστα, αυτό σημαίνει ότι το αρχείο global_macros.dotm δεν βρίσκεται στο φάκελο εκκίνησης του Word. Επιστρέψτε στο βήμα 1 αυτής της ενότητας και βεβαιωθείτε ότι ο φάκελος Εκκίνηση είναι ο ίδιος φάκελος με εκείνον όπου αντιγράψατε το αρχείο global_macros.dotm.

Ορισμός του Καθολικού προτύπου στο Word

 Βήμα 1 - Αρχίστε με την καταγραφή μακροεντολής

Βήμα 2 - Διαβάστε και κατανοήστε τον κώδικα

Βήμα 3 - Μάθετε τα βασικά στοιχεία του προγραμματισμού

Βήμα 4 - Μοιραστείτε τη μακροεντολή σας με άλλους

Βήμα 5 - Πραγματικά παραδείγματα

Αναπτύξτε τις δεξιότητές σας
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×