WENNFEHLER (Funktion)

Sie können die Funktion WENNFEHLER verwenden, um Fehler in einer Formel aufzufangen und zu behandeln. WENNFEHLER gibt einen Wert zurück, den Sie angeben, wenn eine Formel einen Fehler ergibt; Andernfalls wird das Ergebnis der Formel zurückgegeben.

Syntax

WENNFEHLER(Wert;Wert_falls_Fehler)

Die Syntax der Funktion WENNFEHLER weist die folgenden Argumente auf:

  • Wert    Erforderlich. Das Argument, das auf einen Fehler geprüft wird

  • value_if_error    Erforderlich. Der Wert, der zurückgegeben werden soll, wenn die Formel zu einem Fehler ausgewertet wird. Die folgenden Fehlertypen werden ausgewertet: #N/a, #Value!, #ref!, #DIV/0!, #Num!, #Name? oder #NULL!.

Hinweise

  • Wenn Wert oder value_if_error eine leere Zelle ist, wird Sie von WENNFEHLER als leerer Zeichenfolgenwert ("") behandelt.

  • Ist Wert eine Matrixformel, gibt WENNFEHLER ein Array von Ergebnissen für jede Zelle in dem in value angegebenen Bereich zurück. Betrachten Sie hierzu das zweite Beispiel unten.

Beispiele

Kopieren Sie die Beispieldaten in der folgenden Tabelle, und fügen Sie sie in Zelle A1 eines neuen Excel-Arbeitsblatts ein. Um die Ergebnisse der Formeln anzuzeigen, markieren Sie sie, drücken Sie F2 und dann die EINGABETASTE.

Kontingent

Verkaufte Einheiten

210

35

55

0

23

Formel

Beschreibung

Ergebnis

=WENNFEHLER(A2/B2;"Berechnungsfehler")

Sucht in der Formel nach einem Fehler im ersten Argument (210 durch 35 dividieren), findet keinen Fehler, und gibt dann das Ergebnis der Formel zurück.

6

=WENNFEHLER(A3/B3;"Berechnungsfehler")

Sucht in der Formel nach einem Fehler im ersten Argument (55 durch 0 dividieren), findet den Fehler "Division durch 0", und gibt dann den "Wert_falls_Fehler" zurück.

Berechnungsfehler

=WENNFEHLER(A4/B4;"Berechnungsfehler")

Sucht in der Formel nach einem Fehler im ersten Argument ("" durch 23 dividieren), findet keinen Fehler, und gibt dann das Ergebnis der Formel zurück.

0

Beispiel 2

Kontingent

Verkaufte Einheiten

Verhältnis

210

35

6

55

0

Berechnungsfehler

23

0

Formel

Beschreibung

Ergebnis

=C2

Sucht in der Formel nach einem Fehler im ersten Argument des ersten Elements der Matrix (A2/B2 oder 210 durch 35 dividieren), findet keinen Fehler, und gibt dann das Ergebnis der Formel zurück.

6

=C3

Sucht in der Formel nach einem Fehler im ersten Argument des zweiten Elements der Matrix (A3/B3 oder 55 durch 0 dividieren), findet den Fehler "Division durch 0" und gibt dann "Wert_falls_Fehler" zurück.

Berechnungsfehler

=C4

Sucht in der Formel nach einem Fehler im ersten Argument des dritten Elements der Matrix (A4/B4 oder "" durch 23 dividieren), findet keinen Fehler, und gibt dann das Ergebnis der Formel zurück.

0

Hinweis: Wenn Sie über eine aktuelle Version von Office 365verfügen, können Sie die Formel in der oberen linken Zelle des Ausgabebereichs eingeben und dann die EINGABETASTE drücken, um die Formel als dynamische Matrixformel zu bestätigen. Andernfalls muss die Formel als Legacy-Matrixformel eingegeben werden, indem Sie zunächst den Ausgabebereich auswählen, die Formel in der oberen linken Zelle des Ausgabebereichs eingeben und dann STRG + UMSCHALT + EINGABETASTE drücken, um die Formel zu bestätigen. Excel fügt geschweifte Klammern am Anfang und am Ende der Formel ein. Weitere Informationen zu Matrixformeln finden Sie unter Richtlinien und Beispiele für Matrixformeln.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Hinweis:  Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Lassen Sie uns bitte wissen, ob diese Informationen hilfreich für Sie waren. Hier finden Sie den englischen Artikel als Referenz.

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×