Formeln und Funktionen

WENN (Funktion)

WENN-Funktion

Die WENN-Funktion ist eine der am häufigsten verwendeten Funktionen in Excel. Sie ermöglicht den logischen Vergleich zwischen einem aktuellen Wert und einem erwarteten Wert.

Daher kann eine WENN-Anweisung zwei Ergebnisse haben. Das erste Ergebnis wird ausgegeben, wenn der Vergleich wahr ist, das zweite, wenn der Vergleich falsch ist.

Beispiel: Bei "=WENN(C2="Ja";1;2)" lautet die Anweisung: WENN(C2 = Ja, 1 zurückgeben, andernfalls 2 zurückgeben).

Ihr Browser unterstützt kein Video. Installieren Sie Microsoft Silverlight, Adobe Flash Player oder Internet Explorer 9.

Verwenden Sie die Funktion WENN, eine der logischen Funktionen, um einen Wert zurückzugeben, wenn eine Bedingung erfüllt ist, und ein anderen Wert, wenn die Bedingung nicht erfüllt ist.

WENN(Prüfung;Dann_Wert;[Sonst_Wert])

Beispiel:

  • =WENN(A2>B2;"Budget überschritten";"OK")

  • =WENN(A2=B2;B4-A4;"")

Argumentname

Beschreibung

Prüfung    (erforderlich)

Die zu prüfende Bedingung.

Dann_Wert    (erforderlich)

Der Wert, der zurückgegeben werden soll, wenn das Ergebnis des Wahrheitstests WAHR ist.

Sonst_Wert    (optional)

Der Wert, der zurückgegeben werden soll, wenn das Ergebnis des Wahrheitstests FALSCH ist.

Einfache Beispiele für die WENN-Funktion

Zelle D2 enthält die Formel =WENN(C2="Ja";1;2)
  • =WENN(C2="JA";1;2)

Im vorstehenden Beispiel lautet die Anweisung in Zelle D2: WENN(C2 = Ja, gib 1 zurück, andernfalls gib 2 zurück)

Zelle D2 enthält die Formel =WENN(C2=1;"JA";"NEIN")
  • =WENN(C2=1;"Ja";"Nein")

In diesem Beispiel lautet die Formel in Zelle D2 wie folgt: WENN(C2 = 1 ist, gib "Ja" zurück, andernfalls "Nein")Wie Sie sehen, kann die WENN-Funktion zum Auswerten von Text und Werten verwendet werden. Sie kann auch zum Auswerten von Fehlern verwendet werden. Sie sind nicht darauf beschränkt zu prüfen, ob ein Wert gleich einem anderen ist, sodass ein einziges Ergebnis zurückgegeben wird, Sie können auch mathematische Operatoren verwenden und abhängig von Ihren Kriterien weitere Berechnungen anstellen. Sie können auch mehrere WENN-Funktionen schachteln, um mehrere Vergleiche anzustellen.

Die Formel in Zelle D2 lautet =WENN(C2>B2;"Über Budget";"In Budget")
  • =WENN(C2>B2;"Budget überschritten";"In Budget")

Im vorstehenden Beispiel besagt die WENN-Funktion in D2 Folgendes: WENN(C2 größer als B2 ist, gib "Budget überschritten" zurück, andernfalls "In Budget")

Die Formel in Zelle E2 lautet =WENN(C2>B2;C2-B2;"")
  • =WENN(C2>B2;C2-B2;0)

In der vorstehenden Abbildung wird anstelle eines Textergebnisses eine mathematische Berechnung zurückgegeben. Die Formel in E2 besagt also: WENN(der aktuelle Wert größer als der budgetierte Wert ist, subtrahiere den budgetierten Wert vom aktuellen Wert, andernfalls gib nichts zurück).

Die Formel in Zelle F7 lautet WENN(E7="Ja";F5*0,0825;0)
  • =WENN(E7="Ja";F5*0,0825;0)

In diesem Beispiel besagt die Formel in F7 Folgendes: WENN(E7 gleich "Ja" ist, multipliziere die Gesamtsumme in F5 mit 8,25%. Andernfalls ist keine Umsatzsteuer fällig, also gib 0 zurück).

Hinweis: Wenn Sie Text in Formeln verwenden, müssen Sie den Text in Anführungszeichen setzen (z. B. "Text"). Die einzige Ausnahme ist die Verwendung von WAHR und FALSCH, was von Excel automatisch verstanden wird.

Häufig auftretende Probleme

Problem

Ursache

0 (Null) in der Zelle

Es ist entweder für Wert_wenn_wahr oder für Wert_wenn_falsch kein Argument angegeben. Damit der richtige Wert zurückgegeben wird, fügen Sie Argumenttext zu den beiden Argumenten hinzu, oder geben Sie WAHR oder FALSCH für das Argument an.

#NAME? in der Zelle

Dies bedeutet normalerweise, dass die Formel falsch geschrieben wurde.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Siehe auch

Berechnungsoperatoren und Rangfolge in Excel

Verwenden von verschachtelten Funktionen in einer Formel

Verwenden von WENN, um zu prüfen, ob eine Zelle leer ist

Verwenden von WENN, um zu prüfen, ob eine Zelle leer ist

Video: Erweiterte WENN-Funktionen

Funktion WENNS (Office 365, Excel 2016 und höher)

Erweiterte WENN-Funktionen – Arbeiten mit geschachtelten Formeln und Vermeiden von Fallgruben

Schulungsvideos: Erweiterte WENN-Funktionen

Die Funktion ZÄHLENWENN zählt Werte basierend auf einem einzelnen Kriterium

Die Funktion ZÄHLENWENNS zählt Werte basierend auf mehreren Kriterien

Die Funktion SUMMEWENN addiert Werte basierend auf einem einzelnen Kriterium

Die Funktion SUMMEWENNS addiert Werte basierend auf mehreren Kriterien

UND (Funktion)

ODER

SVERWEIS (Funktion)

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Ermitteln von Fehlern in Formeln

Logische Funktionen

Excel-Funktionen (alphabetisch)

Excel-Funktionen (nach Kategorie)

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×