Wegweiser: Anzeigen einer mit Daten verbundenen Visio-Zeichnung in einem SharePoint-Webpart

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Wichtig    Wir empfehlen nicht mehr die Nutzung von Visio Services und des Visio Web Access-Webparts auf SharePoint Online. Verwenden Sie ab jetzt Visio Online zum Anzeigen von Visio-Diagrammen und Erstellen von Visio-Mashups-Lösungen im Web. Weitere Informationen finden Sie unter Visio Services in SharePoint Online – Roadmap. In SharePoint Server werden diese Features in Übereinstimmung mit der Microsoft Lifecycle-Richtlinie weiterhin unterstützt.

Wenn Sie ausführliche Informationen für viele Personen schnell vorführen müssen, erstellen Sie ein Visio-Diagramm als SharePoint-Webpart, das visuelle Berichte bereitstellt. Visio 2010 ermöglicht das Abrufen von Daten aus externen Quellen wie Excel Services, SQL Server, SharePoint-Listen oder anderen OLEDB-oder ODBC-Datenbanken. Sie können dann Datengrafiken auf die Shapes in der Zeichnung anwenden, um diese externen Daten zu visualisieren, die Zeichnung auf einer SharePoint-Website zu veröffentlichenund dann ein Visio Web Access-Webpart zum Anzeigen des Diagramms auf der SharePoint-Website zu verwenden.

Dies eignet sich ideal zum Erstellen benutzerdefinierter Dashboards für umfangreiche Business Intelligence-Lösungen. Entscheidungsträger können eine visuelle Darstellung der Unternehmensleistung auf einen Blick sehen und diese Informationen schnell bearbeiten. Weitere Informationen zur Verwendung von SharePoint for Business Intelligence finden Sie im Artikel Was ist SharePoint Business Intelligence?

HerunterLaden des visuellen Leitfadens

Ihr Browser unterstützt kein Video. Installieren Sie Microsoft Silverlight, Adobe Flash Player oder Internet Explorer 9.

Inhalt dieses Artikels

Anforderungen

Schritt 1: Importieren von Daten in die Visio-Zeichnung

Schritt 2: Anwenden von Datengrafiken auf Formen

Schritt 3: Anzeigen des Diagramms in einem SharePoint-Webpart

Optional: HinzuFügen von Interaktivität zum Visio Web Access-Webpart

Anforderungen

Das Visio Web Access-Webpart ist ein Feature von Visio Services, einem in Microsoft SharePoint Server 2010 enthaltenen Dienst. Um Visio Services verwenden zu können, müssen Sie über Microsoft SharePoint Server 2010 Enterprise Client Access License (ECAL) verfügen, und Visio Services muss bereitgestellt werden, damit Sie verwendet werden können.

Darüber hinaus müssen Sie über Microsoft Visio Professional 2010 oder Microsoft Visio Premium 2010 verfügen, um ein Diagramm auf einer SharePoint-Website speichern zu können.

Weitere Informationen dazu, was Sie tun müssen, um Visio Services auf einer SharePoint-Website zu aktivieren, finden Sie unter Visio-Grafik Dienstverwaltung.

Seitenanfang

Schritt 1: Importieren von Daten in die Visio-Zeichnung

  1. Klicken Sie in Visio auf der Registerkarte Daten in der Gruppe externe Daten auf Daten mit Shapes verknüpfen.

Wählen Sie auf der ersten Seite des Assistenten DatenAuswahl die Datenquelle aus, die Sie verwenden möchten.

Wichtig: Access Services kann nicht als Datenquelle für eine Visio Services-webZeichnung verwendet werden. Einige Diagrammtypen, z. b. "Pivotdiagrammen", können nicht aktualisiert werden, wenn Sie auf der SharePoint-Website veröffentlicht werden. Um optimale Ergebnisse zu erzielen, stellen Sie sicher, dass die Datenquelle auf der gleichen SharePoint-Website wie das Visio Services-Webpart gespeichert wird.

  1. BeFolgen Sie die Anweisungen im Assistenten DatenAuswahl.

  2. Nachdem Sie auf der letzten Seite des Datenauswahl-Assistenten auf " Ende " geklickt haben, wird das Fenster externe Daten mit den importierten Daten in einer Tabelle angezeigt.

  3. Wenn Sie Daten aus der externen Quelle auf ein Shape in der Zeichnung anwenden möchten, ziehen Sie eine Zeile aus dem Fenster externe Daten auf das Shape.

Weitere Informationen zum Importieren von Daten aus einer externen Datenquelle in Visio finden Sie unter Importieren von Daten aus Excel, SQL Server, SharePoint-Websites und anderen externen Quellen.

Seitenanfang

Schritt 2: Anwenden von Datengrafiken auf Formen

Gehen Sie wie folgt vor, um eine neue Datengrafik zu erstellen:

  1. Klicken Sie in Visio auf der Registerkarte Daten in der Gruppe Daten anzeigen auf Datengrafiken, und klicken Sie dann auf Neue Datengrafik erstellen.

  2. Gehen Sie im Dialogfeld Neues Element folgendermaßen vor:

    1. Klicken Sie unter Anzeige in der Liste Datenfeld auf das Shape-Datenfeld, das visuell dargestellt werden soll.

    2. Wählen Sie auch unter Anzeige in der Liste angezeigt als die Grafik aus, die das Datenfeld am besten darstellt(Text, Datenbalken, Symbolsatz oder Farbe nach Wert ).

    3. Wählen Sie auch unter Anzeige in der Liste Formatvorlage die gewünschte Formatvorlage aus. (Wenn Sie als Grafiktyp "Farbe nach Wert" auswählen, ist dies die Liste der Farb Methoden.)

    4. Passen Sie die Grafik unter Details nach Wunsch an.

    5. Wenn Sie die Bearbeitung des Grafikelements abgeschlossen haben, klicken Sie auf OK.

  3. WiederHolen Sie den vorherigen Schritt, bis Sie für alle Shape-Datenfelder, die Sie anzeigen möchten, ein Element erstellt haben.

Gehen Sie wie folgt vor, um eine Datengrafik auf Shapes in der Zeichnung anzuwenden:

  1. Wählen Sie auf dem Zeichenblatt das Shape aus, auf das Sie die Datengrafik anwenden möchten.

Hinweis: Wenn Sie mehrere Shapes auf dem Zeichenblatt auswählen möchten, halten Sie die STRG-Taste gedrückt, und wählen Sie dann die einzelnen Shapes aus, auf die Sie die Datengrafik anwenden möchten.

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Daten anzeigen auf Datengrafiken, und klicken Sie dann unter Verfügbare Datengrafiken auf die gewünschte Datengrafik.

Weitere Informationen zum Erstellen und Anwenden von Datengrafiken finden Sie unter Optimieren von Daten mit Datengrafiken.

Seitenanfang

Schritt 3: Anzeigen des Diagramms in einem SharePoint-Webpart

  1. Klicken Sie auf der SharePoint-Website Seite, der Sie das Webpart hinzufügen möchten, auf der Registerkarte Seite in der Gruppe Bearbeiten auf Bearbeiten.

  2. Klicken Sie unter Bearbeitungs Tools auf der Registerkarte Einfügen in der Gruppe Webparts auf Webpart, und gehen Sie dann folgendermaßen vor:

    1. Klicken Sie unter Kategorien auf Geschäftsdaten.

    2. Klicken Sie unter Webparts auf Visio Web Access.

    3. Klicken Sie auf Hinzufügen.

  3. Klicken Sie im Visio Web Access-Webpart auf den Link, um den Toolbereich zu öffnen.

  4. Erweitern Sie im Toolbereich die Option webzeichnungs Anzeige, und navigieren Sie dann im Feld webzeichnungs- URL zu der Visio-webzeichnung, die Sie anzeigen möchten.

Wichtig: Bevor Sie Visio Web Access zum Anzeigen des Diagramms in einem Webpart verwenden können, müssen Sie die Visio-Datei auf der SharePoint-Website als webZeichnung veröffentlichen. Weitere Informationen zum Veröffentlichen einer Visio-webzeichnung auf einer SharePoint-Website finden Sie unter Roadmap: Veröffentlichen von Visio-Zeichnungen auf einer SharePoint-Website.

  1. Klicken Sie unten im Toolbereich auf über nehmen, und klicken Sie dann auf OK.

Weitere Informationen zum Anzeigen einer Visio-webzeichnung in einem Webpart finden Sie unter Anzeigen einer Visio-webzeichnung in einem Webpart.

Seitenanfang

Optional: HinzuFügen von Interaktivität zum Visio Web Access-Webpart

Wenn Sie ECMAScript schreiben können, können Sie das Visio Web Access-Webpart so anpassen, dass es visuelle Overlays enthält, die zusätzliche Informationen zu den Shapes in der Visio-Zeichnung anzeigen.

Weitere Informationen zum Programmieren eines interaktiven Elements für eine Visio-Zeichnung auf einer Webparts-Seite finden Sie unter MSDN: Erstellen einer ECMAScript-Mashup-Zeichnung in Visio 2010, die in SharePoint Server 2010 angezeigt werden soll.

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×