Verwenden von SUMMENPRODUKT zum Addieren des Produkts korrespondierender Werte in einer oder mehreren Matrizen

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

SUMMENPRODUKT verwendet die Zellbereiche (oder Arrays) als Argumente (die Teile der Formel, die in diesem Fall). Multipliziert, die Elemente in den Arrays zusammen, und klicken Sie dann das Ergebnis addiert.

Diese Beispiel enthält ein Lebensmittelliste. In der ersten Matrix werden die Kosten für jeden Artikel aufgeführt, in der zweiten Matrix wird angegeben, wie viele Artikel eingekauft werden sollen.

Preise und Mengen, die zu multiplizieren und dann zu addieren sind

  1. Um die Formel zu erstellen, geben Sie =SUMMENPRODUKT(B3:B6;C3:C6) ein , und drücken Sie die EINGABETASTE.

Jede Zelle in Spalte B wird nun mit der jeweils entsprechenden Zelle in der gleichen Zeile in Spalte C multipliziert, und die Ergebnisse werden addiert. Der Gesamtbetrag für Lebensmittel beläuft sich demnach auf 21,60 Euro.

  1. Zum Schreiben einer längeren Formel gibt, die Ihnen das gleiche Ergebnis, Typ = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6 und drücken die EINGABETASTE.

Nachdem Sie die EINGABETASTE gedrückt haben, erhalten Sie dasselbe Ergebnis: 21,60 Euro. Zelle B3 wird mit C3 multipliziert, und das Ergebnis wird zum Ergebnis von Zelle B4 multipliziert mit Zelle C4 usw. addiert. Sie können sich sicher vorstellen, wie viel einfacher die Verwendung der Funktion SUMMENPRODUKT ist, wenn Sie tausende (oder auch nur hunderte) von Zeilen verarbeiten müssen.

Hinweise: 

  • Die Spalten oder Zeilen (Matrizen) müssen dieselbe Länge aufweisen.

  • Befindet sich in einer Zelle Text anstelle einer Zahl, wird als Wert 0 angenommen.

Beispiel

Wenn Sie mit der Funktion SUMMENPRODUKT und Matrizenexperimentieren möchten, hier eine Arbeitsmappe Excel Online mit unterschiedlichen Daten als in diesem Artikel verwendeten.

Kopieren Sie die Beispieldaten in der folgenden Tabelle, und fügen Sie sie in Zelle A1 eines neuen Excel-Arbeitsblatts ein. Um die Ergebnisse der Formeln anzuzeigen, markieren Sie sie, drücken Sie F2 und dann die EINGABETASTE. Im Bedarfsfall können Sie die Breite der Spalten anpassen, damit alle Daten angezeigt werden.

A

B

D

E

3

4

2

7

8

6

6

7

1

9

5

3

Formel

Ergebnis

'=SUMMENPRODUKT(A2:B4;D2:E4)

=SUMMENPRODUKT(A2:B4;D2:E4)

Multipliziert alle Elemente in den beiden Matrizen (A2:B4 und D2:E4) und summiert anschließend die Produkte: 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156).

Für eine umfassendere zur Verfügung steht können Sie auch diese Arbeitsmappe in Excel öffnen. Klicken Sie einfach auf das Excel-Symbol in der unteren rechten Ecke der Arbeitsmappe, Excel-Symbol in Excel Web App , speichern Sie die Datei an einem geeigneten Ort auf Ihrem Computer, und öffnen Sie sie.

Seitenanfang

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×