Verwenden von Funktionen und verschachtelten Funktionen in Excel-Formeln

Funktionen sind vordefinierte Formeln, die Berechnungen mithilfe bestimmter Werte, der so genannten Argumente, und in einer bestimmten Reihenfolge oder Struktur ausführen. Funktionen können für einfache oder komplexe Berechnungen verwendet werden. Alle Excel-Funktionen finden Sie auf der Registerkarte "Formeln" im Menüband:

Die Excel-Registerkarte "Formeln" im Menüband
  • Funktionssyntax in Excel

    Das folgende Beispiel, in dem mit der Funktion RUNDEN die Zahl in Zelle A10 abgerundet wird, zeigt die Syntax einer Funktion.

    Struktur einer Funktion

    1. Struktur. Die Struktur einer Funktion beginnt mit einem Gleichheitszeichen (=) gefolgt von dem Funktionsnamen, einer öffnenden Klammer, den durch Semikola getrennten Argumenten der Funktion und einer schließenden Klammer.

    2. Funktionsname. Um eine Liste der verfügbaren Funktionen zu erhalten, klicken Sie auf eine Zelle, und drücken Sie UMSCHALT+F3. Dadurch wird das Dialogfeld Funktion einfügen geöffnet.

    Excel-Formeln – Dialogfeld "Funktion einfügen"

    3. Argumente. Argumente können Zahlen, Text, logische Werte wie WAHR oder FALSCH, Matrizen, Fehlerwerte wie #NV oder Zellbezüge sein. Das Argument, das Sie benennen, muss einen für dieses Argument gültigen Wert ergeben. Argumente können auch Konstanten, Formeln oder andere Funktionen sein.

    4. Argument-QuickInfo. Während Sie die Funktion eingeben, wird eine QuickInfo mit der Syntax und den Argumenten eingeblendet. Wenn Sie beispielsweise =RUNDEN( eingeben, wird die QuickInfo angezeigt. QuickInfos werden nur für integrierte Funktionen angezeigt.

    Hinweis: Sie brauchen Funktionen nicht in Großbuchstaben einzugeben (z. B. =RUNDEN), da Excel automatisch den Namen der Funktion in Großschreibung umwandelt, sobald Sie die EINGABETASTE drücken. Wenn Sie den Namen einer Funktion falsch schreiben, z. B. =SUME(A1:A10) anstelle von = SUMME(A1:A10), gibt Excel den Fehler #NAME? zurück.

  • Eingeben von Excel-Funktionen

    Wenn Sie eine Formel erstellen, die eine Funktion enthält, können Sie das Dialogfeld Funktion einfügen verwenden, das die Eingabe von Arbeitsblattformeln erleichtert. Wenn Sie im Dialogfeld Funktion einfügen eine Funktion auswählen, wird in Excel ein Funktions-Assistent gestartet, der den Namen der Funktion, alle zugehörigen Argumente, eine Beschreibung der Funktion und der einzelnen Argumente, das aktuelle Ergebnis der Funktion und das aktuelle Ergebnis der gesamten Formel enthält.

    Funktions-Assistent in Excel

    Wenn Sie das Erstellen und Bearbeiten von Formeln erleichtern und das Risiko von Eingabe- und Syntaxfehlern minimieren möchten, verwenden Sie AutoVervollständigen für Formeln. Nachdem Sie ein = (Gleichheitszeichen) und die Anfangsbuchstaben einer Funktion eingegeben haben, zeigt Excel eine dynamische Dropdownliste mit gültigen Funktionen, Argumenten und Namen an, die den Buchstaben entsprechen. Sie können dann ein Element aus der Dropdownliste auswählen, und Excel fügt es in die Formel ein.

    Excel-Funktion "AutoVervollständigen für Formeln"

  • Verschachteln von Excel-Funktionen

    In bestimmten Fällen müssen Sie möglicherweise eine Funktion als eines der Argumente einer anderen Funktion verwenden. In der folgenden Formel wird beispielsweise die verschachtelte Funktion MITTELWERT verwendet und anschließend das Ergebnis mit dem Wert 50 verglichen.

    Verschachtelte Funktionen

    1. Die Funktionen MITTELWERT und SUMME werden in der Funktion WENN verschachtelt.

    Gültige Rückgabewerte    Wenn eine verschachtelte Funktion als Argument verwendet wird, muss die verschachtelte Funktion den gleichen Werttyp wie das Argument zurückgeben. Wenn das Argument z  B. WAHR oder FALSCH zurückgibt, muss die verschachtelte Funktion ebenfalls einen Wert vom Typ WAHR oder FALSCH zurückgeben. Wenn dies nicht der Fall ist, zeigt Excel den Fehlerwert #WERT! an.

    Grenzen von Verschachtelungsebenen    Eine Formel kann bis zu sieben Ebenen verschachtelter Funktionen umfassen. Wenn eine Funktion (z. B. Funktion B) als Argument in einer anderen Funktion (z. B. Funktion A) verwendet wird, ist Funktion B eine Funktion zweiter Ebene. Beispielsweise sind die beiden Funktionen MITTELWERT und SUMME Funktionen der zweiten Ebene, wenn sie als Argumente der Funktion WENN verwendet werden. Eine verschachtelte Funktion innerhalb der verschachtelten Funktion MITTELWERT ist dann eine Funktion dritter Ebene usw.

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×