Verwenden Sie die Werte aus einer SQL Server-Datenbank zum Auffüllen eines Listenfelds, Dropdown-Listenfeld oder Kombinationsfeld

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Sie können ein Listenfeld, Dropdown-Listenfeld oder Kombinationsfeld mit Daten aus eine Verbindung zum Abfragen von Daten in einer Microsoft SQL Server-Datenbank füllen.

Inhalt dieses Artikels

(Übersicht)

Vorbemerkung

Schritt 1: Hinzufügen einer Verbindungs zum Abfragen von Daten

Schritt 2: Konfigurieren des Steuerelements

Übersicht

Ein Listenfeld, Dropdown-Listenfeld oder Kombinationsfeld zeigt Elemente, die ein Benutzer auswählen können, beim Ausfüllen eines Formulars, das auf Ihrer Formularvorlage basiert. Sie können diese Typen von Steuerelementen zum Anzeigen von Daten aus einer sekundäre Datenquelle einer Microsoft SQL Server-Datenbank konfigurieren. Eine sekundäre Datenquelle ist eine beliebige Datenverbindung mit einer externen Datenquelle, die Sie einer Formularvorlage hinzufügen, damit Benutzer, die auf dieser Formularvorlage basierende Formulare auszufüllen Abrufen von Daten aus oder Daten in einer externen Datenquelle, beispielsweise einem Webdienst senden können.

Wenn Sie eine sekundäre Datenquelle, die in Abfragen von Daten zur Formularvorlage, Microsoft Office InfoPath erstellt eine sekundäre Datenquelle mit Datenfelder und Gruppen hinzufügen, die die Daten so entspricht, werden in der Datenbank gespeichert. Die Verbindung zum Abfragen von Daten Ruft Daten aus dem Webdienst ab und speichert die Daten in der sekundäre Datenquelle des Formulars. Standardmäßig ist die Daten in der sekundäre Datenquelle verfügbar, während der Benutzer mit einem Netzwerk verbunden sind. Sie können konfigurieren, dass die sekundäre Datenquelle, um die Ergebnisse der Abfrage auf den Computern der Benutzer zu speichern, damit sie haben Zugriff auf die Daten, wenn ihre Form nicht mit einem Netzwerk verbunden ist.

Sicherheitshinweis: Wenn Sie eine sekundäre Datenquelle verwenden, um vertrauliche Daten aus einer externen Datenquelle abzurufen, möchten Sie möglicherweise helfen, die Daten vor unbefugtem Zugriff schützen, falls der Computer verloren gegangen sind oder gestohlen wird diese Funktion deaktivieren. Wenn Sie dieses Feature deaktivieren, werden die Daten nur verfügbar, wenn der Benutzer mit dem Netzwerk verbunden ist.

Da die Datenstruktur in der sekundären Datenquelle wie übereinstimmen muss Daten in der Datenbank gespeichert ist, können nicht Sie vorhandene Felder oder Gruppen in der sekundäre Datenquelle ändern. Finden Sie Links zu weiteren Informationen über datenverbindungen und Datenquellen im Abschnitt Siehe auch.

Seitenanfang

Vorbemerkung

Bevor Sie die Werte aus einer SQL Server-Datenbank zum Füllen eines Steuerelements in der Formularvorlage verwenden können, benötigen Sie die folgende Informationen vom Datenbankadministrator:

  • Der Name des Servers mit der Datenbank, die mit der Formularvorlage soll verwendet werden.

  • Der Name der Datenbank, die mit der Formularvorlage soll verwendet werden.

  • Von der Datenbank erforderliche Authentifizierung. Die Datenbank kann entweder Microsoft Windows-Authentifizierung oder SQL Server-Authentifizierung verwenden, um festzustellen, wie Benutzer die Datenbank zugreifen können.

  • Der Name der Tabelle, die die Daten enthält, die Sie dem Formular senden möchten. Dies ist die primäre Tabelle. Wenn Sie mehr als eine Tabelle in der Datenbank verwenden möchten, benötigen Sie die Namen der anderen, untergeordneten Tabellen. Sie benötigen ferner die Namen der Felder in der untergeordneten Tabellen mit Beziehungen in den Feldern in der primären Tabelle.

  • Gibt an, ob Sie sicher die Ergebnisse der Abfrage auf den Computern der Benutzer für die Offlineverwendung speichern können.

Seitenanfang

Schritt 1: Hinzufügen einer Verbindungs zum Abfragen von Daten

Wenn Sie nicht mit eine bestehenden Verbindung zum Abfragen von Daten verfügen, die Sie in der Formularvorlage verwenden können, folgendermaßen Sie vor, um eine sekundäre Datenquelle zur Formularvorlage diese Daten Abfragen hinzuzufügen. Weist die Formularvorlage bereits eine sekundäre Datenquelle, die Sie verwenden können, können Sie diesen Abschnitt überspringen und wechseln Sie zu Schritt2: Konfigurieren des Steuerelements.

  1. Klicken Sie im Menü Extras auf Datenverbindungen.

  2. Klicken Sie im Dialogfeld Datenverbindungen auf Hinzufügen.

  3. Klicken Sie in den Datenverbindungs-Assistenten auf eine neue Verbindung zu erstellen, klicken Sie auf Daten empfangen, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten klicken Sie auf Datenbank (Microsoft SQL Server oder Microsoft Office Access), und klicken Sie dann auf Weiter.

  5. Klicken Sie auf der nächsten Seite des Assistenten auf Datenbank auswählen.

  6. Klicken Sie im Dialogfeld Datenquelle auswählen auf Neue Quelle.

  7. Klicken Sie auf der nächsten Seite des Assistenten, in der Liste welche Art von Datenquelle möchten Sie Herstellen einer Verbindung mit klicken Sie auf Microsoft SQL Server, und klicken Sie dann auf Weiter.

  8. Geben Sie im Feld Servername den Namen des Servers mit SQL Server-Datenbank ein.

  9. Führen Sie unter Anmeldeinformationen eine der folgenden Aktionen aus:

    • Wenn die Datenbank bestimmt, wer basierend auf den Anmeldeinformationen, die in einem Microsoft Windows-Netzwerk verwendeten zugreifen kann, klicken Sie auf Windows-Authentifizierung verwenden.

    • Wenn die Datenbank bestimmt, wer Zugriff auf der Basis einer angegebenen Benutzernamen und Ihr Kennwort ein, das Sie von der Datenbankadministrator abrufen kann, klicken Sie auf den folgenden Benutzernamen und das Kennwort verwenden, und geben Sie dann Ihren Benutzernamen und Ihr Kennwort in den Benutzernamen und Kennwort Felder.

  10. Klicken Sie auf Weiter.

  11. Klicken Sie in der Liste Wählen Sie die Datenbank, die die Daten enthält auf den Namen der Datenbank, die Sie verwenden möchten, verwenden Sie auf mit einer bestimmten Tabelle verbinden, klicken Sie auf den Namen der primären Tabelle, und klicken Sie dann auf Weiter.

  12. Klicken Sie auf der nächsten Seite des Assistenten in das Feld Dateiname einen Namen für die Datei, die Verbindungsinformationen gespeichert, und klicken Sie dann auf Fertig stellen, um diese Einstellungen zu speichern.

    Wenn Sie beabsichtigen, anderen Tabellen in der Verbindung zum Abfragen von Daten verwenden, können Sie die anderen Tabellen auf dieser Seite des Assistenten hinzufügen.

    Fügen Sie weiterer Tabellen hinzu

    1. Klicken Sie auf Tabelle hinzufügen.

    2. Klicken Sie im Dialogfeld Tabelle oder Abfrage hinzufügen klicken Sie auf den Namen der untergeordneten Tabelle, und klicken Sie dann auf Weiter. InfoPath versucht, die Beziehungen festlegen, indem Sie Feldnamen in beiden Tabellen. Wenn Sie nicht die vorgeschlagenen Beziehung verwenden möchten, wählen Sie die Beziehung aus, und klicken Sie dann auf Beziehung entfernen. Wenn Sie eine Beziehung hinzufügen möchten, klicken Sie auf Beziehung hinzufügen. Klicken Sie im Dialogfeld Beziehung hinzufügen klicken Sie auf den Namen der einzelnen verknüpften Felder in der jeweiligen Spalte, und klicken Sie dann auf OK.

    3. Klicken Sie auf Fertig stellen.

    4. Um weitere untergeordnete Tabellen hinzuzufügen, wiederholen Sie diese Schritte aus.

  13. Klicken Sie auf Weiter.

  14. Wenn die Ergebnisse der Abfrage mit der Formularvorlage speichern möchten, wählen Sie das Kontrollkästchen Kopie der Daten in der Formularvorlage speichern aus. Dadurch werden die Abfrageergebnisse in der Formularvorlage gespeichert. Becuase, die die Daten in der Formularvorlage gespeichert werden. die Daten sind in den Formularen, die Benutzer ausfüllen verfügbar, auch wenn ihre Computer nicht mit einem Netzwerk verbunden sind.

    Sicherheitshinweis: Dadurch werden die Abfrageergebnisse in der Formularvorlage gespeichert. Da die Daten in der Formularvorlage gespeichert ist, ist es in den Formularen, die Benutzer ausfüllen verfügbar, auch wenn ihre Computer nicht mit einem Netzwerk verbunden sind. Wenn dieser Verbindung sensible Daten wiedergegeben werden, können Sie dieses Feature zum Schutz die Daten, falls der Computer verloren gegangen sind oder gestohlen wird deaktivieren möchten.

  15. Klicken Sie auf Weiter.

  16. Geben Sie auf der nächsten Seite des Assistenten einen beschreibenden Namen für diese sekundäre Datenquelle aus. Wenn Sie möchten das Formular, um Daten automatisch zu erhalten, wenn das Formular geöffnet wird, wählen Sie das Kontrollkästchen Daten beim Öffnen des Formulars automatisch abrufen.

Seitenanfang

Schritt 2: Konfigurieren des Steuerelements

  1. Wenn die Formularvorlage mehrere Ansichten aufweist, klicken Sie auf Ansichtsname im Menü Ansicht zum Wechseln Sie zur Ansicht mit dem Steuerelement, wo Sie die Daten aus der sekundäre Datenquelle anzeigen möchten.

  2. Doppelklicken Sie auf das Listenfeld, Dropdown-Listenfeld oder Kombinationsfeld-Steuerelement, das Sie füllen möchten.

  3. Klicken Sie auf die Registerkarte Daten.

  4. Klicken Sie im Feld ListeneinträgeNachschlagen von Werten aus einer externen Datenquelle aus.

  5. Klicken Sie in der Liste Datenquelle auf die Datenquelle, die Sie verwenden möchten.

  6. Klicken Sie auf XPath festlegen Schaltfläche (Symbol) neben dem Feld Einträge.

  7. Geben Sie im Dialogfeld Feld oder Gruppe auswählen welche Daten für den Benutzer angezeigt werden sollen und welche Daten an die externe Datenquelle gesendet werden soll, indem Sie eine der folgenden Aktionen aus.

    Geben Sie an, dass die Daten, die dem Benutzer angezeigt wird, den gleichen Daten ist, die vom Benutzer übermittelt werden

    • Klicken Sie auf ein Feld, und klicken Sie dann auf OK.

    Geben Sie an, dass die Daten, die dem Benutzer angezeigt wird aus den Daten unterscheidet, die vom Benutzer übermittelt werden

    Hinweis: In diesem Szenario die Daten, die dem Benutzer angezeigt wird aus einem der Felder in der Gruppe, und die Daten, die vom Benutzer übermittelt werden in einem anderen Feld in derselben Gruppe ist.

    1. Klicken Sie auf eine Gruppe aus, und klicken Sie dann auf OK.

    2. Klicken Sie im Dialogfeld Steuerelementeigenschaften auf XPath festlegen Schaltfläche (Symbol) neben dem Feld Wert.

    3. Klicken Sie im Dialogfeld Feld oder Gruppe auswählen auf ein Feld, das die Daten enthält, dass der Benutzer an die externe Datenquelle senden, und klicken Sie dann auf OK.

    4. Klicken Sie im Dialogfeld Steuerelementeigenschaften auf XPath festlegen Schaltfläche (Symbol) neben dem Feld Anzeigename.

    5. Klicken Sie im Dialogfeld Feld oder Gruppe auswählen auf ein Feld, das die Daten, die im Steuerelement angezeigt wird enthält, und klicken Sie dann auf OK.

  8. Wenn das Feld in das Feld Anzeigename Werte mit ähnlichen Anzeigenamen weist und nur eindeutige Namen angezeigt werden soll, aktivieren Sie das Kontrollkästchen nur Einträge mit eindeutigen Anzeigenamen anzeigen.

Seitenanfang

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×