Verwenden Sie die Werte aus einer Access-Datenbank zum Auffüllen eines Listenfelds, Dropdown-Listenfeld oder Kombinationsfeld

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

In einem InfoPath-Formular können Sie Füllen eines Listenfelds, Dropdown-Listenfeld oder Kombinationsfeld mit Daten aus eine Verbindung zum Abfragen von Daten in einer Datenbank Microsoft Office Access 2007 (ACCDB) oder einer Access-Datenbank, die in einer früheren Version (MDB-Format) gespeichert wurde.

Inhalt dieses Artikels

(Übersicht)

Kompatibilität Aspekte

Vorbemerkung

Schritt 1: Hinzufügen einer Verbindungs zum Abfragen von Daten

Schritt 2: Konfigurieren des Steuerelements

Optional: Einrichten eines Filters zum Einschränken der Elemente im Steuerelement

Übersicht

Ein Listenfeld, Dropdown-Listenfeld oder Kombinationsfeld zeigt Elemente, die Benutzer beim Ausfüllen eines InfoPath-Formulars auswählen können. Wenn Sie eine Formularvorlage entwerfen, können Sie diese Typen von Steuerelementen zum Anzeigen von Daten aus einer sekundäre Datenquelle in einer Access-Datenbank konfigurieren.

Eine sekundäre Datenquelle ist eine beliebige Datenverbindung mit einer externen Datenquelle, die Sie einer Formularvorlage hinzufügen. Sie können sekundäre datenverbindungen zum Abrufen von Daten, die Ihre Benutzer benötigen, um das Ausfüllen von Formularen, die auf Ihrer Formularvorlage basieren oder Daten aus einer externen Datenquelle, beispielsweise einem Webdienst Formular senden konfigurieren.

Wenn Sie eine sekundäre Datenquelle die Daten Abfragen zur Formularvorlage hinzufügen, erstellt InfoPath eine sekundäre Datenquelle, die enthält Datenfelder und Gruppen, die Art und Weise entsprechen, dass die Daten in der Datenbank gespeichert ist. Die Verbindung zum Abfragen von Daten Ruft Daten aus dem Webdienst ab und anschließend die Daten in sekundäre Datenquelle des Formulars gespeichert.

Sie können konfigurieren, dass die sekundäre Datenquelle, um die Ergebnisse der Abfrage auf den Computern der Benutzer speichern, damit diese Benutzer haben Zugriff auf die Daten, auch wenn ihre Computer nicht mit einem Netzwerk verbunden sind. Je nach Art der Daten sollten Sie den Abfrageergebnissen angezeigt werden, nur, wenn Benutzer mit einem Netzwerk verbunden sind.

Sicherheitshinweis: Wenn Sie eine sekundäre Datenquelle verwenden, um vertrauliche Daten aus einer externen Datenquelle abzurufen, möchten Sie möglicherweise helfen, die Daten vor unbefugtem Zugriff schützen, falls der Computer verloren gegangen sind oder gestohlen wird diese Funktion deaktivieren. Wenn Sie dieses Feature deaktivieren, werden die Daten nur verfügbar, wenn der Benutzer mit dem Netzwerk verbunden ist.

Wenn Sie die Anzahl der Elemente in einem Listenfeld-Steuerelement beschränken möchten, können Sie eine Filter verwenden. Verwenden Sie einen Filter, wenn Sie müssen eine Teilmenge der Daten angezeigt werden, die von einer Abfrage zurückgegeben wird, die basierend auf Kriterien, die von einem Benutzer ausgewählt ist. Diese Kriterien Hiermit werden können, die in ein anderes Steuerelement (z. B. ein Listenfeld, Kombinationsfeld, Dropdown-Listenfeld oder Textfeld) markiert ist, das mit einem Feld in der Datenquelle gebunden ist.

Da die Datenstruktur in der sekundären Datenquelle wie übereinstimmen muss Daten in der Datenbank gespeichert ist, können nicht Sie vorhandene Felder oder Gruppen in der sekundäre Datenquelle ändern. Finden Sie Links zu weiteren Informationen über datenverbindungen und Datenquellen in diesem Artikel im Abschnitt Siehe auch.

Seitenanfang

Überlegungen zur Kompatibilität

Sie können eine Verbindung zum Abfragen von Daten in einer Access-Datenbank nur, wenn Sie eine Formularvorlage entwerfen, der keiner Browserkompatible Formularvorlage hinzufügen.

Seitenanfang

Vorbemerkung

Bevor Sie die Werte aus einer Access-Datenbank zum Füllen eines Steuerelements in der Formularvorlage verwenden können, benötigen Sie die folgende Informationen vom Datenbankadministrator:

  • Der Name und Speicherort der Datenbank.

    Hinweis: Wenn andere Benutzer im Netzwerk Formularen, die auf dieser Formularvorlage basieren erstellt werden, stellen Sie sicher, dass Ihre Datenbank für diesen Benutzer zugegriffen werden kann.

  • Der Name der Tabelle oder Abfrage aus, die die Werte für die Steuerelemente bereitstellt. Verwenden Sie diese Tabelle oder Abfrage als die primäre Tabelle, wenn Sie die Verbindung zum Abfragen von Daten konfigurieren.

  • Die Namen der anderen Tabellen oder Abfragen, aus denen die primäre Tabelle oder Abfrage Daten erfordern möglicherweise. In den meisten Fällen sind die tabellenbeziehungen in der Datenbank bereits eingerichtet. Wenn Sie die Beziehungen zwischen der primären Tabelle oder Abfrage und einer anderen Tabelle oder Abfrage manuell herstellen müssen, benötigen Sie die zugehörigen Feldnamen der beiden Tabellen oder Abfragen.

Seitenanfang

Schritt 1: Hinzufügen einer Verbindungs zum Abfragen von Daten

Wenn Sie nicht mit eine bestehenden Verbindung zum Abfragen von Daten verfügen, die Sie in der Formularvorlage verwenden können, verwenden Sie das folgende Verfahren, eine sekundäre Datenquelle, die Daten Abfragen zur Formularvorlage hinzufügen. Weist die Formularvorlage bereits eine sekundäre Datenquelle, die Sie verwenden können, können Sie diesen Abschnitt überspringen und wechseln Sie zu Schritt2: Konfigurieren des Steuerelements.

  1. Klicken Sie im Menü Extras auf Datenverbindungen.

  2. Klicken Sie im Dialogfeld Datenverbindungen auf Hinzufügen.

  3. Klicken Sie in den Datenverbindungs-Assistenten auf eine neue Verbindung zu erstellen, klicken Sie auf Daten empfangen, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten klicken Sie auf Datenbank (Microsoft SQL Server oder Microsoft Office Access), und klicken Sie dann auf Weiter.

  5. Klicken Sie auf der nächsten Seite des Assistenten auf Datenbank auswählen.

  6. Navigieren Sie im Dialogfeld Datenquelle auswählen auf den Speicherort der Datenbank.

    Hinweis: Wenn die Datenbank in einem Speicherort im Netzwerk gespeichert ist, navigieren Sie zu der universal naming Convention (UNC)) Pfad des Speicherorts. Nicht zum Netzwerkspeicherort über eine zugeordnete Netzlaufwerk navigieren. Wenn Sie ein Netzlaufwerk verwenden (die einen Buchstaben auf einem Netzlaufwerk, z. B. h oder z zuweisen, wird), werden für die Datenbank auf die bestimmte zugeordneten Netzlaufwerk Formulare, die Benutzer erstellen, die auf dieser Formularvorlage basieren suchen. Wenn der Benutzer nicht auf genau die gleiche Weise zugeordneten Netzlaufwerk verfügt, wird das Formular die Datenbank nicht finden.

  7. Klicken Sie auf den Namen der Datenbank, und klicken Sie dann auf Öffnen.

  8. Klicken Sie im Dialogfeld Tabelle auswählen klicken Sie auf die primäre Tabelle oder Abfrage, die Sie verwenden möchten, und klicken Sie dann auf OK.

  9. Wählen Sie auf der nächsten Seite des Assistenten das Kontrollkästchen Tabellenspalten anzeigen aus.

    Standardmäßig werden alle Felder in der Tabelle oder Abfrage in der primären Datenquelle der Formularvorlage hinzugefügt.

  10. Deaktivieren Sie die Kontrollkästchen für die Felder, die Sie nicht in der primären Datenquelle einschließen möchten.

  11. Fügen Sie weitere Tabellen oder Abfragen, die in der Verbindung zum Abfragen von Daten enthalten sein sollen.

    So wird's gemacht

    1. Klicken Sie auf Tabelle hinzufügen.

    2. Klicken Sie im Dialogfeld Tabelle oder Abfrage hinzufügen klicken Sie auf den Namen der untergeordneten Tabelle, und klicken Sie dann auf Weiter. InfoPath versucht, die Beziehungen festlegen, indem Sie Feldnamen in beiden Tabellen. Wenn Sie nicht die vorgeschlagenen Beziehung verwenden möchten, wählen Sie die Beziehung aus, und klicken Sie dann auf Beziehung entfernen. Wenn Sie eine Beziehung hinzufügen möchten, klicken Sie auf Beziehung hinzufügen. Klicken Sie im Dialogfeld Beziehung hinzufügen klicken Sie auf den Namen der einzelnen verknüpften Felder in der jeweiligen Spalte, und klicken Sie dann auf OK.

    3. Klicken Sie auf Fertig stellen.

    4. Um weitere untergeordnete Tabellen hinzuzufügen, wiederholen Sie diese Schritte aus.

  12. Klicken Sie auf Weiter.

  13. Wenn die Ergebnisse der Abfrage Datenverbindung verfügbar, wenn das Formular nicht mit einem Netzwerk verbunden ist, wählen Sie das Kontrollkästchen Kopie der Daten in der Formularvorlage speichern aus.

    Sicherheitshinweis: Das Aktivieren des Kontrollkästchens speichert die Daten auf dem Computer des Benutzers, wenn das Formular diese Datenverbindung verwendet. Wenn das Formular vertrauliche Daten aus dieser Verbindung abgerufen werden, sollten Sie so deaktivieren Sie dieses Feature zum Schutz die Daten, falls der Computer verloren gegangen sind oder gestohlen wird oder erfolgt andernfalls durch nicht autorisierte Benutzer.

  14. Klicken Sie auf Weiter.

  15. Klicken Sie auf der nächsten Seite des Assistenten geben Sie einen beschreibenden Namen für diese sekundäre Datenquelle, und vergewissern Sie sich, dass die Informationen im Abschnitt Zusammenfassung korrekt sind.

  16. Zum Konfigurieren des Formulars, um Daten automatisch zu erhalten, wenn es geöffnet wird, wählen Sie das Kontrollkästchen Daten beim Öffnen des Formulars automatisch abrufen.

Seitenanfang

Schritt 2: Konfigurieren des Steuerelements

  1. Wenn die Formularvorlage mehrere Ansichten aufweist, klicken Sie auf Ansichtsname im Menü Ansicht zum Wechseln Sie zur Ansicht mit dem Steuerelement, wo Sie die Daten aus der sekundäre Datenquelle anzeigen möchten.

  2. Doppelklicken Sie auf das Listenfeld, Dropdown-Listenfeld oder Kombinationsfeld-Steuerelement in der Formularvorlage, die Sie konfigurieren möchten.

  3. Klicken Sie auf die Registerkarte Daten.

  4. Klicken Sie im Feld ListeneinträgeNachschlagen von Werten aus einer externen Datenquelle aus.

  5. Klicken Sie in der Liste Datenquelle auf die Datenquelle, die Sie verwenden möchten.

  6. Klicken Sie auf XPath festlegen Schaltfläche (Symbol) , neben dem Feld Einträge.

  7. Geben Sie im Dialogfeld Feld oder Gruppe auswählen das Feld oder die Gruppe, deren Felder enthalten, die Daten, die für dem Benutzer angezeigt werden und die Daten, die an die externe Datenquelle gesendet werden soll, indem Sie eine der folgenden Aktionen, aus.

    Geben Sie an, dass die Daten, die dem Benutzer angezeigt wird, den gleichen Daten ist, die vom Benutzer übermittelt werden

    • Klicken Sie auf ein Feld, und klicken Sie dann auf OK.

    Geben Sie an, dass die Daten, die dem Benutzer angezeigt wird aus den Daten unterscheidet, die vom Benutzer übermittelt werden

    Hinweis: In diesem Szenario die Daten, die dem Benutzer angezeigt wird stammen aus einem der Felder in der Gruppe, und die Daten, die vom Benutzer übermittelt werden in einem anderen Feld in derselben Gruppe enthalten ist.

    1. Klicken Sie auf eine Gruppe aus, und klicken Sie dann auf OK.

    2. Klicken Sie im Dialogfeld Steuerelementeigenschaften auf XPath festlegen Schaltfläche (Symbol) , neben dem Feld Wert.

    3. Klicken Sie im Dialogfeld Feld oder Gruppe auswählen auf ein Feld, das die Daten enthält, dass der Benutzer an die externe Datenquelle senden, und klicken Sie dann auf OK.

    4. Klicken Sie im Dialogfeld Steuerelementeigenschaften auf XPath festlegen Schaltfläche (Symbol) , neben dem Feld Anzeigename.

    5. Klicken Sie im Dialogfeld Feld oder Gruppe auswählen auf ein Feld, das die Daten, die im Steuerelement angezeigt wird enthält, und klicken Sie dann auf OK.

  8. Wenn das Feld in das Feld Anzeigename Werte mit ähnlichen Anzeigenamen weist und nur eindeutige Namen angezeigt werden soll, aktivieren Sie das Kontrollkästchen nur Einträge mit eindeutigen Anzeigenamen anzeigen.

Seitenanfang

Seitenanfang

Optional: Einrichten eines Filters zum Einschränken der Elemente im Steuerelement

  1. Doppelklicken Sie auf das Listenfeld, Dropdown-Listenfeld oder Kombinationsfeld-Steuerelement in der Formularvorlage, die Sie konfigurieren möchten.

  2. Klicken Sie auf die Registerkarte Daten.

  3. Klicken Sie auf XPath festlegen Schaltfläche (Symbol) neben dem Feld Einträge.

  4. Klicken Sie im Dialogfeld Feld oder Gruppe auswählen klicken Sie auf das Feld oder die Gruppe aus, die die Felder enthält, die Werte für das Steuerelement bereitstellen, und klicken Sie dann auf Filtern von Daten.

  5. Klicken Sie im Dialogfeld Daten filtern auf Hinzufügen.

    Hinweis: Wenn Sie einen vorhandenen Filter eine Bedingung hinzufügen möchten, klicken Sie auf den Filter, den Sie anwenden möchten, und klicken Sie dann auf Ändern.

  6. Klicken Sie im ersten Feld im Dialogfeld Filter Bedingungen angeben auf den Namen des Felds, dessen Daten gefiltert werden soll.

  7. Klicken Sie im zweiten Feld auf den Typ des Filters, die Sie verwenden möchten.

  8. Klicken Sie im dritten Feld klicken Sie auf den Typ der Bedingung, die Sie auf den Filter anwenden möchten, und geben Sie dann die Bedingung.

  9. Klicken Sie auf und mehr als eine Bedingung für den Filter um zu konfigurieren, und führen Sie dann eine der folgenden Aktionen aus:

    • Um die vorhandene als auch die neue Bedingung für Ihren Filter verwenden möchten, klicken Sie auf und, und klicken Sie dann fügen Sie Ihre neue Bedingung hinzu.

    • Um entweder die vorhandene oder die neue Bedingung für Ihren Filter verwenden möchten, klicken Sie auf oder, und klicken Sie dann fügen Sie weitere Bedingung hinzu.

  10. Klicken Sie auf OK, um die Dialogfelder zu schließen.

  11. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

    Die Formularvorlage wird in einem neuen Fenster geöffnet.

  12. Wählen Sie im Fenster Vorschau verschiedene Werte in das Filter-Steuerelement zum Testen der Filters ordnungsgemäß arbeitet.

    Der Filter funktioniert nicht richtig

    Wenn die Werte in das Steuerelement, das einen Filter enthält nicht korrekt sind, entweder weil es zu viele Werte oder nicht genügend Werte sind, probieren Sie Folgendes:

    • Wenn Sie mehrere Konditionen in den Filter verwenden, entfernen Sie alle aber eine Bedingung müssen, um zu überprüfen, dass die richtigen Werte aus die einzelnen Bedingung zurückgegeben werden. Wenn die erste Bedingung die richtigen Werte zurückgegeben werden, klicken Sie dann fügen Sie eine weitere Bedingung hinzu, und Testen Sie es.

    • Filter stellen zwischen Groß-und Kleinbuchstaben unterschieden. Wenn Sie möchten die Daten anzuzeigen, die mit einem klein-oder Großbuchstaben und Zeichen beginnt, erstellen Sie einen Filter mit einer Bedingung Großbuchstaben ein, wählen Sie im Dialogfeld Filtern Bedingung angebenoder aus, und erstellen Sie dann eine Bedingung klein-.

    • Sind die gefilterten Werte genau umgekehrt, was erwarten Sie, beispielsweise die Produkte aller statt der Produkte aus einem einzigen Lieferanten eines Lieferanten, ändern Sie den Filtertyp in der Bedingung. Beispielsweise, wenn Ihre Bedingung der Filters Typ gleich ist verwendet und Sie zu viele Produkte abrufen, versuchen Sie es mithilfe der Filters Typ ist nicht gleich.

Seitenanfang

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×