Verwenden einer PivotTable zu externen Tabellendaten in Excel Services verfügbar zu machen

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Hinweis: Dieser Artikel hat seine Aufgabe erfüllt und wird bald zurückgezogen. Um Probleme vom Typ "Seite nicht gefunden" zu vermeiden, entfernen wir Links, die uns bekannt sind. Wenn Sie Links zu dieser Seite erstellt haben, entfernen Sie diese. Gemeinsam sorgen wir für funktionierende Verbindungen mit dem Internet.

Wenn Sie für die Arbeit mit Tabellendaten basierend auf einer Verbindung mit externen Daten in Excel Services, können nicht Sie ein externen Datenbereichs (auch als eine Abfragetabelle bezeichnet) verwenden. Sie müssen eine PivotTable erstellen, die multidimensionale, hierarchische Daten in einer Tabelle oder zwei Dimensionen fasst zusammen. So sieht wie Zweck aus.

Vergleichen multidimensionaler und zweidimensionaler Daten

1. Konvertieren einer PivotTable mehrdimensionalen...

2.... in hierher ziehen einer zweidimensionalen PivotTable...

3. …sodass Sie die umgewandelten Tabellendaten in Excel Services sehen können.

Was möchten Sie tun?

Hier erfahren Sie, wie Excel Services die Verbindungen zu externen Datenquellen unterstützt

Unterschiede zwischen PivotTable-Berichten, die mit externen Daten verbunden sind, und externen Datenbereichen

Erstellen eines zweidimensionalen, tabellarischen PivotTable-Berichts

Erstellen des PivotTable-Berichts und Herstellen der Verbindung zu der externen Datenquelle

Hinzufügen, Gestalten und Anordnen der Felder im Bereich der Zeilenbeschriftungen

Ändern von PivotTable-Optionen und Feldeinstellungen

Gestalten des PivotTable-Berichts als zweidimensionale Tabelle

Anpassen des Entwurfs des PivotTable-Berichts

Veröffentlichen der Arbeitsmappe in Excel Services

Hier erfahren Sie, wie Excel Services die Verbindungen zu externen Datenquellen unterstützt

PivotTables dienen zahlreiche numerischen Daten in Summen und Gesamtsummen aggregieren und Arbeiten mit mehrdimensionaler Daten, die in einer Hierarchie organisiert ist. Externe Datenbereiche sind andererseits, zweidimensionale Tabellen strukturiert als Zeilen und Spalten, die Quelldaten zusammengesetzten Datensätze angezeigt.

Wenn Sie die Verbindung zu externen Daten im Datenverbindungs-Assistenten oder in Microsoft Query verwenden, erstellen Sie in der Regel einen externen Datenbereich aus. Die einzige Ausnahme ist, wenn Sie eine PivotTable erstellen, die mit externen Daten verbunden ist. Eine PivotTable erstellt keine externen Datenbereich. Dieser Unterschied in der Anzeige von Verbindungen erstellt werden ist wichtig, zu verstehen, wenn Sie eine Arbeitsmappe in Excel Services, veröffentlichen, weil Excel Services nur Verbindungen mit externen Daten ausgehend von PivotTables unterstützt und externe Datenbereiche nicht unterstützt.

Seitenanfang

Erfahren Sie mehr über die Unterschiede zwischen der PivotTables, die mit externen Daten verbunden sind und externe Datenbereiche

Beim Arbeiten mit einer PivotTable, die mit externen Daten verbunden ist, gibt es Unterschiede zwischen das Verhalten einer PivotTable und eines externen Datenbereichs, dem Sie kennen, einschließlich der folgenden sollten:

PivotTable-Gruppen und Untergruppen Daten in einer Reihenfolge von links nach rechts

Im Allgemeinen gruppierte Daten auf eine Sortierung der Daten von einer oder mehreren Spalten basiert. Wenn Sie alle Mitarbeiter, gruppiert nach Abteilung anzeigen möchten, können Sie einen primären, der die Daten nach Abteilungen und einer sekundären Sortierung von Mitarbeitern ausführen. Sie können auch Gruppen, wie z. B. Produktlinie, Kategorie und Produkt oder Geography, Land/Region, Bundesland/Kanton und Ort schachteln. Standardmäßig werden in Gruppen und Untergruppen in einer links-nach-rechts-Reihenfolge zu erleichtern finden Sie unter Verwandte Daten zum Anzeigen der Überschrift "und" zusammenfassende Informationen und zum Erweitern oder Reduzieren der zugehörigen Elemente automatisch PivotTables sortiert.

Daten gruppiert nach Produktlinieund subgrouped in jeder Zeile Produkt nach Kategorie

Produktlinie

Kategorie

Produkt

Antriebssysteme

Flugzeug

Tragflächenbefestigung

Heckbefestigung

Hilfstriebwerk

Auto

269 PS

454 PS

Auspuffsysteme

Kraftfahrzeug

Überhitzungsschutz

Serienmäßig

Geländewagen

Klein

Indem Sie eine Spalte mit eindeutigen Werten in den Bereich der Zeilenbeschriftungen links stellen, können Sie die Daten automatisch abflachen.

Durch Hinzufügen der Spalte ID-Num reduziert sind dieselben Produkt Zeile Daten

ID-Nummer

Produktlinie

Kategorie

Produkt

WM-345

Antriebssysteme

Flugzeug

Tragflächenbefestigung

TM-231

Antriebssysteme

Flugzeug

Heckbefestigung

BSTR-567

Antriebssysteme

Flugzeug

Hilfstriebwerk

6C-734

Antriebssysteme

Auto

269 PS

8C-121

Antriebssysteme

Auto

454 PS

MF-202

Auspuffsysteme

Kraftfahrzeug

Überhitzungsschutz

MF-321

Auspuffsysteme

Kraftfahrzeug

Serienmäßig

MF-211

Auspuffsysteme

Geländewagen

Klein

Wenn Sie nicht die Spalte, nach dem Hinzufügen der Spalte mit der PivotTable anzeigen möchten, können Sie die Spalte ausblenden. (Wählen Sie die Spalte, und klicken Sie auf der Registerkarte Start in der Gruppe Zellen auf den Pfeil neben Format, zeigen Sie auf Ausblenden & einblenden, und klicken Sie dann auf Spalten ausblenden.)

Wichtig: Wenn eine PivotTable zwei oder mehr doppelt vorhandenen Zeilen mit Daten aus der Datenquelle erkennt, zeigt die PivotTable nur eine Zeile aus. Wenn Sie alle Zeilen möchten, auch doppelte Zeilen in einer PivotTable angezeigt, müssen Sie eine Spalte mit eindeutigen Werten in der Tabelle, Abfrage oder Ansicht, die Sie aus der Datenquelle importieren hinzufügen. Wenn die Datenquelle kein eindeutigen Spalten verfügt, können Sie eine in der Datenquelle hinzufügen. Beispielsweise können konnte Sie Hinzufügen einer Spalte, die den Datentyp AutoNum zu einer Microsoft Office Access-Tabelle hat oder eine Spalte, die den Datentyp Identität zu einer Microsoft SQL Server-Tabelle wurde oder eine berechnete Spalte, die eine eindeutige Zahl für jeden Datensatz einer Datenbankabfrage angezeigt wird oder Besprechungsarbeitsbereich w.

Bearbeiten von Zelldaten und Hinzufügen berechneter Spalten

Vor dem Veröffentlichen der Arbeitsmappe auf Excel Services können Sie die Daten in einem externen Datenbereich bearbeiten, aber PivotTable-Daten sind immer schreibgeschützt.

Wenn Sie auf eine Zelle in einem externen Datenbereich doppelklicken, gelangen Sie in den Bearbeitungsmodus, und Sie können den Wert ändern oder sogar eine Formel eingeben. Beachten Sie jedoch, dass Sie nicht den ursprünglichen Wert an der Datenquelle ändern und somit bei der nächsten Datenaktualisierung der neue Wert möglicherweise überschrieben wird, je nach Festlegung der Eigenschaft für den externen Datenbereich Wenn sich bei Datenaktualisierung die Anzahl der Zeilen ändert.

Wenn Sie doppelklicken Sie auf eine Zelle der Zeile Etikett in einer PivotTable, die Zelle Blendet die Inhalte der Elemente in dieser Zeile Bezeichnung. Wenn Sie eine PivotTable in eine zweidimensionale Tabelle reduzieren, hat das reduzieren den Effekt, dass alle Zeilenwerte in einer Gruppe auf der linken Seite der Zelle verschwinden oder wieder angezeigt.

Sie können berechnete Spalten an einer beliebigen Stelle in einer Microsoft Office Excel-Tabelle, die auf einen externen Datenbereich basiert hinzufügen, oder Sie können Spalten einfügen und Formeln in einem externen Datenbereich ausfüllen. Berechnete Spalten innerhalb einer PivotTable können nicht eingefügt (auch wenn Sie berechnete Felder eingefügt werden können). Allerdings können Sie eine Spalte, die nach unten Daten oder Formeln unmittelbar links oder rechts von der PivotTable füllt hinzufügen, und innerhalb einer Formel ausgefüllt-Down können Zellbezüge innerhalb der PivotTable.

Erstellen von Diagrammen

Wenn Sie ein Diagramm auf der Grundlage der Daten in der PivotTable erstellen möchten, können Sie eine PivotChart, der standard-Diagramme auf ähnliche Weise verhält, erstellen, aber es gibt einige Unterschiede, darunter die folgenden:

Interaktion     Mit standard-Diagramme erstellen Sie ein Diagramm für jede Ansicht der Daten, die angezeigt werden sollen, aber die Ansichten sind nicht interaktiv. Mit PivotCharts können Sie ein einzelnes Diagramm erstellen und Anzeigen von Daten interaktiv auf verschiedene Arten ändern, indem das Berichtslayout oder das Detail, das angezeigt wird. In Excel Services sowohl standard-Diagrammen und PivotCharts, kann basierend auf Benutzerinteraktion mit der Arbeitsmappe aktualisiert werden, aber beide Diagramme werden als statische Bilder angezeigt.

Diagrammtypen     Der Standarddiagrammtyp für ein Diagramm standard ist ein gruppiertes Säulendiagramm, das Werte in verschiedenen Kategorien verglichen. Der Standarddiagrammtyp für ein PivotChart ist ein gestapeltes Säulendiagramm, in dem den Anteil einzelner Werte an einem ganzen in verschiedenen Kategorien verglichen. Sie können eine PivotChart auf einen Diagrammtyp mit Ausnahme von Punkt (XY), Stock oder Blasendiagramm ändern.

Diagrammelemente     PivotCharts enthalten die gleichen Elemente als standard-Diagramme, aber sie enthalten auch Felder und Elemente, die hinzugefügt, gedreht oder entfernt werden, um verschiedene Ansichten der Daten angezeigt werden können. Rubriken, Datenreihen und Daten in Diagrammen standard sind Kategorienfelder, von Reihenfeldern und Wertfelder in PivotCharts. PivotCharts können auch Berichtsfilter enthalten. Jedes dieser Felder enthält Elemente, die in standard-Diagramme als Etiketts oder Reihe Kategorienamen in Legenden angezeigt werden.

Formatierung     Die meisten formatieren, einschließlich der Elemente, Layout und Format, wird beibehalten, wenn Sie Aktualisieren ein PivotChart. Trendlinien, datenbeschriftungen, Fehlerindikatoren und andere Änderungen an den Datenreihen werden jedoch nicht beibehalten. Standard-Diagramme verlieren nicht diese Formatierung auf einmal angewendet.

Verschieben oder Ändern der Größe von Elementen     Sie können nicht in einem PivotChart verschieben oder Ändern der Größe der Zeichnungsfläche, Legende, Diagrammtitel oder Achsentitel, obwohl Sie können eines von mehreren voreingestellten Positionen für die Legende auswählen, und Sie können den Schriftgrad der Titel ändern. Sie können in einem standard-Diagramm verschieben und Ändern der Größe aller diese Elemente.

Nachdem Sie eine PivotChart, erstellen, wenn Sie es vorziehen, können Sie es zu einem standard-Diagramm konvertieren. Weitere Informationen finden Sie im Artikel Erstellen einer PivotTable mit Arbeitsblattdaten Anaylzeoder Erstellen eines PivotCharts.

Vergleich zwischen den Eigenschaften von externen Datenbereichen und den PivotTable-Optionen

Externe Datenbereiche und PivotTables müssen das Verhalten Aktualisieren der Daten und Layout und Eigenschaften, die Sie verwenden können, um die Formatierung von Daten zu steuern.

Sowohl externe Datenbereiche und PivotTables aktivieren Sie zum Anpassen der Spaltenbreite beibehalten Spalte sortieren, filtern, zellformatierung und das Layout der Daten, wenn die externen Daten aktualisiert werden.

In einem externen Datenbereich müssen Sie auch die Möglichkeit, einschließlich der Zeilennummern als erste Spalte mit Daten aus. In einer PivotTable gibt es keine ähnliche Option. Finden Sie im Abschnitt PivotTable-Gruppen und Untergruppen Daten in einer Reihenfolge von links nach rechts, ausführliche Informationen zum Hinzufügen von eindeutigen Spalten in der Datenquelle.

Beim Aktualisieren eines externen Datenbereichs können Sie steuern, was mit den vorhandenen Daten geschehen soll, wenn sich die Zeilenanzahl in Datenbereichen aufgrund einer der folgenden Optionen ändert:

  • Zellen für neue Daten einfügen, nicht verwendete Zellen löschen (Standard)

  • Ganze Zeilen für neue Daten einfügen, nicht verwendete Zellen löschen

  • Bestehende Zellinhalte überschreiben, nicht verwendete Zellen löschen

Wenn Sie eine PivotTable aktualisieren, wird nur in die neuen Daten. Jedoch möglicherweise aufgefordert und aufgefordert, zu entscheiden, ob Sie die vorhandene Zellen unter dem aktuellen Bericht zu überschreiben.

Filtern von Daten

Filtern von Daten in einer externen Datenquelle Bereichs- und PivotTable-sind sehr ähnlich, aber es gibt einige Unterschiede, einschließlich der folgenden:

  • Externe Datenbereiche verwenden den Textfilter, Zahlenfilter und Datumsfilter Befehle, während PivotTables Beschriftungsfilter, Wertefilter und Datumsfilter-Befehle verwenden.

  • Klicken Sie im Menü Filter eines externen Datenbereichs entfernt immer Elemente, die nicht mehr gültig sind und die Filtermenü umfasst nie neue Elemente mit einem angewendeten Filter nach einem Aktualisierungsvorgang, eine PivotTable besitzt aber Optionen aus, um dieses Verhalten zu steuern. Weitere Informationen finden Sie im Abschnitt Ändern PivotTable-Optionen und Feldeigenschaften.

  • Eine PivotTable enthält ein Bericht Filterfeature (zu einem externen Datenbereich nicht verfügbar), die ermöglicht Benutzern das Arbeiten mit einer Teilmenge der Daten in der PivotTable.

Sortieren von Daten

In einem externen Datenbereich können Sie bis zu 64 Spalten eine mehrspaltige Sortierung ausführen, können Sie eine Spalte als primäre Sortierung auswählen, und Sie können auswählen, alle anderen Spalten als sekundäre sortiert. Unterscheiden sich jedoch die Prozesse Sortieren von Daten in einer PivotTable und einen externen Datenbereich sortieren. Im Gegensatz zu einem externen Datenbereich können in einer PivotTable Sie nur eine primäre Sortierung in der Spalte ganz links durchführen. Alle anderen Spalten ausführen sekundäre Sortierungen basierend auf der Spalte direkt auf der linken Seite. Kurz gesagt, können Sie eine primäre und sekundäre Sortierung nur in einer Reihenfolge von links nach rechts durchführen.

Wenn Sie eine Spalte mit eindeutigen Werten als erste Spalte ganz links anordnen, können Sie außerdem nur nach dieser Spalte sortieren, weil Sie folglich eine primäre Gruppe für jede Zeile erstellen. Je nach den Anforderungen der Benutzer möchten Sie evtl. die Daten in Excel vorsortieren und nach der Veröffentlichung der Arbeitsmappe auf Excel Services das Sortieren deaktivieren, indem Sie das Kontrollkästchen Sortieren im Microsoft Office Excel Web Access-Webpart-Toolbereich deaktivieren.

Verwendung von Hyperlinks

Anders als in externen Datenbereichen werden aktive Hyperlinks in PivotTable-Zellen nicht unterstützt. Der Hyperlink wird als Text behandelt, und daher können Sie dem Hyperlink nicht in eine Webseite oder in ein Webdokument in Excel oder Excel Services folgen.

Seitenanfang

Damit eine zweidimensionale, tabellarische PivotTable

Es gibt eine Reihe von Schritten, die erforderlich sind, um mehrdimensionaler Daten in einer PivotTable zweidimensionale, tabellarischen reduzieren ein. Die besten Ergebnisse erzielen Sie führen Sie die folgenden Verfahren nacheinander aus.

Seitenanfang

Erstellen der PivotTable, und verbinden Sie es mit der externen Datenquelle

  1. Markieren Sie eine leere Zelle.

  2. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Tabellen auf PivotTable, und klicken Sie dann auf PivotTable.

    Abbildung des Excel-Menübands

    Das Dialogfeld PivotTable erstellen wird angezeigt.

  3. Klicken Sie auf Externe Datenquelle verwenden.

  4. Klicken Sie auf Verbindung auswählen.

    Die Klicken Sie im Dialogfeld Vorhandene Verbindungen wird angezeigt.

  5. Wählen Sie in der Liste Anzeigen oben im Dialogfeld die Kategorie von Verbindungen aus, für die Sie eine Verbindung auswählen möchten, oder wählen Sie Alle vorhandenen Verbindungen (Standardfall) aus.

  6. Wählen Sie in der Liste Verbindung auswählen eine Verbindung aus, und klicken Sie dann auf Öffnen.

  7. Geben Sie einen Speicherort an. Führen Sie einen der folgenden Schritte aus:

    • Klicken Sie auf Neues Arbeitsblatt, um die PivotTable auf einem neuen Arbeitsblatt ab dessen Zelle A1 angeordnet.

    • Um die PivotTable in einem vorhandenen Arbeitsblatt zu platzieren, wählen Sie Vorhandenes Arbeitsblatt aus, und geben Sie dann auf die erste Zelle des Bereichs von Zellen, in die PivotTable angeordnet werden soll.

      Alternativ klicken Sie auf Dialogfeld reduzieren Schaltflächensymbol , um das Dialogfeld vorübergehend auszublenden, markieren Sie die Anfangszelle des Arbeitsblatts, und klicken Sie dann auf Dialogfeld erweitern Schaltflächensymbol .

  8. Klicken Sie auf OK.

Eine leere PivotTable, wobei die PivotTable-Feldliste angezeigt wird, wird die Position hinzugefügt, die Sie eingegeben haben.

Seitenanfang

Hinzufügen, Gestalten und Anordnen der Felder im Bereich der Zeilenbeschriftungen

Verwenden Sie die PivotTable-Feldliste, um die Felder hinzuzufügen, zu gestalten und anzuordnen, und stellen Sie sicher, dass alle Felder dem Zeilenbeschriftungsbereich hinzugefügt werden.

  1. Klicken Sie auf die PivotTable.

  2. Führen Sie eine oder mehrere der folgenden Aktionen aus:

    • Führen Sie zum Hinzufügen von Feldern zum Bericht eine oder mehrere der folgenden Aktionen aus:

      • Aktivieren Sie das Kontrollkästchen neben jedem Feldnamen in dem Feldabschnitt in der Feldliste. Jedes Feld wird in einem Standardbereich des Gestaltungsabschnitts platziert, Sie können jedoch die Felder umordnen.

        Standardmäßig werden die nichtnumerischen Felder dem Bereich der Zeilenbeschriftungen hinzugefügt, die numerischen Felder dem Bereich der Werte und die Uhrzeit/Datumsfelder dem Bereich der Spaltenbeschriftungen.

      • Wenn Sie ein Feld in den Bereich der Zeilenbeschriftungen verschieben möchten, klicken Sie mit der rechten Maustaste auf den Feldnamen und wählen dann im Kontextmenü die Option Zu Zeilenbeschriftungen hinzufügen aus.

        Tipp: Sie können auch auf einen Feldnamen klicken, die Maustaste gedrückt halten und das Feld anschließend vom Feldbereich in einen Bereich im Layoutabschnitt ziehen.

    • Zum Umordnen der Felder klicken Sie auf den Feldnamen in einem der Bereiche, und wählen Sie dann einen der folgenden Befehle aus:

Nach oben   

Verschiebt das Feld im Bereich um eine Position nach oben.

Nach unten   

Das Feld wird innerhalb des Bereichs um eine Position nach unten verschoben.

An den Anfang verschieben   

Verschiebt das Feld an den Anfang des Bereichs.

An das Ende verschieben   

Das Feld wird an das Ende des Bereichs verschoben.

In Zeilenbeschriftungen verschieben   

Verschiebt das Feld in den Zeilenbeschriftungsbereich.

  • So entfernen Sie eine Feld, klicken Sie auf das Feld mit dem Namen in einem der Layoutbereiche, und klicken Sie dann klicken Sie auf Feld entfernen oder deaktivieren Sie das Kontrollkästchen neben jedem Feldnamen ein, die Sie im Feldabschnitt entfernen möchten.

    Tipp: Sie können auch auf einen Feldnamen im Layoutabschnitt klicken, die Maustaste gedrückt halten und anschließend den Feldnamen aus der PivotTable-Feldliste ziehen.

    Hinweis: Durch das Deaktivieren eines Kontrollkästchens im Feldabschnitt werden alle Instanzen des Felds aus dem Bericht entfernt.

Seitenanfang

Ändern von PivotTable-Optionen und Feldeinstellungen

Um sicherzustellen, dass eine PivotTable auf ähnliche Weise in einer externen Bereich verhält, führen Sie folgende Schritte aus:

Ändern der PivotTable-Optionen   

  1. Klicken Sie auf die PivotTable.

  2. Klicken Sie auf der Registerkarte Optionen in der Gruppe PivotTable auf Optionen.

    Das Dialogfeld PivotTable-Optionen wird angezeigt.

  3. Wenn nach einer Aktualisierung die Spaltenbreite automatisch angepasst werden soll, klicken Sie auf die Registerkarte Layout & Format, und anschließend aktivieren Sie unter dem Abschnitt Anzeige das Kontrollkästchen Spaltenbreiten bei Aktualisierung automatisch anpassen.

  4. Wenn nach einer Aktualisierung die Formatierung beibehalten werden soll, klicken Sie auf die Registerkarte Layout & Format, und anschließend aktivieren Sie unter dem Abschnitt Anzeige das Kontrollkästchen Zellformatierung bei Aktualisierung beibehalten.

  5. Um sicherzustellen, dass das Filtermenü nach einer Aktualisierung die nicht mehr gültigen Elemente entfernt, klicken Sie auf die Registerkarte Daten, und wählen Sie in dem Feld Anzahl der pro Feld beizubehaltenden Elemente die Option Keine aus.

Ändern der Feldeinstellungen   

  1. Klicken Sie auf die PivotTable.

  2. Zum Einschließen von neue Elemente in einer PivotTable mit einem angewendeten Filter, für jedes Feld, mit der rechten Maustaste in einer Zelle, klicken Sie im Kontextmenü auf Feldeigenschaften, klicken Sie auf der Registerkarte Teilergebnisse & Filter, und wählen Sie dann unter dem Abschnitt Filter aus der Neue Elemente in manuellen Filter einschließen das Kontrollkästchen.

Seitenanfang

Layout der PivotTable als zweidimensionale Tabelle

Gehen Sie wie folgt vor, um das Layout der PivotTable als zweidimensionale Tabelle:

  1. Klicken Sie auf die PivotTable.

  2. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Layout auf Teilergebnisse und dann auf Teilergebnisse nicht anzeigen.

  3. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Layout auf Gesamtsummen, und klicken Sie dann auf Für Zeilen und Spalten deaktiviert.

  4. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Layout auf Berichtslayout und dann auf In Tabellenformat anzeigen.

  5. Klicken Sie auf der Registerkarte Optionen in der Gruppe Einblenden/Ausblenden auf Feldkopfzeilen.

Seitenanfang

Anpassen des Entwurfs der PivotTable

Die integrierten PivotTable-Formate und Optionen für Tabellenformat dienen zur mehrdimensionaler Daten, keine zweidimensionale Tabelle. Wenn Sie den Bericht in einer zweidimensionalen Tabelle diese Formatvorlagen reduzieren Zellrahmen werden nicht angezeigt, und die Verbundene Zeilen und das Kontrollkästchen in der Gruppe PivotTable Formatoptionen der Registerkarte ' Entwurf ' Verbundene Spalten wirken sich nicht das Format der Zellen. Allerdings können Sie eine PivotTable-Formatvorlage anpassen, damit jede Zelle von Zellrahmen weist und die PivotTable bedingte Formatierung, verwendet um verbundene Zeilen oder Spalten anzuzeigen.

Anpassen der PivotTable-Formatierung   

  1. Klicken Sie auf die PivotTable.

  2. Wählen Sie auf der Registerkarte Entwurf in der Gruppe PivotTable-Formate das gewünschte Format aus, und führen Sie dann folgende Aktionen aus:

    1. Klicken Sie mit der rechten Maustaste auf ein sichtbares Format, blättern Sie durch den Katalog, oder klicken Sie unten auf der Bildlaufleiste auf Weitere, um alle verfügbaren Formate anzuzeigen.

    2. Klicken Sie auf Duplizieren.

      Das Dialogfeld Schnellformatvorlage für PivotTable ändern wird angezeigt.

    3. Geben Sie optional einen neuen Namen in das Feld Name ein.

    4. Wählen Sie im Feld Tabellenelement die Option Ganze Tabelle aus, und klicken Sie dann auf Format.

      Das Dialogfeld Zellen formatieren wird angezeigt.

    5. Klicken Sie auf die Registerkarte Rahmen, und erstellen Sie dann einen Zellenrahmen.

    6. Klicken Sie optional auf die Registerkarten Füllbereich und Schriftart, und nehmen Sie weitere Änderungen vor.

    7. Klicken Sie zweimal auf OK.

    8. Klicken Sie unten auf der Bildlaufleiste auf Weitere, und klicken Sie dann unter der Kategorie Benutzerdefiniert auf das gerade von Ihnen erstellte PivotTable-Format.

Anzeigen verbundener Zeilen oder Spalten mithilfe der bedingten Formatierung   

  1. Wählen Sie alle Spalten in der PivotTable aus.

  2. Klicken Sie auf der Registerkarte Start in der Gruppe Formatvorlagen auf den Pfeil neben Bedingte Formatierung und anschließend auf Regeln verwalten.

    Abbildung des Excel-Menübands

    Das Dialogfeld Manager für Regeln zur bedingten Formatierung wird angezeigt.

  3. Klicken Sie zum Hinzufügen eines bedingten Formats auf Neue Regel.

    Das Dialogfeld Neue Formatierungsregel wird angezeigt.

  4. Klicken Sie unter Regeltyp auswählen auf Formel zur Ermittlung der zu formatierenden Zellen verwenden.

    1. Geben Sie unter Regelbeschreibung bearbeiten im Feld Werte formatieren, für die diese Formel wahr ist eine Formel ein.

    2. Führen Sie einen der folgenden Schritte aus:

      • Um Zeilen abwechselnd unterschiedlich zu formatieren, geben Sie die folgende Formel ein:

=AND(MOD(ROW(),2)=1,ROW()<=COUNTA(A:A))

  • Um Spalten abwechselnd unterschiedlich zu formatieren, geben Sie die folgende Formel ein:

=AND(MOD(COLUMN(),2)=1,COLUMN()<=COUNTA(1:1))

  • Um Zeilen und Spalten abwechselnd unterschiedlich zu formatieren, geben Sie die folgende Formel ein:

=AND(MOD(ROW(),2)=1,ROW()<=COUNTA(A:A),MOD(COLUMN(),2)=1,COLUMN()<=COUNTA(1:1))

  1. Klicken Sie auf Format, um das Dialogfeld Zellen formatieren anzuzeigen.

  2. Wählen Sie die Zahl, die Schriftart, den Rahmen oder das Füllformat aus, das Sie anwenden möchten, wenn der Zellwert die Bedingung erfüllt, und klicken Sie dann auf OK.

    Sie können mehr als ein Format auswählen. Die ausgewählten Formate werden im Feld Vorschau angezeigt.

Seitenanfang

Veröffentlichen der Arbeitsmappe in Excel Services

  1. Klicken Sie auf die Microsoft Office-Schaltfläche Abbildung der Office-Schaltfläche , klicken Sie auf den Pfeil neben Veröffentlichen, und klicken Sie anschließend unter Das Dokument an andere Benutzer verteilen auf Excel Services.

  2. Geben Sie in das Feld Dateiname den Pfad zum Server ein, und übernehmen Sie den vorgeschlagenen Namen für die Arbeitsmappe, oder geben Sie ggf. einen neuen Namen ein.

    Auf einem Computer mit Windows Vista    

    • Wählen Sie in der Adressleiste das Netzwerkverzeichnis aus, auf das die vorgesehenen Benutzer zugreifen können, und klicken Sie auf Speichern.

      Auf einem Computer mit Microsoft Windows XP    

    • Wählen Sie im Feld Speichern in einen Netzwerkpfad aus, auf den die vorgesehenen Benutzer zugreifen können, und klicken Sie dann auf Speichern.

      Geben Sie beispielsweise http://Server/Website/-Dateiname

      Hinweis: In Excel kann eine Arbeitsmappe auf dem Server nur im Microsoft Office Excel 2007 XML-basierten Dateiformat (XLSX) oder im Office Excel 2007 binären Dateiformat (XSLB) veröffentlicht werden.

  3. Klicken Sie auf OK.

  4. Wenn Sie überprüfen möchten, dass die sichtbaren Bereiche der Arbeitsmappe im Browser korrekt angezeigt werden, aktivieren Sie das Kontrollkästchen Diese Arbeitsmappe nach dem Speichern in meinem Browser öffnen.

  5. Klicken Sie auf Speichern.

Seitenanfang

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×