Verwenden des Arguments "Matrix" in einer VERWEIS-Funktion

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Beim Erstellen einer Formel mithilfe der Funktionen SVERWEIS und WVERWEIS verwenden, geben Sie ein Argument "Matrix", also ein Zellbereich, z. B. D2:F39. Die Funktion durchsucht diesem Bereich aus, für die Daten, die Sie suchen möchten.

Das Argument "Matrix" ist immer das zweite Argument einer SVERWEIS- oder WVERWEIS-Funktion (das erste Argument enthält den Wert, nach dem Sie suchen). Diese Funktionen können ohne das Argument "Matrix" nicht ausgeführt werden.

Bei Ihrem ersten Argument kann es sich um einen bestimmten Wert, z. B. "41" oder "Schmidt", oder um einen Zellbezug, z. B. F2, handeln. Das erste Argument würde also wie folgt aussehen:

=SVERWEIS(F2;...

Auf den zu suchenden Wert folgt immer das Argument "Matrix" wie hier:

=SVERWEIS(F2;B4:D39;...

Für den jeweiligen Zellbereich, der im Argument "Matrix" angegeben wird, können relative oder absolute Zellbezüge verwendet werden. Wenn Sie die Formel in andere Zellen kopieren möchten, müssen Sie absolute Zellbezüge (achten Sie auf die $-Zeichen) wie folgt verwenden:

=SVERWEIS(F2;$B$2:BD$39;...

Wenn sich die Zellen im Argument "Matrix" auf einem anderen Arbeitsblatt in Ihrer Arbeitsmappe befinden, muss das Argument den Blattnamen, gefolgt von einem Ausrufezeichen, enthalten. Die entsprechende Syntax sähe wie folgt aus:

=SVERWEIS(F2;Tabelle2!$C$14:E$42;...

Die Spalte mit den gesuchten Werten wird als drittes Argument eingegeben. Diese Spalte wird als Nachschlagespalte bezeichnet. Wenn sich die Werte, die Sie anzeigen möchten, in Spalte D befinden (der dritten Spalte der Matrix), ist das letzte Argument eine 3.

=SVERWEIS(F2;B4:D39;3)

Zwar ist die Verwendung eines vierten Arguments optional, doch empfiehlt es sich, entweder "Falsch" oder "Wahr" zu verwenden. Verwenden Sie "Falsch", wenn Sie nach einer genauen Übereinstimmung suchen.

=SVERWEIS(F2;B4:D39;3;Falsch)

Wenn Sie "Wahr" eingeben oder das vierte Argument nicht angeben, gibt die Funktion eine ungefähre Übereinstimmung des Werts zurück, den Sie im ersten Argument angegeben haben. Wenn also das erste Argument "Schmidt" und das vierte Argument "Wahr" lautet, gibt die SVERWEIS-Funktion "Schmidt", "Schmidtlein" usw. zurück. Wenn Sie dagegen "Falsch" verwenden, gibt sie nur die Zeichenfolge "Schmidt", also die genaue Übereinstimmung zurück, und dieses Ergebnis wird zumeist gewünscht.

Die Verwendung von "Wahr" ist noch komplizierter, wenn die Nachschlagespalte (die Spalte, die Sie im dritten Argument angegeben haben) nicht in aufsteigender Reihenfolge (A bis Z oder kleinste bis größte Zahl) sortiert ist. In diesem Fall gibt die Funktion möglicherweise ein falsches Ergebnis zurück.

Weitere Informationen zu den Funktionen SVERWEIS und WVERWEIS finden Sie unter Nachschlage- und Verweisfunktionen (Referenz).

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×