Verwalten externer Datenbereiche und ihrer Eigenschaften

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Sie können die Eigenschaften eines externen Datenbereichs Steuerelementdaten ändern, die in einem Arbeitsblatt durch eine Verbindung mit einer externen Datenquelle, beispielsweise eine Datenbank, eine Textdatei oder einer Webabfrage importiert wurden.

Externer Datenbereich (auch als eine Abfragetabelle bezeichnet) ist, einen definierten Namen oder Tabellennamen, die die Position der Daten definiert, die in einem Arbeitsblatt eingebracht wurde. Beim Herstellen einer mit externen Daten Verbindung erstellt Excel automatisch einen externen Datenbereich aus. Die einzige Ausnahme ist ein PivotTable-Bericht, der mit einer Datenquelle verbunden ist – ein PivotTable-Bericht verwendet keine externen Datenbereich. Klicken Sie in Excel können Sie formatieren und Entwerfen des Layouts eines externen Datenbereichs oder wie bei allen anderen Daten in der Gruppe Berechnungen verwenden.

Eigenschaften des externen Datenbereichs

Externer Datenbereich hat zusätzlichen Eigenschaften (nicht mit Verbindungseigenschaften verwechselt werden), dass Sie die Daten, wie etwa die Beibehaltung der Formatierung und Spalte Zellenbreite steuern verwenden können. Sie können diese externen Datenbereich-Eigenschaften ändern, indem Sie auf Eigenschaften in der Gruppe Verbindungen auf der Registerkarte Daten. Nehmen Sie die Änderungen folgendermaßen aus:

  • Verwenden Sie für externe Datenbereiche, die aus Microsoft Query und Datenverbindungs-Assistenten erstellt wurden das Dialogfeld Eigenschaften von externen Daten.

  • Verwenden Sie für externe Datenbereiche, die aus einer importierten Textdatei oder einer Webabfrage, der HTML-Daten abruft erstellt wurden das Dialogfeld Eigenschaften des externen Datenbereichs an.

  • Verwenden Sie für externe Datenbereiche, die aus einer Webabfrage erstellt werden, die XML-Daten abruft das Dialogfeld Eigenschaften der XML-Zuordnung aus.

Verwenden von Vorlagen für externe Datenbereiche

Wenn Sie eine Zusammenfassung oder einen Bericht, der auf externen Daten basieren freigeben möchten, können Sie andere Benutzer eine Arbeitsmappe, die einen externen Datenbereich enthält geben, oder Sie können eine Berichtsvorlage erstellen. Eine Berichtvorlage können Sie die Zusammenfassung oder den Bericht speichern, ohne die externen Daten zu speichern, damit die Datei kleiner ist. Die externen Daten abgerufen, wenn ein Benutzer die Berichtsvorlage öffnet.

  1. Wählen Sie das Arbeitsblatt, in dem Sie für eine Externer Datenbereich suchen möchten.

  2. Klicken Sie auf die Bearbeitungsleiste klicken Sie auf den Pfeil neben dem Feld Name ein, und klicken Sie dann auf den Namen des externen Datenbereich, den gewünschte.

  1. Klicken Sie auf der Registerkarte Formeln in der Gruppe Definierte Namen auf Namens-Manager.

    Gruppe "Definierte Namen" auf der Registerkarte "Formeln"

  2. Klicken Sie im Dialogfeld Namens-Manager klicken Sie auf den Namen des externen Datenbereichs, und klicken Sie dann auf Bearbeiten. Sie können auch auf den Namen doppelklicken.

  3. Geben Sie im Dialogfeld Name bearbeiten für den Verweis in das Feld Name den neuen Namen ein.

Hinweis: Die Schaltfläche Schließen schließt das Dialogfeld Namens-Manager. Sie müssen nicht auf Schließen klicken, um die Änderungen zu übernehmen, die Sie bereits vorgenommen.

Sie können die zugrunde liegende Abfrage für einen externen Datenbereich ändern, die aus Microsoft Query, einer importierten Textdatei, Datenverbindungs-Assistenten oder einer Webabfrage erstellt wurde.

  1. Klicken Sie auf eine Zelle im externen Datenbereich für den Sie die zugrunde liegende Abfrage ändern möchten.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung des Excel-Menübands

  3. Klicken Sie im Dialogfeld Eigenschaften von externen Daten auf Verbindungseigenschaften Schaltflächensymbol .

  4. Klicken Sie im Dialogfeld Verbindungseigenschaften klicken Sie auf die Registerkarte Definition, und klicken Sie dann auf Abfrage bearbeiten.

Weitere Informationen zum Erstellen und Bearbeiten von Abfragen in Microsoft Query finden Sie unter Microsoft Query-Hilfe.

  1. Klicken Sie auf eine Zelle im externen Datenbereich für den Sie die zugrunde liegende Abfrage ändern möchten.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Verbindungen.

    Abbildung des Excel-Menübands

  3. Klicken Sie im Dialogfeld Arbeitsmappenverbindungen auf Eigenschaften.

  4. Klicken Sie im Dialogfeld Verbindungseigenschaften klicken Sie auf die Registerkarte Definition, und klicken Sie dann auf Abfrage bearbeiten.

  5. Klicken Sie im Dialogfeld Textdatei importieren auf Importieren.

  6. Nehmen Sie Änderungen an der importierten Textdatei in des Textimport-Assistenten, und klicken Sie dann auf Fertig stellen.

    Weitere Informationen zum Importieren von Textdateien finden Sie unter Importieren oder Exportieren von Textdateien.

  1. Klicken Sie auf eine Zelle im externen Datenbereich für den Sie die zugrunde liegende Abfrage ändern möchten.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung des Excel-Menübands

  3. Klicken Sie im Dialogfeld Arbeitsmappenverbindungen auf Eigenschaften.

  4. Klicken Sie im Dialogfeld Verbindungseigenschaften klicken Sie auf die Registerkarte Definition, und klicken Sie dann auf Abfrage bearbeiten.

  5. Nehmen Sie Änderungen an der Webabfrage im Dialogfeld Webabfrage bearbeiten, und klicken Sie dann auf Fertig stellen.

Weitere Informationen zum Erstellen und Bearbeiten von Web-Abfragen finden Sie unter Verbinden zu einer Webseite (Power Query).

  1. Klicken Sie auf eine Zelle im externen Datenbereich für den Sie die zugrunde liegende Abfrage ändern möchten.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung des Excel-Menübands

  3. Klicken Sie im Dialogfeld Eigenschaften von externen Daten auf Verbindungseigenschaften Schaltflächensymbol .

  4. Klicken Sie im Dialogfeld Verbindungseigenschaften klicken Sie auf die Registerkarte Definition.

  5. Führen Sie eine der folgenden Aktionen aus:

    • Klicken Sie im Befehlstyp klicken Sie auf Tabelle, und klicken Sie dann auf den Namen des eine entsprechende Tabelle, Sicht oder Abfrage in das Textfeld Befehl, Ändern des Werts.

    • Klicken Sie im Befehlstyp klicken Sie auf SQL oder Standard, und klicken Sie dann im Textfeld Befehl bearbeiten Sie die SQL-Anweisung.

      Hinweis: Je nachdem, wie die Verbindung definiert wurde, im Feld Befehl möglicherweise nicht verfügbar (abgeblendet).

  1. Klicken Sie auf den Pfeil neben dem Feld Name, und wählen Sie den Namen des externen Datenbereichs, die Sie kopieren möchten, klicken Sie auf der Bearbeitungsleiste.

    Wählen Sie den Namen des Bereichs für eine Excel-Tabelle, und drücken Sie dann STRG + A, um den Tabellenüberschriften auszuwählen.

    Wenn Sie gehören Spaltenüberschriften oder Formeln, die nicht Bestandteil des externen Datenbereichs sind möchten, markieren Sie die Zellen mit den Spaltenüberschriften oder Formeln, die Sie kopieren möchten. Klicken Sie auf den Pfeil neben dem Feld Name auf die Bearbeitungsleiste ein, und klicken Sie auf den Namen des externen Datenbereichs, die Sie kopieren möchten.

  2. Klicken Sie auf der Registerkarte Start in der Gruppe Zwischenablage auf Kopieren.

    Abbildung des Excel-Menübands

  3. Wechseln Sie zu der Arbeitsmappe, in der Sie den externen Datenbereich einfügen möchten.

  4. Klicken Sie auf die obere linke Zelle von der Bereich zum Einfügen.

    Stellen Sie sicher, dass das Arbeitsblatt hat keine Daten unter oder rechts neben der Zelle, die Sie klicken Sie auf Aktionen aus, um sicherzustellen, dass die Externe Daten keine vorhandene Daten ersetzt werden.

  5. Klicken Sie auf der Registerkarte Start in der Gruppe Zwischenablage auf Einfügen.

Hinweis: Wenn Sie nur einen Teil eines externen Datenbereichs kopieren, die zugrunde liegenden Abfrage wird nicht kopiert, und die kopierten Daten können nicht aktualisiert werden.

Sie können steuern, wie eine kleinere oder größere Datenmenge behandelt, die beim Aktualisieren von Daten nach Excel zurückgegeben wird.

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung des Excel-Menübands

  2. Klicken Sie im Dialogfeld Eigenschaften des externen Datenbereichs unter Wenn die Anzahl der Zeilen im Datenbereich nach der Aktualisierung ändert, klicken Sie auf eine der folgenden Aktionen aus:

    • Zellen für neue Daten einfügen, nicht verwendete Zellen löschen

      Hinweise: 

      • Wenn eine oder mehrere Zeilen in der Datenquelle hinzugefügt haben, direkt unter dem externen Datenbereich Zellen nach unten verschieben, aber Zellen rechts neben dem externen Datenbereich werden nicht verschoben.

      • Wenn Sie eine oder mehrere Zeilen in der Datenquelle gelöscht haben, direkt unter dem externen Datenbereich Zellen nach oben verschieben, aber Zellen rechts neben dem externen Datenbereich werden nicht verschoben.

    • Ganze Zeilen für neue Daten einfügen, nicht verwendete Zellen löschen

      Hinweise: 

      • Wenn eine oder mehrere Zeilen in der Datenquelle hinzugefügt haben, können Sie Zellen, die direkt unterhalb und rechts neben dem externen Datenbereich nach unten verschieben.

      • Wenn Sie eine oder mehrere Zeilen in der Datenquelle gelöscht haben, führen Sie Zellen direkt unter und rechts neben dem externen Datenbereich nicht verschoben werden.

    • Vorhandene Zellen mit neuen Daten überschreiben, nicht verwendete Zellen löschen

      Hinweise: 

      • Wenn eine oder mehrere Zeilen in der Datenquelle hinzugefügt haben, direkt unter dem externen Datenbereich Zellen überschrieben werden, aber Zellen rechts neben dem externen Datenbereich werden nicht verschoben.

      • Wenn Sie eine oder mehrere Zeilen in der Datenquelle gelöscht haben, führen Sie Zellen direkt unter und rechts neben dem externen Datenbereich nicht verschoben werden.

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung des Excel-Menübands

  2. Führen Sie unter Formatieren von Daten und das Layout eine oder mehrere der folgenden Aktionen aus:

    • Aktivieren Sie das Kontrollkästchen Feldnamen einschließen, um die erste Zeile Feldnamen einschließen.

      Hinweis: Dieses Kontrollkästchen steht nur für einen externen Datenbereich, der konvertiert wird, von einem Microsoft Office 2003-Programm oder einen externen Datenbereich, der programmgesteuert erstellt wird.

    • Wählen Sie das Kontrollkästchen Zeilennummern einschließen, zum Hinzufügen einer Spalteninhalts mit Zahlen Zeile.

      Hinweis: Dieses Kontrollkästchen ist nicht verfügbar für einer importierten Textdatei, XML-Datei oder einer Webabfrage.

    • Zum Beibehalten der Zelle Formatierung, die Sie anwenden möchten, wählen Sie das Kontrollkästchen Zellformat beibehalten.

      Hinweis: Diese Option ist für eine Webabfrage automatisch deaktiviert, wenn Sie im Dialogfeld OptionenVolle HTML-Formatierung auswählen. Sie haben im Dialogfeld Optionen im Dialogfeld Abfrage bearbeiten zugreifen.

    • Wenn Sie die Spaltenbreite beibehalten, die Sie festlegen möchten, wählen Sie das Kontrollkästchen Spaltenbreite anpassen.

    • Wählen Sie zum Beibehalten der Spalte sortieren, Filtern und Layout, das Sie anwenden möchten, aktivieren Sie das Kontrollkästchen Sortieren/filtern/Layout für Spalte beibehalten.

      Hinweis: Dieses Kontrollkästchen ist nicht verfügbar für eine Webabfrage.

    • Zum Beibehalten der Spalte filtern, die Sie anwenden möchten, wählen Sie das Kontrollkästchen Filter für Spalte beibehalten.

      Hinweis: Dieses Kontrollkästchen steht nur für eine Webabfrage, die auf XML-Daten basiert.

Hinweis: Das folgende Verfahren gilt nur für einen externen Datenbereich, der von einem Microsoft Office 2003-Programm konvertiert wird, oder eines externen Datenbereichs, das programmgesteuert erstellt wird. Alle externe Datenbereiche, die mithilfe der Benutzeroberfläche erstellt wurden, werden als Excel-Tabellen erstellt. In diesen Tabellen automatisch erweitert, wenn neue Zeilen hinzugefügt werden, und füllen Sie nach unten berechnete Spalten.

  1. Geben Sie eine Formel in eine Zelle, die neben der ersten Zeile der Daten im externen Datenbereich liegt.

    Hinweis: Die erste Zeile mit Daten möglicherweise auf die erste oder zweite Zeile im externen Datenbereich, je nachdem, ob die erste Zeile Spaltenüberschriften enthält.

  2. Wählen Sie die Zelle aus, und doppelklicken Sie auf die Ausfüllkästchen, um die Formel in alle Zeilen im externen Datenbereich zu kopieren.

  3. Klicken Sie auf eine Zelle im externen Datenbereich.

  4. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung des Excel-Menübands

  5. Wählen Sie im Dialogfeld Eigenschaften des externen Datenbereichs das Kontrollkästchen Formeln in angrenzenden Zellen ausfüllen.

    Hinweis: Wenn Sie der externen Datenbereich erweitert, wenn Sie Aktualisieren, Excel nur die Formeln kopiert, die sich direkt neben oder innerhalb des externen Datenbereichs befinden.

Fixieren eines externen Datenbereichs behält die Daten aber nicht die zugrunde liegende Abfrage, sodass ein fixierter externer Datenbereich kann nicht aktualisiert werden.

  1. Klicken Sie auf das Arbeitsblatt, das mit die Excel-Tabelle, aus der Sie die Datenverbindung entfernen möchten.

  2. Klicken Sie auf den Pfeil neben dem Feld Name, und klicken Sie dann auf den Namen des externen Datenbereich aus dem Sie die Datenverbindung entfernen möchten, klicken Sie auf der Bearbeitungsleiste. Der Datenbereich ist dann ausgewählt.

  3. Klicken Sie auf der Registerkarte Tools in der Gruppe Externe Tabellendaten auf Verknüpfung aufheben. Der Datenbereich bleibt und trägt weiterhin denselben Namen, aber die Verbindung wird gelöscht.

Hinweis: Das folgende Verfahren gilt nur für einen externen Datenbereich, der von einem Microsoft Office 2003-Programm konvertiert wird, oder eines externen Datenbereichs, das programmgesteuert erstellt wird. Alle externe Datenbereiche, die mithilfe der Benutzeroberfläche erstellt wurden, werden als Excel-Tabellen erstellt. In diesen Tabellen automatisch erweitert, wenn neue Zeilen hinzugefügt werden, und füllen Sie nach unten berechnete Spalten.

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung des Excel-Menübands

  2. Deaktivieren Sie unter Abfragedefinition das Kontrollkästchen Abfragedefinition speichern aus.

Hinweis: Wenn Sie die Arbeitsmappe speichern, wird die zugrunde liegende Abfrage aus der Arbeitsmappe gelöscht. Die gespeicherte Abfrage Datenbankdateien (DQY oder ODC-Dateien) werden jedoch nicht gelöscht. Wenn Sie die Abfrage gespeichert, wenn Sie es im Abfrage-Assistenten oder in Microsoft Query erstellt haben, die Abfragedatei auf Ihrem Computer gespeichert ist, und Sie die Abfrage erneut zum Abrufen von externer Daten verwenden können. Weitere Informationen finden Sie unter Microsoft Query-Hilfe.

Hinweis: Das folgende Verfahren gilt nur für einen externen Datenbereich, der mithilfe des Datenverbindungs-Assistenten oder Microsoft Query erstellt wird (und nicht mit einer importierten Textdatei oder einer Webabfrage) ein externen Datenbereichs aus einem Microsoft Office 2003-Programm oder eine externe konvertiert Datenbereich programmgesteuert erstellt. Alle externe Datenbereiche, die mithilfe der Benutzeroberfläche erstellt wurden, werden als Excel-Tabellen erstellt.

  1. Fügen Sie eine leere Zeile oberhalb des externen Datenbereichs, indem Sie eine der folgenden Aktionen aus:

    • Wählen Sie eine Zelle, über die in die neue Zeile eingefügt werden soll. Klicken Sie dann auf der Registerkarte Start in der Gruppe Zellen, klicken Sie auf den Pfeil neben der Schaltfläche Einfügen, und klicken Sie dann auf Blattzeilen einfügen. Da Sie eine Zelle markiert haben, wird eine neue Zeile oberhalb der aktuellen Zeile eingefügt.

    • Klicken Sie auf den Zeilenmarkierer der Zeile, über der Sie eine neue Zeile einfügen möchten. Klicken Sie auf der Registerkarte Start in der Gruppe Zellen, klicken Sie dann auf Einfügen. Da Sie eine ganze Zeile markiert haben, wird eine neue Zeile oberhalb der markierten Zeile eingefügt.

  2. Geben Sie die Beschriftungen, die in den Zellen in der leeren Zeile sollen.

  3. Klicken Sie auf eine Zelle im externen Datenbereich.

  4. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung des Excel-Menübands

  5. Klicken Sie im Dialogfeld Eigenschaften des externen Datenbereichs unter datenformatierung und das Layout deaktivieren Sie das Kontrollkästchen Feldnamen einschließen, und klicken Sie dann auf OK.

  6. Wenn Sie die vorhandenen Feldnamen entfernen und Aktualisieren von externen Datenbereich, klicken Sie auf eine Zelle im externen Datenbereich, und klicken Sie dann auf Daten aktualisieren Schaltflächensymbol .

Hinweis: Beim Abrufen von Daten aus einer Datenbank aufbewahrt werden alle Änderungen Spaltennamen in Microsoft Query im externen Datenbereich. Informationen zum Ändern von Spaltennamen in der Abfrage finden Sie unter Microsoft Query-Hilfe.

  1. Klicken Sie auf das Arbeitsblatt, das den externen Datenbereich enthält, den Sie löschen möchten.

  2. Klicken Sie auf den Pfeil neben dem Feld Name, und klicken Sie dann auf den Namen des externen Datenbereichs, die Sie löschen möchten, klicken Sie auf der Bearbeitungsleiste.

    Wenn der externen Datenbereich einer Excel-Tabelle ist, drücken Sie STRG + A, um die gesamte Tabelle zu markieren.

  3. Um den externen Datenbereich zu löschen, drücken Sie ENTF.

  4. Wenn Sie die zugrunde liegende Abfrage löschen möchten, klicken Sie auf Ja, wenn Sie Excel aufgefordert werden.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×