Verschieben einer veröffentlichten Formularvorlage in einer neuen SharePoint-Dokumentbibliothek

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Inhalt dieses Artikels

(Übersicht)

Vorbemerkung

Abrufen einer Arbeitskopie Ihrer Formularvorlage

Schritt 1: Veröffentlichen der Formularvorlage in die neue Dokumentbibliothek

Schritt 2: Kopieren Sie und erneutes Verknüpfen Sie der vorhandenen Formulare

Übersicht

Nachdem Sie zu einer Dokumentbibliothek für Ihre Benutzer zum Ausfüllen eine Formularvorlage veröffentlicht haben, müssen Sie die Formularvorlage in eine andere Dokumentbibliothek verschieben. Angenommen, Sie möglicherweise verschieben Ihrer Formularvorlage auf einem Server mit mehr Kapazität, damit mehrere Benutzer gleichzeitig Formulare ausfüllen können. Einige Benutzer möglicherweise bereits Formulare ausgefüllt haben, die auf Ihrer Formularvorlage basieren, die in der ursprünglichen Dokumentbibliothek gespeichert wurde. Wenn Sie Ihre Formularvorlage in eine neue Dokumentbibliothek verschieben, werden Sie diese vorhandenen Formulare ebenfalls verschieben möchten. Sie möchten sicherstellen, dass diese vorhandenen Formulare in die neue Dokumentbibliothek funktionieren, bevor Sie archivieren oder löschen die alte Dokumentbibliothek.

Tipp: Bevor Sie veröffentlichte Formularvorlagen in eine neue Dokumentbibliothek verschieben, erstellen Sie einen Plan, der Ihre Benutzer darüber informiert, dass ihre Formulare in eine neue Dokumentbibliothek verschoben wurden. Die Benutzer die neue Dokumentbibliothek zum Speichern neuer oder zum Ändern vorhandener Formulare verwendet werden soll. Der Plan sollte auch einen Prozess zum Archivieren oder Löschen der ursprünglichen Dokumentbibliothek umfassen.

Um eine Formularvorlage und deren vorhandene Formulare in eine neue Dokumentbibliothek verschieben möchten, müssen Sie zuerst die Arbeitskopie der Formularvorlage für die neue Dokumentbibliothek veröffentlichen. Die Arbeitskopie ist die Version, die auf Ihrem Computer oder in einem Programm zur Versionskontrolle, wie etwa Microsoft Visual SourceSafe gespeichert ist.

Tipp: Wenn Sie nicht über eine Arbeitskopie der Formularvorlage verfügen, können Sie eine Kopie der Formularvorlage aus der ursprünglichen Dokumentbibliothek auf Ihren Computer mit einer Kopie der Arbeit speichern.

Nachdem Sie die Arbeit kopieren in die neue Dokumentbibliothek veröffentlichen, müssen Sie alle Formulare aus der alten Dokumentbibliothek in die neue Dokumentbibliothek kopieren, und klicken Sie dann in der neuen Dokumentbibliothek mit der neu veröffentlichten Formularvorlage erneuern.

Wenn Sie die Formularvorlage bewegt Änderungen vornehmen müssen, nehmen Sie diese Änderungen, bevor Sie die Formularvorlage veröffentlichen. Beispielsweise kann auch der Speicherort der externen Datenquellen, die von den Formularen verwendet werden, die auf dieser Formularvorlage basieren geändert werden durch das Verschieben der Formularvorlage. In diesem Fall müssen Sie die Datenverbindung in der Formularvorlage an die neue Position der externen Datenquellen ändern, bevor Sie die Formularvorlage veröffentlichen. Suchen nach Links zu weiteren Informationen über das Ändern der datenverbindungen im Abschnitt Siehe auch.

Hinweis: Veröffentlichen einer Formularvorlage ist nicht identisch mit eine Formularvorlage speichern. Wenn Sie eine Formularvorlage veröffentlichen, addiert den Veröffentlichen-Assistenten Ort der Veröffentlichung und verarbeitungsanweisung zur Formularvorlage, damit Benutzer Formulare öffnen können, die auf dieser Formularvorlage basieren. Wenn Sie eine Formularvorlage speichern, werden Sie eine Kopie der Formularvorlage speichern, wie Sie vorgehen, wenn Sie eine Datei auf Ihrem Computer speichern. Wenn Sie Ihre Formularvorlage für Ihre Benutzer zum Ausfüllen zur Verfügung stellen möchten, sollten Sie immer den Veröffentlichen-Assistenten verwenden.

Seitenanfang

Vorbemerkung

Bevor Sie Verschieben der Formularvorlage und alle vorhandenen Formulare, die auf der Formularvorlage, um eine neue Dokumentbibliothek basieren, benötigen Sie Folgendes:

  • Die Arbeitskopie der Formularvorlage    Dies ist eine Kopie der Formularvorlage, die Sie ändern und dann in die neue Dokumentbibliothek veröffentlichen. Die Kopie funktioniert möglicherweise auf Ihrem Computer oder in einem Programm zur Versionskontrolle, z. B. Visual SourceSafe gespeichert werden.

  • Die Speicherorte der neuen externen Datenquellen    Wenn die Formulare, die auf der Formularvorlage basieren externe Datenquellen, die sich geändert haben verwenden, benötigen Sie die neuen Speicherorte der externen Datenquellen. Vergewissern Sie sich mit Ihrem Administrator, dass Sie und Ihre Benutzer die geeigneten Berechtigungen haben für die externen Datenquellen verwenden. Die Formularvorlage Einstellungen in einer Datenverbindungsdatei verwendet, um die Verbindung mit einer externen Datenquelle sicher, dass die Datenverbindungsdatei mit den neuen Speicherort der externen Datenquelle aktualisiert wurde.

  • Die entsprechenden Berechtigungen auf dem Server mit Windows SharePoint Services 3.0    Sie benötigen die entsprechenden Berechtigungen auf dem Server veröffentlichen eine Formularvorlage und alle vorhandenen Formulare aus der alten Dokumentbibliothek in die neue Dokumentbibliothek zu kopieren. Wenden Sie sich an den Serveradministrator, um sicherzustellen, dass Sie diese Rechte haben.

Seitenanfang

Abrufen einer Arbeitskopie Ihrer Formularvorlage

Wenn Sie eine Formularvorlage ändern, die in einer Dokumentbibliothek oder einem freigegebenen Speicherort im Netzwerk veröffentlicht wurde möchten, und Sie verfügen nicht über eine Arbeitskopie der Formularvorlage, können Sie eine Arbeitskopie der Formularvorlage vom Ort Veröffentlichung auf Ihrem Computer speichern.

Tipp: Erwägen Sie einem Programm zur Versionskontrolle, wie etwa Microsoft Visual SourceSafe, die Arbeitskopien Ihrer Formularvorlagen zu verwalten.

Speichern einer Kopie der Formularvorlage aus einer Dokumentbibliothek auf Ihren computer

  1. Öffnen Sie in einem Webbrowser die Dokumentbibliothek, in dem die Formularvorlage veröffentlicht wurde.

  2. Im Menü Einstellungen klicken Sie auf Einstellungen, und klicken Sie dann auf Formular in der Formularbibliothek.

  3. Klicken Sie unter Allgemeine Einstellungen auf Erweiterte Einstellungen.

  4. Klicken Sie im Abschnitt Dokumentvorlage auf Vorlage bearbeiten.

    Die Formularvorlage wird in Microsoft Office InfoPath geöffnet.

  5. Klicken Sie im Dialogfeld Microsoft Office InfoPath klicken Sie auf Ja.

  6. Klicken Sie im Menü Datei auf Speichern unter.

  7. Klicken Sie im Dialogfeld Microsoft Office InfoPath klicken Sie auf OK.

  8. Navigieren Sie im Dialogfeld Speichern unter auf die Stelle, an der Sie eine Kopie der Formularvorlage speichern, und klicken Sie dann auf Speichern.

Speichern einer Kopie der Formularvorlage aus dem freigegebenen Netzwerkordner auf Ihren computer

  1. Klicken Sie im Menü Datei auf eine Formularvorlage entwerfen.

  2. Klicken Sie unter Öffnen einer Formularvorlage klicken Sie auf Auf meinem Computer.

  3. Navigieren Sie zu dem freigegebenen Netzwerkordner der veröffentlichten Formularvorlage, klicken Sie auf die Formularvorlage, und klicken Sie dann auf Öffnen.

  4. Klicken Sie im Menü Datei auf Speichern unter.

  5. Klicken Sie im Dialogfeld Microsoft Office InfoPath klicken Sie auf OK.

  6. Klicken Sie im Dialogfeld Speichern unter wählen Sie einen Speicherort, außer das Original veröffentlichen Stelle, an der Sie eine Arbeitskopie der Formularvorlage speichern möchten, und klicken Sie dann auf Speichern.

Seitenanfang

Schritt 1: Veröffentlichen der Formularvorlage in die neue Dokumentbibliothek

  1. Öffnen Sie die Arbeitskopie der Formularvorlage im Entwurfsmodus.

  2. Klicken Sie im Menü Datei auf Veröffentlichen.

  3. Klicken Sie im Veröffentlichen-Assistenten klicken Sie auf in einer SharePoint-Server mit oder ohne InfoPath Forms Services, und klicken Sie dann auf Weiter.

  4. Klicken Sie im Feld Geben Sie den Speicherort der SharePoint- oder InfoPath Forms Services-Website Geben Sie den Speicherort der SharePoint-Website, die die neue Dokumentbibliothek enthält, der Sie Ihrer Formularvorlage verschieben möchten, und klicken Sie dann auf Weiter.

  5. Klicken Sie auf der nächsten Seite des Assistenten klicken Sie auf Dokumentbibliothek, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf neue Dokumentbibliothek erstellen, und klicken Sie dann auf Weiter.

  7. Klicken Sie auf der nächsten Seite des Assistenten geben Sie einen Namen und eine Beschreibung für die neue Dokumentbibliothek, und klicken Sie dann auf Weiter.

  8. Wählen Sie die Felder in der Formularvorlage, die als Spalten in der Standardansicht der Dokumentbibliothek angezeigt werden soll.

    So wird's gemacht

    1. Klicken Sie auf Hinzufügen.

    2. Wählen Sie das Feld, das Sie als eine Spalte in der Dokumentbibliothek hinzufügen möchten, und führen Sie dann eine der folgenden Aktionen aus:

      • Geben Sie im Feld Spaltenname einen Namen für die Spalte ein.

      • Wählen Sie in der Liste Websitespaltengruppe die Websitespalte aus, wählen Sie in der Liste Spaltenname einen Namen aus, und klicken Sie dann auf OK.

        Hinweis: Wenn Sie ein wiederholtes Feld zum Anzeigen von Daten in der Dokumentbibliothek ausgewählt haben, können Sie definieren, wie Sie das Feld in der Dokumentbibliothek anzeigen, indem Sie auf einen Wert in der Liste (Funktion) möchten. Sie können auswählen, ob den ersten Wert in das Feld, dem letzten Wert in das Feld oder die Anzahl aller Vorkommen des Felds angezeigt, oder ob alle Werte zusammengeführt.

    3. Klicken Sie auf OK.

    Suchen nach Links zu weiteren Informationen zum Anzeigen von Daten in Spalten in einer Dokumentbibliothek im Abschnitt Siehe auch.

  9. Klicken Sie auf Weiter.

  10. Klicken Sie auf der nächsten Seite des Assistenten stellen Sie sicher, dass die angezeigten Informationen richtig ist, und klicken Sie dann auf Veröffentlichen.

  11. Öffnen Sie die Dokumentbibliothek aus, und Testen Sie den Prozess zum Ausfüllen eines Formulars, das auf dieser Formularvorlage basieren, aktivieren Sie das Kontrollkästchen diese Dokumentbibliothek öffnen, und klicken Sie dann auf Schließen.

    Die Dokumentbibliothek wird in einem Browser geöffnet. Wenn Sie auf der Symbolleiste auf neu klicken, wird ein Formular basierend auf dieser Formularvorlage in Microsoft Office InfoPath geöffnet.

Nachdem Sie die Formularvorlage in eine neue Dokumentbibliothek veröffentlichen, können Sie die vorhandenen Formulare kopieren, die auf die alte Version der Formularvorlage aus der alten Dokumentbibliothek in die neue Dokumentbibliothek basieren. Nachdem Sie die vorhandenen Formulare kopiert haben, können Sie die vorhandenen Formulare mit der neuen Version der Formularvorlage erneut verknüpfen. Wenn Sie nicht die vorhandenen Formulare verknüpfen, Benutzer diese vorhandenen Formulare öffnen möglicherweise nicht.

Seitenanfang

Schritt 2: Kopieren Sie und erneutes Verknüpfen Sie der vorhandenen Formulare

Dieses Verfahren wird davon ausgegangen, dass beide Dokumentbibliotheken auf einem Server sind, die Windows SharePoint Services 3.0 ausgeführt wird.

  1. Öffnen Sie die alte Dokumentbibliothek in einem Webbrowser.

  2. Klicken Sie im Menü Ansicht auf Explorer-Ansicht.

  3. Drücken und halten Sie STRG GEDRÜCKT, wählen Sie jedes Formular, das Sie verschieben möchten, und klicken Sie dann mit der rechten Maustaste eines der Formulare.

  4. Klicken Sie im Dialogfeld Internet Explorer klicken Sie auf Ja, und klicken Sie dann im Kontextmenü auf Kopieren.

  5. Öffnen Sie die neue Dokumentbibliothek.

  6. Klicken Sie unter Wählen Sie eine Ansicht auf Explorer-Ansicht.

  7. Mit der rechten Maustaste in den leeren Bereich im Ordnerfenster.

  8. Klicken Sie im Dialogfeld Internet Explorer klicken Sie auf Ja, und klicken Sie dann im Kontextmenü auf Einfügen.

  9. Klicken Sie im Menü Ansicht auf Dokumente erneut verknüpfen.

  10. Wählen Sie das Kontrollkästchen für jedes Formular, das Sie mit der neuen Formularvorlage verknüpfen möchten, in der Spalte neu verknüpfen.

  11. Klicken Sie auf der Symbolleiste der Liste auf Ausgewählte Dokumente erneut verknüpfen.

Nachdem Sie die vorhandenen Formulare mit der neuen Formularvorlage erneut verknüpfen möchten, können die Benutzer die vorhandenen Formulare ändern, die Sie kopiert haben, um die neue Dokumentbibliothek oder füllen neue Formulare, die auf der neu veröffentlichten Formularvorlage basieren.

Seitenanfang

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×