VERGLEICH (Funktion)

Tipp: Versuchen Sie, die neue XMATCH -Funktion, eine verbesserte Version von Match, zu verwenden, die in beliebiger Richtung funktioniert und standardmäßig exakte Übereinstimmungen zurückgibt, wodurch die Verwendung einfacher und bequemer als der Vorgänger ist.

Mit der Funktion VERGLEICH wird in einem Bereich von Zellen nach einem angegebenen Element gesucht und anschließend die relative Position dieses Elements im Bereich zurückgegeben. Ein Beispiel: Wenn der Bereich A1:A3 die Werte "5", "25" und "38" enthält, gibt die Formel =VERGLEICH(25;A1:A3;0) den Wert "2" zurück, weil "25" der zweite Wert im Bereich ist.

Ihr Browser unterstützt kein Video. Installieren Sie Microsoft Silverlight, Adobe Flash Player oder Internet Explorer 9.

Tipp: Verwenden Sie VERGLEICH immer dann statt einer der VERWEIS-Funktionen, wenn Sie die Position eines Elements in einem Bereich und nicht das Element selbst benötigen. Sie können die Funktion VERGLEICH beispielsweise verwenden, um einen Wert für das Argument Zeile in der INDEX-Funktion bereitzustellen.

Syntax

VERGLEICH(Suchkriterium;Suchmatrix;[Vergleichstyp])

Die Syntax der Funktion VERGLEICH weist die folgenden Argumente auf:

  • lookup_value    Erforderlich. Der Wert, den Sie in lookup_arrayabgleichen möchten. Wenn Sie beispielsweise die Nummer einer Person in einem Telefonbuch nachschlagen, verwenden Sie den Namen der Person als Nachschlagewert, aber die Telefonnummer ist der gewünschte Wert.

    Das Argument lookup_value kann ein Wert (Zahl, Text oder Wahrheitswert) oder ein Zellbezug auf eine Zahl, einen Text oder einen Wahrheitswert sein.

  • Suchmatrix    Erforderlich. Der Zellbereich, der durchsucht wird.

  • match_type    Optional. Die Zahl-1, 0 oder 1. Das Argument match_type gibt an, wie Excel lookup_value mit Werten in lookup_arrayentspricht. Der Standardwert für dieses Argument ist 1.

    In der folgenden Tabelle wird beschrieben, wie die Funktion Werte basierend auf der Einstellung des Arguments match_type findet.

Vergleichstyp

Verhalten

1 oder nicht angegeben

VERGLEICH sucht nach dem größten Wert, der kleiner oder gleich dem Wert für Suchkriterium ist. Die Werte im Argument Suchmatrix müssen in aufsteigender Reihenfolge angeordnet sein, z. B. ...-2, -1, 0, 1, 2, ..., A-Z, FALSCH, WAHR.

0

VERGLEICH sucht nach dem ersten Wert, der mit dem Wert für Suchkriterium genau übereinstimmt. Die Werte im Argument Suchmatrix dürfen in beliebiger Reihenfolge angeordnet sein.

-1

Übereinstimmung findet den kleinsten Wert, der größer als oder gleichlookup_valueist. Die Werte im lookup_array -Argument müssen in absteigender Reihenfolge angeordnet werden, beispielsweise: wahr, falsch, z-A,... 2, 1, 0,-1,-2,... usw.

  • Übereinstimmung gibt die Position des übereinstimmenden Werts in lookup_arrayund nicht den Wert selbst zurück. Beispiel: Vergleich ("b"; {"a"; "b"; "c"}; 0) gibt 2 zurück, was die relative Position von "b" innerhalb des Arrays {"a", "b"; "c"} ist.

  • VERGLEICH unterscheidet beim Abgleichen von Zeichenfolgen (Text) nicht zwischen Groß- und Kleinbuchstaben.

  • Findet VERGLEICH keinen übereinstimmenden Wert, gibt die Funktion den Fehlerwert #NV zurück.

  • Ist Vergleichstyp gleich 0 und ist als Suchkriterium eine Zeichenfolge angegeben, können Sie im Argument Suchkriterium die Platzhalterzeichen Fragezeichen (?) und Sternchen (*) verwenden. Ein Fragezeichen ersetzt ein Zeichen; ein Sternchen ersetzt eine beliebige Zeichenfolge. Wenn Sie nach einem Fragezeichen oder Sternchen suchen möchten, müssen Sie eine Tilde (~) vor das zu suchende Zeichen setzen.

Beispiel

Kopieren Sie die Beispieldaten in der folgenden Tabelle, und fügen Sie sie in Zelle A1 eines neuen Excel-Arbeitsblatts ein. Um die Ergebnisse der Formeln anzuzeigen, markieren Sie sie, drücken Sie F2 und dann die EINGABETASTE. Im Bedarfsfall können Sie die Breite der Spalten anpassen, damit alle Daten angezeigt werden.

Produkt

Anzahl

Bananen

25

Orangen

38

Äpfel

40

Birnen

41

Formel

Beschreibung

Ergebnis

=VERGLEICH(39;B2:B5;1)

Da es keine genaue Übereinstimmung gibt, wird die Position des nächstkleineren Werts (38) im Bereich B2:B5 zurückgegeben.

2

=VERGLEICH(41;B2:B5;0)

Die Position des Werts 41 im Bereich B2:B5.

4

=VERGLEICH(40;B2:B5;-1)

Gibt einen Fehlerwert zurück, da die Werte im Bereich B2:B5 nicht in absteigender Reihenfolge angeordnet sind.

#NV

Siehe auch

Funktion SVERWEIS

Funktion INDEX

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×