Suchen nach angepassten Benutzerelemente in Project Online und Project Server-Benutzer Exportieren von Daten

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Dieser Artikel beschreibt, wie Sie für die Suche nach einer bestimmten Benutzern benutzerdefinierte Elemente (Ansichten, filtern, Anlagen, Tabellen und Makros) in einem Projekt, wenn Sie einen Benutzer Daten in Project Online oder Project Server Export ausführen. Dies umfasst:

Die Verfahren in diesem Artikel müssen Sie über Folgendes verfügen:

  • Die MPP-Datei für das Projekt

  • Die XML-Datei für das Projekt

Für Project Online wurden beide Dateien Ihnen zur Verfügung gestellt beim Exportieren der Benutzerdaten durch die Verfahren in Benutzerdaten von Project Online exportieren.

Für Project Server müssen Sie die bestimmte Projektdatei in XML-Format zum Erstellen der XML-Datei zu speichern.

Hinweis: Beim Speichern einer Projektdatei in XML-Format mit Project Professional, stellen Sie sicher, dass Sie die neuesten Updates angewendet haben.

Suchen und speichern Sie benutzerdefinierte Ansichten

  1. Öffnen Sie das bestimmte Projekt XML-Datei in einem Text-Editor ein.

  2. Suchen Sie in den Text < Ansichten > , um eine Liste der Benutzeransichten für das Projekt zu finden.

  3. Suchen Sie in der Liste der Ansichten für alle Ansichten, die die IsCustomized -Eigenschaft auf truefestgelegt haben. Beispielsweise weist die folgenden bedeutet, dass eine Ansicht namens aktive Aufgaben aus der globalen/Standardvorlage angepasst wurde:

    <View>
    <Name>Task Sheet</Name>
    <IsCustomized>true</IsCustomized>
    </View>
    
  4. Öffnen Sie jetzt MPP-Datei des Projekts in die Project Online-Desktopclient oder Project Professional 2016 ein.

  5. Klicken Sie zum Öffnen des Menübands, und wählen im Menüband im Dropdownmenü Andere Ansicht im Menü Ansicht auf, und klicken Sie dann auf Weitere Ansichten.

  6. Wählen Sie im Fenster Weitere Ansichten in der Liste Ansichten die Ansicht, die Sie suchen, und klicken Sie dann auf Übernehmen.

    Weitere Filter
  7. Die ausgewählte Ansicht wird angezeigt. Ein Bildschirmabbild der Ansicht, und speichern Sie sie.

  8. Verwenden Sie dasselbe Verfahren, das für alle verbleibenden benutzerdefinierte Ansichten, die Sie in der XML-Datei gefunden.

Sie können diesen Vorgang für jedes Projekt wiederholen, in denen Sie für Ihre benutzerdefinierte Benutzeransichten suchen möchten.

So suchen und speichern Sie die angepasste Filter

  1. Öffnen Sie das bestimmte Projekt XML-Datei in einem Text-Editor ein.

  2. Suchen Sie in den Text nach < Filter > , um eine Liste der Benutzer Filter für das Projekt zu finden.

  3. Suchen Sie in der Liste der Filter für alle Filter, die die IsCustomized -Eigenschaft auf truefestgelegt haben. Beispielsweise weist die folgenden bedeutet, dass ein Filter mit dem Namen aktive Aufgaben aus der globalen/Standardvorlage angepasst wurde:

    <Filters>
    <Name>Active Tasks</Name>
    <IsCustomized>true</IsCustomized>
    </Filter>
    
  4. Öffnen Sie zum Speichern der Ansicht des Projekts MPP-Datei in die Project Online-Desktopclient oder Project Professional 2016 ein.

  5. Klicken Sie im Menü Ansicht auf, und wählen Sie in dem Dropdownmenü FilterWeitere Filter.

  6. Wählen Sie den Filter, den Sie suchen, den und klicken Sie dann auf Bearbeiten, klicken Sie im Menü Weitere Filter .

    Weitere Filter
  7. Die Filterdefinition für den ausgewählten Filter wird angezeigt. Sie können einen Screenshot der Filterdefinition und gespeichert.

  8. Verwenden Sie dasselbe Verfahren, das für alle verbleibenden benutzerdefinierten Filter, die Sie in der XML-Datei gefunden.

Sie können diesen Vorgang für jedes Projekt wiederholen, in denen Sie Suchen des Benutzers Filter anpassen möchten.

Suchen und Speichern von Anlagen

  1. Öffnen Sie das bestimmte Projekt XML-Datei in einem Text-Editor ein.

  2. Suchen Sie in den Text nach < Aufgaben > , um eine Liste der Benutzeraufgaben für das Projekt zu finden.

  3. Suchen Sie in der Liste der Aufgaben für alle Vorgänge, die die NoteContainsObjects -Eigenschaft auf truefestgelegt haben. Angenommen, enthält die folgenden bedeutet, dass die 18 Aufgabenbereich Anlage:

    <Task>
    <UID>18</UID>
    <NoteContainsObjects>true</NoteContainsObjects>
    </Task>
    
  4. Öffnen Sie zum Speichern der Anlage des Projekts MPP-Datei in die Project Online-Desktopclient oder Project Professional 2016 ein.

  5. Klicken Sie im Menü Aufgaben auf, und öffnen Sie die Aufgabe, die Anlage (z. B. Vorgang #18) zugeordnet.

  6. Wählen Sie im Bildschirm Informationen zum Vorgang die Registerkarte Notizen . Sie sollten die Anlage Element aufgeführt sehen.

    Anlagen zu Vorgängen
  7. Öffnen Sie das Element Anlage, und speichern Sie es.

  8. Verwenden Sie dasselbe Verfahren, das für alle verbleibenden Anlagen, die Sie in der XML-Datei gefunden.

Sie können diesen Vorgang für jedes Projekt wiederholen, in denen Sie für des Benutzers Anlagen suchen möchten.

So suchen und speichern Sie die angepasste Tabellen

  1. Öffnen Sie das bestimmte Projekt XML-Datei in einem Text-Editor ein.

  2. Suchen Sie in den Text nach < Tabellen > , um die Tabellen im Projekt zu finden.

  3. Suchen Sie in der Liste der Tabellen für alle Tabellen, die die IsCustomized -Eigenschaft auf truefestgelegt haben. Beispielsweise weist die folgenden bedeutet, dass die Tabelle den Eintrag aus der globalen/Standardvorlage angepasst wurde:

    <Tables>
    <Table>Entry</Name>
    <IsCustomized>true</IsCustomized>
    </Table>
    
  4. Öffnen Sie jetzt MPP-Datei des Projekts in die Project Online-Desktopclient oder Project Professional 2016 ein.

  5. Klicken Sie im Menü Ansicht , um das Menüband zu öffnen, und wählen Sie im Menüband im Dropdownmenü Tabellen auf, und klicken Sie dann auf Weitere Tabellen.

  6. Wählen Sie im Fenster Weitere Tabellen in der Liste Tabellen die Tabelle, die Sie suchen, die und klicken Sie dann auf Bearbeiten.

    Tabellendefinition
  7. Die Definition der Tabelle wird für die ausgewählte Tabelle angezeigt. Bildschirmabbild des alle Informationen in das Definitionsfenster und gespeichert.

  8. Verwenden Sie dasselbe Verfahren, das für alle verbleibenden angepasste Tabellen, die Sie in der XML-Datei gefunden.

Sie können diesen Vorgang für jedes Projekt wiederholen, in denen Sie für angepasste Tabellen des Benutzers suchen möchten.

Suchen und Benutzermakros speichern

Hinweis: Die XML-Dateien eines Projekts werden nicht markiert, wenn sie VBA-Makros enthält. Sie müssen manuell Öffnen des Benutzers Projekte, um zu überprüfen, ob sie eine VBA-Makros enthält.

  1. Öffnen des Projekts MPP-Datei in die Project Online-Desktopclient oder Project Professional 2016.

  2. Klicken Sie zum Öffnen des Menübands, und wählen im Menüband im Dropdownmenü Makros im Menü Ansicht auf, und klicken Sie dann auf Makros anzeigen.

  3. Wählen Sie auf der Seite MakrosVisual Basic im Visual Basic-Editor geöffnet.

  4. Im Visual Basic-Editor können Sie jede der Benutzer benutzerdefinierte VBA-Dateien speichern.

Sie können diesen Vorgang für jedes Projekt wiederholen, in denen Sie Suchen des Benutzers Makros anpassen möchten.

Siehe auch

Exportieren von Benutzerdaten in Project Online

Exportieren von Benutzerdaten von Project Server

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×