Steuern einer Website mit Visio

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Wenn Sie den täglichen Betrieb einer Website verwalten, wissen Sie, dass es wichtig ist, ein klares Bild der Gesamtstruktur und des Datenflusses der Website zu haben, Entwicklungsänderungen nachzuverfolgen und beschädigte Links zu überwachen und zu reparieren. Sie können all diese Aufgaben und mehr mithilfe der Website Kartentools in Microsoft Office Visio Professional ausführen.

Inhalt dieses Artikels

Zuordnen der Inhalte Ihrer Website

Automatische Überprüfungen Ihrer Website auf Fehler

Nachverfolgen von Änderungen an Ihrer Website

Zuordnen der Inhalte Ihrer Website

Die Verwaltung Ihrer Website beginnt mit der Analyse des aktuellen Zustands. Wenn Sie Ihre Website zuordnen, erstellen Sie eine aktuelle grafische Darstellung der Struktur und der Inhalte der Website.

Eine Websiteübersicht, mit der die aktuelle hierarchische Struktur der Verknüpfungen auf der Website angezeigt wird

Jedes Shape in der Sitemap stellt einen Link auf Ihrer Website dar, und jedes Shape enthält Informationen zu Linktyp und Speicherort. Wenn Sie mit der rechten Maustaste auf eine Form klicken, können Sie direkt von der Form zu Ihrer Website navigieren.

  1. Zeigen Sie in Visio im Menü Datei auf neu, zeigen Sie auf Software und Datenbank, und klicken Sie dann auf Websiteübersicht.

  2. Geben Sie im Dialogfeld Sitemap generieren eine Websiteadresse für eine der folgenden Optionen ein:

    • Geben Sie bei einem HTTP-Server im Feld Adresse die Adresse der Website ein, die Sie zuordnen möchten.

    • Wenn Sie einen Netzwerkserver oder eine lokale Festplatte anzeigen möchten, klicken Sie auf Durchsuchen, navigieren Sie zu der Datei, die Sie an der Stammebene Ihrer Websiteübersicht wünschen, und klicken Sie dann auf Öffnen.

  3. Klicken Sie im Dialogfeld Sitemap generieren auf Einstellungen, um die Einstellungen für die maximale Anzahl von Ebenen und die Anzahl der zu entdeckende Links zu überprüfen.

  4. Wenn Sie die Einstellungen ändern möchten, gehen Sie folgendermaßen vor:

    • Ändern Sie auf der Registerkarte Layout die Layout-Formatvorlage der Websiteübersicht, z. b. die Anzahl der Ebenen, die ermittelt werden sollen, oder ob die Zeichnung eine kompakte Struktur oder ein Flussdiagramm darstellt.

    • Wählen Sie auf der Registerkarte Erweiterungen den Typ der Dateien aus, die Sie zuordnen möchten (z. b. doc, JPG oder exe).

    • Wählen Sie auf der Registerkarte Protokolle die Protokolle (z. b. mailto, FTP oder NNTP) aus, die Sie zuordnen möchten.

    • Wählen Sie auf der Registerkarte Attribute die HTML-Attribute (z. b. href, src oder Code) aus, die nach Links gesucht werden sollen.

    • Wählen Sie auf der Registerkarte erweitert die Optionen aus, mit denen Sie Ihre Suchkriterien weiter verfeinern.

    • Klicken Sie auf OK.

  5. Klicken Sie im Dialogfeld Websiteübersicht generieren auf OK.

  6. Um die Sitemap zu speichern, klicken Sie im Menü Datei auf Speichern.

Seitenanfang

Automatische Überprüfungen Ihrer Website auf Fehler

Es ist die wichtigste Aufgabe der Websiteverwaltung, die Links der Website aktiv und fehlerfrei zu halten.

Wenn Sie Ihre Website zuordnen, folgt Visio jedem Link innerhalb der von Ihnen festgelegten Parameter und verfolgt alle gefundenen Fehler. Die Verknüpfungen mit Fehlern werden auf der Sitemap, im Filter Fenster und im Listen Fenster als Formen mit rotem XS angezeigt. Wenn diese Fenster nicht angezeigt werden, zeigen Sie im Menü Websiteübersicht auf Fenster, und klicken Sie dann entweder auf das Listenfenster oder auf das Filter Fenster. Sie können schnell eine Liste der fehlerhaften Verknüpfungen mit den zugehörigen Fehlern erstellen, damit Sie Ihre Arbeit nachverfolgen und die erforderlichen Reparaturen ausführen.

Eine Websiteübersicht, mit der die Struktur einer Website angezeigt wird. Jedes Shape mit einem roten X stellt eine unterbrochene Verknüpfung dar.

Erstellen eines Berichts mit Links mit Fehlern auf Ihrer Website

  1. Öffnen Sie die Websiteübersicht, für die Sie einen Fehlerbericht erstellen möchten.

  2. Zeigen Sie im Menü Websiteübersicht auf Berichte, klicken Sie auf Website Übersichts Links mit Fehlern, und klicken Sie dann auf Ausführen.

  3. Wählen Sie die Art der Datei (z. b. Excel oder XML) aus, in der die Informationen gespeichert werden sollen, und klicken Sie dann auf OK.

    Visio erstellt einen Bericht, in dem alle Links mit Link Fehlern aufgelistet sind.

  4. Wenn Ihr Bericht in einem Programm außerhalb von Visio geöffnet wird, z. b. Microsoft Office Excel, benennen Sie den Bericht, und speichern Sie ihn.

Beheben fehlerhafter Verknüpfungen

Einige fehlerhafte Verknüpfungen werden durch Timeoutfehler verursacht. Um diese Fehler zu beheben, klicken Sie mit der rechten Maustaste auf den Link, und klicken Sie dann auf Aktualisieren oder auf übergeordnetes Element aktualisieren.

Andere fehlerhafte Links werden durch die Website nicht gefunden, "Zugriff verweigert" oder "Kennwort erforderlich" oder durch falsche Dateinamen, falsche Dateispeicherorte und fehlende Dateien verursacht, die eine 404-oder Datei nicht gefundene Problemmeldung auslösen können. Jede dieser Schritte muss auf der Website korrigiert werden.

Ihre Website und die Websiteübersicht sind nicht dynamisch verknüpft; eine Änderung wirkt sich nicht automatisch auf die andere aus. Nachdem Sie einen fehlerhaften Link auf der Website korrigiert haben, können Sie die Sitemap aktualisieren, indem Sie mit der rechten Maustaste auf die Form klicken, die den fehlerhaften Link darstellt, und dann auf Hyperlink aktualisieren klicken. Das rote X verschwindet.

Seitenanfang

Nachverfolgen von Änderungen an Ihrer Website

Wenn mehrere Entwickler an Ihrer Website arbeiten, kann das Nachverfolgen Ihrer Arbeit schnell zu einer Vollzeitaufgabe werden. Mithilfe des Vergleichsberichts für die websiteÜbersicht können Sie zwei Versionen Ihrer Website vergleichen, um die in einem bestimmten Zeitraum vorgenommenen Änderungen zu quantifizieren. Der Bericht vergleicht die beiden Versionen und generiert eine Liste mit unterschieden. Sie identifiziert nicht nur die Links, die nur in einer der Karten angezeigt werden, sondern listet auch die folgenden Link Änderungen in beiden Karten auf:

  • Fehlerstatus

  • Datei Titel

  • Dateigröße

  • Dateiänderungsdatum

Nehmen wir beispielsweise an, Sie möchten die Arbeit, die auf der Website geleistet wird, wöchentlich quantifizieren. Ordnen Sie die Website einfach am Anfang der Woche und am Ende wieder an. Vergleichen Sie dann die beiden Karten, um einen Bericht über die Änderungen zu generieren. Sie können den Bericht auch anhand eines für die Woche geplanten Arbeitsplans Messen, um festzustellen, ob sich das Websiteprojekt im Ziel befindet.

Vergleichen von Website Karten

  1. Öffnen Sie die neueste Karte Ihrer Website.

  2. Klicken Sie im Menü Websiteübersicht auf mit vorherigem Dokument vergleichen.

  3. Navigieren Sie zu der Websiteübersicht, mit der Sie vergleichen möchten, wählen Sie die Datei aus, und klicken Sie dann auf Öffnen.

    Visio vergleicht die beiden Karten und generiert einen HTML-Bericht, in dem die Unterschiede aufgelistet werden.

  4. Benennen Sie den Bericht, und speichern Sie ihn.

Seitenanfang

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×