Senden von Formulardaten an eine Microsoft SQL Server-Datenbank

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Inhalt dieses Artikels

(Übersicht)

Schritt 1: Aktivieren der Verbindungs zum Absenden von Daten

Schritt 2: Konfigurieren der Absendeoptionen

Übersicht

Beim Entwerfen einer Formularvorlage, die auf einer Microsoft SQL Server-Datenbank basiert, ermöglicht Datenverbindungs-Assistenten eine Verbindung zum Absenden von Daten in die Datenbank aus, wenn die folgenden Bedingungen erfüllt sind:

  • Formulare, die auf dieser Formularvorlage basieren müssen mithilfe von Microsoft Office InfoPath ausgefüllt werden. Wenn das Formular ausgefüllt werden mithilfe eines Webbrowsers, kann nicht das Formular direkt Daten an eine Datenbank senden. Verwenden Sie zum Konfigurieren einer Browserkompatible Formularvorlage zum Senden von Daten in einer Datenbank eine Datenverbindung, die Daten an einen Webdienst sendet, mit denen die Datenbank zusammenarbeitet.

  • Die primäre Datenbank-Tabelle, die in den Hauptfenster-Verbindung verwendet wird enthält einen Primärschlüssel, eindeutigen Einschränkung oder eindeutigen Index.

  • Andere Datenbanktabellen, die mit dieser Datenverbindung Hauptfenster verwendet werden müssen in die primäre Datenbanktabelle eine einfache Beziehung.

Wenn die Datenbank diese Anforderungen erfüllt, InfoPath ermöglicht die Verbindung zum Absenden von Daten, und fügt eine Schaltfläche zum Sendender Standardsymbolleiste und der Befehl Absenden im Menü Datei auf dem Formular.

Sie können auswählen, deaktivieren Sie die Verbindung zum Absenden von Daten im Assistenten beim Entwerfen einer Formularvorlage, die auf einer Datenbank basiert. Wenn Sie die Verbindung zum Absenden von Daten im Assistenten deaktivieren, und klicken Sie dann später entscheiden, dass Sie diese Verbindung zum Absenden von Daten verwenden möchten, können Sie die Verbindung zum Absenden von Daten durch Ändern der Verbindungs zum Hauptfenster Daten aktivieren. In diesem Artikel wird erläutert, wie Sie aktivieren, die Datenverbindung senden.

Hinweis: Sie können eine Verbindung zum Absenden von Daten nur die wichtigsten Verbindung mit einer Datenbank haben. Sie können eine Verbindung zum Absenden von Daten in der Formularvorlage hinzufügen, die eine sekundäre Datenquelle zu einer Datenbank ist. Wenn Sie eine Verbindung zum Absenden von Daten in einer Datenbank als eine sekundäre Datenquelle verwenden möchten, mithilfe eines Webdiensts, mit das die Datenbank zusammenarbeitet, und klicken Sie dann eine Verbindung zum Übermitteln von Daten zu diesen Webdienst hinzufügen.

Nachdem Sie die Verbindung zum Absenden von Daten aktiviert haben, können Sie auch die Absendeoptionen für Ihre Formularvorlage auf folgende Weise anpassen:

  • Ändern Sie den Text, der auf die Schaltfläche Senden, klicken Sie auf der Standardsymbolleiste und den Befehl Absenden im Menü Datei angezeigt wird.

  • Ändern Sie die Tastenkombination für die Schaltfläche Senden, klicken Sie auf der Standardsymbolleiste und den Befehl Absenden im Menü Datei.

  • Erstellen Sie benutzerdefinierte Nachrichten an die Benutzer angezeigt werden, wenn sie ihre Formulare absenden.

  • Geben Sie an, ob das Formular geöffnet lassen, schließen Sie das Formular, oder öffnen Sie ein neues leeres Formular aus, nachdem Sie das Formular gesendet wird.

Seitenanfang

Schritt 1: Aktivieren der Verbindungs zum Absenden von Daten

  1. Klicken Sie im Menü Extras auf Datenverbindungen.

  2. Klicken Sie im Dialogfeld Datenverbindungen klicken Sie auf das Hauptfenster Datenverbindung, und klicken Sie dann auf Ändern.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten aktivieren Sie das Kontrollkästchen Absenden für diese Verbindung aktivieren, und klicken Sie dann auf Fertig stellen.

Seitenanfang

Schritt 2: Konfigurieren der Absendeoptionen

Nachdem Sie die Verbindung zum Absenden von Daten aktivieren, fügt InfoPath die Senden-Schaltfläche auf der Standardsymbolleiste und der Befehl Absenden im Menü Datei an. InfoPath konfiguriert außerdem die Formularen, die auf dieser Formularvorlage für Benutzer eine Meldung angezeigt, nachdem sie ihre ausgefüllten Formulare absenden basieren. Die Meldung weist darauf hin, ob das Formular erfolgreich gesendet wurde. Standardmäßig bleibt InfoPath auch Formulare öffnen nach dem Benutzer, die sie senden. Führen Sie folgende Schritte aus, um den Text zu ändern, der angezeigt, klicken Sie auf die Schaltfläche Senden als auch das Verhalten, das auftritt wird, nachdem die Benutzer ihre Formulare senden:

  1. Klicken Sie im Menü Extras auf Optionen zum Absenden.

    1. Wenn der Name der Senden-Schaltfläche, die angezeigt, klicken Sie auf der Standardsymbolleiste und den Befehl Absenden, der Sie im Menü Datei angezeigt wird wird, wenn Benutzer des Formulars ausfüllen ändern möchten, geben Sie den neuen Namen im Feld Beschriftung die übermitteln Optionen im Dialogfeld.

      Tipp: Wenn Sie diese Schaltfläche und den Befehl eine Tastenkombination zuweisen möchten, geben Sie ein kaufmännisches und-Zeichen (&) vor dem Zeichen, die Sie als Tastenkombination verwenden möchten. Geben Sie beispielsweise ALT + B als die Tastenkombination für die Senden-Schaltfläche und der Befehl zuzuweisen, & bsenden.

  2. Wenn Sie keine anderen Befehl Absenden oder die Senden-Schaltfläche auf der Standardsymbolleiste verwendet, beim Ausfüllen eines Formulars, deaktivieren Sie das Kontrollkästchen anzeigen das Menüelement übermitteln und die Symbolleisten-Schaltfläche Absenden.

    1. Standardmäßig nach dem Senden eines Formulars, InfoPath behält das Formular zu öffnen, und wird eine Meldung angezeigt, um anzugeben, ob das Formular erfolgreich gesendet wurde. Wenn Sie dieses Standardverhalten ändern möchten, klicken Sie auf Erweitert, und führen Sie dann eine der folgenden Aktionen aus:

      • Wenn Sie das Formular schließen, oder erstellen ein neues leeres Formular aus, nach der Benutzer ein ausgefülltes Formular übermittelt, klicken Sie auf die Option, die Sie in der Liste nach dem Senden möchten.

      • Zum Erstellen einer benutzerdefinierten Nachricht, um anzugeben, ob das Formular erfolgreich gesendet wurde, aktivieren Sie das Kontrollkästchen benutzerdefinierte Meldung verwenden, und geben Sie dann Ihre Nachrichten in den Feldern bei Erfolg und bei einem Fehler.

        Tipp: Verwenden Sie eine Nachricht im Feld auf Fehler zu Benutzern mitteilen, was zu tun ist, wenn sie ihr Formular übermitteln können. Beispielsweise können Sie vorschlagen, dass Benutzer Formular zu speichern und Weitere Informationen zum Kontaktieren einer Person.

      • Wenn Sie keine zum Anzeigen einer Meldung, nachdem der Benutzer ein Formular übermittelt, deaktivieren Sie das Kontrollkästchen Erfolg und Fehler Nachrichten anzeigen.

Seitenanfang

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×