Optimieren von Access

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Dieser Artikel enthält Tipps zum Verbessern der Leistung einer Microsoft Office Access-Datenbank. Mithilfe der folgenden Tipps können Sie viele Datenbankvorgänge beschleunigen, z. b. das Ausführen von Berichten oder das Öffnen von Formularen auf der Grundlage komplexer Abfragen.

Eine der besten Möglichkeiten zum Verbessern der Leistung einer Datenbank besteht darin, Indizes für häufig verwendete Felder zu erstellen. Durch das Erstellen von Indizes können Sie die Leistung mehr verbessern, als Sie mithilfe der Tipps in diesem Artikel erreichen können. Access erstellt automatisch einige Indizes, Sie sollten jedoch genau überlegen, ob zusätzliche Indizes die Leistung verbessern.

In diesem Artikel werden keine Möglichkeiten besprochen, die Leistung bestimmter Datenbankobjekte zu optimieren, z. b. durch Erstellen eines Indexes. Weitere Informationen finden Sie im Artikel Erstellen und Verwenden eines Indexes, um die Leistung zu verbessern.

Inhalt dieses Artikels

Verbessern der Leistung einer lokalen Datenbank

Verbessern der Leistung in einer Mehrbenutzerumgebung

Helfen Sie, die Zugriffsleistung auf Ihrem Computer zu verbessern.

Verbessern der Leistung einer lokalen Datenbank

Mithilfe der folgenden Richtlinien können Sie die Leistung einer lokalen Access-Datenbank optimieren – einer Datenbank, die auf einem lokalen Festplattenlaufwerk gespeichert ist, und nicht in einem Netzwerk.

Deaktivieren der Namen-AutoKorrektur

Automatisches Komprimieren und Reparieren der Datenbank

Öffnen der Datenbank im Exklusivmodus

Deaktivieren von AutoKorrektur-Optionen

Deaktivieren der Namen-AutoKorrektur

Mit dem Feature "Objektnamenautokorrektur" können Sie sicherstellen, dass die Funktionalität von Datenbankobjekten intakt bleibt, wenn andere Datenbankobjekte, von denen Sie abhängig sind, umbenannt werden Wenn Sie z. b. eine Tabelle umbenennen und es Abfragen gibt, die diese Tabelle verwenden, stellt die namens AutoKorrektur sicher, dass diese Abfragen nicht durch die Änderung unterbrochen werden. Diese Funktion kann nützlich sein, führt jedoch einige Leistungseinbußen aus.

Wenn Ihr Datenbankentwurf stabil ist und seine Objekte nicht umbenannt werden, können Sie die Objektnamenautokorrektur gefahrlos deaktivieren, um die Leistung zu verbessern.

  1. Öffnen Sie die Datenbank, die Sie optimieren möchten.

  2. Klicken Sie auf Datei > Optionen, um das Dialogfeld Access-Optionen zu öffnen.

  3. Klicken Sie links im Dialogfeld Access-Optionen auf Aktuelle Datenbank.

  4. Deaktivieren Sie im rechten Bereich unter AutoKorrektur-Optionenalle Kontrollkästchen.

Automatisches Komprimieren und Reparieren der Datenbank

Im Lauf der Zeit kann sich die Leistung einer Datenbankdatei aufgrund von Speicherplatz verlangsamen, der gelöschten oder temporären Objekten zugewiesen bleibt. Der Befehl komprimieren und reparieren entfernt diesen vergeudeten Speicherplatz und kann eine Datenbank schneller und effizienter ausführen. Sie können eine Option zum automatischen Ausführen des Befehls komprimieren und reparieren festlegen, wenn eine Datenbank geschlossen wird.

  1. Öffnen Sie die Datenbank, die Sie optimieren möchten.

  2. Klicken Sie auf Datei > Optionen, um das Dialogfeld Access-Optionen zu öffnen.

  3. Klicken Sie links im Dialogfeld Access-Optionen auf Aktuelle Datenbank.

  4. Aktivieren Sie im rechten Bereich unter Anwendungsoptionendas Kontrollkästchen beim Schließen komprimieren .

Öffnen der Datenbank im Exklusivmodus

Wenn Sie als einziger eine Datenbank verwenden, verhindert das Öffnen der Datenbank im Exklusiv-Modus, dass andere Benutzer die Datenbank gleichzeitig verwenden und die Leistung verbessern können.

  1. Starten Sie Access, aber öffnen Sie keine Datenbank. Wenn Sie bereits eine Datenbank geöffnet haben, schließen Sie Sie.

  2. Klicken Sie auf Öffnen , und klicken Sie dann auf Durchsuchen.

  3. Wählen Sie im Dialogfeld Öffnen die Datenbankdatei aus, die Sie öffnen möchten. Sie können die Liste Suchen in verwenden, wenn Sie nach der Datenbankdatei suchen müssen.

  4. Klicken Sie auf den Pfeil auf der Schaltfläche Öffnen , und klicken Sie dann auf exklusiv öffnen.

Deaktivieren von AutoKorrektur-Optionen

Standardmäßig korrigiert Access Ihre Rechtschreibung während der Eingabe. Sie können das Feature AutoKorrektur deaktivieren, um die Leistung zu verbessern.

  1. Öffnen Sie die Datenbank, die Sie optimieren möchten.

  2. Klicken Sie auf Datei > Optionen, um das Dialogfeld Access-Optionen zu öffnen.

  3. Klicken Sie im linken Bereich des Dialogfelds Access-Optionen auf DokumentPrüfung.

  4. Klicken Sie im rechten Bereich unter AutoKorrektur-Optionenauf AutoKorrektur-Optionen.

  5. Deaktivieren Sie im Dialogfeld AutoKorrektur-Optionen die Kontrollkästchen für die Optionen, die nicht angezeigt werden sollen.

    Hinweis: Sie müssen nicht alle AutoKorrektur-Optionen deaktivieren, um einen Vorteil zu sehen, aber je mehr AutoKorrektur-Optionen Sie deaktivieren, desto größer der nutzen.

Seitenanfang

Verbessern der Leistung in einer Mehrbenutzerumgebung

Mithilfe der folgenden Richtlinien können Sie die Leistung einer Access-Datenbank optimieren, die in einer Mehrbenutzerumgebung verwendet wird.

AufTeilen der Datenbank

Ändern der Sperreinstellung auf Seitenebene oder auf Datensatzebene

Auswählen einer geeigneten Einstellung für die Datensatzsperrung

Anpassen der Einstellungen für die Netzwerkaktualisierung und-Aktualisierung

AufTeilen der Datenbank

Wenn Sie eine Datenbank aufteilen, legen Sie die Datentabellen in einer Datenbankdatei auf einem Netzwerkserver in einer sogenannten Back-End-Datenbank ab. Sie fügen die anderen Datenbankobjekte, wie Abfragen, Formulare und Berichte, in eine andere Datenbankdatei ein, die als Front-End-Datenbank bezeichnet wird. Die Benutzer behalten eine eigene Kopie der Front-End-Datenbank auf ihren Computern. Die Leistung wird verbessert, da nur die Daten über das Netzwerk gesendet werden.

Sie haben eine Datenbank mithilfe des Assistenten zum Hinzufügen von Daten Bank Splittern geteilt.

  • Klicken Sie auf der Registerkarte Daten Bank Tools in der Gruppe Daten verschieben auf Access-Datenbank.

Ändern der Sperreinstellung auf Seitenebene oder auf Datensatzebene

Access sperrt eine bestimmte Datenmenge, während Sie Datensätze bearbeiten. Wie viele Daten gesperrt werden, hängt von der von Ihnen ausgewählten Sperreinstellung ab. Sie können die Leistung verbessern, indem Sie Sperren auf Seitenebene auswählen. Durch Sperren auf Seitenebene kann die Datenverfügbarkeit jedoch verringert werden, da mehr Daten als mit Sperren auf Datensatzebene gesperrt werden.

  • Sperren auf Seitenebene    Access sperrt die Seite, die den Eintrag enthält (die Seite ist der Speicherbereich, in dem sich der Datensatz befindet). Das Bearbeiten eines Datensatzes mit aktiviertem Sperren auf Seitenebene kann auch dazu führen, dass andere im Arbeitsspeicher gespeicherte Einträge gesperrt werden. Die Leistung ist jedoch in der Regel schneller, wenn Sie Sperren auf Seitenebene anstelle von Sperren auf Datensatzebene verwenden.

  • Sperren auf Datensatzebene    Access sperrt nur den zu bearbeitenden Datensatz. Andere Datensätze sind hiervon nicht betroffen.

Ändern der Sperreinstellung auf Seitenebene oder auf Datensatzebene    

  1. Öffnen Sie die Datenbank, die Sie anpassen möchten.

  2. Klicken Sie auf Datei > Optionen, um das Dialogfeld Access-Optionen zu öffnen.

  3. Klicken Sie im linken Bereich auf Client Einstellungen.

  4. Aktivieren oder deaktivieren Sie im rechten Bereich im Abschnitt erweitert das Kontrollkästchen Datenbanken mithilfe von Sperren auf Datensatzebene öffnen .

Auswählen einer geeigneten Einstellung für die Datensatzsperrung

Access sperrt Datensätze, während Sie Sie bearbeiten. Die Anzahl der Datensätze, die von Access gesperrt werden, und die Zeitdauer, die diese Datensätze sperren, hängt von der von Ihnen ausgewählten Einstellung für die Datensatzsperrung ab.

  • Keine Sperren     Access sperrt keinen Datensatz oder keine Seite, bis ein Benutzer Änderungen daran speichert, wodurch Daten leichter verfügbar sind. Datenkonflikte (gleichzeitige Änderungen an demselben Datensatz) können jedoch auftreten, wenn Sie diese Einstellung verwenden. Wenn ein Datenkonflikt auftritt, muss der Benutzer entscheiden, welche Version der Daten beibehalten werden soll. Dies ist im Allgemeinen die schnellste Option, aber Datenkonflikte überwiegen möglicherweise den Leistungsgewinn.

  • BeArbeiteter Datensatz     Access sperrt einen Datensatz, sobald der Benutzer mit der Bearbeitung beginnt. Infolgedessen werden Datensätze für längere Zeiträume gesperrt, Datenkonflikte sind jedoch weniger wahrscheinlich.

  • All records     Access sperrt alle Datensätze in einer Tabelle, während ein Formular oder Datenblatt, das diese Tabelle verwendet, geöffnet ist. Dies kann die Leistung für den Benutzer, der Daten in der Tabelle bearbeitet, verbessern, schränkt jedoch die Fähigkeit anderer Benutzer ein, Daten mehr zu bearbeiten als die anderen Optionen.

Ändern der Einstellung für die Datensatzsperrung    

  1. Öffnen Sie die Datenbank, die Sie anpassen möchten.

  2. Klicken Sie auf Datei > Optionen, um das Dialogfeld Access-Optionen zu öffnen.

  3. Klicken Sie im linken Bereich auf Client Einstellungen.

  4. Klicken Sie im rechten Bereich im Abschnitt erweitert unter standardmäßige Datensatzsperrungauf die gewünschte Option.

Anpassen der Einstellungen für die Netzwerkaktualisierung und-Aktualisierung

Versuchen Sie, die Einstellungen für Aktualisierungsintervall (SEK), Update Wiederholungsintervall (MS), Anzahl der Aktualisierungsversucheund ODBC-Aktualisierungsintervall (sec) anzupassen.

Sie verwenden das Aktualisierungsintervall für Wiederholungen und die Anzahl der Einstellungen für Aktualisierungsversuche , um anzugeben, wie häufig und wie oft Access versucht, einen Eintrag zu speichern, wenn er von einem anderen Benutzer gesperrt wurde.

Sie verwenden die Einstellungen für ODBC-Aktualisierungsintervall und Aktualisierungsintervall , um zu steuern, wie oft Access Ihre Daten aktualisiert. Durch das Aktualisieren werden nur Daten aktualisiert, die bereits in Ihrem Datenblatt oder Formular vorhanden sind. Bei der Aktualisierung werden keine Datensätze neu angeordnet, neue Einträge angezeigt oder gelöschte Datensätze und Datensätze aus Abfrageergebnissen entfernt, die die angegebenen Kriterien nicht mehr erfüllen. Um diese Änderungen anzuzeigen, müssen Sie die zugrunde liegenden Datensätze für das Datenblatt oder Formular erneut Abfragen.

Ändern der Einstellungen für die Netzwerkaktualisierung und-Aktualisierung    

  1. Öffnen Sie die Datenbank, die Sie schneller ausführen möchten.

  2. Klicken Sie auf Datei > Optionen, um das Dialogfeld Access-Optionen zu öffnen.

  3. Klicken Sie im linken Bereich auf Client Einstellungen.

  4. Ändern Sie im rechten Bereich im Abschnitt erweitert die gewünschten Einstellungen.

Tipp: Drücken Sie zum erneuten Abfragen UMSCHALT + F9.

Seitenanfang

Helfen Sie, die Zugriffsleistung auf Ihrem Computer zu verbessern.

Die folgenden Richtlinien können dazu beitragen, die Zugriffsleistung zu verbessern, unabhängig davon, ob die Datenbank, mit der Sie arbeiten, auf dem Computer oder im Netzwerk gespeichert ist.

Deaktivieren von Animationen der Benutzeroberfläche

Deaktivieren von Aktionstags

Schließen anderer nicht verwendeter Programme

Hinzufügen von mehr Arbeitsspeicher auf Ihrem Computer

BeReinigen der Festplatten

Deaktivieren von Windows-Diensten, die Sie nicht benötigen

Anpassen der Einstellungen für den virtuellen Speicher

Verwenden Sie keinen Bildschirmschoner

Verwenden Sie keinen Desktop Hintergrund

Deaktivieren von Animationen der Benutzeroberfläche

Die Benutzeroberfläche von Access enthält Animationen, z. b. beim Öffnen von Menüs. Obwohl diese Animationen dazu beitragen, die Benutzeroberfläche einfacher zu verwenden, können Sie die Dinge ein wenig verlangsamen. Sie können Sie deaktivieren, um die Leistung zu verbessern.

  1. Klicken Sie auf Datei > Optionen, um das Dialogfeld Access-Optionen zu öffnen.

  2. Klicken Sie im linken Bereich auf Client Einstellungen.

  3. Deaktivieren Sie im rechten Bereich unter anzeigendas Kontrollkästchen Animationen anzeigen .

Deaktivieren von Aktionstags

Wenn Sie keine Aktionskategorien verwenden, deaktivieren Sie Sie, um die Leistung zu verbessern.

  1. Klicken Sie auf Datei > Optionen, um das Dialogfeld Access-Optionen zu öffnen.

  2. Klicken Sie im linken Bereich auf Client Einstellungen.

  3. Deaktivieren Sie im rechten Bereich unter Anzeigedie Kontrollkästchen Aktionskategorien auf Datenblättern anzeigen und Aktionstags in Formularen und Berichten anzeigen .

Schließen anderer nicht verwendeter Programme

Durch das Schließen anderer Programme wird mehr Arbeitsspeicher für Access zur Verfügung gestellt, wodurch die Datenträgernutzung minimiert und die Leistung verbessert wird.

Hinweis: Möglicherweise möchten Sie auch einige Programme beenden, die nach dem Schließen im Hintergrund fortgesetzt werden. Suchen Sie in Ihrem Infobereich nach diesen Programmen. Seien Sie beim Beenden dieser Programme vorsichtig, da einige Programme möglicherweise erforderlich sind, damit Ihr Computer wie erwartet funktioniert. Wenn Sie Zweifel haben, sollten Sie diese Programme wahrscheinlich nicht beenden.

Hinzufügen von mehr Arbeitsspeicher auf Ihrem Computer

Durch das Hinzufügen von RAM zu Ihrem Computer können große Abfragen schneller ausgeführt werden und es Ihnen ermöglichen, mehr Datenbankobjekte gleichzeitig zu öffnen. Darüber hinaus ist der RAM-Speicher viel schneller als der virtuelle Arbeitsspeicher auf einem Festplattenlaufwerk. Wenn Sie RAM hinzufügen, können Sie die Datenträgernutzung minimieren und die Leistung verbessern.

BeReinigen der Festplatten

Führen Sie periodisch diese Schritte aus:

  1. Löschen Sie Dateien von Ihrem Computer, die Sie nicht mehr benötigen.

  2. Löschen Sie Ihre temporären Internet Dateien.

  3. Leeren Sie den Papierkorb.

  4. Ausführen von Komprimierungs-und Reparaturvorgängen für Ihre Datenbanken.

  5. DeFragmentieren Sie Ihre Festplatten.

Deaktivieren von Windows-Diensten, die Sie nicht benötigen

Wenn Sie beispielsweise eine gute Desktop Sicherungslösung eingerichtet haben, sollten Sie den System wiederHerstellungs Dienst deaktivieren. Durch Deaktivieren von Microsoft Windows-Diensten, die Sie nicht verwenden, wird mehr Arbeitsspeicher für Access verfügbar.

Wichtig: Wenn Sie sich entscheiden, die Windows-Dienste zu deaktivieren, behalten Sie den Überblick, was Sie deaktivieren, damit Sie alle von Ihnen gewünschten Windows-Dienste ganz einfach wieder aktivieren können.

Anpassen der Einstellungen für den virtuellen Speicher

In den meisten Fällen sollte die von Windows verwendete Standardeinstellung für den virtuellen Speicher optimal ausgeführt werden. In einigen Fällen kann die Anpassung des virtuellen Speichers jedoch die Zugriffsleistung verbessern. Passen Sie die Einstellungen für den virtuellen Standardspeicher in den folgenden Fällen an:

  • Auf dem Laufwerk, das derzeit für den virtuellen Speicher verwendet wird, steht nicht viel Speicherplatz zur Verfügung, und auf einem anderen lokalen Laufwerk steht ein Speicherplatz zur Verfügung.

  • Ein anderes lokales Laufwerk, das schneller als das aktuelle Laufwerk ist, verfügt über verfügbaren Speicherplatz und wird nicht stark genutzt.

In diesen Fällen erhalten Sie möglicherweise eine bessere Leistung, indem Sie ein anderes Laufwerk für den virtuellen Speicher angeben.

Sie erhalten möglicherweise auch eine bessere Leistung, indem Sie einen festgelegten Speicherplatz für den virtuellen Speicher angeben. Es empfiehlt sich, 1,5-mal so viel virtuellen Speicher wie die RAM-Größe anzugeben, die auf Ihrem Computer installiert ist. Wenn Sie z. b. 1.024 Megabyte (MB) RAM besitzen, geben Sie 1.536 MB für den virtuellen Speicher an.

Hinweis: Wenn Sie häufig mehrere große Anwendungen gleichzeitig ausführen, möchten Sie möglicherweise mehr virtuellen Speicher angeben.

Hilfe zum Ändern der Einstellungen des virtuellen Speichers finden Sie in der Windows-Hilfe unter "Ändern des virtuellen Speichers".

Verwenden Sie keinen Bildschirmschoner

Bildschirmschoner verwenden Arbeitsspeicher und werden automatisch gestartet. Aufgrund von Verfeinerungen bei der Gestaltung von Monitoren werden Bildschirmschoner nicht mehr benötigt, um den Monitor vor "Burn-in" zu schützen. Sie können die Leistung ein wenig verbessern und Ihren Computer reibungsloser ausführen, indem Sie keinen Bildschirmschoner verwenden.

Tipp: Verlassen Sie sich nicht auf einen Bildschirmschoner, um Ihren Computer vor unbefugtem Zugriff zu schützen. Drücken Sie die Windows-Logo-Taste + L, um Ihren Computer bei einem Schritt zu schützen.

Verwenden Sie keinen Desktop Hintergrund

Möglicherweise wird einiges verbessert, indem der Desktop Hintergrund auf (keine)festgelegt wird.

Seitenanfang

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×