Neuerungen in Microsoft Access 2010

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

In Microsoft Access 2010 können Sie Webdatenbanken erstellen und auf einer SharePoint-Website veröffentlichen. SharePoint-Besucher können Ihre Datenbankanwendung mit SharePoint-Berechtigungen in einem Webbrowser verwenden, um festzustellen, wer was sehen kann. Und Sie können mit einer Vorlage beginnen, damit Sie sofort mit der Zusammenarbeit beginnen können.

Die Benutzeroberfläche von Access hat sich ebenfalls geändert. Wenn Sie mit Office Access 2007 nicht vertraut sind, sind das Menüband und der Navigationsbereich möglicherweise neu für Sie. Das Menüband ersetzt die Menüs und Symbolleisten aus vorherigen Versionen. Der NavigationsBereich ersetzt und erweitert die Funktionalität des DatenBankfensters. Und neu in Access 2010 gewährt Ihnen die Backstage-Ansicht Zugriff auf alle Befehle, die für eine gesamte Datenbank gelten, beispielsweise Komprimieren und reparieren, oder Befehle, die aus dem Menü " Datei " stammen.

In diesem Artikel werden die Features beschrieben, die in Office Access 2007 und Access 2010 eingeführt wurden. Wenn Sie eine allgemeine Einführung in Access benötigen, lesen Sie den Artikel Erste Schritte mit Access 2010.

Inhalt dieses Artikels

Übersicht

Neue Benutzeroberfläche

Leistungsstärkere Tools zum Erstellen von Objekten

Neue Datentypen und Steuerelemente

Verbesserte Datenpräsentation

Verbesserte Sicherheit

EINE bessere Möglichkeit zum Beheben von Problemen

Verbesserte Rechtschreibprüfung

Übersicht

Wenn Sie Zugriff auf eine SharePoint-Website mit konfigurierten Access Services haben, können Sie mithilfe von Access 2010 eine Webdatenbank erstellen. Personen, die über Konten auf der SharePoint-Website verfügen, können Ihre Datenbank in einem Webbrowser verwenden, aber Sie müssen Access 2010 verwenden, um Änderungen am Entwurf vorzunehmen. Obwohl einige Desktopdaten Bank Features nicht im Web übersetzt werden, können Sie viele der gleichen Aufgaben mithilfe neuer Features wie berechnete Felder und datenmakros erledigen.

Freigeben einer Datenbank im Web

  • Verwenden einer Vorlage    Fünf Vorlagen kommen mit Access 2010: Kontakte, Vermögenswerte, Projekte, Ereignisse und karitative Beiträge. Sie können auch eine beliebige Vorlage ändern, vor oder nach der Veröffentlichung.

  • Ganz neu beginnen    Wenn Sie eine leere neue Datenbank erstellen, wählen Sie zwischen einer regulären Datenbank und einer Webdatenbank aus. Diese Wahl wirkt sich auf die Entwurfsfeatures und Befehle aus, die angezeigt werden, damit Sie sicherstellen können, dass Ihre Anwendung im Web kompatibel ist.

  • Konvertieren einer vorhandenen Datenbank in eine Webdatenbank    Sie können eine vorhandene Anwendung im Web veröffentlichen. Nicht alle Desktopdaten Bank Features werden im Web unterstützt, daher müssen Sie möglicherweise einige Features Ihrer Anwendung anpassen.

    Sie können die neue webKompatibilitäts Prüfung ausführen, um Kompatibilitätsprobleme zu ermitteln und zu beheben.

  • Intranet oder Internet    Sie können auf Ihrem eigenen SharePoint-Server veröffentlichen, oder Sie können eine gehostete SharePoint-Lösung verwenden.

    Hinweis:  Zum Verwenden einer Webdatenbank ist ein Benutzerkonto erforderlich. Der anonyme Zugriff wird nicht unterstützt.

Weitere Informationen zu Webdatenbanken finden Sie im Artikel Erstellen einer im Web freizugebenden Datenbank.

Neuer Makro-Generator

Access 2010 bietet einen neuen Makro-Generator mit IntelliSense und einer übersichtlichen, übersichtlichen Oberfläche.

Makro-Generator

1. Wählen Sie eine Aktion aus der Liste aus.

2.... oder Doppelklicken Sie auf eine Aktion im AktionsKatalog, um Sie Ihrem Makro hinzuzufügen.

3. die Registerkarte Entwurf wird angezeigt, wenn Sie an einem Makro arbeiten.

Wenn Sie eine Aktion hinzufügen, werden im Makro-Generator weitere Optionen angezeigt. Wenn Sie beispielsweise eine "Wenn"-Aktion hinzufügen, wird Folgendes angezeigt:

Makro mit 'If'-Aktion

Schauen Sie sich das folgende Video an, um zu sehen, wie der neue Makro-Generator funktioniert.

Ihr Browser unterstützt kein Video. Installieren Sie Microsoft Silverlight, Adobe Flash Player oder Internet Explorer 9.

Neben herkömmlichen Makros verwenden Sie den neuen Makro-Generator zum Erstellen von datenmakros, ein neues Feature.

Datenmakros: Daten basierend auf Ereignissen ändern

Datenmakros helfen bei der Unterstützung von Aggregaten in Webdatenbanken und bieten außerdem eine Möglichkeit, "Trigger" in einer beliebigen Access 2010-Datenbank zu implementieren.

Nehmen wir beispielsweise an, Sie verfügen über ein PercentComplete-Feld und ein Status Feld. Sie können ein datenmakro verwenden, um PercentComplete auf 100 festzulegen, wenn Sie den Status auf " abgeschlossen" festlegen, und 0 , wenn Sie den Status auf " nicht gestartet" festgelegt haben.

Im folgenden Video werden datenmakros in Aktion angezeigt.

Ihr Browser unterstützt kein Video. Installieren Sie Microsoft Silverlight, Adobe Flash Player oder Internet Explorer 9.

Erweiterter Ausdrucks-Generator

Der Ausdrucks-Generator enthält jetzt IntelliSense, sodass Sie während der Eingabe die Optionen sehen können. Außerdem wird Hilfe für den aktuell ausgewählten Ausdruckswert im Fenster des Ausdrucks-Generators angezeigt. Wenn Sie z. b. die Trim-Funktion auswählen, wird im Ausdrucks-Generator Folgendes angezeigt:

Trim (String) gibt eine Variante vom Typ String zurück, die eine Kopie einer angegebenen Zeichenfolge ohne führende und nachgestellte Leerräume enthält.

Weitere Informationen finden Sie im Artikel Verwenden des Ausdrucks-Generators.

Berechnete Felder

Sie können ein Feld erstellen, in dem die Ergebnisse einer Berechnung angezeigt werden. Die Berechnung muss sich auf andere Felder in derselben Tabelle beziehen. Mit dem Ausdrucks-Generator erstellen Sie die Berechnung.

Neue Datenbankvorlagen

Access 2010 enthält eine Reihe professionell gestalteter Datenbankvorlagen für die Nachverfolgung von Kontakten, Aufgaben, Ereignissen, Kursteilnehmern und Ressourcen unter anderen Arten von Daten. Sie können Sie sofort verwenden oder optimieren, um die Informationen nach Wunsch genau nachzuverfolgen.

Verfügbare Vorlagen in der Backstage-Ansicht

Jede Vorlage ist eine vollständige Nachverfolgungsanwendung, die vordefinierte Tabellen, Formulare, Berichte, Abfragen, Makros und Beziehungen enthält. Die Vorlagen sind so konzipiert, dass Sie sofort von Nutzen sind, damit Sie schnell auf den Weg kommen können. Wenn das Vorlagendesign Ihren Anforderungen entspricht, können Sie loslegen. Andernfalls können Sie die Vorlage verwenden, um einen Vorsprung beim Erstellen der Datenbank zu erhalten, die ihren spezifischen Anforderungen entspricht.

Posten-Webdatenbank

Zusätzlich zu den im Lieferumfang von Access 2010 enthaltenen Vorlagen können Sie eine Verbindung mit Office.com herstellen und weitere Vorlagen herunterladen.

Anwendungsparts zum Hinzufügen von Funktionen zu einer vorhandenen Datenbank

Sie können einer vorhandenen Datenbank mithilfe eines anwendungsparts ganz einfach Funktionen hinzufügen. Neu in Access 2010 ist ein Anwendungsteil eine Vorlage, die Bestandteileiner Datenbank umfasst – z. b. eine vorformatierte Tabelle oder eine Tabelle mit einem zugeordneten Formular und Bericht. Fügen Sie der Datenbank beispielsweise ein Aufgaben Anwendungsteil hinzu, und Sie erhalten eine Aufgaben Tabelle, ein Aufgabenformular und die Option, die Aufgaben Tabelle mit einer anderen Tabelle in Ihrer Datenbank zu verknüpfen.

Anwendungsparts auf der Registerkarte 'Erstellen'

Weitere Informationen finden Sie im Artikel Speichern und wieder verwenden von Datenbankentwurfs Elementen.

Verbesserte DatenBlattansicht

Sie können eine Tabelle erstellen und mit der Verwendung beginnen, ohne die Felder im Voraus zu definieren – klicken Sie einfach auf der Registerkarte Erstellen auf Tabelle, und beginnen Sie mit der Eingabe von Daten in das neue Datenblatt, das angezeigt wird. Access 2010 ermittelt automatisch den besten Datentyp für jedes Feld, sodass Sie in kürzester Zeit in Betrieb sind. Mit der Spalte zum Hinzufügen klicken wird angezeigt, wo Sie ein neues Feld hinzufügen müssen – und wenn Sie den Datentyp oder das Anzeigeformat eines neuen oder vorhandenen Felds ändern möchten, können Sie die Befehle im Menüband auf der Registerkarte Felder verwenden. Sie können Daten aus Microsoft Excel-Tabellen auch in ein neues Datenblatt einfügen – Access 2010 erstellt alle Felder und erkennt die Datentypen automatisch.

'Zum Hinzufügen klicken' in der Datenblattansicht

Bereich 'Feldliste'

Mit dem Bereich Feldliste, der in Access 2007 eingeführt wurde, können Sie Felder aus anderen Tabellen hinzufügen. Sie können Felder aus der Tabelle in der Datensatzquelle, aus verknüpften Tabellen oder aus nicht verknüpften Tabellen in der Datenbank ziehen. Wenn eine Beziehung zwischen Tabellen benötigt wird, wird Sie automatisch erstellt, oder Sie werden durch den Prozess aufgefordert.

Bereich 'Feldliste'

Die Layoutansicht beschleunigt das Entwerfen von Formularen und Berichten

Verwenden Sie die Layoutansicht, um Entwurfsänderungen vorzunehmen, während Sie Daten in einem Formular oder Bericht anzeigen.

Die Layoutansicht bietet verschiedene Verbesserungen gegenüber Access 2007 und ist erforderlich, wenn Sie ein Formular oder einen Bericht für das Web entwerfen.

Formular in der Layoutansicht mit Livedaten

Verwenden von Steuerelementlayouts, damit die Dinge aufgeräumt bleiben

Layouts, die in Office Access 2007 eingeführt werden, sind Steuerelementgruppen, die Sie als Einheit verschieben und deren Größe ändern können. In Access 2010 wurden Layouts erweitert, um eine flexiblere Platzierung von Steuerelementen in Formularen und Berichten zu ermöglichen. Sie können Zellen horizontal oder vertikal teilen oder verbinden, sodass Sie Felder, Spalten oder Zeilen ganz einfach neu anordnen.

Sie müssen beim Entwerfen von Webdatenbanken die Layoutansicht verwenden, die Entwurfsansicht bleibt jedoch für die Arbeit mit dem Desktopdaten Bank Entwurf weiterhin verfügbar.

Neue Benutzeroberfläche

Die in Office Access 2007 und Enhanced in Access 2010 implementierte neue Benutzeroberfläche wurde entwickelt, um Ihnen die Suche nach Befehlen und Features zu erleichtern, die zuvor häufig in komplexen Menüs und Symbolleisten begraben wurden.

Das Menüband

Das Menüband ist eine Sammlung von Registerkarten, die Befehlsgruppen enthalten, die nach Features und Funktionen organisiert sind. Das Menüband ersetzt die Ebenen von Menüs und Symbolleisten, die in früheren Versionen von Access gefunden wurden. Die folgende Abbildung zeigt das Menüband mit ausgewählter Registerkarte " Start ".

Das Menüband in Access 2010

Zu den wichtigsten Features des Menübands gehören:

  • Befehlsregisterkarten – RegisterKarten, in denen Befehle angezeigt werden, die häufig zusammen verwendet werden, damit Sie die Befehle finden können, die Sie benötigen, wenn Sie Sie benötigen.

  • KontextBezogene Befehlsregisterkarten – eine Befehlsregisterkarte, die je nach Kontext angezeigt wird, d. h. das Objekt, an dem Sie gerade arbeiten, oder die Aufgabe, die Sie ausführen. EINE kontextbezogene Befehlsregisterkarte enthält die Befehle, die am ehesten für Ihre Arbeit gelten.

  • Galerien – neue Steuerelemente, die eine Vorschau auf eine Formatvorlage oder Option anzeigen, damit Sie die Ergebnisse sehen können, bevor Sie sich für eine Auswahl verpflichten.

Backstage-Ansicht

Neu in Access 2010 enthält die Backstage-Ansicht Befehle, die Sie auf eine ganze Datenbank anwenden, z. b. komprimieren und reparieren, oder öffnen Sie eine neue Datenbank. Befehle werden auf Registerkarten auf der linken Seite des Bildschirms angeordnet, und jede Registerkarte enthält eine Gruppe verwandter Befehle oder Links. Wenn Sie z. b. auf " neu " klicken, sehen Sie eine Reihe von Schaltflächen, mit denen Sie eine neue Datenbank ganz neu erstellen können, oder indem Sie aus einer Bibliothek mit professionell gestalteten Datenbankvorlagen auswählen.

Registerkarte 'Neu' in der Backstage-Ansicht

Viele der Befehle, die Sie in der Backstage-Ansicht finden, wurden im Menü " Datei " in früheren Versionen von Access zusätzlich zu Datenbanken, die Sie kürzlich geöffnet haben, und (wenn Sie mit dem Internet verbunden sind), Links zu Office.com-Artikeln verfügbar.

Um zur Backstage-Ansicht zu gelangen, klicken Sie auf die Registerkarte Datei.

Navigationsbereich

Diese Funktion wurde in Access 2007 eingeführt.

Der NavigationsBereich listet die Listen auf und bietet einfachen Zugriff auf alle Objekte in der aktuell geöffneten Datenbank.

Navigationsbereich Nordwind 2007

Mithilfe des NavigationsBereichs können Sie Ihre Objekte nach Objekttyp, Erstellungsdatum, Änderungsdatum, zugehöriger Tabelle (basierend auf Objektabhängigkeiten) oder in benutzerdefinierten Gruppen, die Sie erstellen, organisieren. Benötigen Sie mehr Platz für die Arbeit am Formularentwurf? Sie können den NavigationsBereich ganz einfach reduzieren, sodass er wenig Platz beansprucht, aber dennoch verfügbar bleibt.

Der Navigationsbereich ersetzt das Datenbankfenster, das in früheren Versionen von Access als Access 2007 verwendet wurde.

RegisterKarten Objekte

Diese Funktion wurde in Access 2007 eingeführt.

Standardmäßig werden Tabellen, Abfragen, Formulare, Berichte und Makros im Access-Fenster als Objekte im Registerkartenformat angezeigt.

Sie können diese Einstellung pro Datenbank ändern und Objekte anstelle von Registerkarten verwenden.

Objekte im Registerkartenformat in Access 2007 Durch Klicken auf die Registerkarte Objekt können Sie auf einfache Weise zwischen verschiedenen Objekten wechseln.

Hilfefenster

Access 2010 bietet sowohl Access-Hilfe als auch Zugriff auf Entwicklerreferenz Inhalte im gleichen Hilfefenster. Die beiden Systeme enthalten unterschiedliche Arten von Unterstützungs Inhalten. Mithilfe der HilfeAnzeige können Sie auswählen, welche Inhalte angezeigt werden sollen. Sie können den Umfang Ihrer Suche beispielsweise auf den Access-EntwicklerReferenz Inhalt ändern. Unabhängig von den Einstellungen, die Sie im Hilfefenster vornehmen, stehen alle Access-Hilfe-und Access-EntwicklerReferenz Inhalte immer online, unter Office.com oder auf MSDN zur Verfügung.

Leistungsstärkere Tools zum Erstellen von Objekten

Access 2010 bietet eine intuitive Umgebung zum Erstellen von Datenbankobjekten.

Registerkarte 'Erstellen'

Auf der Registerkarte Erstellen können Sie schnell neue Formulare, Berichte, Tabellen, Abfragen und andere Datenbankobjekte erstellen. Wenn Sie eine Tabelle oder Abfrage im Navigationsbereich auswählen, können Sie mithilfe des Befehls Formular oder Bericht ein neues Formular oder einen neuen Bericht auf der Grundlage dieses Objekts erstellen.

Die Registerkarte 'Erstellen' im Menüband von Access

Die neuen Formulare und Berichte, die durch diesen Vorgang mit einem Mausklick erstellt werden, verwenden ein aktualisiertes Design, um Sie visuell ansprechender und sofort nutzbar zu machen. Automatisch generierte Formulare und Berichte erhalten eine professionell aussehende Gestaltung mit Überschriften, die ein Logo und einen Titel enthalten. Darüber hinaus enthält ein automatisch generierter Bericht auch Datum und Uhrzeit sowie informative Fußzeilen und Gesamtergebnisse.

Berichtsansicht und Layoutansicht

Mit diesen Ansichten, die in Office Access 2007 eingeführt und in Access 2010 verbessert wurden, können Sie interaktiv mit Formularen und Berichten arbeiten. Mithilfe der Berichtsansicht können Sie ein genaues Rendering des Berichts durchsuchen, ohne es in der SeitenAnsicht drucken oder anzeigen zu müssen. Wenn Sie sich auf bestimmte Datensätze konzentrieren möchten, verwenden Sie das Filterfeature, oder verwenden Sie einen Suchvorgang, um nach übereinstimmenden Text zu suchen. Sie können den Befehl Kopieren verwenden, um Text in die Zwischenablage zu kopieren, oder auf die im Bericht angezeigten aktiven Links klicken, um einem Link im Browser zu folgen.

In der Layoutansicht können Sie Designänderungen vornehmen, während Sie Ihre Daten durchsuchen. Sie können die Layoutansicht verwenden, um viele allgemeine Entwurfsänderungen vorzunehmen, während Sie Daten in einem Formular oder Bericht anzeigen. Fügen Sie beispielsweise ein Feld hinzu, indem Sie einen Feldnamen aus dem Bereich "neue Feldliste" ziehen oder Eigenschaften mithilfe des Eigenschaftenblatts ändern.

Die Layoutansicht bietet jetzt verbesserte Entwurfs Layouts – Gruppen von Steuerelementen, die Sie so anpassen können, dass Sie einfach Felder, Spalten, Zeilen oder ganze Layouts neu anordnen können. Sie können in der Layoutansicht auch ein Feld entfernen oder eine Formatierung hinzufügen. Bericht in der Layoutansicht

Optimierte Erstellung von Gruppierungen und Sortierungen in Berichten

Diese Funktion wurde in Access 2007 eingeführt.

Access bietet eine neue Möglichkeit zum Gruppieren und Sortieren von Daten in Berichten sowie zum Addieren von Gesamtsummen. Die Benutzeroberfläche ist einfach zu navigieren und zu verstehen, und wenn Sie in der neuen Layoutansicht verwendet wird, sehen Sie sofort die Auswirkungen der Änderungen.

Bereich 'Gruppieren, Sortieren und Summe'

Angenommen, Sie möchten die Gesamtumsätze nach Regionen in einem Bericht anzeigen. Verwenden Sie die Layoutansicht und den Bereich Gruppieren, Sortieren und Summe, um eine Gruppenebene hinzuzufügen und eine Gesamtsumme anzufordern – und die Änderungen Live im Bericht anzuzeigen. Mit der Zeile Ergebnis können Sie den Kopf-oder Fußzeilen des Berichts eine Summe, einen Durchschnitt, eine Anzahl, ein Maximum oder ein Minimum hinzufügen. Einfache Gesamtergebnisse erfordern nicht mehr das manuelle Erstellen eines berechneten Felds. Jetzt zeigen Sie einfach, und klicken Sie darauf.

Erstellen von Summen in einem Bericht

Verbesserte Steuerungslayouts, mit denen Sie polierte Formulare und Berichte erstellen können

Formulare und Berichte enthalten häufig Tabelleninformationen, z. b. eine Spalte mit Kundennamen oder eine Zeile, die alle Felder für einen Kunden enthält. Sie können diese Steuerelemente in einem Layout gruppieren, das problemlos als eine Einheit bearbeitet werden kann, einschließlich der Beschriftung.

Befehle in der Gruppe 'Layout bestimmen' auf der Registerkarte 'Anordnen'

Da Sie Steuerelemente aus unterschiedlichen Abschnitten auswählen können, z. b. die Beschriftung in der Abschnittskopf-oder-Fußzeile, gibt es erhebliche Flexibilität. Sie können ganz einfach:

  • Verschieben oder Ändern der Größe eines Layouts Verschieben Sie beispielsweise eine Spalte nach links oder rechts.

  • Formatieren eines Layouts Legen Sie beispielsweise eine Spalte Kundenname in Fettschrift so fest, dass Sie hervorsticht.

  • Fügen Sie einem Layout eine Spalte (Feld) hinzu.

  • Löschen Sie eine Spalte (Feld) aus einem Layout.

  • Zusammenführen oder Teilen von Zellen

Eine Spalte in der Layoutansicht verschieben

Layouts werden mit Ihrem Entwurf gespeichert, sodass Sie weiterhin zur Verfügung stehen. Im folgenden Video wird gezeigt, wie Layouts in Formularen und Berichten funktionieren.

Ihr Browser unterstützt kein Video. Installieren Sie Microsoft Silverlight, Adobe Flash Player oder Internet Explorer 9.

GeTeilte Formulare zum schnellen Durchsuchen von Daten

Diese Funktion wurde in Access 2007 eingeführt.

Verwenden Sie ein geteiltes Formular, um ein Formular zu erstellen, in dem eine DatenBlattansicht und eine Formularansicht kombiniert werden. Sie können eine Eigenschaft festlegen, um Access mitzuteilen, dass das Datenblatt oben, unten, Links oder rechts platziert werden soll.

Geteiltes Formular

Hinweis: GeTeilte Formulare stehen in Webdatenbanken nicht zur Verfügung.

Eingebettete Makros in Formularen und Berichten

Diese Funktion wurde in Access 2007 eingeführt.

Verwenden Sie eingebettete Makros, um zu vermeiden, dass Code geschrieben werden muss. Ein eingebettetes Makro wird in einer Eigenschaft gespeichert und ist ein Teil des Objekts, zu dem es gehört. Sie können den Entwurf eines eingebetteten Makros ändern, ohne sich um andere Steuerelemente kümmern zu müssen, die das Makro möglicherweise verwenden – jedes eingebettete Makro ist unabhängig. Eingebettete Makros werden als vertrauenswürdig eingestuft, weil Sie automatisch daran gehindert werden, potenziell unsichere Vorgänge auszuführen.

Zuweisen eines eingebetteten Makros zu einem BeimDoppelklicken-Ereignis

Neue Datentypen und Steuerelemente

Neu in Access 2010 können berechnete Felder das Ergebnis einer Berechnung speichern.

Office Access 2007 hat die folgenden neuen und verbesserten Datentypen und Steuerelemente eingeführt:

  • Felder mit mehreren Werten

  • Datentyp "Anlage"

  • Erweiterte Memo Felder

  • Integriertes Kalendersteuerelement für die Felder "Datum/Uhrzeit"

Berechnete Felder

Sie können ein Feld erstellen, das einen Wert anzeigt, der aus anderen Daten in derselben Tabelle berechnet wird. Sie verwenden den Ausdrucks-Generator, um die Berechnung zu erstellen, sodass Sie von IntelliSense profitieren und einfachen Zugriff auf Hilfe für Ausdruckswerte erhalten.

Daten aus anderen Tabellen können nicht als Quelle für die berechneten Daten verwendet werden. Einige Ausdrücke werden von berechneten Feldern nicht unterstützt.

Felder mit mehreren Werten

Diese Funktion wurde in Access 2007 eingeführt.

EIN mehrwertiges Feld kann mehr als einen Wert pro Datensatz speichern. Nehmen wir an, Sie müssen eine Aufgabe einem ihrer Mitarbeiter oder Auftragnehmer zuordnen, Sie möchten Sie aber mehreren Personen zuweisen. In den meisten Datenbankverwaltungssystemen und in früheren Versionen von Access als Office Access 2007 mussten Sie eine viele-zu-viele-Beziehung erstellen, um diese ordnungsgemäß zu machen.

Hinweis: Access erstellt eine ausgeblendete Tabelle, um für jedes mehrwertige Feld die erforderliche Zahl-zu-Zahl-Beziehung beizubehalten.

Mehrwertige Felder eignen sich besonders, wenn Sie mit einer SharePoint-Liste arbeiten, die einen der mehrwertigen Feldtypen enthält, die in Windows SharePoint Services verwendet werden. Access 2010 ist mit diesen Datentypen kompatibel.

Mehrwertiges Feld

Anlagenfelder für Dateien

Diese Funktion wurde in Access 2007 eingeführt.

Mit dem Datentyp "Anlage" können Sie auf einfache Weise alle Arten von Dokumenten und Binärdateien in Ihrer Datenbank speichern, ohne dass die Datenbankgröße unnötig wächst. Access komprimiert Anlagen automatisch, wenn dies möglich ist, um den Platzbedarf zu minimieren. Möchten Sie ein Word-Dokument an einen Datensatz anfügen oder eine Reihe digitaler Bilder in Ihrer Datenbank speichern? Die Verwendung von Anlagen erleichtert diese Aufgaben. Sie können sogar mehrere Anlagen zu einem einzelnen Datensatz hinzufügen.

Dialogfeld 'Anlagen'

Hinweis: Sie können Anlagefelder in Webdatenbanken verwenden, aber jede Webtabelle kann maximal ein Anlagefeld aufweisen.

Memo-Felder speichern jetzt Rich-Text-und Support-Versionsverlauf

Diese Funktion wurde in Access 2007 eingeführt.

Rich-Text-Memofelder bedeuten, dass Sie nicht mehr auf nur-Text in Ihren Datensätzen beschränkt sind. Sie können Text mit Optionen (z. b. Fett, kursiv, zusätzlich zu unterschiedlichen Schriftarten und Farben und anderen gängigen Formatierungsoptionen) formatieren und den Text in der Datenbank speichern. Rich-Text wird in einem Memofeld in einem HTML-basierten Format gespeichert, das mit dem Datentyp "Rich-Text" in Windows SharePoint Services kompatibel ist. Sie legen die neue Textformat -Eigenschaft auf " RichText " oder " Klartext" fest, und die Informationen werden dann in Textfeldsteuerelementen und in der Datenblattansicht ordnungsgemäß formatiert.

Memo Felder eignen sich zum Speichern großer Datenmengen. Sie können die Eigenschaft Nur anfügen so konfigurieren, dass ein Verlauf aller Änderungen an einem Memofeld beibehalten wird. Sie können einen Verlauf dieser Änderungen anzeigen. Dieses Feature unterstützt auch die Nachverfolgungsfunktion in Windows SharePoint Services, sodass Sie auch Access zum Anzeigen des Inhalts Verlaufs der SharePoint-Liste verwenden können.

Kalender für die Auswahl von Datumsangaben

Diese Funktion wurde in Access 2007 eingeführt.

Felder und Steuerelemente, die den Datentyp "Datum/Uhrzeit" verwenden, erhalten automatisch Unterstützung für einen integrierten interaktiven Kalender, der in Access 2007 eingeführt wurde. Die Schaltfläche "Kalender" wird automatisch rechts neben dem Datum angezeigt. Möchten Sie wissen, welches Datum für diesen kommenden Freitag vorliegt? Klicken Sie auf die Schaltfläche, damit der Kalender automatisch angezeigt wird, um das Datum zu finden und auszuwählen. Mithilfe einer Eigenschaft können Sie den Kalender für ein Feld oder ein Steuerelement deaktivieren.

Verbesserte Datenpräsentation

Mithilfe der neuen Features für die Datenpräsentation können Sie Datenbankobjekte schneller erstellen und dann Ihre Daten einfacher analysieren.

Erweiterte Sortier-und Filtertools

Diese Funktion wurde in Access 2007 eingeführt.

Angenommen, Sie müssen schnell einen übereinstimmenden Wert finden oder eine Spalte mit Daten sortieren. Das in Office Access 2007 eingeführte AutoFilter-Feature erweitert bereits leistungsfähige Filterfunktionen, sodass Sie sich schnell auf die benötigten Daten konzentrieren können. Sie können auf einfache Weise aus den eindeutigen Werten in einer Spalte auswählen, was für Situationen nützlich ist, in denen Sie den gewünschten Namen nicht zurückrufen können, oder Sie die Werte mithilfe von Kontextmenüoptionen in der einfachen Sprache sortieren, z. b. absteigend nach neuestem sortieren oder aufsteigend sortieren.

AutoFilter

Die am häufigsten verwendeten Filteroptionen sind in Menübefehlen leicht sichtbar, oder Sie können mithilfe von schnell filtern die Informationen auf der Grundlage der von Ihnen eingegebenen Daten einschränken. Die Optionen für Schnellfilter werden basierend auf dem Datentyp automatisch geändert, sodass Sie sinnvolle Auswahlmöglichkeiten für Text, Datum und numerische Informationen sehen.

Menü 'Datumsfilter'

Summen und wechselnde Hintergrundfarben in Datenblättern

Diese Funktion wurde in Access 2007 eingeführt.

Die DatenBlattansicht bietet eine Ergebniszeile, in der Sie eine Summe, Anzahl, Mittelwert, Maximum, Minimum, Standardabweichung oder Varianz anzeigen können. Nachdem Sie die Ergebniszeile hinzugefügt haben, zeigen Sie auf den Pfeil in der Zelle der Spalte, und wählen Sie die gewünschte Berechnung aus.

Summenzeilen in einem Datenblatt

Datenblätter, Berichte und fortlaufende Formulare unterstützen eine wechselnde Hintergrundfarbe für Zeilen, die Sie unabhängig von der Standardhintergrund Farbe konfigurieren können. Das Schattieren jeder anderen Zeile ist einfach, und Sie können eine beliebige Farbe auswählen.

Datenblatt mit wechselnden Zeilenfarben

Bedingte Formatierung

Access 2010 fügt neue Features für die bedingte Formatierung hinzu, sodass Sie einige der gleichen Formatierungs Formate wie in Excel erreichen können. So können Sie z. b. jetzt DatenBalken hinzufügen, um eine Spalte mit Zahlen besser lesbar zu machen, wie in der folgenden Abbildung dargestellt:

Bedingte Formatierung in einem Access-Bericht

Hinweis: Eine bedingte Formatierung ist in Webdatenbanken nicht verfügbar.

Verbesserte Sicherheit

Erweiterte Sicherheitsfeatures und die starke Integration in Windows SharePoint Services unterstützen Sie bei der effektiven Verwaltung und ermöglichen es Ihnen, Ihre Informationen Nachverfolgungsanwendungen sicherer zu machen als zuvor. Wenn Sie Ihre nach Verfolgungs Anwendungsdaten in Listen auf Windows SharePoint Services speichern, können Sie den Versionsverlauf überwachen, gelöschte Informationen wiederherstellen und Datenzugriffsberechtigungen konfigurieren.

Office Access 2007 führte ein neues Sicherheitsmodell ein, das in Access 2010 weitergeleitet und verbessert wurde. Einheitliche Vertrauensentscheidungen werden in das Microsoft Office Trust Center integriert. VertrauensWürdige Speicherorte vereinfachen das Vertrauen in alle Datenbanken in sicheren Ordnern. Sie können eine Office Access 2007-Anwendung mit Code oder Makros laden, die deaktiviert sind, um eine sicherere, Sandbox-Erfahrung (d. h. unsichere Befehle können nicht ausgeführt werden) bereitzustellen. VertrauensWürdige Makros werden im SandKastenmodus ausgeführt.

Sammeln von Daten mithilfe von InfoPath-Formularen und Outlook

Diese Funktion wurde in Access 2007 eingeführt.

Mithilfe des DatenSammlungsfeatures können Sie Feedback mithilfe von Outlook und optional mit InfoPath sammeln. Sie können automatisch ein InfoPath-Formular oder ein HTML-Formular generieren und im Textkörper einer e-Mail-Nachricht einbetten. Sie können das Formular dann an Empfänger senden, die aus Ihren Outlook-Kontakten ausgewählt wurden, oder an die Namen der Empfänger, die in einem Feld in Ihrer Access-Datenbank gespeichert sind.

Verwenden einer E-Mail-Nachricht zum Sammeln von Daten

Sie entscheiden, ob Sie neue Informationen sammeln oder vorhandene Informationen aktualisieren möchten. Die Empfänger füllen dann das Formular aus und geben es zurück. Outlook erkennt die eingehenden Formulare und speichert die Daten automatisch in Ihrer Access-Datenbank – keine erneute Eingabe erforderlich.

Exportieren nach PDF und XPS

In Access 2010 können Sie Daten in eine PDF-Datei (Portable Document Format) oder XPS (XML Paper Specification) exportieren, um Sie zu drucken, zu veröffentlichen und per e-Mail zu verteilen, vorausgesetzt, Sie installieren zuerst das Add-in "als PDF oder XPS veröffentlichen". Exportieren eines Formulars, Berichts oder Datenblatt zu einer PDF-oder XPS-Datei ermöglicht das Erfassen von Informationen in einem einfach zu verteilenden Formular, das alle Formatierungsmerkmale aufrecht erhält, jedoch keine anderen Personen zum Installieren von Access auf ihren Computern zum Drucken oder Überprüfen der Ausgabe benötigt.

  • Portables Dokument Format    EINE PDF-Datei ist ein elektronisches Format mit festem Layout, das die Dokumentformatierung bewahrt und die Dateifreigabe unterstützt. Durch das PDF-Format wird sichergestellt, dass beim Anzeigen der Datei online oder beim Drucken das gewünschte Format beibehalten wird und die Daten in der Datei nicht einfach kopiert oder geändert werden können. Das PDF-Format eignet sich auch für Dokumente, die mithilfe von professionellen Druckmethoden wiederhergestellt werden.

  • XML Paper Specification    Bei einem XPS handelt es sich um ein elektronisches Dateiformat, das die Dokumentformatierung bewahrt und die Dateifreigabe unterstützt. Im XPS-Format wird sichergestellt, dass das Format, das Sie beabsichtigt haben und die Daten in der Datei nicht einfach kopiert oder geändert werden können, wenn die Datei online angezeigt oder gedruckt wird.

Einfachere Arbeit mit externen Daten

Sie können jetzt eine Verbindung mit einem Webdienst als externe Datenquelle herstellen. Sie benötigen eine Webdienstdefinitionsdatei, die vom Webdienstadministrator zur Verfügung steht. Nach der Installation der Definitionsdatei können Sie eine Verknüpfung mit Webdienst Daten als verknüpfte Tabelle erstellen.

Neue Features in Office Access 2007 erleichtern das Importieren und Exportieren von Daten. Sie können einen Import-oder Exportvorgang speichern und dann den gespeicherten Vorgang wieder verwenden, wenn Sie die gleiche Aufgabe das nächste Mal ausführen möchten. Mit dem Import-Tabellenkalkulations-Assistenten können Sie den von Access ausgewählten Datentyp außer Kraft setzen und Dateien mit mindestens Office Excel 2007 Dateiformaten importieren, exportieren und verknüpfen.

EINE bessere Möglichkeit zum Beheben von Problemen

Diese Funktion wurde in Access 2007 eingeführt.

Microsoft Office-Diagnose ist eine Reihe von Diagnosetests, mit denen Sie ermitteln können, warum Ihr Computer abstürzt. Mit den Diagnosetests können einige Probleme direkt gelöst werden, und es können Methoden zum Beheben anderer Probleme ermittelt werden. Microsoft Office-Diagnose ersetzt die folgenden Microsoft Office 2003-Features: erkennen und reparieren und WiederHerstellung von Microsoft Office-Anwendungen.

Verbesserte Rechtschreibprüfung

Diese Funktion wurde in Access 2007 eingeführt.

Im folgenden finden Sie einige neue Features der Rechtschreibprüfung.

  • Die Rechtschreibprüfung verhält sich einheitlich in den Office-Programmen. Beispiele für diese Änderung sind die folgenden:

    • Mehrere Optionen für die Rechtschreibprüfung sind jetzt Global. Wenn Sie eine dieser Optionen in einem Office-Programm ändern, wird diese Option auch für alle anderen Office-Programme geändert.

    • Zusätzlich zur Freigabe der gleichen Benutzerwörterbücher können alle Programme diese mithilfe desselben Dialogfelds verwalten. Weitere Informationen finden Sie im Artikel Verwenden von Benutzerwörterbüchern zum Hinzufügen von Wörtern zur Rechtschreibprüfung.

  • Die Rechtschreibprüfung umfasst das französische Wörterbuch nach der Reform. In Microsoft Office 2003 war dies ein Add-in, das separat installiert werden musste.

  • Wenn die Sprache zum ersten Mal verwendet wird, wird automatisch ein Ausschlusswörterbuch für eine Sprache erstellt. Sie können mit Ausschlusswörterbüchern erzwingen, dass die Rechtschreibprüfung Wörter kennzeichnet, die Sie nicht verwenden möchten. Ausschlusswörterbücher sind hilfreich, um obszöne Wörter zu vermeiden, die nicht mit Ihrem Stilleitfaden übereinstimmen. Weitere Informationen finden Sie im Artikel Verwenden von Ausschlusswörterbüchern zum Angeben einer bevorzugten Schreibweise für ein Wort.

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×