Korrigieren eines #WERT!-Fehlers in der SUMMENPRODUKT-Funktion

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Dieses Thema befasst sich mit den gängigen Szenarios, wenn der #WERT!-Fehler bei der Arbeit mit SUMMENPRODUKT auftritt.

Problem: Die Matrixargumente weisen nicht dieselbe Dimension auf.

Alle Matrixargumente müssen dieselbe Dimension aufweisen. Ist dies nicht der Fall, erhalten Sie den #WERT!-Fehler. Wenn beispielsweise Matrix 1 auf einen Bereich von 3 Zeilen und 2 Spalten verweist, muss Matrix 2 ebenfalls dem ähnlichen Bereich entsprechen.

Die SUMMENPRODUKT-Formel, die einen Fehler verursacht, ist =SUMMENPRODUKT(D2:D13;E2:E10) – E10 muss in E13 geändert werden, um dem ersten Bereich zu entsprechen.
  • =SUMMENPRODUKT(D2:D13; E2:E10)

Schlägt fehl, weil die referenzierten Bereiche nicht dieselbe Anzahl von Zeilen haben (13 im ersten Bereich, aber nur 10 im zweiten).

Lösung: Ändern Sie die Formel in:

  • =SUMMENPRODUKT(D2:D13;E2:E13)

Sodass beide Bereiche dieselben Start- und Endzeilennummern haben, und probieren Sie die Formel noch mal aus.

Beheben des #WERT!-Fehlers in den Daten, um den SUMMENPRODUKT-Fehler zu beheben

Problem: Mindestens eine Zelle im Bereich enthält Text.

Wenn mindestens eine Zelle im referenzierten Bereich Text enthält oder als Textdatentyp formatiert ist, erhalten Sie den #WERT!-Fehler. Der Text könnte das Ergebnis einer Berechnung aus einer anderen Formel sein, oder vielleicht ist die Zelle auch einfach nicht ordnungsgemäß formatiert.

Die Formel in Zelle E15 liefert einen #WERT!-Fehler, weil in Spalte E ein #WERT!-Fehler auftritt.

Lösung: Überprüfen Sie auf Zellen, die Text enthalten oder als Text formatiert sind, und legen Sie sie auf den richtigen Datentyp fest.

Haben Sie eine Frage zu einer bestimmten Funktion?

Posten Sie eine Frage im Excel-Communityforum.

Helfen Sie uns, Excel zu verbessern

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice.

Siehe auch

Korrigieren eines Fehlerwerts vom Typ #WERT!

SUMMENPRODUKT

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Ermitteln von Fehlern in Formeln

Alle Excel-Funktionen (alphabetisch)

Alle Excel-Funktionen (nach Kategorie)

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×