Korrigieren eines #WERT!-Fehlers in den Funktionen MITTELWERT und SUMME

Wenn MITTELWERT oder SUMME auf Zellen verweisen, die #WERT!-Fehler enthalten, führen die Formeln zu einem #WERT!-Fehler.

#WERT!-Fehler in MITTELWERT

Um die Fehlerwerte zu "übersehen", konstruieren wir eine Formel, die die Fehler im Bezugsbereich ignoriert und gleichzeitig den Mittelwert mit den restlichen "normalen" Werten berechnet.

Um dieses Szenario zu umgehen, verwenden wir eine Kombination aus MITTELWERT zusammen mit WENN und ISTFEHLER, um zu bestimmen, ob im angegebenen Bereich ein Fehler vorhanden ist. Dieses spezielle Szenario erfordert eine Matrixformel:

=MITTELWERT(WENN(ISTFEHLER(B2:D2);"";B2:D2))

Hinweis: Dies ist eine Matrixformel, die mit STRG+UMSCHALT+EINGABETASTE eingegeben werden muss. Excel schließt die Formel automatisch in geschweifte Klammern {} ein. Wenn Sie versuchen, diese manuell einzugeben, zeigt Excel die Formel als Text an.

Matrixfunktion in MITTELWERT zum Beheben des #WERT!-Fehlers

Hinweis: Die oben gezeigte Funktion funktioniert nicht nur für #WERT!-Fehler, sondern auch für #N/V-, #NULL-, #DIV/0!- und andere Fehler.

Sie können auch SUMME auf dieselbe Art verwenden:

=SUMME(WENN(ISTFEHLER(B2:D2);"";B2:D2))

Haben Sie eine Frage zu einer bestimmten Funktion?

Posten Sie eine Frage im Excel-Communityforum.

Helfen Sie uns, Excel zu verbessern

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice.

Siehe auch

Korrigieren eines #WERT!-Fehlers

Funktion MITTELWERT

Funktion SUMME

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Verwenden der Fehlerüberprüfung zum Ermitteln von Fehlern in Formeln

Alle Excel-Funktionen (alphabetisch)

Alle Excel-Funktionen (nach Kategorie)

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×