Korrigieren eines Fehlerwerts vom Typ Fehler in der SUMMEWENN/SUMMEWENNS-Funktion

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

In diesem Thema werden die häufigeren Ursachen der #VALUE! Fehler in den Funktionen SUMMEWENN und SUMMEWENNS und deren Lösung.

Problem: Die Formel verweist auf Zellen in einer geschlossenen Arbeitsmappe.

SUMMEWENN/SUMMEWENNS-Funktionen, die auf eine Zelle oder einen Bereich in einer geschlossenen Arbeitsmappe verweisen, führen zu einem #VALUE! Fehler.

Hinweis: Dies ist ein bekanntes Problem mit einigen anderen Excel-Funktionen wie ZÄHLENWENN, ZÄHLENWENNS, ANZAHLLEEREZELLEN, um nur einige zu nennen. Sehen Sie sich die SUMMEWENN-, ZÄHLENWENN-und ANZAHLLEEREZELLEN-Funktionen "#VALUE!" zurück. Fehlermeldung Artikel, um weitere Informationen zu erhalten.

Lösung: Öffnen Sie die in der Formel angegebene Arbeitsmappe, und drücken Sie F9, um die Formel zu aktualisieren.

Sie können dieses Problem auch umgehen, indem Sie die Funktionen Summe und wenn in einer Matrixformel zusammen verwenden. Sehen Sie sich die SUMMEWENN-, ZÄHLENWENN-und ANZAHLLEEREZELLEN-funktionen #VALUE!-Fehler zurück. Artikel, um weitere Informationen zu erhalten.

Problem: Die Kriterienzeichenfolge ist länger als 255 Zeichen.

Die Funktionen SUMMEWENN/SUMMEWENNS geben falsche Ergebnisse zurück, wenn Sie versuchen, mit ihnen Zeichenfolgen mit mehr als 255 Zeichen abzugleichen.

Lösung: Kürzen Sie die Zeichenfolge, falls möglich. Wenn Sie sie nicht kürzen können, verwenden Sie die Funktion VERKETTEN oder den &-Operator (kaufmännisches Und-Zeichen), um den Wert in mehrere Zeichenfolgen zu unterteilen. Beispiel:

=SUMMEWENN(B2:B12;"lange Zeichenfolge"&"weitere lange Zeichenfolge")

Problem: In SUMMEWENNS ist das Argument Kriterien_Bereich nicht mit dem Argument Summe_Bereich konsistent.

Der Bereichsargumente müssen in SUMMEWENNS immer identisch sein. Das bedeutet, dass die Argumente Kriterien_Bereich und Summe_Bereich auf dieselbe Anzahl von Zeilen und Spalten verweisen müssen.

Im folgenden Beispiel soll die Formel die Summe der täglichen Umsätze von Äpfeln in Bellevue zurückgeben. Das sum_range (C2: C10)- Argument entspricht jedoch nicht der gleichen Anzahl von Zeilen und Spalten in den Argumenten criteria_range (a2: A12 _AMP_ B2: B12) . Die Verwendung der Syntax = SUMMEWENNS (C2: C10;a2: A12; a14;B2: B12, B14) führt zu #VALUE! Fehler.

Die fehlerhafte Formel lautet =SUMMEWENNS(C2:C10;A2:A12;A14;B2:B12;B14), wobei C2:C10 C2:C12 sein muss

Lösung: Ändern Sie gemäß diesem Beispiel den Summe_Bereich in C2:C12, und probieren Sie die Formel noch mal.

Hinweis:  SUMMEWENN kann Bereiche unterschiedlicher Größen verwenden.

Haben Sie eine Frage zu einer bestimmten Funktion?

Helfen Sie uns, Excel zu verbessern

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice.

Siehe auch

Korrigieren einer #VALUE! #WERT!

SUMMEWENN

SUMMEWENNS

Erweiterte IF-Funktions Videos

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Ermitteln von Fehlern in Formeln

Alle Excel-Funktionen (alphabetisch)

Alle Excel-Funktionen (nach Kategorie)

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×