Korrigieren einer #VALUE! Fehler in den Funktionen Mittelwert oder Summe

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Wenn Mittelwert oder Summe auf Zellen verweisen, die #VALUE enthalten! Fehler, führen die Formeln zu einem #VALUE! zurück.

#WERT! Fehler im Mittelwert

Um die Fehlerwerte zu "übersehen", konstruieren wir eine Formel, die die Fehler im Bezugsbereich ignoriert und gleichzeitig den Mittelwert mit den restlichen "normalen" Werten berechnet.

Um dieses Szenario zu umgehen, verwenden wir eine Kombination aus MITTELWERT zusammen mit WENN und ISTFEHLER, um zu bestimmen, ob im angegebenen Bereich ein Fehler vorhanden ist. Dieses spezielle Szenario erfordert eine Matrixformel:

=MITTELWERT(WENN(ISTFEHLER(B2:D2);"";B2:D2))

Hierbei handelt es sich um eine Matrixformel. Sie müssen also entweder die Eingabe Taste drücken (nur, wenn Sie Office365 verwenden) oder STRG + UMSCHALT + Eingabe Taste in der Formel.

Hinweis: Wenn Sie über eine aktuelle Version von Office 365verfügen, können Sie die Formel einfach in die Ausgabezelle eingeben und dann die Eingabe Taste drücken, um die Formel als dynamische Matrixformel zu bestätigen. Andernfalls muss die Formel als Legacy-Arrayformel eingegeben werden, indem Sie zunächst die Ausgabezelle auswählen, die Formel in die Ausgabezelle eingeben und dann STRG + UMSCHALT + Eingabe Taste drücken, um Sie zu bestätigen. Excel fügt geschweifte Klammern am Anfang und am Ende der Formel ein. Weitere Informationen zu Matrixformeln finden Sie unter Richtlinien und Beispiele für Matrixformeln.

Array-Funktion im Mittelwert, um den #VALUE zu beheben! zu unterdrücken

Hinweis: Die oben gezeigte Funktion funktioniert nicht nur für #WERT!-Fehler, sondern auch für #N/V-, #NULL-, #DIV/0!- und andere Fehler.

Sie können auch SUMME auf dieselbe Art verwenden:

=SUMME(WENN(ISTFEHLER(B2:D2);"";B2:D2))

Haben Sie eine Frage zu einer bestimmten Funktion?

Posten einer Frage im Excel Community-Forum

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Siehe auch

Korrigieren eines Fehlerwerts vom Typ #WERT!

Mittelwert

Summe (Funktion

Übersicht über Formeln in Excel

Erkennen von Fehlern in Formeln

Alle Excel-Funktionen (alphabetisch)

Alle Excel-Funktionen (nach Kategorie)

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×