Importieren von oder Verknüpfen mit Daten in einer SQL Server-Datenbank

Importieren von oder Verknüpfen mit Daten in einer SQL Server-Datenbank

Sie können eine Verknüpfung mit Daten in einer SQL-Datenbank (einer für unternehmenskritische Anwendungen verwendeten verwalteten Hochleistungsdatenbank) herstellen oder Daten daraus importieren. Weitere Informationen finden Sie unter SQL Server 2016.

  • Wenn Sie eine Verknüpfung zu Daten herstellen, erstellt Access eine wechselseitige Verbindung, die Änderungen an Daten in Access und der SQL-Datenbank synchronisiert.

  • Wenn Sie Daten importieren, erstellt Access eine einmalige Kopie der Daten. Änderungen an Daten in Access oder der SQL-Datenbank werden somit nicht synchronisiert.

Übersicht über das Verbinden von Access mit SQL Server

Vorbereitende Schritte

Sie wünschen einen reibungsloseren Ablauf? Dann treffen Sie die folgenden Vorbereitungen, bevor Sie die Verknüpfung zu Daten herstellen oder Daten importieren:

  • Suchen Sie den Servernamen der SQL Server-Datenbank, identifizieren Sie erforderliche Verbindungsinformationen, und wählen Sie eine Authentifizierungsmethode aus (Windows oder SQL Server). Weitere Informationen zu den Methoden der Authentifizierung finden Sie unter Verbindung mit Server herstellen (Datenbankmodul) und Sichern der SQL-Datenbank.

  • Identifizieren Sie die Tabellen oder Ansichten, die Sie verknüpfen oder importieren möchten, und eindeutig bewertete Felder für verknüpfte Tabellen. Sie können in einem einzigen Vorgang mehrere Tabellen oder Ansichten verknüpfen oder importieren.

  • Beachten Sie die Anzahl der Spalten in jeder Tabelle oder Ansicht. Access unterstützt höchstens 255 Felder in einer Tabelle, sodass nur die ersten 255 Spalten verknüpft oder importiert werden. Als Problemumgehung können Sie eine Ansicht in der SQL Server-Datenbank erstellen, um auf die Spalten zuzugreifen, die diese Begrenzung überschreiten.

  • Ermitteln Sie die Gesamtmenge der zu importierenden Daten. Die maximale Größe einer Access-Datenbank beträgt 2 GB, abzüglich des für Systemobjekte erforderlichen Speicherplatzes. Wenn die SQL Server-Datenbank umfangreiche Tabellen enthält, können Sie möglicherweise nicht alle Tabellen in eine einzige Access-Datenbank importieren. In diesem Fall sollten Sie eine Verknüpfung mit den Daten herstellen, anstatt sie zu importieren.

  • Sichern Sie Ihre Access-Datenbank und die darin enthaltenen Verbindungsinformationen unter Verwendung eines vertrauenswürdigen Speicherorts und eines Kennworts für die Access-Datenbank. Dies ist besonders wichtig, wenn Sie das SQL Server-Kennwort in Access speichern möchten.

  • Planen Sie zusätzliche Beziehungen ein. Access erstellt die Beziehungen zwischen verknüpften Tabellen am Ende eines Importvorgangs nicht automatisch. Sie können die Beziehungen zwischen neuen und vorhandenen Tabellen mithilfe des Fensters "Beziehungen" manuell erstellen. Weitere Informationen finden Sie unter Was ist das Fenster "Beziehungen"? und Erstellen, Bearbeiten oder Löschen einer Beziehung.

Phase 1: Erste Schritte

  1. Wählen Sie Externe Daten > Neue Datenquelle > Aus Datenbank > Aus SQL Server aus.

  2. Führen Sie im Dialogfeld Externe Daten abrufen – ODBC-Datenbank eine der folgenden Aktionen aus:

    • Zum Importieren von Daten klicken Sie auf Importieren Sie die Quelldaten in eine neue Tabelle in der aktuellen Datenbank.

    • Zum Herstellen einer Verknüpfung mit Daten wählen Sie Erstellen Sie eine Verknüpfung zur Datenquelle, indem Sie eine verknüpfte Tabelle erstellen aus.

  3. Wählen Sie OK aus.

Phase 2: Erstellen oder Wiederverwenden einer DSN-Datei

Sie können eine neue DSN-Datei erstellen oder eine vorhandene wiederverwenden. Verwenden Sie eine DSN-Datei, wenn die gleichen Verbindungsinformationen für verschiedene Verknüpfungs- und Importvorgänge genutzt oder für eine andere Anwendung, die ebenfalls DSN-Dateien verwendet, freigegeben werden sollen. Sie können eine DSN-Datei direkt mithilfe des Datenverbindungs-Managers erstellen. Weitere Informationen finden Sie unter Verwalten von ODBC-Datenquellen.

Sie können frühere Versionen des SQL-ODBC-Treibers zwar weiterhin verwenden, wir empfehlen jedoch die Version 13.1, die zahlreiche Verbesserungen bietet und neue SQL Server 2016-Features unterstützt. Weitere Informationen finden Sie unter Microsoft ODBC-Treiber für SQL Server unter Windows.

  1. Führen Sie eine der folgenden Aktionen aus:

    • Wenn die DSN-Datei, die Sie verwenden möchten, bereits vorhanden ist, wählen Sie sie aus der Liste aus.

      Dialogfeld 'Datenquelle auswählen'

      Je nachdem, welche Authentifizierungsmethode Sie in den Verbindungsinformationen festgelegt haben, müssen Sie möglicherweise erneut ein Kennwort eingeben.

    • So erstellen Sie eine neue DSN-Datei

      1. Wählen Sie Neu aus.

        Dialogfeld "Neue Datenquelle erstellen"
      2. Wählen Sie ODBC-Treiber 13 für SQL Server und dann Weiter aus.

      3. Geben Sie einen Namen für die DSN-Datei ein, oder klicken Sie auf Durchsuchen, um die Datei an einem anderen Speicherort zu erstellen.

  2. Klicken Sie auf Weiter, um die Zusammenfassungsinformationen zu überprüfen, und klicken Sie dann auf Fertig stellen.

Phase 3: Verwenden Sie den Assistenten "Neue Datenquelle für SQL Server erstellen".

Führen Sie im Assistenten Neue Datenquelle für SQL Server erstellen folgende Schritte aus:

  1. Geben Sie auf der ersten Seite Identifikationsinformationen ein:

    • Geben Sie im Feld Beschreibung optional beschreibende Informationen zur DSN-Datei ein.

    • Geben Sie im Feld Server den Namen des Computers mit SQL Server ein. Klicken Sie nicht auf den Pfeil nach unten.

  2. Wählen Sie auf Seite 2 eine der folgenden Authentifizierungsmethoden aus:

    • Integrierte Windows-Authentifizierung    Stellen Sie die Verbindung über ein Windows-Benutzerkonto her. Geben Sie optional einen Dienstprinzipalnamen (SPN) ein. Weitere Informationen finden Sie unter Dienstprinzipalnamen (SPN) in Clientverbindungen (ODBC).

    • SQL Server-Authentifizierung   Stellen Sie die Verbindung mit den in der Datenbank eingerichteten Anmeldeinformationen her, indem Sie die Anmelde-ID und das Kennwort eingeben.

  3. Wählen Sie auf den Seiten 3 und 4 verschiedene Optionen zum Anpassen Ihrer Verbindung aus. Weitere Informationen zu diesen Optionen finden Sie unter Microsoft ODBC-Treiber für SQL Server.

  4. Ein Bildschirm wird angezeigt, damit Sie Ihre Einstellungen bestätigen. Wählen Sie Datenquelle testen aus, um die Verbindung zu bestätigen.

  5. Möglicherweise müssen Sie sich bei der Datenbank anmelden. Geben Sie im Dialogfeld SQL Server-Anmeldung die Anmelde-ID und das Kennwort ein. Um weitere Einstellungen zu ändern, wählen Sie Optionen aus.

Phase 4: Auswählen von Tabellen und Ansichten zum Verknüpfen oder importieren

  1. Wählen Sie im Dialogfeld Tabellen verknüpfen oder Objekte importieren unter Tabellen jede Tabelle oder Ansicht aus, die Sie verknüpfen oder importieren möchten, und klicken Sie dann auf OK.

    Liste der Tabellen, die Sie verknüpfen oder importieren möchten
  2. Entscheiden Sie in einem Verknüpfungsvorgang, ob das Kennwort gespeichert werden soll.

    Sicherheit    Wenn Sie diese Option auswählen, müssen Sie nicht jedes Mal Anmeldeinformationen eingeben, wenn Sie Access öffnen und auf die Daten zugreifen. Dies speichert aber ein unverschlüsseltes Kennwort in der Access-Datenbank, was bedeutet, dass Personen, die auf den Quellinhalt zugreifen können, den Benutzernamen und das Kennwort sehen können. Wenn Sie diese Option auswählen, wird dringend empfohlen, die Access-Datenbank an einem vertrauenswürdigen Speicherort zu speichern und ein Kennwort für die Access-Datenbank zu erstellen. Weitere Informationen finden Sie unter Entscheiden, ob einer Datenbank vertraut werden soll und Verschlüsseln einer Datenbank mithilfe eines Datenbankkennworts.

    Hinweis    Wenn Sie sich entscheiden, das Kennwort nicht zu speichern, aber dann Ihre Entscheidung zu ändern, müssen Sie die verknüpfte Tabelle löschen und neu erstellen und dann Kennwort speichernauswählen.

Phase 5: Erstellen von Spezifikationen und Aufgaben (nur für den Import)

Ergebnisse

Wenn ein Verknüpfungs- oder Importvorgang abgeschlossen ist, werden die Tabellen mit dem gleichen Namen wie die SQL Server-Tabelle oder -Ansicht, kombiniert mit den Namen des Besitzers, im Navigationsbereich angezeigt. Ist der SQL-Name z. B. "dbo.Product", lautet der Access-Name "dbo_Product". Wird dieser Name bereits verwendet, fügt Access an den neuen Tabellennamen eine "1" an – z. B. "dbo_Product1". Wird auch "dbo_Product1" bereits verwendet, erstellt Access den Namen "dbo_Product2" und so weiter. Sie können den Tabellen jedoch umbenennen und ihnen aussagekräftigere Namen geben.

In einem Importvorgang überschreibt Access nie eine Tabelle in der Datenbank. Sie können SQL Server-Daten zwar nicht direkt an eine vorhandene Tabelle anfügen, aber Sie können nach dem Importieren von Daten aus ähnlichen Tabellen eine Anfügeabfrage erstellen, um die Daten anzufügen.

Wenn in einem Verknüpfungsvorgang die Spalten in einer SQL Server-Tabelle schreibgeschützt sind, sind sie auch in Access schreibgeschützt.

Tipp    Um die Verbindungszeichenfolge anzuzeigen, zeigen Sie auf die Tabelle im Access-Navigationsbereich.

Aktualisieren des Entwurfs der verknüpften Tabelle

Sie können in einer verknüpften Tabelle keine Spalten hinzufügen, löschen oder ändern und keine Datentypen ändern. Wenn Sie Änderungen am Entwurf vornehmen möchten, nehmen Sie diese in der SQL Server-Datenbank vor. Damit die Entwurfsänderungen in Access angezeigt werden, aktualisieren Sie die verknüpften Tabellen:

  1. Wählen Sie Externe Daten > Tabellenverknüpfungs-Manager aus.

  2. Markieren Sie alle verknüpften Tabellen, die Sie aktualisieren möchten, wählen Sie OK und dann Schließen aus.

Datentypen vergleichen

Access-Datentypen heißen anders als SQL Server-Datentypen. Eine SQL Server-Spalte mit dem Datentyp bit wird in Access mit dem Datentyp Ja/Nein importiert oder verknüpft. Weitere Informationen finden Sie unter Vergleichen von Access-und SQL Server-Datentypen.

Sie können mit Daten arbeiten, die in SQL Server gespeichert sind, indem Sie entweder eine Verknüpfung dazu erstellen oder die Daten in eine Access-Datenbank importieren. Das Verknüpfen ist eine bessere Option, wenn Sie die Daten für andere freigeben, da die Daten an einem zentralen Speicherort gespeichert werden und Sie die neuesten Daten anzeigen, die Daten hinzufügen oder bearbeiten sowie Abfragen oder Berichte in Access ausführen können.

Schritt 1: Vorbereitung für ein Verknüpfen

  1. Suchen Sie die SQL Server-Datenbank, mit der Sie eine Verknüpfung herstellen möchten. Wenden Sie sich bei Bedarf an den Datenbankadministrator, um Verbindungsinformationen zu erhalten.

  2. Definieren Sie die Tabellen und Ansichten für die Verknüpfung in der SQL-Datenbank. Sie können gleichzeitig eine Verknüpfung zu mehreren Objekten herstellen.

Überprüfen Sie die Quelldaten unter folgenden Aspekten:

  • Access unterstützt maximal 255 Felder (Spalten) in einer Tabelle. Die verknüpfte Tabelle enthält daher nur die ersten 255 Felder des verknüpften Objekts.

  • Die Spalten, die in einer SQL Server-Tabelle schreibgeschützt sind, sind auch in Access schreibgeschützt.

  1. Wenn die verknüpfte Tabelle in einer neuen Datenbank erstellt werden soll: Klicken Sie auf Datei > Neu > Leere Desktopdatenbank. Wenn die verknüpfte Tabelle in einer vorhandenen Access-Datenbank erstellt werden soll, müssen Sie über die Berechtigungen verfügen, die zum Hinzufügen von Daten zur Datenbank erforderlich sind.

    Hinweis: Eine verknüpfte Tabelle, die in einer vorhandenen Access-Datenbank erstellt wird, erhält den Namen, den sie auch im Quellobjekt hat. Wird bereits eine andere Tabelle gleichen Namens verwendet, wird der Name der verknüpften Tabelle mit dem Zusatz "1" versehen, z. B. "Kontaktdaten1". (Wird auch "Kontaktdaten1" bereits verwendet wird, erstellt Access den Namen "Kontaktdaten2" usw.)

Schritt 2: Verknüpfen mit Daten

Wenn Sie eine Verknüpfung mit einer Tabelle oder Sicht in einer SQL Server-Datenbank herstellen, erstellt Access eine neue Tabelle (auch als verknüpfte Tabelle bezeichnet), die die Struktur und den Inhalt der Quelltabelle wiedergibt. Sie können die Daten entweder in SQL Server oder in der Datenblattansicht oder in der Formularansicht aus Access ändern, und die Änderungen werden sowohl in SQL als auch in Access widergespiegelt. Alle strukturellen Änderungen an verknüpften Tabellen wie das Entfernen oder Ändern von Spalten müssen vom SQL Server und nicht von Access erfolgen.

  1. Öffnen Sie die Access-Zieldatenbank.

  2. Klicken Sie auf der Registerkarte Daten auf ODBC-Datenbank.

  3. Klicken Sie auf Erstellen Sie eine Verknüpfung zur Datenquelle, indem Sie eine verknüpfte Tabelle erstellen > OK, und führen Sie die vom Assistenten vorgegebenen Schritte aus. Wenn die DSN-Datei, die Sie verwenden möchten, bereits vorhanden ist, klicken Sie in der Liste Datenquelle auswählen auf den entsprechenden Dateinamen.

    So erstellen Sie eine neue DSN-Datei:

    Klicken Sie im Feld Datenquelle auswählen auf Neu> SQL Server > Weiter.

    1. Geben Sie einen Namen für die DSN-Datei ein, oder klicken Sie auf Durchsuchen.

      Hinweis: Sie müssen über Schreibberechtigungen für den Ordner verfügen, um die DSN-Datei speichern zu können.

    2. Klicken Sie auf Weiter, damit Sie die Zusammenfassungsinformationen überprüfen können, und klicken Sie dann auf Fertig stellen.

      Führen Sie die vom Assistenten Neue Datenquelle für SQL Server erstellen vorgegebenen Schritte aus.

  4. Klicken Sie auf OK. Klicken Sie unter Tabellen auf alle zu verknüpfenden Tabellen oder Ansichten, und klicken Sie dann auf OK.

Wenn der Bezeichner "eindeutigen Daten Satz auswählen"angezeigt wird, bedeutet dies, dass Access nicht ermitteln konnte, welche Felder die einzelnen Zeilen der Quelldaten eindeutig identifizieren. Wählen Sie einfach das Feld oder die Kombination von Feldern aus, die für jede Zeile eindeutig sind, und wenn Sie sich nicht sicher sind, wenden Sie sich an den SQL Server-Datenbankadministrator.

Wenn der Verknüpfungsvorgang abgeschlossen ist, wird die neue verknüpfte Tabelle (bzw. Tabellen) im Navigationsbereich angezeigt.

Übernehmen der aktuellen Struktur des SQL Server-Objekts

Beim Öffnen einer verknüpften Tabelle oder des Quellobjekts werden die jeweils aktuellen Daten angezeigt. Wurden jedoch Änderungen an der Struktur eines SQL Server-Objekts vorgenommenen, müssen Sie die verknüpfte(n) Tabelle(n) aktualisieren, damit diese Änderungen angezeigt werden.

  1. Klicken Sie im Navigationsbereich mit der rechten Maustaste auf die Tabelle, und klicken Sie dann im Kontextmenü auf Tabellenverknüpfungs-Manager.

  2. Aktivieren Sie jeweils das Kontrollkästchen neben den einzelnen verknüpften Tabellen, die aktualisiert werden sollen, oder klicken Sie auf Alle auswählen, um alle verknüpften Tabellen auszuwählen.

  3. Klicken Sie auf OK > Schließen. .

Hinweis: Da sich die Datentypen in Access von den Datentypen in SQL Server unterscheiden, stellt Access für jede Spalte eine Verknüpfung zum am besten passenden Datentyp her. Die in Access zugewiesenen Datentypen können nur angezeigt und nicht geändert werden.

Weitere Informationen finden Sie unter Möglichkeiten der Freigabe einer Access-Desktopdatenbank.

Seitenanfang

Wenn Ihre Abteilung oder Arbeitsgruppe Microsoft SQL Server zum Speichern von Daten verwendet, müssen Sie möglicherweise mit einigen SQL Server-Daten in Access arbeiten.

Es gibt zwei Möglichkeiten, Daten aus SQL Server-Objekten (Tabellen oder Ansichten) nach Access zu übertragen: durch Importieren oder durch Verknüpfen. Der folgende Unterschied besteht zwischen diesen beiden Vorgängen:

  • Wenn Sie die Daten importieren, erstellt Access eine Kopie der SQL Server-Daten, und alle späteren Änderungen, die an den Daten in Ihrer Access-Datenbank vorgenommen werden, werden in der SQL Server-Datenbank nicht wiedergegeben. Auch spätere Änderungen, die in der SQL Server-Tabelle oder-Ansicht vorgenommen wurden, werden in Access nicht wiedergegeben.

  • Wenn Sie eine Verknüpfung mit den SQL Server-Daten herstellen, stellen Sie direkt eine Verbindung mit den Quelldaten her, sodass spätere Änderungen, die an Daten in Access vorgenommen werden, in SQL Server angezeigt werden (und umgekehrt).

In diesem Artikel wird beschrieben, wie SQL Server-Daten importiert werden oder eine Verknüpfung mit ihnen hergestellt wird.

Entscheiden, ob eine Verknüpfung oder ein Import erfolgen soll

Umstände, unter denen ein Import geeignet ist

In der Regel importieren Sie SQL Server-Daten aus den folgenden Gründen in eine Access-Datenbank:

  • Wenn Sie SQL Server-Daten dauerhaft in eine Access-Datenbank verschieben möchten, weil Sie die Daten nicht mehr in der SQL Server-Datenbank benötigen. Nachdem Sie die Daten in Access importiert haben, können Sie die Daten aus der SQL Server-Datenbank löschen.

  • In Ihrer Abteilung oder Arbeitsgruppe wird Access verwendet. Sie werden aber bisweilen an eine SQL Server-Datenbank verwiesen, weil Sie zusätzliche Daten benötigen, die in die Access-Datenbanken überführt werden müssen.

Da beim Importieren von SQL Server-Daten eine Kopie der Daten in Ihrer Access-Datenbank erstellt wird, geben Sie während des Importvorgangs die Tabellen oder Ansichten an, die kopiert werden sollen.

Umstände, unter denen eine Verknüpfung geeignet ist

In der Regel erfolgen Verknüpfungen mit SQL Server-Daten aus den folgenden Gründen:

  • Wenn eine direkte Verbindung mit den Quelldaten hergestellt werden soll, damit die Anzeige und Bearbeitung der neuesten Informationen sowohl in der SQL Server-Datenbank als auch in Ihrer Access-Datenbank erfolgen kann.

  • Wenn die SQL Server-Datenbank zahlreiche umfangreiche Tabellen enthält und Sie nicht alle Tabellen in eine einzige ACCDB-Datei importieren können. Die maximale Größe einer Access-Datenbank beträgt 2 GB, abzüglich des für Systemobjekte erforderlichen Speicherplatzes.

  • Wenn Sie Abfragen ausführen und Berichte generieren möchten, die auf Daten aus SQL Server basieren, ohne dass eine Kopie der Daten erstellt wird, sollten Sie Verknüpfungen mit den SQL Server-Daten in Betracht ziehen.

  • Ihre Abteilung oder Arbeitsgruppe verwendet Access für Berichte und Abfragen und verwendet SQL Server für die Datenspeicherung. Einzelne Teams können SQL Server-Tabellen und-Ansichten für zentralisierten Speicher erstellen, aber diese Daten müssen häufig in Desktop Programme für Aggregation und Berichterstellung gebracht werden. Das Verknüpfen ist die geeignete Option, da es Benutzern der SQL Server-Datenbank und der Access-Datenbank ermöglicht, Daten hinzuzufügen und zu aktualisieren und die neuesten Daten immer anzuzeigen und zu bearbeiten.

  • Sie sind ein Benutzer von Access, der erst seit kurzem SQL Server verwendet. Sie haben einige Ihrer Datenbanken nach SQL Server migriert, und die meisten Tabellen in diesen Datenbanken sind verknüpfte Tabellen. Von nun an erstellen Sie keine lokalen Tabellen mehr, sondern Sie erstellen Tabellen und Ansichten in SQL Server und verknüpfen diese mit den Access-Datenbanken.

  • Sie möchten Ihre Daten weiterhin in SQL Server speichern, Sie möchten aber auch mit den aktuellen Daten in Access arbeiten, um Abfragen auszuführen und Berichte auszugeben, die Sie in Access entworfen haben.

Seitenanfang

Importieren von Daten aus SQL Server

Vorbereiten des Imports

Während des Importvorgangs erstellt Access eine Tabelle und kopiert dann die Daten aus der SQL Server-Datenbank in diese Tabelle. Am Ende des Importvorgangs können Sie auswählen, ob die Details des Importvorgangs als Spezifikation gespeichert werden sollen.

Hinweis: Eine Importspezifikation unterstützt Sie beim Wiederholen des Importvorgang zu einem späteren Zeitpunkt, ohne die Schritte des Import-Assistenten erneut ausführen zu müssen.

  1. Suchen Sie nach der SQL Server-Datenbank, die die Daten enthält, die Sie importieren möchten. Wenden Sie sich an den Administrator der Datenbank, um Verbindungsinformationen zu erhalten.

  2. Identifizieren Sie die Tabellen oder Ansichten, die Sie importieren möchten. Sie können mehrere Objekte in einem einzigen Importvorgang importieren.

  3. Überprüfen Sie die Quelldaten unter den folgenden Aspekten:

    • Access unterstützt höchstens 255 Felder in einer Tabelle, sodass nur die ersten 255 Spalten importiert werden.

    • Die maximale Größe einer Access-Datenbank beträgt 2 GB, abzüglich des für Systemobjekte erforderlichen Speicherplatzes. Wenn die SQL Server-Datenbank zahlreiche umfangreiche Tabellen enthält, können Sie möglicherweise nicht alle Tabellen in eine einzige ACCDB-Datei importieren. In diesem Fall sollten Sie stattdessen eine Verknüpfung der Daten mit Ihrer Access-Datenbank herstellen.

    • Am Ende eines Importvorgangs erstellt Access nicht automatisch Beziehungen zwischen verbundenen Tabellen. Sie müssen die Beziehungen zwischen den verschiedenen neuen und vorhandenen Tabellen manuell über die Optionen im Fenster Beziehungen erstellen. So zeigen Sie das Fenster Beziehungen an:

      • Klicken Sie auf Datenbanktools > Beziehungen.

  4. Identifizieren Sie die Access-Datenbank, in die Sie die SQL Server-Daten importieren möchten.

    Stellen Sie sicher, dass Sie über die erforderlichen Berechtigungen zum Hinzufügen von Daten zur Access-Datenbank verfügen. Wenn die Daten nicht in einer bestehenden Datenbank gespeichert werden sollen, erstellen Sie eine neue leere Datenbank.

  5. Überprüfen Sie die Tabellen (sofern vorhanden) in der Access-Datenbank.

    Beim Importvorgang wird eine Tabelle mit dem gleichen Namen wie das SQL Server-Objekt erstellt. Wenn dieser Name bereits verwendet wird, fügt Access "1" an den neuen Tabellennamen an, beispielsweise Kontakte1. (Wird auch "Kontaktdaten1" bereits verwendet wird, erstellt Access den Namen "Kontaktdaten2" usw.)

    Hinweis: Access überschreibt im Rahmen eines Importvorgangs niemals eine Tabelle in der Datenbank, und Sie können SQL Server-Daten nicht an eine vorhandene Tabelle anfügen.

Importieren der Daten

  1. Öffnen Sie die Zieldatenbank.

    Klicken Sie auf der Registerkarte Daten in der Gruppe Importieren und Verknüpfen auf ODBC-Datenbank.

  2. Klicken Sie auf Importieren Sie die Quelldaten in eine neue Tabelle in der aktuellen Datenbank, und klicken Sie dann auf OK.

  3. Wenn die DSN-Datei, die Sie verwenden möchten, bereits vorhanden ist, klicken Sie im Dialogfeld Datenquelle auswählen auf die Datei in der Liste.

    Ich muss eine neue DSN-Datei erstellen

    Hinweis: Die Schritte in diesem Verfahren weichen für Sie möglicherweise abhängig von der Software ab, die auf Ihrem Computer installiert ist.

    1. Klicken Sie auf Neu, um einen neuen Datenquellennamen (DSN) zu erstellen.

      Der Assistent zum Erstellen neuer Datenquellen wird gestartet.

    2. Wählen Sie im Assistenten in der Liste der Treiber SQL Server aus, und klicken Sie dann auf Weiter.

    3. Geben Sie einen Namen für die DSN-Datei ein, oder klicken Sie auf Durchsuchen, um die Datei an einem anderen Speicherort zu speichern.

      Hinweis: Sie müssen über Schreibberechtigungen für den Ordner verfügen, um die DSN-Datei speichern zu können.

    4. Klicken Sie auf Weiter, um die Zusammenfassungsinformationen zu überprüfen, und klicken Sie dann auf Fertig stellen, um den Assistenten abzuschließen.

      Das Dialogfeld Neue Datenquelle für SQL Server erstellen wird angezeigt.

    5. Geben Sie eine Beschreibung der Datenquelle im Feld Beschreibung ein. Dieser Schritt ist optional.

    6. Geben Sie unter Mit welchem SQL Server möchten Sie eine Verbindung herstellen im Feld Server den Namen des Computers mit SQL Server ein, mit dem Sie eine Verbindung herstellen möchten, oder wählen Sie ihn aus, und klicken Sie dann auf Weiter, um den Vorgang fortzusetzen.

    7. Möglicherweise benötigen Sie Informationen vom SQL Server-Datenbankadministrator, beispielsweise ob Sie die Microsoft Windows NT-Authentifizierung oder die SQL Server-Authentifizierung verwenden möchten. Klicken Sie auf Weiter, um den Vorgang fortzusetzen.

    8. Wenn Sie mit einer bestimmten Datenbank eine Verbindung herstellen möchten, stellen Sie sicher, dass das Kontrollkästchen Standarddatenbank ändern auf aktiviert ist. Wählen Sie dann die Datenbank aus, mit der Sie arbeiten möchten, und klicken Sie auf Weiter.

    9. Klicken Sie auf Fertig stellen.

    10. Überprüfen Sie die Zusammenfassungsinformationen, und klicken Sie dann auf Datenquelle testen.

    11. Überprüfen Sie die Testergebnisse, und klicken Sie dann auf OK, um das Dialogfeld zu schließen.

      Wenn der Test erfolgreich war, klicken Sie erneut auf OK, oder klicken Sie auf Abbrechen, um Ihre Einstellungen zu ändern.

  4. Klicken Sie auf OK, um das Dialogfeld Datenquelle auswählen zu schließen.

    Access zeigt das Dialogfeld Objekte importieren an.

  5. Klicken Sie unter Tabellen auf alle zu importierenden Tabellen oder Ansichten, und klicken Sie dann auf OK.

  6. Wenn das Dialogfeld Eindeutigen Datensatzbezeichner auswählen angezeigt wird, konnte Access nicht ermitteln, welche Zeilen eines bestimmten Objekts durch welche Felder eindeutig identifiziert werden. Wählen Sie in diesem Fall einfach das Feld oder eine Kombination von Feldern aus, das/die für jede Zeile eindeutig ist, und klicken Sie auf OK. Wenden Sie sich an den SQL Server-Datenbankadministrator, wenn Sie sich nicht sicher sind.

    Access importiert die Daten. Wenn Sie den Importvorgang später wiederholen möchten, können Sie die Importschritte als Importspezifikation speichern und die gleichen Importschritte später ganz einfach erneut ausführen. Microsoft Office Outlook muss auf Ihrem Computer installiert sein, um eine Aufgabe erstellen zu können.

  7. Klicken Sie im Dialogfeld externe Daten abrufen – ODBC-Datenbank auf Schließen unter Import Schritte speichern . Access beendet den Importvorgang und zeigt die neuen Tabellen im Navigationsbereich an.

Wenn Sie den Import als Aufgabe zur Wiederverwendung speichern möchten, fahren Sie mit dem nächsten Abschnitt fort.

Seitenanfang

Herstellen einer Verknüpfung mit SQL Server-Daten

Weil die Daten in Tabellen gespeichert sind, erstellt Access eine neue Tabelle (häufig als verknüpfte Tabelle bezeichnet), die die Struktur und den Inhalt des Quellobjekts widerspiegelt, wenn Sie eine Verknüpfung mit einer Tabelle oder Ansicht in einer SQL Server-Datenbank herstellen. Sie können Daten in SQL Server oder in der Datenblattansicht oder Formularansicht aus Access ändern. Die Änderungen, die Sie an Daten an einem Speicherort vornehmen, werden am anderen Speicherort widergespiegelt. Wenn Sie aber strukturelle Änderungen vornehmen möchten, z. B. eine Spalte entfernen oder ändern, muss dies in der SQL Server-Datenbank oder über ein Access-Projekt geschehen, das mit dieser Datenbank verbunden ist. Sie können die Felder in einer verknüpften Tabelle nicht in Access hinzufügen, löschen oder ändern.

Vorbereiten der Verknüpfung

  1. Suchen Sie die SQL Server-Datenbank, die die Daten enthält, mit denen Sie eine Verknüpfung herstellen möchten. Wenden Sie sich für Verbindungsinformationen an den Datenbankadministrator.

  2. Identifizieren Sie die Tabellen und Ansichten, mit denen eine Verknüpfung erfolgen soll. Sie können eine Verknüpfung mit mehreren Objekten in einem einzigen Verknüpfungsvorgang herstellen.

  3. Überprüfen Sie die Quelldaten unter den folgenden Aspekten:

    • Access unterstützt maximal 255 Felder in einer Tabelle. Die verknüpfte Tabelle enthält daher nur die ersten 255 Felder des verknüpften Objekts.

    • Die Spalten, die in einem SQL Server-Objekt schreibgeschützt sind, sind auch in Access weiterhin schreibgeschützt.

    • Sie können in der verknüpften Tabelle in Access keine Spalten hinzufügen, löschen oder ändern.

  4. Ermitteln Sie die Access-Datenbank, in der Sie die verknüpfte Tabelle erstellen möchten. Stellen Sie sicher, dass Sie über die erforderlichen Berechtigungen zum Hinzufügen von Daten zur Datenbank verfügen. Wenn Sie die Daten nicht in einer der vorhandenen Datenbanken speichern möchten, erstellen Sie eine leere Datenbank, indem Sie auf die Registerkarte Datei und dann auf der Registerkarte Neu auf Leere Datenbank klicken.

  5. Überprüfen Sie die Tabellen in der Access-Datenbank. Wenn Sie eine Verknüpfung mit einer SQL Server-Tabelle oder-Ansicht herstellen, erstellt Access eine verknüpfte Tabelle mit dem gleichen Namen wie das Quellobjekt. Wenn dieser Name bereits verwendet wird, fügt Access "1" an den neuen verknüpften Tabellennamen an, beispielsweise Kontakte1. (Wird auch "Kontaktdaten1" bereits verwendet wird, erstellt Access den Namen "Kontaktdaten2" usw.)

  6. Um eine Verknüpfung mit den Daten herzustellen, öffnen Sie die Zieldatenbank.

  7. Klicken Sie auf der Registerkarte Daten in der Gruppe Importieren und Verknüpfen auf ODBC-Datenbank.

  8. Klicken Sie auf Erstellen Sie eine Verknüpfung zur Datenquelle, indem Sie eine verknüpfte Tabelle erstellen, und klicken Sie dann auf OK.

  9. Klicken Sie im Dialogfeld Datenquelle auswählen auf die DSN-Datei, die Sie verwenden möchten, oder klicken Sie auf Neu, um einen neuen Datenquellennamen (DSN) zu erstellen.

  10. Wenn die DSN-Datei, die Sie verwenden möchten, bereits vorhanden ist, klicken Sie im Dialogfeld Datenquelle auswählen auf die Datei in der Liste.

    Ich muss eine neue DSN-Datei erstellen

    Hinweis: Die Schritte in diesem Verfahren weichen für Sie möglicherweise abhängig von der Software ab, die auf Ihrem Computer installiert ist.

    1. Klicken Sie auf Neu, um einen neuen Datenquellennamen (DSN) zu erstellen.

      Der Assistent zum Erstellen neuer Datenquellen wird gestartet.

    2. Wählen Sie im Assistenten in der Liste der Treiber SQL Server aus, und klicken Sie dann auf Weiter.

    3. Geben Sie einen Namen für die DSN-Datei ein, oder klicken Sie auf Durchsuchen, um die Datei an einem anderen Speicherort zu speichern.

      Hinweis: Sie müssen über Schreibberechtigungen für den Ordner verfügen, um die DSN-Datei speichern zu können.

    4. Klicken Sie auf Weiter, um die Zusammenfassungsinformationen zu überprüfen, und klicken Sie dann auf Fertig stellen, um den Assistenten zum Erstellen neuer Datenquellen abzuschließen.

      Der Assistent zum Erstellen neuer Datenquellen für SQL Server wird gestartet.

    5. Geben Sie im Assistenten eine Beschreibung der Datenquelle im Feld Beschreibung ein. Dieser Schritt ist optional.

    6. Geben Sie unter Mit welchem SQL Server möchten Sie eine Verbindung herstellen im Feld Server den Namen des Computers mit SQL Server ein, mit dem Sie eine Verbindung herstellen möchten, oder wählen Sie ihn aus, und klicken Sie dann auf Weiter, um den Vorgang fortzusetzen.

    7. Auf dieser Seite des Assistenten müssen Sie möglicherweise Informationen vom SQL Server-Datenbankadministrator abrufen, beispielsweise ob Sie die Windows NT-Authentifizierung oder die SQL Server-Authentifizierung verwenden möchten. Klicken Sie auf Weiter, um den Vorgang fortzusetzen.

    8. Auf der nächsten Seite des Assistenten müssen Sie möglicherweise weitere Informationen vom SQL Server-Datenbankadministrator erfragen. Wenn Sie mit einer bestimmten Datenbank eine Verbindung herstellen möchten, stellen Sie sicher, dass das Kontrollkästchen Standarddatenbank ändern in aktiviert ist, wählen Sie die SQL Server-Datenbank aus, die Sie verwenden möchten, und klicken Sie dann auf Weiter.

    9. Klicken Sie auf Fertig stellen. Überprüfen Sie die Zusammenfassungsinformationen, und klicken Sie dann auf Datenquelle testen.

    10. Überprüfen Sie die Testergebnisse, und klicken Sie dann auf OK, um das Dialogfeld SQL Server ODBC-Datenquelle testen zu schließen.

      Wenn der Test erfolgreich war, klicken Sie erneut auf OK, um den Assistenten abzuschließen, oder klicken Sie auf Abbrechen, um zum Assistenten zurückzukehren und Ihre Einstellungen zu ändern.

  11. Klicken Sie auf OK.

    Access zeigt das Dialogfeld Tabellen verknüpfen an.

  12. Klicken Sie unter Tabellen auf alle zu verknüpfenden Tabellen oder Ansichten, und klicken Sie dann auf OK.

    1. Wenn das Dialogfeld Eindeutigen Datensatzbezeichner auswählen angezeigt wird, konnte Access nicht ermitteln, welche Zeilen der Quelldaten durch welche Felder eindeutig identifiziert werden. Wählen Sie in diesem Fall einfach das Feld oder eine Kombination von Feldern aus, das/die für jede Zeile eindeutig ist, und klicken Sie auf OK. Wenden Sie sich an den SQL Server-Datenbankadministrator, wenn Sie sich nicht sicher sind.

Access schließt den Verknüpfungsvorgang ab und zeigt die neue verknüpfte Tabelle bzw. die Tabellen im Navigationsbereich an.

Wichtig: Bei jedem Öffnen einer verknüpften Tabelle oder des Quellobjekts werden die neuesten Daten darin angezeigt. Strukturelle Änderungen, die an einem SQL Server-Objekt vorgenommen werden, werden jedoch nicht automatisch in einer verknüpften Tabelle angezeigt.

Aktualisieren einer verknüpfter Tabelle durch Anwenden der neuesten SQL Server-Objektstruktur

  1. Klicken Sie im Navigationsbereich mit der rechten Maustaste auf die Tabelle, und klicken Sie dann im Kontextmenü auf Tabellenverknüpfungs-Manager.

  2. Aktivieren Sie jeweils das Kontrollkästchen neben den einzelnen verknüpften Tabellen, die aktualisiert werden sollen, oder klicken Sie auf Alle auswählen, um alle verknüpften Tabellen auszuwählen.

  3. Klicken Sie auf OK.

    Wenn die Aktualisierung erfolgreich ist, zeigt Access eine diesbezügliche Meldung an. Andernfalls zeigt Access eine Fehlermeldung an.

  4. Klicken Sie auf Schließen, um den Tabellenverknüpfungs-Manager zu schließen.

Seitenanfang

Was sollte ich noch wissen?

Seitenanfang

Umsetzung von SQL Server-Datentypen durch Access

Da sich die Access-Datentypen von SQL Server-Datentypen unterscheiden, muss Access den am besten geeigneten Access-Datentyp ermitteln, der für jede Spalte jeder SQL Server-Tabelle oder-Ansicht verwendet werden soll, die Sie importieren oder verknüpfen. Beispielsweise wird eine SQL Server-Spalte des Datentyps Bit importiert oder in Access mit dem Datentyp Ja/Neinverknüpft. Ein weiteres Beispiel: eine SQL Server-Spalte des Datentyps nvarchar (255) (oder kleiner) wird importiert oder mit dem Datentyp Textverknüpft, aber eine Spalte des Datentyps nvarchar (256) (oder größer) wird als Access- Memofeld importiert. Nachdem Sie einen Import-oder Verknüpfungsvorgang abgeschlossen haben, können Sie die Tabelle in der Entwurfsansicht öffnen und bestätigen, welche Datentypen Access ihren Feldern zugewiesen ist. Sie können Datentypen von Feldern in importierten Tabellen ändern. Sie können jedoch keine Datentypen von Feldern in verknüpften Tabellen ändern, es sei denn, Sie werden in der SQL Server-Datenbank selbst oder in einem Access-Projekt geändert, das mit dieser Datenbank verbunden ist.

In der folgenden Tabelle werden die wichtigsten SQL Server-Datentypen aufgeführt. Die zweite und dritte Spalte zeigen, wie Access jeden Typ interpretiert.

SQL Server-Datentyp

Access-Datentyp

Access-Feldgröße

bigint

Text

255

binary( Feldgröße )

Binär

Entspricht der SQL Server-Feldgröße

bit

Ja/Nein

char( Feldgröße ), mit einer Feldgröße kleiner oder gleich 255

Text

Entspricht der SQL Server-Feldgröße

char( Feldgröße ), mit einer Feldgröße größer als 255

Memo

datetime

Datum/Uhrzeit

decimal( Genauigkeit , Skalierung )

Zahl

Decimal (die Access-Eigenschaften Genauigkeit: und Skalierung entsprechen den SQL Server-Eigenschaften "precision" und "scale".)

float

Zahl

Double

image

OLE-Objekt

int

Zahl

Long Integer

money

Währung

nchar( Feldgröße ), mit einer Feldgröße kleiner oder gleich 255

Text

Entspricht der SQL Server-Feldgröße

nchar( Feldgröße ), mit einer Feldgröße größer als 255

Memo

ntext

Memo

numeric( Genauigkeit , Skalierung )

Zahl

Decimal (die Access-Eigenschaften Genauigkeit: und Skalierung entsprechen den SQL Server-Eigenschaften "precision" und "scale".)

nvarchar( Feldgröße ), mit einer Feldgröße kleiner oder gleich 255

Text

Entspricht der SQL Server-Feldgröße

nvarchar( Feldgröße ), mit einer Feldgröße größer als 255

Memo

nvarchar(MAX)

Memo

real

Zahl

Single

smalldatetime

Datum/Uhrzeit

smallint

Zahl

Ganze Zahl

smallmoney

Währung

sql_variant

Text

255

text

Memo

timestamp

Binär

8

tinyint

Zahl

Byte

uniqueidentifier

Zahl

Replikations-ID

varbinary

Binär

Entspricht der SQL Server-Feldgröße

varbinary(max)

OLE-Objekt

varchar( Feldgröße ), mit einer Feldgröße kleiner oder gleich 255

Text

Entspricht der SQL Server-Feldgröße

varchar( Feldgröße), mit einer Feldgröße größer als 255

Memo

varchar(MAX)

Memo

xml

Memo

Seitenanfang

Hinweis:  Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Lassen Sie uns bitte wissen, ob diese Informationen hilfreich für Sie waren. Hier finden Sie den englischen Artikel als Referenz.

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×