Ich kann meine replizierte Datenbank nicht im Access 2007-Format speichern

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Symptome

In Microsoft Office Access 2007 wurden replizierte Datenbanken, die in früheren Versionen von Access erstellt wurden (. MDB-Format) kann nicht in der neuen Datei gespeichert werden. ACCDB-Dateiformat. Die Option wird abgeblendet (nicht verfügbar), wenn Sie versuchen, den Befehl Datenbank speichern unter zu verwenden (Klicken Sie auf die Microsoft Office-Schaltfläche Abbildung der Office-Schaltfläche , und klicken Sie dann auf den Pfeil neben Speichernunter).

Ursache

Die. Das ACCDB-Dateiformat unterstützt keine Replikation.

Lösung

Verwenden Sie die replizierte Datenbank in der. MDB-Dateiformat

Sie können Ihre replizierte Datenbank weiterhin in der verwenden. MDB-Dateiformat. Die Replikationsfunktionalität wird weiterhin unterstützt. MDB-Dateiformat.

Manuelles erneutes Erstellen der Datenbank im Office Access 2007-Dateiformat

Wenn Sie entscheiden, dass das neue Dateiformat Vorteile bietet, die die Vorteile der Replikation überwiegen, können Sie eine neue Datenbank im Office Access 2007-Format erstellen und die replizierte Datenbank manuell neu erstellen.

Hinweis: Diese Methode funktioniert für jede replizierte Datenbank, es sei denn, Sie arbeiten mit einem vollständigen Replikat, das mit allen anderen Replikaten des Replikatsatzes synchronisiert wurde, alle Daten und Projekte, die sich noch nicht im Replikat befinden, werden nicht in der neuen Datenbank gespeichert.

Bevor Sie mit der erneuten Erstellung der Datenbank beginnen, sollten Sie sicherstellen, dass alle ausgeblendeten und Systemobjekte im Replikat sichtbar sind. Dadurch wird sichergestellt, dass Sie beim erneuten Erstellen auf die Replikat spezifischen Felder im Replikat zugreifen können.

  1. Öffnen Sie das Replikat, das Sie konvertieren möchten. Sie müssen das Replikat mithilfe der gleichen Access-Version öffnen, die ursprünglich zum Erstellen des Replikats verwendet wurde, um die Felder ausgeblendet und System anzuzeigen.

  2. Klicken Sie im Menü Extras auf Optionen. Das Dialogfeld Optionen wird geöffnet.

  3. Wählen Sie auf der Registerkarte Ansicht im Abschnitt anzeigen die Option Ausgeblendete Objekte und System Objekteaus. Klicken Sie auf OK , um die neuen Einstellungen anzuwenden und das Dialogfeldoptionen zu schließen.

Manuelles erneutes Erstellen der Datenbank

  1. Erstellen Sie eine leere Datenbank, und öffnen Sie Sie.

    Hinweis: Access erstellt eine neue, leere Tabelle mit dem Namen Tabelle1. Sie sollten diese Tabelle löschen, indem Sie Sie sofort schließen, bevor Sie Änderungen daran vornehmen. Klicken Sie mit der rechten Maustaste auf die Objektregisterkarte, und klicken Sie dann im Kontextmenü auf Schließen .

  2. Klicken Sie auf der Registerkarte Externe Daten in der Gruppe Importieren auf Access.

    Das Dialogfeld externe Daten abrufen – Access-Datenbank wird angezeigt.

  3. Klicken Sie auf Durchsuchen , um die replizierte Datenbank zu suchen.

  4. Klicken Sie auf die replizierte Datenbank, die die Datenbankobjekte enthält, die Sie in der neuen Datenbank neu erstellen möchten, und klicken Sie dann auf Öffnen.

  5. Klicken Sie im Dialogfeld externe Daten abrufen – Access-Datenbank auf Tabellen, Abfragen, Formulare, Berichte, Makros und Module in die aktuelle Datenbank importieren, und klicken Sie dann auf OK.

  6. Klicken Sie auf die Datenbankobjekte, die Sie in die neue Datenbank importieren möchten. Wenn Sie alle Objekte importieren möchten, klicken Sie auf jeder Registerkarte auf Alles auswählen .

    Wichtig    Wählen Sie an dieser Stelle keine Tabellen aus. Sie erstellen die Tabellen in einem späteren Schritt erneut.

  7. Klicken Sie nach dem Auswählen von Objekten auf OK , um Sie zu importieren.

    Auf der letzten Seite des Assistenten können Sie die Importschritte für die spätere Verwendung speichern. Aktivieren Sie hierzu das Kontrollkästchen Importschritte speichern , geben Sie die entsprechenden Informationen ein, und klicken Sie dann auf Import speichern.

  8. Öffnen Sie die replizierte Datenbank in Office Access 2007. Erstellen Sie für jede Tabelle in der replizierten Datenbank eine Tabellenerstellungsabfrage, die alle Daten in der alten Tabelle annimmt und eine Tabelle in der neuen Datenbank mit denselben Daten erstellt.

    Hinweis: Wenn s_GUID ein Primärschlüssel ist (und sich Fremdschlüssel in anderen Tabellen darauf beziehen), sollten Sie das Feld s_GUID in die neue Tabelle aufnehmen. Wenn das s_GUID-Feld nicht als Primärschlüssel verwendet wird, gibt es keinen Grund, es in der neuen Tabelle beizubehalten. Kopieren Sie die Felder "s_Lineage" und "s_Generation" nicht in die neue Tabelle.

    Standardmäßig sind die Felder "s_GUID", "s_Lineage" und "s_Generation" ausgeblendet. Gehen Sie wie folgt vor, um diese Felder anzuzeigen:

    1. Stellen Sie sicher, dass in der replizierten Datenbank alle Tabellen geschlossen sind.

    2. Klicken Sie mit der rechten Maustaste auf den oberen Rand des Navigationsbereichs, und klicken Sie dann auf Navigationsoptionen. Das Dialogfeld Navigationsoptionen wird geöffnet.

    3. Wählen Sie im Abschnitt Anzeigeoptionen die Option System Objekte anzeigenaus, und klicken Sie dann auf OK.

      Wie?

      1. Erstellen Sie eine Abfrage, und wählen Sie die Tabellen aus, die die Datensätze enthalten, die Sie in die neue Tabelle einfügen möchten.

        Wie?

        1. Klicken Sie auf der Registerkarte Erstellen in der Gruppe Abfragen auf Abfrageentwurf.

        2. Klicken Sie im Dialogfeld Tabelle anzeigen auf die Registerkarte, auf der die Tabellen aufgelistet sind, mit denen Sie arbeiten möchten.

        3. Doppelklicken Sie auf den Namen der einzelnen Objekte, die Sie der Abfrage hinzufügen möchten, und klicken Sie dann auf Schließen.

        4. Fügen Sie der Zeile Feld im Entwurfsbereich Felder hinzu.

        5. Wenn Sie die Ergebnisse der Abfrage anzeigen möchten, klicken Sie im Menü Ansicht auf Datenblattansicht.

      2. Klicken Sie in Query Entwurfsansicht auf der Registerkarte Entwurf in der Gruppe Abfragetyp auf Tabelle erstellen. Das Dialogfeld Tabelle erstellen wird angezeigt.

      3. Geben Sie im Feld Tabellenname den Namen der Tabelle ein, die Sie erstellen oder ersetzen möchten.

      4. Klicken Sie auf eine andere Datenbank, und geben Sie dann entweder den Pfad der Datenbank ein, in der Sie die neue Tabelle einfügen möchten, oder klicken Sie auf Durchsuchen , um die Datenbank zu suchen.

      5. Klicken Sie auf OK.

      6. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Ergebnisse auf Ausführen. Dadurch wird die neue Tabelle erstellt.

        Hinweis: Die von Ihnen erstellte neue Tabelle erbt weder die Feldeigenschaften noch die Primärschlüssel-Einstellung aus der ursprünglichen Tabelle.

  9. Erstellen Sie für jede Tabelle in der neuen Datenbank denselben Index und Primärschlüssel, der in der Tabelle des Replikats verwendet wird.

    Wie?

    1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

    2. Klicken Sie im oberen Bereich des Fensters auf das Feld, für das Sie eine Index erstellen möchten.

    3. Klicken Sie im oberen Bereich des Fensters in das Feld indizierte Eigenschaft, und klicken Sie dann auf Ja (Duplikate OK) oder Ja (ohne Duplikate).

    4. Wählen Sie das Feld oder die Felder aus, aus denen sich der Primärschlüssel zusammensetzt.

    5. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Tools auf Primärschlüssel.

  10. Erstellen Sie für jede Tabelle in der neuen Datenbank die Beziehungen, die für die Tabelle des Replikats vorhanden waren.

    Wie?

    Wenn Sie eine Beziehung zwischen Tabellen erstellen, müssen die verknüpften Felder nicht dieselben Namen haben. Verwandte Felder müssen jedoch denselben Datentyp aufweisen, es sei denn, das Primärschlüsselfeld ist ein AutoWert-Feld. Sie können ein AutoWert-Feld nur dann mit einem Zahlfeld vergleichen, wenn die Feldgröße-Eigenschaft der beiden übereinstimmenden Felder identisch ist. So können Sie z. b. ein AutoWert-Feld und ein number-Feld zuordnen, wenn die Feldgröße-Eigenschaft beider Felder eine lange Ganzzahlist. Auch wenn beide übereinstimmenden Felder Zahlenfelder sind, müssen Sie die gleiche Einstellung für die Feldgröße-Eigenschaft aufweisen.

    Definieren einer 1: n-Beziehung oder einer 1:1-Verbindung

    1. Schließen Sie alle geöffneten Tabellen. Es ist nicht möglich, Beziehungen zwischen geöffneten Tabellen zu erstellen oder zu ändern.

    2. Klicken Sie auf der Registerkarte Datenbanktools in der Gruppe Einblenden/Ausblenden auf Beziehungen.

    3. Wenn Sie noch keine Beziehungen in Ihrer Datenbank definiert haben, wird das Dialogfeld Tabelle anzeigen automatisch angezeigt.

      Wenn Sie die Tabellen hinzufügen müssen, die Sie verknüpfen möchten, und das Dialogfeld Tabelle anzeigen nicht angezeigt wird, rufen Sie Sie auf: Klicken Sie auf der Registerkarte Entwurf in der Gruppe einblenden/ausblenden auf die Schaltfläche Tabelle anzeigen .

    4. Doppelklicken Sie auf die Namen der Tabellen, die Sie verknüpfen möchten, und schließen Sie dann das Dialogfeld Tabelle anzeigen . Um eine Beziehung zwischen einer Tabelle und sich selbst zu erstellen, fügen Sie die Tabelle zweimal hinzu.

    5. Ziehen Sie das Feld, das Sie beziehen möchten, aus einer Tabelle in das zugehörige Feld in der anderen Tabelle.

      Wenn Sie mehrere Felder zugleich ziehen möchten, drücken Sie die STRG-TASTE, klicken Sie auf die einzelnen Felder, und ziehen Sie diese dann.

      In den meisten Fällen ziehen Sie das Primärschlüsselfeld (das in fett formatierter Text angezeigt wird) aus einer Tabelle in ein ähnliches Feld (oft mit demselben Namen), das als Fremdschlüssel in der anderen Tabelle bezeichnet wird.

    6. Das Dialogfeld Beziehungen bearbeiten wird angezeigt. Überprüfen Sie die Feldnamen, die in den beiden Spalten angezeigt werden, um sicherzustellen, dass Sie korrekt sind. Sie können diese bei Bedarf ändern.

      Legen Sie bei Bedarf die Beziehungsoptionen fest.

    7. Klicken Sie auf die Schaltfläche Erstellen , um die Beziehung zu erstellen.

    8. Wiederholen Sie die Schritte 4 bis 7 für jedes Paar von Tabellen, die Sie verknüpfen möchten.

      Wenn Sie das Dialogfeld "Beziehungen" schließen, werden Sie von Microsoft Access gefragt, ob Sie das Layout speichern möchten. Unabhängig davon, ob Sie das Layout speichern, werden die von Ihnen erstellten Beziehungen in der Datenbank gespeichert.

    Definieren einer n: n-Beziehung

    1. Erstellen Sie die beiden Tabellen mit einem m:n-Beziehung.

    2. Erstellen Sie eine dritte Tabelle, die als Verknüpfungstabelle bezeichnet wird, und fügen Sie der Verknüpfungstabelle neue Felder mit denselben Definitionen wie die Primärschlüsselfelder aus den beiden anderen Tabellen hinzu. In der Verknüpfungstabelle fungieren die Primärschlüsselfelder als Fremdschlüssel. Sie können der Verknüpfungstabelle weitere Felder hinzufügen, wie dies bei jeder anderen Tabelle möglich ist.

    3. Legen Sie in der Verknüpfungstabelle den Primärschlüssel so fest, dass die Primärschlüsselfelder aus den beiden anderen Tabellen aufgenommen werden. In einer Verzweigungs Tabelle für Auftrags Details würde der Primärschlüssel beispielsweise aus den Feldern "Bestell-Nr" und "ProductID" bestehen.

      Wie?

      1. Öffnen Sie die Tabelle in der Entwurfsansicht.

      2. Wählen Sie die Felder aus, die Sie als Primärschlüssel definieren möchten.

        Zum Auswählen eines Felds klicken Sie auf den Zeilenmarkierer für das gewünschte Feld.

        Wenn Sie mehrere Felder auswählen möchten, halten Sie die STRG-Taste gedrückt, und klicken Sie dann auf den Zeilenmarkierer für jedes Feld.

      3. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Tools auf Primärschlüssel.

        Hinweis: Wenn die Reihenfolge der Felder in einem mehr Feld Primärschlüssel von der Reihenfolge der Felder in der Tabelle abweichen soll, klicken Sie in der Gruppe einblenden/ausblenden auf die Schaltfläche Indizes , um die Fenster "Indizes" anzuzeigen, und ordnen Sie die Feldnamen für die Index mit dem Namen "Primär".

    4. Definieren Sie eine 1:n-Beziehung zwischen den beiden primären Tabellen und der Verknüpfungstabelle.

  11. Speichern Sie die neue Datenbank.

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×