Hinzufügen einer Verbindungs von Daten in einer Microsoft Access-Datenbank

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Falls Ihre Benutzer Daten aus einer Datenbank Microsoft Office Access 2007 (ACCDB) oder aus einer Access-Datenbank in einer früheren Version (MDB-Format) zum Ausfüllen eines Formulars basierend auf Ihrer Microsoft Office InfoPath-Formularvorlage gespeichert werden, können Sie eine sekundäre Datenquelle zum Formular hinzufügen. die Vorlage, die eine Access-Datenbank in Abfragen.

Sie können eine sekundäre Datenquelle hinzufügen, aber diese Datenverbindung kann nur Abfragen einer Access-Datenbank. Sie können keine sekundäre Datenquelle hinzufügen, die Daten aus einer Access-Datenbank Formular übermittelt.

Wenn Sie Ihre Benutzer ihre Formulardaten an einer Access-Datenbank und übermitteln möchten, können Sie Entwerfen einer Formularvorlage, die auf einer Access-Datenbank basiert, und aktivieren Sie die Verbindung zum Absenden von Daten in das Hauptfenster Datenverbindung. Alternativ können Sie eine sekundäre Datenquelle mit einem Webdienst hinzufügen, die mit einer Access-Datenbank funktioniert.

Suchen nach Links zu weiteren Informationen zum Entwerfen von Formularvorlagen, die auf einer Access-Datenbank basieren und Hinzufügen einer sekundären Datenverbindung zu einem Webdienst im Abschnitt Siehe auch.

Inhalt dieses Artikels

(Übersicht)

Kompatibilität Aspekte

Vorbemerkung

Schritt 1: Hinzufügen einer sekundäre Datenquelle

Schritt 2: Konfigurieren der Formularvorlage, um die Datenverbindung verwenden

Übersicht

Eine sekundäre Datenverbindung ist eine Datenverbindung, die Sie einer Formularvorlage hinzu. Eine sekundäre Datenquelle unterscheidet sich von der Hauptseite Datenverbindung, die Sie erstellen, wenn Sie eine neue Formularvorlage entwerfen, die auf einer Datenbank oder einem Webdienst basiert. Hauptfenster Datenverbindung einer Formularvorlage kann Daten aus einer externen Datenquelle erhalten und kann auch Daten aus einer externen Datenquelle Formular senden. Eine Formularvorlage kann jedoch nur eine Verbindung zum Hauptfenster Daten haben.

Sie können beliebig viele sekundäre datenverbindungen mit einer Formularvorlage beliebig hinzufügen. Nehmen Sie beispielsweise an, dass Sie eine Access-Datenbank, die eine Tabelle verfügen, die Mitarbeiterdaten gespeichert, und einer weiteren Tabelle, in der Kundendaten gespeichert enthält. Sie können eine sekundäre Datenquelle, die Daten aus der Tabelle Employee abruft hinzufügen, und Sie können auch eine andere sekundäre Datenquelle, die Daten aus der Kundentabelle "in derselben Access-Datenbank abruft hinzufügen.

Obwohl Sie eine sekundäre Datenquelle zur Formularvorlage hinzufügen können, die Daten aus einer externen Datenquelle, beispielsweise einem Webdienst oder Windows SharePoint Services-Bibliothek Formular senden können nur können sekundären Datenquellen Sie zum Abrufen von Daten aus einer Access Datenbank. Sie können keine sekundäre Datenquelle hinzufügen, die Daten aus einer Access-Datenbank Formular übermittelt.

Wenn Sie eine Verbindung zum Abfragen von Daten in einer Datenbank hinzufügen, erstellt InfoPath eine sekundäre Datenquelle, die enthält Datenfelder und Gruppen, die Art und Weise entsprechen, dass die Daten in der Datenbank gespeichert sind. Da die Datenstruktur in der sekundäre Datenquelle mit der Speicherung der Daten in den Tabellen übereinstimmen muss, können nicht Sie die Felder oder Gruppen in der sekundäre Datenquelle ändern.

Sie können konfigurieren, dass jede Abfrage Datenverbindung, um die Ergebnisse zu speichern, damit Benutzer haben Zugriff auf die Daten aus, wenn ihre Form nicht mit einem Netzwerk verbunden ist. Je nach Art der Daten sollten Sie den Abfrageergebnissen angezeigt werden, nur, wenn Benutzer mit einem Netzwerk verbunden sind.

Sicherheitshinweis: Wenn Sie eine sekundäre Datenquelle verwenden, um vertrauliche Daten aus einer externen Datenquelle abzurufen, möchten Sie möglicherweise helfen, die Daten vor unbefugtem Zugriff schützen, falls der Computer verloren gegangen sind oder gestohlen wird diese Funktion deaktivieren. Wenn Sie dieses Feature deaktivieren, werden die Daten nur verfügbar, wenn der Benutzer mit dem Netzwerk verbunden ist.

Wenn Sie eine Verbindung zum Abfragen von Daten in einer Formularvorlage hinzufügen, verwendet standardmäßig die Formularen, die auf dieser Formularvorlage basieren die Datenverbindung, wenn sie von einem Benutzer geöffnet werden. Sie können auch die Formularvorlage so verwenden Sie die Verbindung zum Abfragen von Daten in einem der folgenden Methoden konfigurieren:

  • Hinzufügen einer Regel    Sie können eine Regel, um die Verbindung zum Abfragen von Daten verwenden, wenn die Bedingung in der Regel eintritt konfigurieren.

  • Hinzufügen einer Schaltfläche    Sie können die Formularvorlage eine Schaltfläche hinzufügen, die Benutzer klicken können, um Daten zu erhalten, indem Sie die Verbindung zum Abfragen von Daten.

  • Verwenden Sie benutzerdefiniertem code    Wenn Sie eine Regel oder eine Schaltfläche hinzufügen können, können Sie benutzerdefinierten Code zum Abrufen von Daten mithilfe der Verbindungs zum Abfragen von Daten verwenden. Mithilfe von benutzerdefiniertem Code erfordert einen Entwickler zum Erstellen von benutzerdefinierten Codes.

Seitenanfang

Überlegungen zur Kompatibilität

Sie können keine Verbindung von Daten in einer Access-Datenbank zu einer Browserkompatible Formularvorlage hinzufügen.

Seitenanfang

Vorbemerkung

Bevor Sie eine Access-Datenbank eine sekundäre Datenquelle zur Formularvorlage hinzufügen, benötigen Sie die folgenden Informationen:

  • Der Name und Speicherort der Datenbank.

    Hinweis: Wenn Sie einem Speicherort im Netzwerk Ihrer Access-Datenbank gespeichert ist, stellen Sie sicher, dass Ihre Datenbank für Ihre Benutzer zugegriffen werden kann.

  • Der Name der Tabelle oder Abfrage, die Daten zu Formularen bereitstellt, die auf dieser Formularvorlage basieren. Verwenden Sie diese Tabelle oder Abfrage als die primäre Tabelle oder Abfrage aus, wenn Sie die Verbindung zum Abfragen von Daten konfigurieren.

  • Die Namen der anderen Tabellen oder Abfragen, die weitere Daten zur die primäre Tabelle oder Abfrage angeben. In den meisten Fällen sind die tabellenbeziehungen in der Datenbank bereits eingerichtet. Wenn Sie die Beziehungen zwischen der primären Tabelle oder Abfrage und einer anderen Tabelle oder Abfrage manuell herstellen müssen, benötigen Sie die zugehörigen Feldnamen der beiden Tabellen oder Abfragen.

Seitenanfang

Schritt 1: Hinzufügen einer sekundäre Datenquelle

  1. Klicken Sie im Menü Extras auf Datenverbindungen.

  2. Klicken Sie im Dialogfeld Datenverbindungen auf Hinzufügen.

  3. Klicken Sie in den Datenverbindungs-Assistenten auf eine neue Verbindung zu erstellen, klicken Sie auf Daten empfangen, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten klicken Sie auf Datenbank (Microsoft SQL Server oder Microsoft Office Access), und klicken Sie dann auf Weiter.

  5. Klicken Sie auf der nächsten Seite des Assistenten auf Datenbank auswählen.

  6. Navigieren Sie im Dialogfeld Datenquelle auswählen auf den Speicherort der Datenbank.

    Hinweis: Wenn die Datenbank in einem Speicherort im Netzwerk gespeichert ist, navigieren Sie zu der universal naming Convention (UNC)) Pfad des Speicherorts. Nicht zum Netzwerkspeicherort über eine zugeordnete Netzlaufwerk navigieren. Wenn Sie ein zugeordneten Netzlaufwerk verwenden, werden Benutzer, die Erstellen von Formularen, die auf dieser Formularvorlage basieren für die Datenbank aus einem zugeordneten Netzlaufwerk suchen. Wenn der Benutzer nicht mit ein zugeordneten Netzlaufwerk verfügt, wird das Formular die Datenbank nicht finden.

  7. Klicken Sie auf den Namen der Datenbank, und klicken Sie dann auf Öffnen.

  8. Klicken Sie im Dialogfeld Tabelle auswählen klicken Sie auf die primäre Tabelle oder Abfrage, die Sie verwenden möchten, und klicken Sie dann auf OK.

  9. Wählen Sie auf der nächsten Seite des Assistenten das Kontrollkästchen Tabellenspalten anzeigen aus.

    Standardmäßig werden alle Felder in der Tabelle oder Abfrage in der primären Datenquelle der Formularvorlage hinzugefügt.

  10. Deaktivieren Sie die Kontrollkästchen für die Felder, die Sie nicht in der sekundäre Datenquelle einschließen möchten.

    Fügen Sie weitere Tabellen oder Abfragen hinzu die Datenverbindung ein.

    So wird's gemacht

    1. Klicken Sie auf Tabelle hinzufügen.

    2. Klicken Sie im Dialogfeld Tabelle oder Abfrage hinzufügen klicken Sie auf den Namen der untergeordneten Tabelle, und klicken Sie dann auf Weiter. InfoPath versucht, die Beziehungen festlegen, indem Sie Feldnamen in beiden Tabellen. Wenn Sie nicht die vorgeschlagenen Beziehung verwenden möchten, wählen Sie die Beziehung aus, und klicken Sie dann auf Beziehung entfernen. Wenn Sie eine Beziehung hinzufügen möchten, klicken Sie auf Beziehung hinzufügen. Klicken Sie im Dialogfeld Beziehung hinzufügen klicken Sie auf den Namen der einzelnen verknüpften Felder in der jeweiligen Spalte, und klicken Sie dann auf OK.

    3. Klicken Sie auf Fertig stellen.

    4. Um weitere untergeordnete Tabellen hinzuzufügen, wiederholen Sie diese Schritte aus.

  11. Klicken Sie auf Weiter.

  12. Wenn die Ergebnisse der Abfrage Datenverbindung verfügbar, wenn das Formular nicht mit einem Netzwerk verbunden ist, wählen Sie das Kontrollkästchen Kopie der Daten in der Formularvorlage speichern aus.

    Sicherheitshinweis: Das Aktivieren des Kontrollkästchens speichert die Daten auf dem Computer des Benutzers, wenn das Formular diese Datenverbindung verwendet. Wenn das Formular vertrauliche Daten aus dieser Verbindung abgerufen werden, sollten Sie so deaktivieren Sie dieses Feature zum Schutz die Daten, falls der Computer verloren gegangen sind oder gestohlen wird.

  13. Klicken Sie auf Weiter.

  14. Klicken Sie auf der nächsten Seite des Assistenten geben Sie einen beschreibenden Namen für diese sekundäre Datenquelle, und vergewissern Sie sich, dass die Informationen im Abschnitt Zusammenfassung korrekt sind.

  15. Zum Konfigurieren des Formulars, um Daten automatisch zu erhalten, wenn das Formular geöffnet wird, wählen Sie das Kontrollkästchen Daten beim Öffnen des Formulars automatisch abrufen.

Seitenanfang

Schritt 2: Konfigurieren der Formularvorlage, um die Datenverbindung verwenden

Wenn Sie die Formulare möchten, die auf diese Datenverbindung verwenden, nachdem der Benutzer das Formular öffnet dieser Formularvorlage basieren, können Sie die Formularvorlage, die diese Datenverbindung unter einer bestimmten Bedingung verwendet eine Regel hinzufügen oder können Sie eine Schaltfläche zur Formularvorlage hinzufügen, Verwenden Sie diese Datenverbindung können die Benutzer klicken.

Eine Regel hinzufügen

Sie können eine Regel zur Formularvorlage hinzufügen, die dient zum Abrufen von Daten aus der Verbindung zum Abfragen von Daten, wenn die Bedingung für die Regel erfüllt ist. Beispielsweise können Sie ein Textfeld zur Formularvorlage hinzufügen, die ein Benutzer ausfüllen können, um bestimmte Daten aus einer externen Datenquelle zu erhalten. Sie können eine Regel, die die Datenverbindung verwendet, wenn ein Benutzer Daten in das Textfeld eingibt, klicken Sie dann hinzufügen.

Im folgende Verfahren wird davon ausgegangen, dass Sie eine Verbindung zum Abfragen von Daten für die Formularvorlage erstellt haben und Sie ein anderes Steuerelement (als eine Schaltfläche) konfiguriert haben in der Formularvorlage, um die Daten aus dieser Datenverbindung anzuzeigen.

  1. Wenn die Formularvorlage mehrere Ansichten aufweist, klicken Sie auf Ansichtsname im Menü Ansicht zum Wechseln Sie zur Ansicht mit dem Steuerelement, wo Sie die Daten aus der sekundäre Datenquelle anzeigen möchten.

  2. Doppelklicken Sie auf das Steuerelement, dem Sie eine Regel hinzufügen möchten.

  3. Klicken Sie auf die Registerkarte Daten.

  4. Klicken Sie unter Überprüfung und Regeln klicken Sie auf Regeln.

  5. Klicken Sie im Dialogfeld Regeln auf Hinzufügen.

  6. Geben Sie im Feld Name einen Namen für die Regel ein.

  7. Wenn Sie eine Bedingung angeben, wenn die Regel ausgeführt werden soll, klicken Sie auf Bedingung festlegen, und geben Sie dann die Bedingung. Die Regel wird ausgeführt, wenn die Bedingung eintritt. Wenn Sie keine Bedingung festlegen, wird die Regel ausgeführt, wenn vom Benutzer den Wert in das Steuerelement ändert, und klicken Sie dann den Cursor nicht an diesem Steuerelement verschiebt.

  8. Klicken Sie auf die Aktion hinzufügen.

  9. Klicken Sie in der Liste Aktion auf Abfrage eine Verbindung mit Daten verwenden.

  10. Klicken Sie in der Liste Datenverbindung klicken Sie auf die Verbindung zum Abfragen von Daten, die Sie verwenden möchten, und klicken Sie dann auf OK, um die einzelnen geöffneten Dialogfelder zu schließen.

  11. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

Hinzufügen einer Schaltfläche

Sie können ein Schaltflächensteuerelement zur Formularvorlage hinzufügen, die die Benutzer klicken können, um Daten aus der Verbindung zum Abfragen von Daten abrufen.

  1. Wenn die Formularvorlage mehrere Ansichten aufweist, klicken Sie auf Ansichtsname im Menü Ansicht zum Wechseln Sie zur Ansicht mit dem Steuerelement, wo Sie die Daten aus der sekundäre Datenquelle anzeigen möchten.

  2. Wenn der Aufgabenbereich Steuerelemente nicht angezeigt wird, klicken Sie im Menü Einfügen auf Weitere Steuerelemente, oder drücken Sie ALT+I, C.

  3. Ziehen Sie eine Schaltfläche auf der Formularvorlage.

  4. Doppelklicken Sie auf das Steuerelement, das Sie gerade hinzugefügt haben, klicken Sie in der Formularvorlage.

  5. Klicken Sie auf die Registerkarte Allgemein.

  6. Klicken Sie in der Liste Aktion auf Aktualisieren.

  7. Geben Sie im Feld Beschriftung den Namen, den in der Formularvorlage auf die Schaltfläche angezeigt werden soll.

  8. Klicken Sie auf Einstellungen.

  9. Führen Sie im Dialogfeld Aktualisieren eine der folgenden Aktionen aus:

    • Um die neusten Daten alle Daten aus externen Datenquellen mit der externen Datenquelle für diese Formularvorlage zu erhalten, klicken Sie auf Alle sekundären Datenquellen.

    • Um die Schaltfläche, um die neusten Daten aus einer externen Datenquelle für eine sekundäre Datenquelle zur Formularvorlage empfangen zu konfigurieren, klicken Sie auf eine sekundäre Datenquelle, und klicken Sie dann auf eine sekundäre Datenquelle in der auswählen die sekundäre Datenquelle Liste.

  10. Klicken Sie auf OK, um jedes geöffnete Dialogfeld zu schließen.

  11. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

Seitenanfang

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×