Hinzufügen einer Verbindungs von Daten in einem Webdienst

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Sie können eine oder mehrere sekundäre datenverbindungen zur Formularvorlage hinzufügen, die Abfrage oder Daten an einen Webdienst senden können.

Inhalt dieses Artikels

(Übersicht)

Kompatibilität Aspekte

Vorbemerkung

Hinzufügen einer Verbindungs zum Abfragen von Daten

Hinzufügen einer Verbindungs zum Absenden von Daten

Übersicht

Eine sekundäre Datenquelle ist eine beliebige Datenverbindung mit einer externen Datenquelle, die Sie einer Formularvorlage hinzufügen. Diese Datenverbindung unterscheidet sich von der Hauptseite Datenverbindung, die beim Entwerfen einer Formularvorlage basierend auf einer Datenbank, Webdienst oder Einstellungen in einer Verbindungsbibliothek erstellt wird. Nur, wenn Sie keine Abfragen oder Daten über die wichtigsten Datenverbindung senden, fügen Sie eine sekundäre Datenquelle.

Wenn Sie eine sekundäre Datenquelle zur Formularvorlage, die Daten für Abfragen, Microsoft Office InfoPath erstellt eine sekundäre Datenquelle mit Datenfelder und Gruppen, die die XML-Schema des Webdiensts entspricht, hinzufügen. Da die Datenstruktur in der sekundären Datenquelle das XML-Schema übereinstimmen muss, können nicht Sie vorhandene Felder oder Gruppen in der sekundäre Datenquelle ändern. Wenn Sie eine Verbindung zum Absenden von Daten zur Formularvorlage hinzufügen, Sie Konfigurieren der Formularvorlage, damit Benutzer ihre Formulardaten absenden können, und Sie konfigurieren die Absendeoptionen für die Formulare, die auf Ihrer Formularvorlage basieren.

Seitenanfang

Überlegungen zur Kompatibilität

Sie können keine Verbindung zum Absenden von Daten in einer Browserkompatible Formularvorlage auf zulassen, dass Benutzer übermitteln zusammen mit den Formulardaten an einen Webdienst zu ändern, der ein Microsoft ADO.NET DataSet akzeptiert konfigurieren. Von Änderungsinformationen besteht aus Änderungen, die ein Benutzer auf die Daten in einer Datenbank gespeichert ist. Die Datenbank verwendet einen Webdienst, um Benutzer mit der Datenbank herstellen. ADO.NET können Benutzerinformationen geändert, um zu bestimmen, wie die Daten in der Datenbank zu aktualisieren. Bitten Sie Ihren Web Service-Administrator, wenn der Webdienst Änderungsinformationen zum Aktualisieren einer Datenbank erforderlich sind. Wenn dies der Fall ist, sollten Sie eine Formularvorlage entwerfen, deren Formulare ausgefüllt werden können nur mithilfe von InfoPath.

Seitenanfang

Vorbemerkung

Bevor Sie eine sekundäre Datenquelle zur Formularvorlage hinzufügen, benötigen Sie die folgende Informationen aus dem Webdienstadministrator:

  • Die Position des Webdiensts.

  • Überprüfung, dass der Webdienst Dokument/Literal-Codierung verwendet. InfoPath kann nur Dokument/Literal-Webdiensten nutzen.

  • Der Name der Vorgang im Webdienst, der Daten zu senden oder Empfangen von Daten aus Formularen, die auf dieser Formularvorlage basieren.

Seitenanfang

Hinzufügen einer Verbindungs zum Abfragen von Daten

Damit Benutzer zum Abfragen von Daten von einem Webdienst können mithilfe der Formularvorlage, müssen Sie in der Formularvorlage Folgendes ausführen:

  1. Fügen Sie eine sekundäre Datenquelle hinzu.

  2. Konfigurieren der Formularvorlage, um die sekundäre Datenquelle verwenden.

Schritt 1: Hinzufügen einer sekundäre Datenquelle

  1. Klicken Sie im Menü Extras auf Datenverbindungen.

  2. Klicken Sie im Dialogfeld Datenverbindungen auf Hinzufügen.

  3. Klicken Sie in den Datenverbindungs-Assistenten auf eine neue Verbindung zu erstellen, klicken Sie auf Daten empfangen, und klicken Sie dann auf Weiter.

  4. Klicken Sie unter woher möchten Sie Ihre Daten zu erhalten klicken Sie auf Webdienst aus, und klicken Sie dann auf Weiter.

  5. Klicken Sie auf der nächsten Seite des Assistenten geben Sie den Speicherort des Webdiensts ein, und klicken Sie dann auf Weiter.

    Hinweis: Wenn Sie einem Webdienst mithilfe eines Servers Universal Description Discovery and Integration (UDDI) suchen möchten, klicken Sie auf UDDI durchsuchen, geben Sie die URL des UDDI-Servers ein, die Sie suchen möchten, geben an, ob Sie nach Anbieter oder nach einem Dienst, der suchen möchten zur Verfügung gestellt wird, geben Sie ein Suchschlüsselwort, und klicken Sie dann auf Suchen. Webdienste, die das Stichwort entsprechen, werden in der Liste Suchergebnis angezeigt. Wählen Sie den Webdienst, den Sie verwenden möchten, und klicken Sie dann auf OK.

  6. Klicken Sie in der Liste Wählen Sie einen Vorgang auf der nächsten Seite des Assistenten klicken Sie auf den Vorgang im Webdienst, der Daten in das Formular zurückgibt, und klicken Sie dann auf Weiter.

  7. Wenn Datenverbindungs-Assistenten ein unbekanntes Element im Schema des Webdiensts vorgefunden wird, kann die nächste Seite des Assistenten in Beispielwerte für jeden Parameter bestimmen, welche Felder oder Gruppen zum Hinzufügen zur der primären Datenquelle angeben aufgefordert werden.

    So wird's gemacht

    1. Wählen Sie einen Parameter in der Tabelle Parameter aus, und klicken Sie dann auf Stichprobe Wert festlegen.

    2. Geben Sie im Sample-Wert einen Wert Ihrer Benutzer für dieses Feld verwenden, und klicken Sie dann auf OK.

    3. Wiederholen Sie diese Schritte für jeden Parameter in der Tabelle Parameter aus, und klicken Sie dann auf Weiter.

    Technische details

    Wenn Sie eine Datenverbindung zu einem Webdienst im Datenverbindungs-Assistenten konfigurieren, wird von Microsoft Office InfoPath eine Verbindung mit der Web-Dienst und fordert die Datei Web Service Description Language (WSDL). WSDL-Datei enthält das Schema vom Webdienst verwendet. Webdienst reagiert auf die Anfrage und senden diese Datei in InfoPath. InfoPath verwendet die Informationen in dieser Datei, um die entsprechenden Felder und Gruppen in der Formularvorlage der sekundäre Datenquelle hinzufügen. Findet InfoPath einen unbekannten Elementtyp in der WSDL-Datei, InfoPath Beispieldaten verwendet, um die Definition des Typs unbekanntes Element zu bestimmen, und addiert dann an die sekundäre Datenquelle die entsprechenden Felder und Gruppen.

  8. Wenn Sie möchten die Ergebnisse der Abfrage zur Verfügung, wenn das Formular nicht mit einem Netzwerk verbunden ist, aktivieren Sie das Kontrollkästchen Kopie der Daten in der Formularvorlage speichern.

    Sicherheitshinweis: Dadurch werden die Abfrageergebnisse in der Formularvorlage gespeichert. Da die Daten in der Formularvorlage gespeichert ist, ist es in den Formularen, die Benutzer ausfüllen verfügbar, auch wenn ihre Computer nicht mit einem Netzwerk verbunden sind. Wenn dieser Verbindung sensible Daten wiedergegeben werden, können Sie dieses Feature zum Schutz die Daten, falls der Computer verloren gegangen sind oder gestohlen wird deaktivieren möchten.

  9. Klicken Sie auf Weiter.

  10. Geben Sie auf der nächsten Seite des Assistenten einen beschreibenden Namen für die Verbindung zum Abfragen von Daten aus.

  11. Aktivieren Sie das Kontrollkästchen Daten beim Öffnen des Formulars automatisch abrufen, um Formulare zu aktivieren, die auf dieser Formularvorlage Daten automatisch zu erhalten, wenn sie geöffnet werden basieren.

  12. Stellen Sie sicher, dass die Informationen im Abschnitt Zusammenfassung korrekt ist, und klicken Sie dann auf Fertig stellen.

  13. Klicken Sie auf Schließen.

Schritt 2: Konfigurieren der Formularvorlage, um die sekundäre Datenquelle verwenden

Wenn Sie eine Verbindung zum Abfragen von Daten in einer Formularvorlage hinzufügen, verwendet standardmäßig die Formularen, die auf dieser Formularvorlage basieren die Datenverbindung, wenn sie von einem Benutzer geöffnet werden. Sie können auch die Formularvorlage so verwenden Sie die Verbindung zum Abfragen von Daten in einem der folgenden Methoden konfigurieren:

  • Hinzufügen einer Regel    Sie können eine Regel, um die Verbindung zum Abfragen von Daten verwenden, wenn die Bedingung in der Regel eintritt konfigurieren.

  • Hinzufügen einer Schaltfläche    Sie können die Formularvorlage eine Schaltfläche hinzufügen, die Benutzer klicken können, um Daten zu erhalten, indem Sie die Verbindung zum Abfragen von Daten.

  • Verwenden Sie benutzerdefiniertem code    Wenn Sie eine Regel oder eine Schaltfläche hinzufügen können, können Sie benutzerdefinierten Code zum Abrufen von Daten mithilfe der Verbindungs zum Abfragen von Daten verwenden. Mithilfe von benutzerdefiniertem Code erfordert einen Entwickler zum Erstellen von benutzerdefinierten Codes.

Eine Regel hinzufügen

Sie können eine Regel hinzufügen, um zur Formularvorlage zum Abrufen von Daten aus der Verbindung zum Abfragen von Daten, wenn die Bedingung für die Regel erfüllt ist. Das folgende Verfahren setzt voraus, dass Sie eine Verbindung zum Abfragen von Daten für die Formularvorlage erstellt haben und Sie ein Steuerelement in der Formularvorlage zum Anzeigen der Daten aus dieser Datenverbindung konfiguriert haben.

  1. Wenn die Formularvorlage mehrere Ansichten aufweist, klicken Sie auf Ansichtsname im Menü Ansicht zum Wechseln Sie zur Ansicht mit dem Steuerelement, wo Sie die Daten aus der sekundäre Datenquelle anzeigen möchten.

  2. Doppelklicken Sie auf das Steuerelement, dem Sie eine Regel hinzufügen möchten.

  3. Klicken Sie auf die Registerkarte Daten.

  4. Klicken Sie unter Überprüfung und Regeln klicken Sie auf Regeln.

  5. Klicken Sie im Dialogfeld Regeln auf Hinzufügen.

  6. Geben Sie im Feld Name einen Namen für die Regel ein.

  7. Wenn Sie eine Bedingung angeben, wenn die Regel ausgeführt werden soll, klicken Sie auf Bedingung festlegen, und geben Sie dann die Bedingung. Die Regel wird ausgeführt, wenn die Bedingung eintritt. Wenn Sie keine Bedingung festlegen, wird die Regel ausgeführt, wenn vom Benutzer den Wert in das Steuerelement ändert, und klicken Sie dann den Cursor nicht an diesem Steuerelement verschiebt.

  8. Klicken Sie auf die Aktion hinzufügen.

  9. Klicken Sie in der Liste Aktion auf Abfrage eine Verbindung mit Daten verwenden.

  10. Klicken Sie in der Liste Datenverbindung klicken Sie auf die Verbindung zum Abfragen von Daten, die Sie verwenden möchten, und klicken Sie dann auf OK, um die einzelnen geöffneten Dialogfelder zu schließen.

  11. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

Hinzufügen einer Schaltfläche

Sie können ein Schaltflächensteuerelement zur Formularvorlage hinzufügen, die die Benutzer klicken können, um Daten aus der Verbindung zum Abfragen von Daten abrufen. Im folgende Verfahren wird davon ausgegangen, dass Sie eine Verbindung zum Abfragen von Daten für die Formularvorlage erstellt haben.

  1. Wenn die Formularvorlage mehrere Ansichten aufweist, klicken Sie auf Ansichtsname im Menü Ansicht zum Wechseln Sie zur Ansicht mit dem Steuerelement, wo Sie die Daten aus der sekundäre Datenquelle anzeigen möchten.

  2. Wenn der Aufgabenbereich Steuerelemente nicht angezeigt wird, klicken Sie im Menü Einfügen auf Weitere Steuerelemente, oder drücken Sie ALT+I, C.

  3. Ziehen Sie eine Schaltfläche auf der Formularvorlage.

  4. Doppelklicken Sie auf die Schaltfläche, die Sie soeben Ihrer Formularvorlage hinzugefügt haben.

  5. Klicken Sie auf die Registerkarte Allgemein.

  6. Klicken Sie in der Liste Aktion auf Aktualisieren.

  7. Geben Sie im Feld Beschriftung den Namen, den in der Formularvorlage auf die Schaltfläche angezeigt werden soll.

  8. Klicken Sie auf Einstellungen.

  9. Klicken Sie im Dialogfeld " Aktualisieren " auf eine sekundäre Datenquelle.

  10. Klicken Sie in der Liste Wählen Sie die sekundäre Datenquelle klicken Sie auf die sekundäre Datenquelle, die die Verbindung zum Abfragen von Daten zugeordnet ist, und klicken Sie dann auf OK, um die einzelnen geöffneten Dialogfelder zu schließen.

  11. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

Seitenanfang

Hinzufügen einer Verbindungs zum Absenden von Daten

Damit die Benutzer zum Senden von Formularen, die in der Formularvorlage mit einem Webdienst basieren, zuerst fügen Sie eine sekundäre Datenquelle zur Formularvorlage, die Daten übermittelt, und klicken Sie dann konfigurieren Sie die Formularvorlage, damit Ihre Benutzer ihre Formulardaten absenden können.

Schritt 1: Hinzufügen einer sekundäre Datenquelle

  1. Klicken Sie im Menü Extras auf Datenverbindungen.

  2. Klicken Sie im Dialogfeld Datenverbindungen auf Hinzufügen.

  3. Klicken Sie in den Datenverbindungs-Assistenten auf eine neue Verbindung zu erstellen, klicken Sie auf Daten senden, und klicken Sie dann auf Weiter.

  4. Klicken Sie unter Wie möchten Sie Ihre Daten zu senden klicken Sie auf an einen Webdienst aus, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der nächsten Seite des Assistenten die Position des Webdiensts, wo die Benutzer ihre Daten absenden, und klicken Sie dann auf Weiter.

    Hinweis: Wenn Sie einem Webdienst mithilfe eines Servers Universal Description Discovery and Integration (UDDI) suchen möchten, klicken Sie auf UDDI durchsuchen, geben Sie die URL des UDDI-Servers ein, die Sie suchen möchten, geben an, ob Sie nach Anbieter oder nach einem Dienst, der suchen möchten zur Verfügung gestellt wird, geben Sie ein Suchschlüsselwort, und klicken Sie dann auf Suchen. Webdienste, die das Stichwort entsprechen, werden in der Liste Suchergebnis angezeigt. Wählen Sie den Webdienst, den Sie verwenden möchten, und klicken Sie dann auf OK.

  6. Klicken Sie in der Liste Wählen Sie einen Vorgang aus auf den Vorgang im Webdienst, der die Formulardaten empfangen, und klicken Sie dann auf Weiter.

  7. Führen Sie auf der nächsten Seite des Assistenten um auswählen, welche Daten im Formular für jeden Parameter im Webdienst abgesendet, eine der folgenden Aktionen aus:

    Übermitteln Sie die Daten in einem Feld oder Gruppe

    1. Klicken Sie in der Liste Parameter auf, der die Daten aus dem Formular empfängt Parameter für den Webdienst.

    2. Klicken Sie unter Optionen für Parameter auf Feld oder Gruppe.

    3. Klicken Sie auf Ändern Schaltfläche (Symbol) .

    4. Klicken Sie im Dialogfeld Feld oder Gruppe auswählen klicken Sie auf das Feld oder die Gruppe, deren Daten, die Sie senden möchten, und klicken Sie dann auf OK.

    5. Klicken Sie im Feld einschließen auf nur Text und untergeordnete Elemente aus, um nur die Daten in diesem Feld und die untergeordneten Elemente des Felds oder der Gruppe übermitteln, oder klicken Sie auf untergeordneter XML-Baum, einschließlich ausgewähltem Element, um den Feldnamen, die Daten im Feld übermitteln und die untergeordneten Elemente in der ausgewählten Gruppe oder ein Feld.

    Senden Sie alle Daten im Formular

    1. Klicken Sie in der Liste Parameter auf, der die Daten aus dem Formular empfängt Parameter für den Webdienst.

    2. Klicken Sie auf Gesamtes Formular (XML-Dokument, einschließlich verarbeitungsanweisung), klicken Sie unter Optionen für Parameter.

    Senden Sie die Daten als Zeichenfolge

    1. Klicken Sie in der Liste Parameter auf, der die Daten aus dem Formular empfängt Parameter für den Webdienst.

    2. Klicken Sie auf Gesamtes Formular (XML-Dokument, einschließlich verarbeitungsanweisung), klicken Sie unter Optionen für Parameter.

    3. Aktivieren Sie das Kontrollkästchen Daten als Zeichenfolge senden.

      Hinweis: Wählen Sie in der Regel das Kontrollkästchen Digital signierte Daten übermitteln aus. In den meisten Fällen können deaktivieren Sie dieses Kontrollkästchen.

    Technische Notiz zu ADO.NET DataSet-Objekte

    Wenn der Webdienst ein ADO.NET DataSet-Objekt erforderlich sind, wählen Sie einen Dataset-Knoten, wenn Sie diese Datenverbindung konfigurieren. Wenn Sie eine andere Art von Knoten für eine Datenverbindung mit einem Webdienst, die Objekt ADO.NET DataSet erfordert verwenden, tritt die Aktion abzusenden.

  8. Klicken Sie auf Weiter.

  9. Geben Sie auf der nächsten Seite des Assistenten einen Namen für die Verbindung zum Absenden von Daten aus.

  10. Stellen Sie sicher, dass die Informationen im Abschnitt Zusammenfassung korrekt ist, und klicken Sie dann auf Fertig stellen.

  11. Klicken Sie auf Schließen.

Nach dem Hinzufügen des sekundären Datenverbindung zum Absenden von, müssen Sie die Formularvorlage so, dass Benutzer übermitteln Absenden ihrer Formulardaten mithilfe dieser Datenverbindung konfigurieren.

Schritt 2: In der Formularvorlage Absenden aktivieren

Wenn Sie die Formularvorlage, damit Benutzer ihre Formulardaten absenden können konfigurieren, addiert InfoPath eine Senden-Schaltfläche auf der Standardsymbolleiste und der Befehl Absenden im Menü Datei auf dem Formular an. Sie können auch die Absendeoptionen für Ihre Formularvorlage auf folgende Weise anpassen:

  • Ändern Sie den Text, der auf die Schaltfläche Senden und den Befehl Absenden angezeigt wird.

  • Ändern Sie die Tastenkombination für die Senden-Schaltfläche und den Befehl Absenden.

  • Erstellen Sie benutzerdefinierte Nachrichten an die Benutzer angezeigt werden, wenn sie ihre Formulare absenden.

  • Geben Sie an, ob das Formular geöffnet lassen, schließen Sie das Formular, oder öffnen Sie ein neues leeres Formular aus, nachdem Sie das Formular gesendet wird.

  • Klicken Sie im Menü Extras auf Optionen zum Absenden.

  • Klicken Sie im Dialogfeld Optionen zum Absenden aktivieren Sie das Kontrollkästchen Benutzern erlauben, senden Sie dieses Formular, klicken Sie auf Senden von Formulardaten an ein einziges Ziel, und klicken Sie dann in der Liste auf Webdienst.

  • Klicken Sie in der Liste Wählen Sie eine Verbindung für das Senden von Daten auf den Namen der Verbindung zum Absenden von Daten an den Webdienst, die Sie in den vorherigen Schritten erstellt haben.

    1. Wenn der Name der Senden-Schaltfläche, die angezeigt, klicken Sie auf der Standardsymbolleiste und den Befehl Absenden, der Sie im Menü Datei angezeigt wird wird, wenn Benutzer des Formulars ausfüllen ändern möchten, geben Sie den neuen Namen im Feld Beschriftung die übermitteln Optionen im Dialogfeld.

      Tipp: Wenn Sie diese Schaltfläche und den Befehl eine Tastenkombination zuweisen möchten, geben Sie ein kaufmännisches und-Zeichen (&) vor dem Zeichen, die Sie als Tastenkombination verwenden möchten. Geben Sie beispielsweise ALT + B als die Tastenkombination für die Senden-Schaltfläche und der Befehl zuzuweisen, & bsenden.

  • Wenn Sie keine anderen Befehl Absenden oder die Senden-Schaltfläche auf der Standardsymbolleiste verwendet, beim Ausfüllen eines Formulars, deaktivieren Sie das Kontrollkästchen anzeigen das Menüelement übermitteln und die Symbolleisten-Schaltfläche Absenden.

    1. Standardmäßig nach dem Senden eines Formulars, InfoPath behält das Formular zu öffnen, und wird eine Meldung angezeigt, um anzugeben, ob das Formular erfolgreich gesendet wurde. Wenn Sie dieses Standardverhalten ändern möchten, klicken Sie auf Erweitert, und führen Sie dann eine der folgenden Aktionen aus:

      • Wenn Sie das Formular schließen, oder erstellen ein neues leeres Formular aus, nach der Benutzer ein ausgefülltes Formular übermittelt, klicken Sie auf die Option, die Sie in der Liste nach dem Senden möchten.

      • Zum Erstellen einer benutzerdefinierten Nachricht, um anzugeben, ob das Formular erfolgreich gesendet wurde, aktivieren Sie das Kontrollkästchen benutzerdefinierte Meldung verwenden, und geben Sie dann Ihre Nachrichten in den Feldern bei Erfolg und bei einem Fehler.

        Tipp: Verwenden Sie eine Nachricht im Feld auf Fehler zu Benutzern mitteilen, was zu tun ist, wenn sie ihr Formular übermitteln können. Beispielsweise können Sie vorschlagen, dass Benutzer Formular zu speichern und Weitere Informationen zum Kontaktieren einer Person.

      • Wenn Sie keine zum Anzeigen einer Meldung, nachdem der Benutzer ein Formular übermittelt, deaktivieren Sie das Kontrollkästchen Erfolg und Fehler Nachrichten anzeigen.

Seitenanfang

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×