Zu Hauptinhalt springen
PivotTables

Filtern von Daten in einer PivotTable

Filtern von Daten in einer PivotTable

Filtern Sie Ihre Daten so, dass Sie sich auf einen kleineren Teil Ihrer PivotTable-Daten konzentrieren, um eine eingehende Analyse zu erhalten. Fügen Sie zunächst einen oder mehrere datenschnitte ein, damit Sie Ihre Daten schnell und effektiv filtern können. Datenschnitte verfügen über Schaltflächen, auf die Sie klicken können, um die Daten zu filtern und mit Ihren Daten sichtbar zu bleiben, damit Sie immer wissen, welche Felder in der gefilterten PivotTable angezeigt oder ausgeblendet werden.

Tipp: In Excel 2016 können Sie nun mehrere Datenschnitte auswählen, indem Sie wie oben gezeigt auf die Schaltfläche in der Beschriftung klicken.

Datenschnittoptionen mit hervorgehobener Schaltfläche für Mehrfachauswahl
Ihr Browser unterstützt kein Video. Installieren Sie Microsoft Silverlight, Adobe Flash Player oder Internet Explorer 9.

Filtern von Daten in einer PivotTable

  1. Wählen Sie eine Zelle in der PivotTable aus. Wählen Sie Analysieren > Datenschnitt einfügen Datenschnitt aus.

  2. Wählen Sie die Felder aus, für die Sie Datenschnitte erstellen möchten. Wählen Sie dann OKaus.

  3. Wählen Sie die Elemente aus, die in der PivotTable angezeigt werden sollen.

Manuelles Filtern von Daten

  1. Wählen Sie den Pfeil in der Spaltenüberschrift Filter-Dropdownpfeil für die Spalte aus, die Sie filtern möchten.

  2. Deaktivieren Sie (Alles auswählen), und aktivieren Sie die Kontrollkästchen, die angezeigt werden sollen. Wählen Sie dann OK aus.

  1. Klicken Sie an eine beliebige Stelle in der PivotTable, damit im Menüband die PivotTable-Registerkarten (PivotTable-Analyse und Entwurf angezeigt werden.

  2. Klicken Sie auf PivotTable-Analyse > Datenschnitt einfügen.

  3. Aktivieren Sie im Dialogfeld Datenschnitt auswählen die Kontrollkästchen der Felder, für die Datenschnitte erstellt werden sollen.

  4. Klicken Sie auf OK.

    Es wird für jedes Feld, das Sie im Dialogfeld Datenschnitt auswählen aktiviert haben, ein Datenschnitt angezeigt.

  5. Klicken Sie in jedem Datenschnitt auf die Elemente, die in der PivotTable angezeigt werden sollen.

Tipp: Wenn Sie das Aussehen des Datenschnitts ändern möchten, klicken Sie darauf, damit im Menüband die Registerkarte Datenschnitt angezeigt wird. Sie können ein Datenschnittformat anwenden oder Einstellungen über die verschiedenen Registerkartenoptionen ändern.

Weitere Möglichkeiten zum Filtern von PivotTable

Die folgenden Features zum Filtern können anstelle von oder zusätzlich zu Datenschnitten verwenden, um genau die Daten anzuzeigen, die Sie analysieren möchten.

Manuelles Filtern von Daten

Verwenden eines Berichtsfilters zum Filtern von Elementen

Anzeigen der obersten oder untersten 10 Elemente

Filtern nach Auswahl, um nur ausgewählte Elemente anzuzeigen oder auszublenden

Aktivieren oder Deaktivieren von Filteroptionen

Manuelles Filtern von Daten

  1. Klicken Sie in der PivotTable auf den Pfeil Filter-Dropdownpfeil in Zeilenbeschriftungen oder Spaltenbeschriftungen.

  2. Deaktivieren Sie in der Liste der Zeilen- oder Spaltenbeschriftungen das Kontrollkästchen (Alle anzeigen), und aktivieren Sie dann die Kontrollkästchen für die Elemente, die in der PivotTable angezeigt werden sollen.

  3. Der Filterpfeil wird in dieses Symbol Symbol für angewendeten Filter geändert, um zu kennzeichnen, dass ein Filter angewendet ist. Klicken Sie auf das Symbol, um den Filter zu ändern oder zu löschen, indem Sie auf Filter löschen aus <Feldname>.

    Wenn Sie alle Filter gleichzeitig entfernen möchten, klicken Sie auf die Registerkarte PivotTable-Analyse > Löschen > Filter löschen.

Verwenden eines Berichtsfilters zum Filtern von Elementen

Mithilfe eines Berichtsfilters können Sie schnell einen anderen Satz von Werten in der PivotTable anzeigen. Elemente, die Sie im Filter auswählen, werden in der PivotTable angezeigt, und Elemente, die nicht ausgewählt sind, werden ausgeblendet. Wenn Sie Filter Seiten (die Gruppe von Werten, die den ausgewählten Berichtsfilter Elementen entsprechen) auf separaten Arbeitsblättern anzeigen möchten, können Sie diese Option angeben.

Hinzufügen eines Berichtsfilters

  1. Klicken Sie an einer beliebigen Stelle in der PivotTable.

    Der Bereich PivotTable-Felder wird angezeigt.

  2. Klicken Sie in der PivotTable-Feldliste auf das Feld in einem Bereich, und wählen Sie In den Berichtsfilter verschieben aus.

Sie können diesen Schritt wiederholen, um mehr als einen Berichtsfilter zu erstellen. Berichtsfilter werden oberhalb der PivotTable angezeigt, damit Sie einfach darauf zugreifen können.

  • Wenn Sie die Reihenfolge der Felder ändern möchten, können Sie im Bereich Filter entweder die Felder an die gewünschte Position ziehen oder auf ein Feld doppelklicken und Nach oben oder Nach unten auswählen. Die Reihenfolge der Berichtsfilter wird in der PivotTable entsprechend angegeben.

Anzeigen von Berichtsfiltern in Zeilen oder Spalten

  1. Klicken Sie auf die PivotTable oder die zugehörige PivotTable eines PivotCharts.

  2. Klicken Sie mit der rechten Maustaste auf eine beliebige Stelle in der PivotTable, und klicken Sie dann auf PivotTable-Optionen.

  3. Legen Sie auf der Registerkarte Layout die folgenden Optionen fest:

    1. Führen Sie im Bereich Berichtsfilter im Listenfeld Felder anordnen eine der folgenden Aktionen aus:

      • Zum Anzeigen von Berichtsfiltern in Zeilen von oben nach unten wählen Sie Zuerst nach unten aus.

      • Zum Anzeigen von Berichtsfiltern in Spalten von links nach rechts wählen Sie Rechts, dann nach unten aus.

    2. Geben Sie im Feld Berichtsfilterfelder nach Spalte die Anzahl der anzuzeigenden Felder ein, oder wählen Sie sie aus, bevor eine andere Spalte oder Zeile einbezogen werden soll (basierend auf der Einstellung von Felder anordnen, die Sie im vorhergehenden Schritt angegeben haben).

Auswählen von Elementen im Berichtsfilter

  1. Klicken Sie in der PivotTable auf den Dropdownpfeil neben dem Berichtsfilter.

  2. Aktivieren Sie die Kontrollkästchen neben den Elementen, die im Bericht angezeigt werden sollen. Um alle Elemente zu aktivieren, klicken Sie auf das Kontrollkästchen neben (Alle auswählen).

    Im Berichtsfilter werden nun die gefilterten Elemente angezeigt.

Anzeigen von Berichtsfilterseiten auf unterschiedlichen Arbeitsblättern

  1. Klicken Sie an eine beliebige Stelle in der PivotTable (oder die zugehörige PivotTable eines PivotChart), die über einen oder mehrere Berichtsfilter verfügt.

  2. Klicken Sie (im Menüband) auf PivotTable-Analyse > Optionen > Berichtsfilterdateien anzeigen.

  3. Wählen Sie im Dialogfeld Berichtsfilterseiten anzeigen ein Berichtsfilterfeld aus, und klicken Sie auf OK.

Anzeigen der obersten oder untersten 10 Elemente

Ferner können Sie Filter anwenden, die die 10 obersten (größten) bzw. untersten (kleinsten) Werte oder die Daten anzeigen, die den angegebenen Kriterien entsprechen.

  1. Klicken Sie in der PivotTable auf den Pfeil Filter-Dropdownpfeil neben Zeilenbeschriftungen oder Spaltenbeschriftungen.

  2. Klicken Sie mit der rechten Maustaste auf ein Element in der Auswahl, und klicken Sie dann auf Filtern > Obere 10 oder Untere 10.

  3. Geben Sie im ersten Feld eine Zahl ein.

  4. Wählen Sie im zweiten Feld die Option aus, nach der Sie filtern möchten. Die folgenden Optionen sind verfügbar:

    • Soll nach der Anzahl von Elementen gefiltert werden, wählen Sie Elemente aus.

    • Soll nach Prozentwerten gefiltert werden, wählen Sie Prozentsatz aus.

    • Soll nach Summen gefiltert werden, wählen Sie Summe aus.

  5. Im Suchfeld können Sie optional nach einem bestimmten Wert suchen.

Filtern nach Auswahl, um nur ausgewählte Elemente anzuzeigen oder auszublenden

  1. Wählen Sie in der PivotTable eines oder mehrere Elemente in dem Feld aus, das Sie nach Auswahl filtern möchten.

  2. Klicken Sie mit der rechten Maustaste auf ein Element in der Auswahl, und klicken Sie auf Filtern.

  3. Führen Sie eine der folgenden Aktionen aus:

    • Zum Anzeigen der ausgewählten Elemente klicken Sie auf Nur ausgewählte Elemente beibehalten.

    • Zum Ausblenden der ausgewählten Elemente klicken Sie auf Ausgewählte Elemente ausblenden.

      Tipp: Sie können ausgeblendete Elemente wieder anzeigen, indem Sie den Filter entfernen. Klicken Sie mit der rechten Maustaste auf ein anderes Element in demselben Feld, klicken Sie auf Filtern, und klicken Sie dann auf Filter löschen.

Aktivieren oder Deaktivieren von Filteroptionen

Wenn Sie pro Feld mehrere Filter anwenden möchten oder wenn in der PivotTable keine Filterschaltflächen angezeigt werden sollen, können Sie diese sowie andere Filteroptionen ein- oder ausschalten:

  1. Klicken Sie auf eine beliebige Stelle in der PivotTable, damit die PivotTable-Registerkarten im Menüband angezeigt werden.

  2. Klicken Sie auf der Registerkarte PivotTable-Analyse auf Optionen.

    1. Klicken Sie im Dialogfeld PivotTable-Optionen auf die Registerkarte Layout.

    2. Aktivieren oder deaktivieren Sie im Bereich Layout – je nach Ihren Anforderungen – das Kontrollkästchen Mehrere Felder pro Feld zulassen.

    3. Klicken Sie auf die Registerkarte Anzeige, und aktivieren oder deaktivieren Sie das Kontrollkästchen Feldbeschriftungen und Filter, um Feldüberschriften und Filter-Dropdownlisten anzuzeigen oder auszublenden.

Sie können PivotTables in Excel für das Web anzeigen und mit ihnen interagieren, was einige manuelle Filterung und die Verwendung von datenschnitten enthält, die in der Excel-Desktopanwendung zum Filtern Ihrer Daten erstellt wurden. Sie können in Excel für das Web keine neuen datenschnitte erstellen.

Führen Sie eine der folgenden Aktionen aus, um Ihre PivotTable-Daten zu filtern:

  • Um einen manuellen Filter anzuwenden, klicken Sie auf den Pfeil in Zeilenbeschriftungen oder Spaltenbeschriftungen, und wählen Sie dann die gewünschten Filteroptionen aus.

Filteroptionen für PivotTable-Daten

  • Wenn Ihre PivotTable Datenschnitte aufweist, klicken Sie einfach auf die Elemente, die Sie in den einzelnen Datenschnitten anzeigen möchten.

Datenschnitt mit ausgewählten Elementen

Wenn Sie über die Excel-Desktopanwendung verfügen, können Sie stattdessen die Schaltfläche In Excel öffnen verwenden, um die Arbeitsmappe dort zu öffnen und weitere Filter anzuwenden oder neue Datenschnitte für Ihre PivotTable-Daten zu erstellen. Das geht so:

Klicken Sie auf In Excel öffnen, und filtern Sie Ihre Daten in der PivotTable.

Schaltfläche zum Bearbeiten in Excel

Informationen zu den neuesten Excel für das Web-Updates finden Sie im Microsoft Excel-Blog.

Um die gesamte Suite der Office-Anwendungen und Dienste kennenzulernen, testen oder kaufen Sie sie auf Office.com.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Siehe auch

Video: Filtern von Daten in einer PivotTable

Erstellen einer PivotTable zum Analysieren von Arbeitsblattdaten

Erstellen einer PivotTable zum Analysieren von externen Daten

Erstellen einer PivotTable zum Analysieren von Daten in mehreren Tabellen

Sortieren von Daten in einer PivotTable

Gruppieren oder Aufheben der Gruppierung von Daten in einer PivotTable

Hinweis:  Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Lassen Sie uns bitte wissen, ob diese Informationen hilfreich für Sie waren. Hier finden Sie den englischen Artikel als Referenz.

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×