Zu Hauptinhalt springen

Feldfunktionen: = (Formel)-Feld

Die Feldfunktion "= (Formel)" berechnet eine Zahl mithilfe einer mathematischen Formel. Sie können dazu den Befehl Formel auf der Registerkarte Layout verwenden, die angezeigt wird, wenn Sie innerhalb einer Tabelle klicken.

Wenn Sie mit einer Tabellenkalkulationsanwendung wie Excel arbeiten, ist es oft einfacher, ein Arbeitsblatt ganz oder zum Teil in ein Dokument einzubetten, als das "= (Formel)"-Feld zu verwenden.

Syntax

Wenn Sie die Feldfunktion "= (Formel)" in einem Dokument anzeigen, sieht die Syntax wie folgt aus:

{ = Formel [Textmarke ] [\#Numerisches Bild ] }

Hinweis: Mit einer Feldfunktion wird angegeben, was im Feld angezeigt werden soll. Die Feldergebnisse sind das, was im Dokument angezeigt wird, nachdem die Feldfunktion ausgewertet wurde. Wenn Sie zwischen der Anzeige der Feldfunktion und der Ergebnisse der Feldfunktion umschalten möchten, drücken Sie ALT+F9.

Anweisungen

Eine Formel ist ein Ausdruck, der eine beliebige Kombination aus Zahlen, Textmarken, die sich auf Zahlen beziehen, und Feldern, die Zahlen ergeben, sowie die verfügbaren Operatoren und Funktionen enthalten kann. Der Ausdruck kann sich auf Werte in einer Tabelle und auf von Funktionen zurückgegebene Werte beziehen.

Weitere Informationen:

Operatoren

In einem "= (Formel)"-Feld können Sie eine beliebige Kombination aus Werten und den folgenden mathematischen und relationalen Operatoren verwenden.

+

Addition

Subtraktion

*

Multiplikation

/

Division

%

Prozentsatz

^

Potenzen und Wurzeln

=

Gleich

<

Kleiner als

<=

Kleiner oder gleich

>

Größer als

>=

Größer oder gleich

< >

Ungleich

Funktionen

Im "= (Formel)"-Feld können die von den nachfolgend aufgeführten Funktionen zurückgegebenen Werte verwendet werden. Funktionen mit leeren Klammern können beliebig viele Argumente akzeptieren. Argumente müssen durch das in der Microsoft Windows-Systemsteuerung in den Ländereinstellungen festgelegte Listentrennzeichen, also entweder durch ein Komma (,) oder Semikolon (;), voneinander getrennt sein. Bei Argumenten kann es sich um Zahlen, Formeln oder Textmarkennamen handeln. Die Funktionen MITTELWERT(), ANZAHL(), MAX(), MIN(), PRODUKT() und SUMME() können auch Verweise auf Tabellenzellen als Argumente akzeptieren.

ABS(x)

Hiermit wird der positive Wert einer Zahl oder Formel zurückgegeben, und zwar unabhängig vom tatsächlichen positiven oder negativen Wert.

UND(x,y)

Hiermit wird der Wert "1" zurückgegeben, wenn die logischen Ausdrücke x und y WAHR sind. Oder es wird der Wert "0" (Null) zurückgegeben, wenn einer der beiden Ausdrücke FALSCH ist.

MITTELWERT( )

Hiermit wird der Mittelwert einer Liste von Werten zurückgegeben.

ANZAHL()

Hiermit wird die Anzahl von Elementen in einer Liste zurückgegeben.

DEFINIERT(x)

Hiermit wird der Wert "1" (WAHR) zurückgegeben, wenn der Ausdruck x gültig ist. Oder es wird der Wert "0" (FALSCH) zurückgegeben, wenn der Ausdruck nicht berechnet werden kann.

FALSCH

Hiermit wird "0" (Null) zurückgegeben.

GANZZAHL(x)

Hiermit werden die Zahlen links von der Dezimalstelle im Wert oder in der Formel x zurückgegeben.

MIN( )

Hiermit wird der kleinste Wert in einer Liste zurückgegeben.

MAX( )

Hiermit wird der größte Wert in einer Liste zurückgegeben.

REST(x,y)

Hiermit wird der Restwert zurückgegeben, der sich aus der Division des Werts x durch den Wert y ergibt.

NICHT(x)

Hiermit wird der Wert "0" (Null) (FALSCH) zurückgegeben, wenn der logische Ausdruck x WAHR ist. Oder es wird der Wert "1" (WAHR) zurückgegeben, wenn der Ausdruck FALSCH ist.

ODER(x,y)

Hiermit wird der Wert "1" (WAHR) zurückgegeben, wenn einer der oder beide logischen Ausdrücke x und y WAHR sind. Oder es wird der Wert "0" (Null) (FALSCH) zurückgegeben, wenn beide Ausdrücke FALSCH sind.

PRODUKT( )

Hiermit wird das Ergebnis der Multiplikation einer Liste von Werten zurückgegeben. So gibt beispielsweise die Funktion { = PRODUKT (1,3,7,9) } den Wert "189" zurück.

RUNDEN(x,y)

Hiermit wird der Wert von x gerundet auf die angegebene Anzahl von Dezimalstellen y zurückgegeben. x kann entweder eine Zahl oder das Ergebnis einer Formel darstellen.

VORZEICHEN(x)

Hiermit wird der Wert "1" zurückgegeben, wenn x ein positiver Wert ist. Oder es wird der Wert "-1" zurückgegeben, wenn x ein negativer Wert ist.

SUMME()

Hiermit wird die Summe einer Liste von Werten oder Formeln zurückgegeben.

WAHR

Hiermit wird der Wert "1" zurückgegeben.

Tabellenbezüge

Beim Ausführen von Berechnungen in einer Tabelle referenzieren Sie die Tabellenzellen mit A1, A2, B1, B2 usw., wobei der Buchstabe eine Spalte und die Zahl eine Zeile darstellt. Bei Zellbezügen in Microsoft Word handelt es sich (im Gegensatz zu Zellbezügen in Microsoft Excel) immer um absolute Bezüge, die nicht mit Dollarzeichen angezeigt werden. Wenn Sie beispielsweise in Word mit A1 auf eine Zelle verweisen, so entspricht das in Excel dem Referenzieren der Zelle mit $A$1.

Tabelle mit Zellbezügen

Verweisen auf einzelne Zellen

Verwenden Sie zum Verweisen auf Zellen in Formeln ein Komma, um Verweise auf einzelne Zellen voneinander zu trennen, und trennen Sie die jeweils ersten und letzten Zellen eines angegebenen Bereichs durch einen Doppelpunkt. Diese Vorgehensweise wird in den folgenden Beispielen veranschaulicht.

Ermitteln des Mittelwerts dieser Zellen:

Tabelle mit ausgewähltem Zellbereich

=MITTELWERT(b:b) oder =MITTELWERT(b1:b3)

Tabelle mit ausgewähltem Zellbereich

=MITTELWERT(a1:b2)

Tabelle mit ausgewähltem Zellbereich

=MITTELWERT(a1:c2) oder =MITTELWERT(1:1,2:2)

Tabelle mit ausgewähltem Zellbereich

=MITTELWERT(a1,a3,c2)

Verweisen auf eine ganze Zeile oder Spalte

Zum Verweisen auf eine ganze Zeile oder Spalte in einer Berechnung stehen Ihnen folgende Möglichkeiten zur Verfügung:

  • Verwenden Sie einen Bereich, der nur den Buchstaben oder die Zahl umfasst, der/die diesen Bereich darstellt (z. B. 1:1), um auf die erste Zeile in der Tabelle zu verweisen. Auf diese Weise können automatisch alle Zellen in der Zeile in die Berechnung einbezogen werden, wenn Sie später noch weitere Zellen hinzufügen möchten.

  • Verwenden Sie einen Bereich, der bestimmte Zellen umfasst (z. B. a1:a3), um auf eine Spalte mit drei Zeilen zu verweisen. Auf diese Weise werden nur diese bestimmten Zellen in die Berechnung einbezogen. Wenn Sie später weitere Zellen hinzufügen und diese in die Berechnung einbezogen werden sollen, müssen Sie die Berechnung bearbeiten.

Verweisen auf Zellen in einer anderen Tabelle

Wenn Sie auf Zellen in einer anderen Tabelle oder auf eine Zelle außerhalb einer Tabelle verweisen möchten, müssen Sie die Tabelle durch eine Textmarke definieren. Beispiel: Für das Feld { =MITTELWERT(Tabelle2 b:b) } wird der Mittelwert von Spalte B in der Tabelle berechnet, die durch die Textmarke "Tabelle2" definiert ist.

Textmarke

Hierbei handelt es sich um den Namen einer Textmarke, die auf einen oder mehrere Werte verweist.

\# Numerisches Bild

Hiermit wird die Darstellung eines numerischen Ergebnisses festgelegt. Dieser Schalter wird als "Bild" bezeichnet, weil Sie Symbole zum Darstellen des Feldergebnisformats verwenden.

Beispielsweise zeigt der Schalter \# #.##0,00 € in { = SUMME(ÜBER) \# #.##0,00 € "}" ein Ergebnis wie "4.455,70 €" an. Ist das Ergebnis eines Felds keine Zahl, hat dieser Schalter keine Wirkung.

Hinweis: Anführungszeichen sind bei einfachen numerischen Bildern ohne Leerstellen nicht erforderlich, z. B. { UmsatzMärz \# #.##0,00 }. Bei komplexeren numerischen Bildern und bei Bildern, die Text oder Leerstellen enthalten, muss das numerische Bild wie in den folgenden Beispielen für Bildelemente in Anführungszeichen stehen. In Word werden numerischen Bildschaltern Anführungszeichen hinzugefügt, wenn Sie ein Feld mit dem Befehl Feld auf der Registerkarte Einfügen oder mit dem Befehl Formel einfügen (im Menü Layout, das angezeigt wird, wenn Sie innerhalb einer Tabelle klicken).

Durch Kombinieren der folgenden Bildelemente können Sie einen numerischen Bildschalter erstellen:

Bildelemente

0 (Null)

Hiermit wird die Anzahl der Stellen für die Anzeige des Ergebnisses festgelegt. Enthält das Ergebnis an einer Stelle keine Ziffer, wird in Word eine 0 (Null) angezeigt. Für { = 4 + 5 \# 00.00 } wird z. B. das Ergebnis "09.00" angezeigt.

#

Hiermit wird die Anzahl der Stellen für die Anzeige des Ergebnisses festgelegt. Enthält das Ergebnis an einer Stelle keine Ziffer, wird in Word eine Leerstelle angezeigt. Für { = 9 + 6 \# ### € } wird z. B. das Ergebnis "15 €" angezeigt.

x

Hiermit werden alle links vom Platzhalter "x" stehenden Ziffern unterdrückt. Wenn der Platzhalter rechts neben dem Dezimalkomma eingefügt wird, rundet Word das Ergebnis auf diese Stelle. Beispiel: 
{ = 111053 + 111439 \# x## } ergibt "492". 
{ = 1/8 \# 0,00x } ergibt "0,125". 
{ = 3/4 \# ,x } ergibt ",8".

, (Dezimalkomma)

Hiermit wird die Position des Dezimalkommas festgelegt. Für { = SUMME(ÜBER) \# ###,00 € } wird z. B. das Ergebnis "495,47 €" angezeigt.

Hinweis: Verwenden Sie das in der Microsoft Windows-Systemsteuerung in den Ländereinstellungen festgelegte Dezimaltrennzeichen.

. (Tausendertrennzeichen)

Hiermit werden große Zahlen in Blöcke zu jeweils drei Ziffern unterteilt. Für { = Nettogewinn \# #.###.### } wird z. B. das Ergebnis "2.456.800" angezeigt.

Hinweis: Verwenden Sie das in der Windows-Systemsteuerung in den Ländereinstellungen festgelegte Tausendertrennzeichen.

- (Minuszeichen)

Hiermit wird einem negativen Ergebnis ein Minuszeichen hinzugefügt, oder es wird eine Leerstelle eingefügt, wenn das Ergebnis positiv oder gleich 0 (Null) ist. Für { = 10 - 90 \# -## } wird z. B. das Ergebnis "-80" angezeigt.

+ (Pluszeichen)

Hiermit wird einem positiven Ergebnis ein Pluszeichen bzw. einem negativen Ergebnis ein Minuszeichen hinzugefügt, oder es wird eine Leerstelle eingefügt, wenn das Ergebnis gleich 0 (Null) ist. Für { = 100 - 90 \# +## } wird beispielsweise "+10" und für { = 90 - 100 \# +## } wird das Ergebnis "-10" angezeigt.

%, €, * usw.

Hiermit wird das angegebene Zeichen in das Ergebnis eingefügt. Für { = Nettogewinn \# "## %" } wird z. B. das Ergebnis "33 %" angezeigt.

"positiv; negativ"

Hiermit werden unterschiedliche Zahlenformate für positive und negative Ergebnisse festgelegt. Handelt es sich bei der Textmarke "Umsatz95" beispielsweise um einen positiven Wert, wird im Feld { Umsatz95 \# "#.##0,00 €;-#.##0,00 €" } der Wert ohne besondere Formatierung angezeigt (z. B. "1.245,65 €"). Ein negativer Wert wird jedoch fett formatiert und mit einem Minuszeichen angezeigt, z. B. "-345,56 €".

"positiv; negativ; Null"

Hiermit werden unterschiedliche Zahlenformate für ein positives Ergebnis, ein negatives Ergebnis und 0 (Null) festgelegt. Je nach dem Wert der Textmarke "Umsatz95" zeigt die Feldfunktion { Umsatz95 \# "#.##0,00 €;(#.##0,00 €);0 €" } positive, negative und Nullwerte folgendermaßen an: 1.245,65 €; (345,56 €); 0 €.

'Text'

Hiermit wird dem Ergebnis Text hinzugefügt. Schließen Sie den Text in einfache Anführungszeichen ein. Für { = { Preis } *16% \# "##0,00 € '= MwSt.' " } wird z. B. das Ergebnis "347,44 € = MwSt." angezeigt.

`Reihenfolge`

Hiermit wird die Nummer des vorherigen Elements angezeigt, das Sie mithilfe des Befehls Beschriftung (Menü Einfügen, Untermenü Verweise) oder durch Einfügen eines SEQ-Felds nummeriert haben. Schließen Sie das Erkennungszeichen, z. B. "Tabelle" oder "Abbildung", in Graviszeichen (`) ein. Die fortlaufende Nummer wird in arabischen Ziffern angezeigt. Für { = SUMME(A1:D4) \# "##0,00 'ist die Summe aus Tabelle' `Tabelle`" } wird z. B. das Ergebnis "456,34 ist die Summe aus Tabelle 2" angezeigt.

Beispiele

Beispiel 1

Im folgenden Feld wird ein durch den Textmarke "Bruttoumsatz" dargestellter Wert subtrahiert. Vom numerischen Bildschalter werden die Ergebnisse mit einem Währungszeichen (z. B. 14.786,17 €) angezeigt:

{ = Bruttoumsatz-29.897,62 \# "#.##0,00 €" }

Beispiel 2

Im folgenden "= (Formel)"-Feld wird die Gesamtanzahl der Seiten in einem Dokument berechnet, dessen Seitennummerierung mit 47 beginnt. Es wird z. B. ein Ergebnis wie "Seite 51 von 92" angezeigt:

Seite { PAGE } von { = (47 - 1) + { NUMPAGES } }

Beispiel 3

Die folgenden Beispiele beziehen sich auf Werte in einer Tabelle. Die Zellbezüge in den Beispielen beziehen sich auf Zellen in der Tabelle, in der das "= (Formel)"-Feld enthalten ist. Wenn das Feld nicht in der referenzierten Tabelle enthalten ist, definieren Sie die Tabelle durch eine Textmarke, und geben Sie die Textmarke gefolgt von den Zellbezügen an.

{ = SUMME(ÜBER) } (in eine Tabellenzelle eingefügt)

Dies stellt die Summe der Zellen dar, von der Zelle über dem Feld bis zum Anfang der Spalte oder bis zur ersten leeren Zelle oder bis zu einem unzulässigen Wert.

{ = SUMME(Tabelle3 C3) }

Dies ist der Inhalt der Zelle in der dritten Spalte der dritten Zeile der Tabelle, die durch die Textmarke "Tabelle3" definiert ist.

{ = MIN(Tabelle3 A3:D3) }

Dies ist der kleinste Wert in den ersten vier Zellen der dritten Zeile der Tabelle, die durch die Textmarke "Tabelle3" definiert ist.

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×