Exportieren von Shape-Daten in eine Datenbank

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Wenn Ihre Shapes Daten enthalten, können Sie den Assistenten zum Exportieren von Datenbanken ausführen, um eine Datenbanktabelle zu erstellen, die diese Daten enthält.

Der Unterschied zwischen dem Daten Bank Export-Assistenten und dem Dialogfeld, das mit dem Befehl in Datenbank exportieren erreicht wird, besteht darin, dass Sie über den Assistenten alle Shapes auf einem Layer exportieren können. Wenn Sie nicht nach Layern exportieren müssen, können Sie feststellen, dass die Verwendung des Befehls zum Exportieren in die Datenbank optimiert ist.

Verwenden des Assistenten zum Exportieren von DatenBanken

  1. Klicken Sie auf der Registerkarte Ansicht auf Add-ons > Visio-Extras > Daten Bank Export-Assistent.

  2. BeFolgen Sie die Anweisungen auf den Seiten des Assistenten.

    Tipps: 

    • Die Zellnamen der Shape-Daten, die in der Liste angezeigt werden, sind mit Prop (z . b. prop. Cost ) vorangestellt.

    • Wenn Sie den Datenbankexport-Assistenten ausführen, um Shape-Daten zu exportieren, speichert der Assistent exportbezogene Informationen auf dem Zeichenblatt. Wenn Sie Änderungen an den Shapes vornehmen und die Daten erneut exportieren möchten, klicken Sie mit der rechten Maustaste auf das Zeichenblatt, und wählen Sie dann Datenbankexport Tabelle aus.

Verwenden des Befehls "in Datenbank exportieren"

  1. Klicken Sie auf der Registerkarte Ansicht auf Add-ons > Visio-Extras > in Datenbank exportieren.

  2. Wählen Sie die Datenbanktabelle aus, die Sie verwenden möchten.

    • Wenn sich die Datenquelle nicht am Standardspeicherort befindet, klicken Sie auf Durchsuchen, um die Datei zu suchen.

    • Klicken Sie auf Erstellen, um eine neue Datenquelle zu erstellen. Führen Sie den Assistenten zum Erstellen einer neuen Datenquelle aus. Nach dem Klicken auf " Ende " wird das Dialogfeld " ODBC-Setup " angezeigt. Von dort aus können Sie entweder eine vorhandene Datenbank auswählen oder eine neue erstellen. Die Tabelle wird später in der Datenbank erstellt.

      Hinweise: 

      • Wenn Sie Excel als Datenquelle verwenden, können Sie eine vorhandene Arbeitsmappe auswählen, Sie können Sie jedoch nicht im Assistenten erstellen.

      • Wenn Sie eine Excel-Arbeitsmappe auswählen, müssen Sie das Kontrollkästchen schreibgeschützt im Dialogfeld Arbeitsmappe auswählen deaktivieren.

  3. Wenn Ihre Datenbank Besitzer unterstützt, klicken Sie in der Liste Besitzer auf einen Besitzernamen, um die Liste der Tabellenbesitzer zu filtern. Die Datenbanktabelle wird mit dem Namen erstellt, den Sie für die Anmeldung bei der Datenbank verwendet haben.

  4. Wenn Sie über Ihre Datenbank Zugriff auf mehrere Datenbanken haben, klicken Sie in der Liste Kennung auf die gewünschte Datenbank.

    Tipp: Wenn Sie Access oder Excel verwenden, werden der Name und der Pfad der Datenbank, in die die Daten exportiert werden, hier aufgelistet.

  5. Klicken Sie in der Liste Tabelle auf die Datenbanktabelle, die Sie verwenden möchten. Wenn Sie eine neue Tabelle erstellen möchten, geben Sie einen Namen dafür ein.

  6. Wenn Sie die Art und Weise des Exports von Daten aus ShapeSheet-Zellen ändern möchten, führen Sie eine der folgenden Aktionen aus:

    HinzuFügen einer ShapeSheet-Zelle zur Export Liste

    1. Klicken Sie auf Hinzufügen.

    2. Wählen Sie die ShapeSheet-Zelle aus, die exportiert werden soll.

    3. Wählen Sie im Feld Auswerten als den Datentyp für den im Datenbankfeld gespeicherten Wert aus.

    4. Wählen Sie das Datenbankfeld aus, in das die Shape-Daten kopiert werden.

    5. Geben Sie den Datenbank-Datentyp, die Feldlänge und die Anzahl der Dezimalstellen für das Datenbankfeld an.

    Ändern der exportierten Daten in einer ShapeSheet-Zelle

    1. Wählen Sie einen Zellen Namen aus, und klicken Sie auf ändern.

    2. Ändern, wie Daten exportiert werden.

    Löschen einer ShapeSheet-Zelle aus der Export Liste

    Wählen Sie einen Zellen Namen aus, und klicken Sie auf Löschen.

Verwenden des Assistenten zum Exportieren von DatenBanken

  1. Zeigen Sie im Menü Extras auf Add-ons, zeigen Sie auf Visio-Extras, und klicken Sie dann auf Daten Bank Export-Assistent.

  2. BeFolgen Sie die Anweisungen auf den Seiten des Assistenten.

    Tipps: 

    • Die Zellnamen der Shape-Daten, die in der Liste angezeigt werden, sind mit Prop (z . b. prop. Cost ) vorangestellt.

    • Wenn Sie den Datenbankexport-Assistenten ausführen, um Shape-Daten zu exportieren, speichert der Assistent exportbezogene Informationen auf dem Zeichenblatt. Wenn Sie Änderungen an den Shapes vornehmen und die Daten erneut exportieren möchten, klicken Sie mit der rechten Maustaste auf das Zeichenblatt, und wählen Sie dann Datenbankexport Tabelle aus.

Verwenden des Befehls "in Datenbank exportieren"

  1. Zeigen Sie im Menü Extras auf Add-ons, zeigen Sie dann auf Visio-Extras, und klicken Sie dann auf in Datenbank exportieren.

  2. Wählen Sie die Datenbanktabelle aus, die Sie verwenden möchten.

    • Wenn sich die Datenquelle nicht am Standardspeicherort befindet, klicken Sie auf Durchsuchen, um die Datei zu suchen.

    • Klicken Sie auf Erstellen, um eine neue Datenquelle zu erstellen. Führen Sie den Assistenten zum Erstellen einer neuen Datenquelle aus. Nach dem Klicken auf " Ende " wird das Dialogfeld " ODBC-Setup " angezeigt. Von dort aus können Sie entweder eine vorhandene Datenbank auswählen oder eine neue erstellen. Die Tabelle wird später in der Datenbank erstellt.

      Hinweise: 

      • Wenn Sie Microsoft Office Excel als Datenquelle verwenden, können Sie eine vorhandene Arbeitsmappe auswählen, Sie können Sie jedoch nicht im Assistenten erstellen.

      • Wenn Sie eine Excel-Arbeitsmappe auswählen, müssen Sie das Kontrollkästchen schreibgeschützt im Dialogfeld Arbeitsmappe auswählen deaktivieren.

  3. Wenn Ihre Datenbank Besitzer unterstützt, klicken Sie in der Liste Besitzer auf einen Besitzernamen, um die Liste der Tabellenbesitzer zu filtern. Die Datenbanktabelle wird mit dem Namen erstellt, den Sie für die Anmeldung bei der Datenbank verwendet haben.

  4. Wenn Sie über Ihre Datenbank Zugriff auf mehrere Datenbanken haben, klicken Sie in der Liste Kennung auf die gewünschte Datenbank.

    Tipp: Wenn Sie Microsoft Office Access oder Excel verwenden, werden der Name und der Standort der Datenbank, in die die Daten exportiert werden, hier aufgelistet.

  5. Klicken Sie in der Liste Tabelle auf die Datenbanktabelle, die Sie verwenden möchten. Wenn Sie eine neue Tabelle erstellen möchten, geben Sie einen Namen dafür ein.

  6. Wenn Sie die Art und Weise des Exports von Daten aus ShapeSheet-Zellen ändern möchten, führen Sie eine der folgenden Aktionen aus:

    HinzuFügen einer ShapeSheet-Zelle zur Export Liste

    1. Klicken Sie auf Hinzufügen.

    2. Wählen Sie die ShapeSheet-Zelle aus, die exportiert werden soll.

    3. Wählen Sie im Feld Auswerten als den Datentyp für den im Datenbankfeld gespeicherten Wert aus.

    4. Wählen Sie das Datenbankfeld aus, in das die Shape-Daten kopiert werden.

    5. Geben Sie den Datenbank-Datentyp, die Feldlänge und die Anzahl der Dezimalstellen für das Datenbankfeld an.

    Ändern der exportierten Daten in einer ShapeSheet-Zelle

    1. Wählen Sie einen Zellen Namen aus, und klicken Sie auf ändern.

    2. Ändern, wie Daten exportiert werden.

    Löschen einer ShapeSheet-Zelle aus der Export Liste

    Wählen Sie einen Zellen Namen aus, und klicken Sie auf Löschen.

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×