Erstellen oder Bearbeiten von Ansichten in Datenbankmodelldiagrammen

Sie können sich eine Ansicht als eine gespeicherte Abfrage vorstellen. Ansichten sind besonders nützlich, wenn Sie auf dieselben Informationen aus mehreren Tabellen zugreifen oder Daten für Benutzer verfügbar machen und gleichzeitig verhindern möchten, dass die Benutzer an den eigentlichen Tabellen Änderungen vornehmen.

Hinweis: Das Datenbankmodelldiagramm ist nur in bestimmten Versionen von Visio verfügbar. Weitere Informationen finden Sie unter Sie können die Datenbankmodellierungsfeatures nicht finden?

Hinzufügen einer Ansicht zu einem Datenbankmodelldiagramm

  • Ziehen Sie aus der Schablone Entitätsbeziehung oder Objektrelational ein Shape Ansicht auf das Zeichenblatt.

Zuweisen von Spalten aus Tabellen zu einer Ansicht

  1. Öffnen Sie das Datenbankmodelldiagramm mit der Ansicht, der Sie Spalten hinzufügen möchten.

  2. Doppelklicken Sie auf die Ansicht, und klicken Sie dann im Fenster Datenbankeigenschaften in der Liste Kategorien auf Spalten.

  3. Führen Sie eine der folgenden Aktionen aus:

    • Klicken Sie in das Feld Physischer Name einer leeren Zeile, und geben Sie den Namen der Spalte ein. Wiederholen Sie diesen Schritt für jede Spalte, die Sie der Ansicht hinzufügen möchten.

    • Klicken Sie auf Hinzufügen. Der Standardname für die neue Spalte folgt den Namenskonventionen, die Sie im Dialogfeld Modellierungsvoreinstellungen festgelegt haben. Wenn Sie den Namen der Spalte ändern möchten, klicken Sie auf den Standardnamen der Spalte, und geben Sie einen neuen Namen ein. Wiederholen Sie diesen Schritt für jede Spalte, die Sie der Ansicht hinzufügen möchten.

  4. Klicken Sie auf den Namen der Spalte, deren Eigenschaften Sie definieren möchten, und klicken Sie dann auf Bearbeiten.

  5. Klicken Sie im Dialogfeld Spalteneigenschaften anzeigen auf der Registerkarte Quelle auf Bekannte Spalte in einer anderen Tabelle oder Ansicht, und klicken Sie dann auf Ändern.

  6. Wählen Sie im Dialogfeld Spalte auswählen eine Spalte aus der Liste der Tabellen und Ansichten in Ihrem Datenbankmodelldiagramm aus, und klicken Sie dann auf OK.

  7. Wenn die Einstellungen Ihren Vorstellungen entsprechen, klicken Sie auf OK.

  8. Wiederholen Sie die Schritte 4 bis 7 für jede Spalte, die Sie in Schritt 3 hinzugefügt haben.

Bearbeiten der Eigenschaften einer Spalte in einer Ansicht

  1. Öffnen Sie das Datenbankmodelldiagramm.

  2. Doppelklicken Sie auf die Ansicht mit den Spalten, die Sie ändern möchten, und klicken Sie dann im Fenster Datenbankeigenschaften in der Liste Kategorien auf Spalten.

  3. Klicken Sie auf den Namen der Spalte, die Sie ändern möchten, und klicken Sie dann auf Bearbeiten.

  4. Klicken Sie im Dialogfeld Spalteneigenschaften anzeigen auf die Registerkarte mit den Informationen, die Sie bearbeiten möchten, und nehmen Sie dann Ihre Änderungen vor.

  5. Wenn die Einstellungen Ihren Vorstellungen entsprechen, klicken Sie auf OK.

Bearbeiten der Eigenschaften einer Ansicht

  1. Öffnen Sie das Datenbankmodelldiagramm.

  2. Doppelklicken Sie auf die Ansicht, deren Eigenschaften Sie bearbeiten möchten, um das Fenster Datenbankeigenschaften zu öffnen.

  3. Klicken Sie im Fenster Datenbankeigenschaften auf die Kategorie mit den Informationen, die Sie bearbeiten möchten, und nehmen Sie dann Ihre Änderungen vor.

Das Datenbankmodelldiagramm wird automatisch aktualisiert.

Entfernen einer Ansicht

  1. Öffnen Sie das Datenbankmodelldiagramm.

  2. Klicken Sie auf dem Zeichenblatt auf die Ansicht, die Sie entfernen möchten, und drücken Sie dann ENTF.

  3. Führen Sie im Dialogfeld Objekt löschen eine der folgenden Aktionen aus:

    • Klicken Sie auf Ja, um die Ansicht aus dem Zeichenblatt, dem Modell und dem Fenster Tabellen und Ansichten zu entfernen.

    • Klicken Sie auf Nein, um die Ansicht aus dem Zeichenblatt, aber nicht aus dem Modell oder dem Fenster Tabellen und Ansichten zu entfernen.

Hinweis: Wenn das Dialogfeld Objekt löschen beim Löschen eines Objekts aus dem Diagramm nicht angezeigt wird, zeigen Sie im Menü Datenbank auf Optionen, klicken Sie auf Modellierung, und klicken Sie dann auf der Registerkarte Logisches Diagramm im Dialogfeld Voreinstellungen für Datenbankmodellierung unter Beim Entfernen eines Objekts aus dem Diagramm auf Benutzer nach gewünschter Aktion fragen. Wenn Sie die Ansicht aus dem Modell entfernen möchten, klicken Sie im Fenster Tabellen und Ansichten auf die Ansicht, und drücken Sie dann die ENTF-Taste.

Neuanordnen der Ansichten im Fenster "Code"

  1. Wenn das Fenster Code noch nicht geöffnet ist, zeigen Sie im Menü Datenbank auf Ansicht, und klicken Sie dann auf Code, um das Fenster zu öffnen.

    Hinweis: Dieser Befehl steht nur in der Vorlage Datenbankmodelldiagramm zur Verfügung.

  2. Ziehen Sie die Ansicht, die Sie neu anordnen möchten, an eine neue Position im Fenster.

Definieren eines Namespacewerts für eine Entität oder Ansicht

  1. Öffnen Sie das Datenbankmodelldiagramm.

  2. Doppelklicken Sie auf die Entität oder Ansicht, deren Namespace Sie festlegen möchten, um das Fenster Datenbankeigenschaften zu öffnen.

  3. Klicken Sie in der Liste Kategorien auf Definition, und geben Sie dann den kennzeichnenden Text in das Feld Namespace ein.

Das Datenbankmodell wird automatisch aktualisiert.

Erstellen von Code für Ansichten

  1. Ziehen Sie ein Shape Ansicht entweder aus der Schablone Entitätsbeziehung oder Objektrelational.

  2. Doppelklicken Sie auf das Shape, um das Fenster Datenbankeigenschaften zu öffnen.

  3. Klicken Sie unter Kategorien auf SQL.

  4. Geben Sie Ihren Code in das SQL-Fenster ein.

Sie können die Datenbankmodellierungsfeatures nicht finden?

Wahrscheinlich sind die Features, die Sie suchen, in Ihrer Version von Visio nicht enthalten. Wenn Sie herausfinden möchten, über welche Visio-Version Sie verfügen, klicken Sie im Menü Hilfe auf Info. Der Name der Version wird im Dialogfeld in der obersten Textzeile angezeigt.

In Visio Standard ist die Vorlage "Datenbankmodelldiagramm" nicht enthalten.

Visio Professional unterstützt die Reverse Engineering-Features für die Vorlage "Datenbankmodelldiagramm" (also das Verwenden einer vorhandenen Datenbank zum Erstellen eines Modells in Visio). Das Forward Engineering (also das Verwenden eines Visio-Datenbankmodells zum Generieren von SQL-Code) wird jedoch nicht unterstützt. Weitere Informationen finden Sie im Thema Durchführen von Reverse Engineering für eine vorhandene Datenbank.

Wenn Sie Microsoft Visio Pro für Office 365 verwenden und erfahren möchten, wie Sie eine bestehende Datenbank zum Erstellen eines Datenbankmodells verwenden können, lesen Sie das Thema Durchführen von Reverse Engineering für eine vorhandene Datenbank.

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×