Erstellen eines Datenmodells in Excel

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

EIN DatenModell ermöglicht die Integration von Daten aus mehreren Tabellen, wodurch eine relationale Datenquelle in einer Excel-Arbeitsmappe effektiv aufgebaut wird. In Excel werden DatenModelle transparent verwendet, sodass Tabellendaten in PivotTables und PivotCharts verwendet werden. EIN DatenModell wird als eine Sammlung von Tabellen in einer feldListe visualisiert, und die meiste Zeit werden Sie nie wissen, dass es vorhanden ist.

Bevor Sie mit dem Arbeiten mit dem DatenModell beginnen können, müssen Sie einige Daten abrufen. Dafür verwenden wir die Funktion "abrufen und Transformieren" (Power Query), sodass Sie möglicherweise einen Schritt zurückgehen und ein Video ansehen möchten, oder wenn Sie unserem lernleitfaden für Get & Transform und Power Pivot folgen.

Wo ist Power Pivot enthalten?

Wo befindet sich "abrufen und transFormieren" (Power Query)?

  • Excel 2016 & Excel für Office 365 -abrufen und Transformieren (Power Query) wurde in Excel auf der Registerkarte " Daten " integriert.

  • Excel 2013 – Power Query ist ein Add-in, das in Excel enthalten ist, jedoch aktiviert werden muss. Wechseln Sie zu Datei > Optionen > Add-ins, und wählen Sie dann in der Dropdownliste Verwalten unten im Bereich die Option com-Add-ins > wechseln aus. Aktivieren Sie Microsoft Power Query für Excel, und klicken Sie dann auf OK. Dem Menüband wird eine Power Query-Registerkarte hinzugefügt.

  • Excel 2010herunterladen und Installieren des Power Query-Add-Ins.. Nach der Aktivierung wird dem Menüband eine Power Query-Registerkarte hinzugefügt.

Erste Schritte

Zuerst müssen Sie einige Daten abrufen.

  1. Verwenden Sie in Excel 2016 und Excel für Office 365 Daten > Abrufen und Transformieren von Daten > Daten zum Importieren von Daten aus einer beliebigen Anzahl von externen Datenquellen, z. b. einer Textdatei, einer Excel-Arbeitsmappe, einer Website, Microsoft Access, SQL Server oder einer anderen. relationale Datenbank, die mehrere verknüpfte Tabellen enthält.

    Wechseln Sie in Excel 2013 und 2010 zu Power Query > externe Daten abrufen, und wählen Sie Ihre Datenquelle aus.

  2. Excel fordert Sie auf, eine Tabelle auszuwählen. Wenn Sie mehrere Tabellen aus derselben Datenquelle abrufen möchten, aktivieren Sie die Option Auswahl mehrerer Tabellen zulassen . Wenn Sie mehrere Tabellen auswählen, erstellt Excel automatisch ein DatenModell für Sie.

    Hinweis: Für diese Beispiele verwenden wir eine Excel-Arbeitsmappe mit fiktiven Kursteilnehmer Details zu Klassen und Noten. Sie können die Beispielarbeitsmappe für das Studentendaten Modellherunterladen und folgen. Sie können eine Version auch mit einem abgeschlossenen Datenmodell herunterladen.

    Navigator "abrufen und transFormieren" (Power Query)
  3. Wählen Sie eine oder mehrere Tabellen aus, und klicken Sie dann auf Laden.

    Wenn Sie die Quelldaten bearbeiten müssen, können Sie die Option " Bearbeiten " auswählen. Weitere Informationen finden Sie unter: Einführung in den Abfrage-Editor (Power Query).

Sie verfügen jetzt über ein Datenmodell, das alle importierten Tabellen enthält und in der PivotTable-Feldliste angezeigt werden .

Hinweise: 

  • Modelle werden implizit erstellt, wenn Sie mindestens zwei Tabellen gleichzeitig in Excel importieren.

  • Modelle werden explizit erstellt, wenn Sie das Power Pivot-Add-in zum Importieren von Daten verwenden. Im Add-in wird das Modell in einem Layout mit Registerkarten ähnlich wie in Excel dargestellt, wobei jede Registerkarte Tabellendaten enthält. Weitere Informationen finden Sie unter Abrufen von Daten mithilfe des Power Pivot-Add-inszum Erlernen der Grundlagen des Datenimports mit einer SQL Server-Datenbank.

  • Ein Modell kann eine einzelne Tabelle enthalten. Um ein Modell auf der Grundlage nur einer Tabelle zu erstellen, wählen Sie die Tabelle aus, und klicken Sie in Power Pivot auf Zu Datenmodell hinzufügen. Dies ist beispielsweise sinnvoll, wenn Sie Power Pivot-Funktionen, z. B. gefilterte Datasets, berechnete Spalten, berechnete Felder, KPIs und Hierarchien, verwenden möchten.

  • Tabellenbeziehungen können automatisch erstellt werden, wenn Sie verknüpfte Tabellen importieren, die Primär- und Fremdschlüsselbeziehungen aufweisen. In Excel können die Informationen zu importierten Beziehungen normalerweise als Grundlage für Tabellenbeziehungen im Datenmodell verwendet werden.

  • Tipps zum Verringern der Größe eines Datenmodells finden Sie unter Erstellen eines Speicher effizienten Datenmodells mithilfe von Excel und Power Pivot.

  • Weitere Informationen finden Sie unter Lernprogramm: Importieren von Daten in Excel und Erstellen eines Datenmodells.

Tipp: Wie können Sie feststellen, ob die Arbeitsmappe ein DatenModell aufweist? Wechseln Sie zu Power Pivot > Verwalten. Wenn Arbeitsblatt ähnliche Daten angezeigt werden, ist ein Modell vorhanden. Weitere Informationen finden Sie unter: ermitteln, welche Datenquellen in einem Arbeitsmappen-Datenmodell verwendet werden .

Erstellen von Beziehungen zwischen Tabellen

Der nächste Schritt besteht darin, Beziehungen zwischen den Tabellen zu erstellen, damit Sie Daten aus einer beliebigen Tabelle abrufen können. Jede Tabelle muss einen Primärschlüssel oder eine eindeutige Feld-ID aufweisen, z. b. die Studenten-oder Kursnummer. Die einfachste Möglichkeit besteht darin, diese Felder durch Ziehen und Ablegen in der Diagrammansicht von Power Pivot zu verbinden.

  1. Wechseln Sie zu Power Pivot > Verwalten.

  2. Wählen Sie auf der Registerkarte Start die Option Diagrammansicht aus.

  3. Alle importierten Tabellen werden angezeigt, und Sie können einige Zeit in Anspruch genommen werden, um die Größe zu ändern, je nachdem, wie viele Felder jeweils vorhanden sind.

  4. Ziehen Sie als nächstes das Primärschlüsselfeld aus einer Tabelle in die nächste. Das folgende Beispiel zeigt die DiagrammAnsicht der Kursteilnehmer Tabellen:

    Power Query-DatenModell BeziehungsDiagramm-Ansicht

    Wir haben die folgenden Links erstellt:

    • tbl_Students | KursTeilnehmer-ID > tbl_Grades | KursTeilnehmer-ID

      Ziehen Sie also das Feld KursTeilnehmer-ID aus der Tabelle Kursteilnehmer in das Feld KursTeilnehmer-ID in der Tabelle Noten.

    • tbl_Semesters | Semester-ID > tbl_Grades | Semesters

    • tbl_Classes | KursNummer > tbl_Grades | KursNummer

    Hinweise: 

    • Feldnamen müssen nicht identisch sein, um eine Beziehung zu erstellen, Sie müssen jedoch denselben Datentyp aufweisen.

    • Die Verbinder in der Diagrammansicht weisen eine "1" auf einer Seite und ein "*" auf der anderen auf. Dies bedeutet, dass es eine 1: n-Beziehung zwischen den Tabellen gibt und bestimmt, wie die Daten in ihren PivotTables verwendet werden. Weitere Informationen finden Sie unter: Beziehungen zwischen Tabellen in einem Datenmodell .

    • Die Verbinder zeigen nur an, dass es eine Beziehung zwischen Tabellen gibt. Sie zeigen nicht an, welche Felder miteinander verknüpft sind. Um die Links anzuzeigen, wechseln Sie zu Power Pivot > Verwalten > Entwurf > Beziehungen > Beziehungen verwalten. In Excel können Sie zu Daten > Beziehungen wechseln.

Verwenden eines DatenModells zum Erstellen einer PivotTable oder eines PivotCharts

Eine Excel-Arbeitsmappe kann nur ein DatenModell enthalten, aber dieses Modell enthält mehrere Tabellen, die in der gesamten Arbeitsmappe wiederholt verwendet werden können. Sie können einem vorhandenen DatenModell jederzeit weitere Tabellen hinzufügen.

  1. Navigieren Sie in Power Pivotzu Manage.

  2. Wählen Sie auf der Registerkarte Start die Option PivotTable aus.

  3. Wählen Sie die Position aus, an der die PivotTable platziert werden soll: ein neues Arbeitsblatt oder die aktuelle Position.

  4. Klicken Sie auf OK, und Excel fügt eine leere PivotTable hinzu, wobei der Bereich Feldliste auf der rechten Seite angezeigt wird.

    Power Pivot PivotTable-feldListe

Erstellen Sie als nächstes eine PivotTable, oder Erstellen Sie ein Pivot-Diagramm. Wenn Sie bereits Beziehungen zwischen den Tabellen erstellt haben, können Sie alle Felder in der PivotTable verwenden. Wir haben bereits Beziehungen in der Beispielarbeitsmappe "StudentenDaten Modell" erstellt.

Hinzufügen von vorhandenen, nicht verknüpften Daten zu einem Datenmodell

Angenommen, Sie haben viele Daten importiert oder kopiert, die Sie in einem Modell verwenden möchten, die Sie jedoch nicht zum DatenModell hinzugefügt haben. Das Verschieben neuer Daten in ein Modell ist einfacher als Sie denken.

  1. Wählen Sie zunächst eine beliebige Zelle innerhalb der Daten aus, die Sie dem Modell hinzufügen möchten. Dabei kann es sich um einen beliebigen Datenbereich handeln, die Daten, die als Excel-Tabelle formatiert werden, sind jedoch am besten geeignet.

  2. Fügen Sie die Daten mithilfe eines der folgenden Verfahren hinzu:

  3. Klicken Sie auf Power Pivot > Zu Datenmodell hinzufügen.

  4. Klicken Sie auf Einfügen > PivotTable, und aktivieren Sie dann im Dialogfeld "PivotTable erstellen" die Option Dem Datenmodell diese Daten hinzufügen.

Jetzt wird der Bereich oder die Tabelle dem Modell als verknüpfte Tabelle hinzugefügt. Weitere Informationen zum Arbeiten mit verknüpften Tabellen in einem Modell finden Sie unter Hinzufügen von Daten mit verknüpften Excel-Tabellen in Power Pivot.

Hinzufügen von Daten zu einer Power Pivot-Tabelle

In Power Pivot können Sie keine Zeile zu einer Tabelle hinzufügen, indem Sie eine neue Zeile wie in einem Excel-Arbeitsblatt direkt eingeben. Sie können jedoch Zeilen hinzufügen, indem Sie die Quelldaten Kopieren und Einfügenoder aktualisieren und das Power Pivot-Modellaktualisieren.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Siehe auch

Lernpfade für abrufen und transFormieren und Power Pivot

Einführung in den Abfrage-Editor (Power Query)

Erstellen eines Speicher effizienten DatenModells mithilfe von Excel und Power Pivot

LernProgramm: Importieren von Daten in Excel und Erstellen eines DatenModells

Feststellen, welche Datenquellen im Datenmodell einer Arbeitsmappe verwendet werden

Beziehungen zwischen Tabellen in einem Datenmodell

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×