PivotTables

Erstellen einer PivotTable zum Analysieren von Arbeitsblattdaten

Erstellen einer PivotTable zum Analysieren von Arbeitsblattdaten

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Eine PivotTable ist ein leistungsfähiges Tool zum Berechnen, Zusammenfassen und Analysieren von Daten, mit dem Sie Vergleiche vornehmen sowie Muster und Trends in Ihren Daten erkennen können.

Ihr Browser unterstützt kein Video. Installieren Sie Microsoft Silverlight, Adobe Flash Player oder Internet Explorer 9.

Erstellen einer PivotTable

  1. Wählen Sie die Zellen aus, aus denen Sie eine PivotTable erstellen möchten.

    Hinweis: Ihre Daten sollten keine leeren Zeilen oder Spalten enthalten. Es darf nur eine einzeilige Überschrift vorhanden sein.

  2. Wählen Sie Einfügen > PivotTable aus.

    PivotTable

  3. Wählen Sie unter Wählen Sie die zu analysierenden Daten aus die Option Tabelle oder Bereich auswählen aus.

    PivotTable

  4. Überprüfen Sie in Tabelle/Bereich den Zellbereich.

  5. Wählen Sie unter Legen Sie fest, wo der PivotTable-Bericht abgelegt werden soll den Eintrag Neues Arbeitsblatt aus, um die PivotTable auf einer neuen Arbeitsblattregisterkarte einzufügen. Sie können auch auf Vorhandenes Arbeitsblatt klicken und dann die Position auswählen, an der die PivotTable angezeigt werden soll.

  6. Wählen Sie OK aus.

Erweitern der PivotTable

  1. Wenn Sie Ihrer PivotTable ein Feld hinzufügen möchten, aktivieren Sie im Bereich PivotTables-Felder das Kontrollkästchen für den Feldnamen.

    Hinweis: Ausgewählte Felder werden dem jeweiligen Standardbereich hinzugefügt: Nicht numerische Felder werden dem Bereich Zeilen, Datums- und Uhrzeithierarchien dem Bereich Spalten und numerische Felder dem Bereich Werte hinzugefügt.

    PivotTable

  2. Wenn Sie ein Feld aus einem Bereich in einen anderen verschieben möchten, ziehen Sie es in den Zielbereich.

Vor Beginn:

  • Die Daten müssen in einem tabellarischen Format angeordnet sein, und es darf keine leeren Zeilen oder Spalten geben. Im Idealfall können Sie eine Excel-Tabelle verwenden (wie im obigen Beispiel).

  • Tabellen sind eine hervorragende PivotTable-Datenquelle, weil Zeilen, die einer Tabelle hinzugefügt wurden, automatisch in die PivotTable einbezogen werden, wenn Sie die Daten aktualisieren. Außerdem wird jede neue Spalte in die Liste PivotTable-Felder aufgenommen. Andernfalls müssen Sie entweder den Datenquellenbereich manuell aktualisieren oder eine dynamische benannte Bereichsformel verwenden.

  • Datentypen in Spalten müssen identisch sein. Beispielsweise sollten Sie keine Datumswerte und Text in derselben Spalte kombinieren.

  • In einer PivotTable wird eine als Cache bezeichnete Momentaufnahme der jeweiligen Daten verarbeitet, sodass die tatsächlichen Daten in keiner Weise geändert werden.

Erstellen einer PivotTable

Wenn Sie nur über geringe Erfahrungen mit PivotTables verfügen oder nicht genau wissen, wie die ersten Schritte ausgeführt werden, ist eine empfohlene PivotTable eine gute Option. Wenn Sie dieses Feature verwenden, legt Excel ein aussagekräftiges Layout fest, indem es die Daten mit den geeignetsten Bereichen in der PivotTable abgleicht. Auf diese Weise erhalten Sie einen guten Ausgangspunkt für zusätzliche Experimente. Nachdem eine empfohlene PivotTable erstellt wurde, sollten Sie unterschiedliche Ausrichtungen untersuchen und Felder neu anordnen, um Ihre spezifischen Ergebnisse zu erzielen.

Sie können auch unser interaktives Tutorial Erstellen Sie Ihre erste PivotTable herunterladen.

Empfohlene PivotTable

Manuelles Erstellen einer PivotTable

  1. Klicken Sie auf eine Zelle im Quelldaten- oder Tabellenbereich.

  2. Wechseln Sie zu Einfügen > Empfohlene PivotTable.

    Wechseln Sie zu "Einfügen" > "empfohlene PivotTables", damit Excel eine PivotTable für Sie erstellt.

  3. Excel analysiert die Daten und bietet Ihnen mehrere Optionen an, so wie in diesem Beispiel das Verwenden der Daten der Haushaltsausgaben.

    Excel-Dialogfeld "Empfohlene PivotTables"
  4. Wählen Sie die PivotTable aus, die für Sie am besten geeignet ist, und wählen Sie OK aus. Excel erstellt die PivotTable auf einem neuen Blatt und zeigt die Liste PivotTable-Felder an.

  1. Klicken Sie auf eine Zelle im Quelldaten- oder Tabellenbereich.

  2. Wechseln Sie zu Einfügen > PivotTable.

    Wenn Sie mit Excel für Mac 2011 oder früher arbeiten, befindet sich die Schaltfläche "PivotTable" auf der Registerkarte Daten in der Gruppe Analyse.

    Registerkarte "Daten", Gruppe "Analyse"

  3. Excel zeigt das Dialogfeld PivotTable erstellen an, in dem der Bereichs- oder Tabellenname ausgewählt ist. In diesem Fall wird eine Tabelle namens "tbl_HouseholdExpenses" verwendet.

  4. Wählen Sie im Abschnitt Legen Sie fest, wo der PivotTable-Bericht abgelegt werden soll die Option Neues Arbeitsblatt oder Vorhandenes Arbeitsblatt aus. Wählen Sie bei Vorhandenes Arbeitsblatt die Zelle aus, ab der Sie die PivotTable platzieren möchten.

  5. Klicken Sie auf OK. Excel erstellt dann eine leere PivotTable und zeigt die Liste PivotTable-Felder an.

Aktivieren Sie im oben befindlichen Bereich Feldname das Kontrollkästchen für jedes Feld, das Sie Ihrer PivotTable hinzufügen möchten. Standardmäßig werden nicht numerische Felder dem Bereich Zeile, Datums- und Uhrzeitfelder dem Bereich Spalte und numerische Felder dem Bereich Werte hinzugefügt. Sie können auch jedes verfügbare Element manuell per Drag & Drop in jedes der PivotTable-Felder übernehmen, oder Sie können, wenn Sie ein Element nicht mehr in der PivotTable haben möchten, dieses einfach aus der Liste der Felder ziehen oder deaktivieren. Die Möglichkeit, Feldelemente neu anzuordnen, ist eines der PivotTable-Features, die es so einfach machen, das Erscheinungsbild einer PivotTable zu ändern.

Liste "PivotTable-Felder"

Entsprechende Felder in einer PivotTable

Beispiel für das Excel-Listendialogfeld "PivotTable-Felder"



Beispiel für eine PivotTable und die Korrelation der Felder mit der Liste "Felder"

  • Zusammenfassen nach

    Standardmäßig werden PivotTable-Felder, die im Bereich Werte platziert sind, als SUMME angezeigt. Wenn Excel die Daten als Text interpretiert, werden sie als ANZAHL angezeigt. Dies ist der Grund, warum sichergestellt sein muss, dass Datentypen für Wertfelder nicht kombiniert werden. Sie können die Standardberechnung ändern, indem Sie zuerst auf den Pfeil rechts neben dem Feldnamen klicken und dann die Option Feldeinstellungen auswählen.

    Ändern Sie danach die Berechnung im Abschnitt Werte zusammenfassen nach. Wenn Sie die Berechnungsmethode ändern, wird sie von Excel automatisch im Abschnitt Benutzerdefinierter Name hinzugefügt, etwa "Summe von Feldname", aber Sie können den Namen ändern. Wenn Sie auf die Schaltfläche Zahlenformat... klicken, können Sie das Zahlenformat für das gesamte Feld ändern.

    Tipp: Da ein Ändern der Berechnung im Abschnitt Werte zusammenfassen nach dazu führt, dass der PivotTable-Feldname geändert wird, sollten Sie Ihre PivotTable-Felder erst umbenennen, nachdem Sie Ihre PivotTable fertig eingerichtet haben. Eine Möglichkeit besteht darin, auf Ersetzen (im Menü "Bearbeiten") > Suchen nach > "Summe von" zu klicken und dann Ersetzen durch leer zu lassen. So können Sie alle Namen auf einmal ersetzen, statt sie manuell erneut eingeben zu müssen.

  • Daten anzeigen als

    Statt die Daten über eine Berechnung zusammenzufassen, können Sie sie auch als Prozentsatz eines Felds anzeigen. Im folgenden Beispiel wurde die Anzeige der Beträge der Haushaltsausgaben so geändert, dass sie als % der Gesamtsumme statt als Summe der Werte angezeigt werden.

    Beispiel für eine PivotTable, in der die Werte als Prozentsatz der Gesamtsumme angezeigt werden

    Sobald Sie das Dialogfeld Feldeinstellungen geöffnet haben, können Sie die Optionen auf der Registerkarte Daten anzeigen als festlegen.

  • Anzeigen eines Werts als Berechnung und als Prozentsatz

    Ziehen Sie das Element einfach zweimal in den Abschnitt Werte, klicken Sie mit der rechten Maustaste auf den Wert, und wählen Sie Feldeinstellungen aus. Legen Sie dann für jeden der Werte die Optionen Zusammenfassen nach und Daten anzeigen als fest.

Wenn Sie neue Daten zu Ihrer PivotTable-Datenquelle hinzufügen, müssen alle aus der Datenquelle erstellten PivotTables aktualisiert werden. Um nur eine PivotTable zu aktualisieren, klicken Sie mit der rechten Maustaste auf eine beliebige Stelle im PivotTable-Bereich, und wählen Sie Aktualisieren aus. Wenn mehrere PivotTables vorhanden sind, wählen Sie zuerst eine beliebige Zelle in einer beliebigen PivotTable aus, und navigieren Sie im Menüband zu PivotTable analysieren. Klicken Sie dann auf den Pfeil unter der Schaltfläche Aktualisieren, und wählen Sie Alle aktualisieren aus.

Wenn Sie eine PivotTable erstellt haben, aber dann entscheiden, dass Sie sie nicht mehr benötigen, können Sie einfach den gesamten PivotTable-Bereich markieren und Löschen auswählen. Dies hat keine Auswirkungen auf andere Daten, PivotTables oder Diagramme im Umfeld der PivotTable. Befindet sich die PivotTable auf einem separaten Arbeitsblatt, das keine weiteren Daten enthält, die erhalten bleiben sollen, ist das Löschen dieses Arbeitsblatts eine schnelle Art, die PivotTable zu entfernen.

Sie können jetzt in Excel Online eine PivotTable in Ihre Kalkulationstabelle einfügen.

Wichtig: PivotTables sollten in einer Kalkulationstabelle allerdings nicht erstellt oder bearbeitet werden, wenn andere Benutzer gleichzeitig daran arbeiten.

  1. Wählen Sie die Tabelle oder den Bereich in Ihrer Kalkulationstabelle aus.

  2. Wechseln Sie zu Einfügen > PivotTable.

  3. Excel zeigt das Dialogfeld PivotTable erstellen an, in dem der Bereichs- oder Tabellenname ausgewählt ist.

    Erstellen einer PivotTable
  4. Wählen Sie im Abschnitt Legen Sie fest, wo der PivotTable-Bericht abgelegt werden soll die Option Neues Arbeitsblatt oder Vorhandenes Arbeitsblatt aus. Wählen Sie bei Vorhandenes Arbeitsblatt die Zelle aus, ab der Sie die PivotTable platzieren möchten.

    Hinweis: Die Zelle, auf die Sie Bezug nehmen, sollte außerhalb der Tabelle oder des Bereichs liegen.

  5. Klicken Sie auf OK. Excel erstellt dann eine leere PivotTable und zeigt die Liste PivotTable-Felder an.

Aktivieren Sie im Bereich PivotTable-Felder oben das Kontrollkästchen für jedes Feld, das Sie Ihrer PivotTable hinzufügen möchten. Standardmäßig werden nicht numerische Felder dem Bereich Zeile, Datums- und Uhrzeitfelder dem Bereich Spalte und numerische Felder dem Bereich Werte hinzugefügt. Sie können auch jedes verfügbare Element manuell per Drag & Drop in jedes der PivotTable-Felder übernehmen, oder Sie können ein Element, das Sie nicht mehr in der PivotTable haben möchten, einfach aus der Liste "Felder" ziehen oder deaktivieren. Die Möglichkeit, Feldelemente neu anzuordnen, ist eines der PivotTable-Features, die es so einfach machen, das Erscheinungsbild einer PivotTable zu ändern.

Liste "PivotTable-Felder"

Entsprechende Felder in einer PivotTable

Beispiel für das Excel-Listendialogfeld "PivotTable-Felder"



Beispiel für eine PivotTable und die Korrelation der Felder mit der Liste "Felder"

  • Werte zusammenfassen nach

    Standardmäßig werden PivotTable-Felder, die im Bereich Werte platziert sind, als SUMME angezeigt. Wenn Excel die Daten als Text interpretiert, werden sie als ANZAHL angezeigt. Dies ist der Grund, warum sichergestellt sein muss, dass Datentypen für Wertfelder nicht kombiniert werden. Sie können die Standardberechnung ändern, indem Sie zuerst auf den Pfeil rechts neben dem Feldnamen klicken und dann die Option Wertfeldeinstellungen auswählen.

    Excel-Dialogfeld "Wertfeldeinstellungen"

    Ändern Sie danach die Berechnung im Abschnitt Werte zusammenfassen nach. Wenn Sie die Berechnungsmethode ändern, wird diese von Excel automatisch im Abschnitt Benutzerdefinierter Name hinzugefügt, etwa "Summe von Feldname", aber Sie können den Namen ändern. Wenn Sie auf die Schaltfläche Zahlenformat klicken, können Sie das Zahlenformat für das gesamte Feld ändern.

    Excel-Dialogfeld "Wertfeldeinstellungen" für "Werte zusammenfassen nach"-Optionen

    Tipp: Da ein Ändern der Berechnung im Bereich Werte zusammenfassen nach dazu führt, dass der PivotTable-Feldname geändert wird, sollten Sie Ihre PivotTable-Felder erst umbenennen, nachdem Sie Ihre PivotTable fertig eingerichtet haben. Eine Möglichkeit besteht darin, Suchen und Ersetzen (STRG+H) > Suchen nach > Summe von zu verwenden und Ersetzen durch leer zu belassen. So können Sie alle Namen auf einmal ersetzen, statt sie manuell erneut einzugeben.

  • Werte anzeigen als

    Statt die Daten über eine Berechnung zusammenzufassen, können Sie sie auch als Prozentsatz eines Felds anzeigen. Im folgenden Beispiel wurde die Anzeige der Beträge der Haushaltsausgaben so geändert, dass sie als % der Gesamtsumme statt als Summe der Werte angezeigt werden.

    Beispiel für eine PivotTable, in der die Werte als Prozentsatz der Gesamtsumme angezeigt werden

    Sobald Sie das Dialogfeld Wertfeldeinstellungen geöffnet haben, können Sie die Optionen auf der Registerkarte Werte anzeigen als festlegen.

    PivotTable-Wertfeldeinstellungen > Dialogfeld "Werte anzeigen als"
  • Anzeigen eines Werts als Berechnung und als Prozentsatz

    Ziehen Sie das Element einfach zweimal in den Abschnitt Werte, und legen Sie dann für jeden der Werte die Optionen Werte zusammenfassen nach und Werte anzeigen als fest.

Wenn Sie Ihrer PivotTable-Datenquelle neue Daten hinzufügen, müssen alle PivotTables, die aus der Datenquelle erstellt wurden, aktualisiert werden.Um die PivotTable zu aktualisieren, können Sie mit der rechten Maustaste auf eine beliebige Stelle im PivotTable-Bereich klicken und dann Aktualisieren auswählen.

Aktualisieren einer PivotTable

Wenn Sie eine PivotTable erstellt haben, aber dann entscheiden, dass Sie sie nicht mehr benötigen, können Sie einfach den gesamten PivotTable-Bereich markieren und Löschen auswählen. Dies hat keine Auswirkungen auf andere Daten, PivotTables oder Diagramme im Umfeld der PivotTable. Befindet sich die PivotTable auf einem separaten Arbeitsblatt, das keine weiteren Daten enthält, die erhalten bleiben sollen, ist das Löschen dieses Arbeitsblatts eine schnelle Art, die PivotTable zu entfernen.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Siehe auch

Erstellen eines PivotCharts

Verwenden von datenschnitten zum Filtern von PivotTable-Daten

Erstellen einer PivotTable-Zeitachse zum Filtern von Datumswerten

Erstellen einer PivotTable mit dem Datenmodell zum Analysieren von Daten in mehreren Tabellen

Verwenden der Feldliste zum Anordnen von Feldern in einer PivotTable

Ändern der Quelldaten einer PivotTable

Berechnen von Werten in einer PivotTable

Löschen einer PivotTable

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×