Erstellen einer Asset Tracker-Lösung mithilfe von InfoPath und Excel

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Microsoft Office InfoPath ermöglicht Ihnen das Erstellen von Formularvorlagen für die Dateneingabe und-Sammlung. Microsoft Office Excel 2007 ermöglicht es Benutzern, Daten zu berechnen, zu chartern und zu analysieren. Indem Sie beide Programme und XML verwenden, können Sie ganz einfach eine einfache, aber effektive, nicht-Code-Geschäftslösung für die Nachverfolgung von Ressourcen in einem Unternehmen erstellen.

Überblick einer Lösung für das Nachverfolgen von Posten

Inhalt dieses Artikels

Einführung in das Erstellen einer Asset Tracker-Lösung

Schritt 1: Anpassen der Formularvorlage "Asset Tracker"

Schritt 2: Zuordnen der Schemadatei und Anpassen des Tabellenlayouts in Excel

Schritt 3: Erstellen eines PivotTable-und PivotChart-Zusammenfassungsberichts

Schritt 4: Erfassen von Ressourceninformationen von Benutzern

Schritt 5: Importieren von Formularen in Excel

Abschließende Gedanken: erwägen der Verwendung einer SharePoint-Liste oder einer Access-Datenbank

Einführung in das Erstellen einer Asset Tracker-Lösung

Sie können XML-Daten zwischen InfoPath und Excel austauschen. Obwohl es sich bei dem Befehl zum exportieren von InfoPath um eine einfache und einfache Möglichkeit zum Senden von Formulardaten an Excel handelt, gibt es einen anderen Ansatz, der Ihnen viel mehr Flexibilität bietet. Indem Sie die InfoPath-XML-Schemadatei (XSD) in Excel explizit zuordnen und dann InfoPath-Formulardateien (XML) in Excel importieren, können Sie das Layout Ihrer Daten anpassen und die Features in Excel besser nutzen, um Sie bei der effizienten Verwaltung und Analyse Ihrer Daten zu unterstützen.

In diesem Artikel verwenden wir die InfoPath Asset Tracker-Beispielformularvorlage, um zu veranschaulichen, wie Sie die Zusammenarbeit von InfoPath, XML und Excel vereinfachen können. Stellen Sie sich vor, dass Ihre Organisation jedes Jahr Ressourcen in jedem Mitarbeiter Büro inventarisiert. Anschließend wird ein Excel-Bericht ausgeführt, um zu entscheiden, wie das Geräte Budget für das nächste Jahr zugewiesen werden soll. Das folgende Diagramm bietet eine Übersicht darüber, wie Sie Ressourcendaten in Ihrer Abteilung sammeln, nachverfolgen und melden können.

a

1. die Formularvorlage "Asset Tracker" wird erstellt.

2. die Schemadatei wird einer Excel-Tabelle zugeordnet, und das Tabellenlayout ist angepasst.

3. es wird ein leeres PivotTable-und PivotChart-Zusammenfassungsbericht erstellt.

4. das Asset Tracker-Formular wird verwendet, um Daten von Benutzern zu sammeln.

5. alle Formulardaten werden in die Excel-Tabelle exportiert, und die PivotTable-und PivotChart-Berichte werden aktualisiert.

Diese Lösung umfasst die folgenden Benutzerrollen und Produkte:

Symbol 'Vollständige Unterstützung' = Erforderliches Symbol 'Keine Unterstützung' = nicht erforderlich

Software Anforderungen

Rollen

Office InfoPath 2007

Office Outlook 2007

Office Excel 2007

Lösungs-Designer

Symbol 'Vollständige Unterstützung'

Symbol 'Vollständige Unterstützung'

Symbol 'Vollständige Unterstützung'

Entscheidungsträger

Symbol 'Vollständige Unterstützung'

Symbol 'Vollständige Unterstützung'

Symbol 'Vollständige Unterstützung'

Employees

Symbol 'Vollständige Unterstützung'

Symbol 'Vollständige Unterstützung'

Symbol 'Keine Unterstützung'

Seitenanfang

Schritt 1: Anpassen der Formularvorlage "Asset Tracker"

Mit der Formularvorlage "Asset Tracker", die in InfoPath enthalten ist, können Sie Informationen zu den einzelnen Ressourcen im Büro eines Mitarbeiters, zu der Abteilung, der der Mitarbeiter gehört, zu Kategorien von Ressourcen und zu Details zu den einzelnen Ressourcen sammeln. In dieser Lösung sendet ein Formulardesigner die Formularvorlage mithilfe von Office Outlook 2007 an das e-Mail-Konto des Entscheidungsträgers.

Vorlage für die Bestandsnachverfolgung

Aufgabe 1: Öffnen und Anpassen der Formularvorlage "Asset Tracker"

Da eine Formularvorlage nicht in einer Liste von e-Mail-Empfängern veröffentlicht werden kann, wenn Sie über ein Rich-Text-Feld-Steuerelement mit verknüpften Bildern verfügt, müssen Sie eine kleine Änderung am Formular "Asset Tracker-Beispielvorlage" vornehmen.

  1. Klicken Sie im Menü Datei auf Formularvorlage entwerfen.

  2. Klicken Sie im Dialogfeld Formularvorlage entwerfen unter Formularvorlage öffnen auf Beispiel anpassen.

  3. Klicken Sie im Dialogfeld Erste Schritte auf Sample-Asset Tracker, und klicken Sie dann unter Formularaufgaben auf dieses Formular entwerfen.

  4. Klicken Sie mit der rechten Maustaste auf das Steuerelement assetNotes, zeigen Sie auf Eigenschaften für Rich-Text-Feld, klicken Sie auf die Registerkarte Anzeige, und deaktivieren Sie dann unter Verfügbare Formatierung das Kontrollkästchen verknüpfte Bilder.

Aufgabe 2: Definieren der Übermittlungsoptionen

Als nächste Aufgabe müssen die Submit-Optionen definiert werden, damit die Mitarbeiter eine eindeutig benannte Formulardatei (XML) an das e-Mail-Konto des Entscheidungsträgers als angefügte Datei übermitteln können.

  1. Klicken Sie im Menü Extras auf Optionen zum Absenden.

  2. Aktivieren Sie im Dialogfeld Optionen für Absenden das Kontrollkästchen Benutzern das Senden dieses Formulars gestatten.

  3. Klicken Sie auf Formulardaten an ein einzelnes Ziel senden, und klicken Sie dann in der Liste auf E-Mail.

  4. Klicken Sie auf Hinzufügen.

    Der Datenverbindungs- Assistent wird angezeigt.

  5. Geben Sie im Feld an den Alias des Entscheidungs Machers ein, der alle gesendeten Formulare erhalten soll.

  6. Um eine eindeutige Betreffzeile anzugeben, wählen Sie im Feld Betreff Folgendes aus:

    • Klicken Sie auf Formel Formelschaltfläche einfügen.

    • Geben Sie die folgende Formel ein:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  • Klicken Sie auf Formel überprüfen, und klicken Sie dann zweimal auf OK.

  • Geben Sie im Feld Einführung eine entsprechende Nachricht ein, oder fügen Sie wichtige Anweisungen für diese Lösung hinzu.

  • Klicken Sie auf Weiter.

  • Klicken Sie auf der nächsten Seite des Assistenten auf Formulardaten als Anlage senden, und wählen Sie dann die Formularvorlage anfügen aus, um sicherzustellen, dass Benutzer das Formular über das Kontrollkästchen öffnen können.

    Dadurch wird sichergestellt, dass Mitarbeiter auf die Formularvorlagendatei (XSN) zugreifen können, wenn Sie nicht über die Netzwerkadresse des Formulars darauf zugreifen können.

  • So geben Sie einen eindeutigen Dateinamen für jede Formulardatei (XML) im Feld Anlagenname an:

    1. Klicken Sie auf Formel Formelschaltfläche einfügen.

    2. Geben Sie die gleiche Formel wie in der Betreffzeile ein:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  1. Klicken Sie auf Formel überprüfen, und klicken Sie dann zweimal auf OK.

  • Klicken Sie auf Weiter.

  • Geben Sie auf der nächsten Seite des Assistenten im Feld Geben Sie einen Namen für die Datenverbindung ein einen aussagekräftigen Namen für diese Datenverbindung ein.

  • Überprüfen Sie, ob die Informationen im Abschnitt Zusammenfassung korrekt sind, und klicken Sie dann auf Fertig stellen.

  • Speichern Sie das Formular in einem öffentlichen Netzwerkordner, auf den der Entscheidungsträger und alle Mitarbeiter zugreifen können.

Seitenanfang

Schritt 2: Zuordnen der Schemadatei und Anpassen des Tabellenlayouts in Excel

Zum Einrichten der Verbindung zwischen InfoPath und Excel sind drei Aufgaben erforderlich: Extrahieren der Schemadatei für die Asset Tracker-Formularvorlage, Zuordnen dieser Schemadatei in Excel und Anpassen des Standardlayouts der Excel-Tabelle, die alle importierten XML-Dateien enthalten soll Formulardaten Dateien.

Aufgabe 1: Extrahieren der Schemadatei aus InfoPath

  1. Öffnen Sie in InfoPath die Datei Asset Tracker-Formularvorlage.

  2. Klicken Sie im Menü Extras auf dieses Formular entwerfen.

  3. Klicken Sie im Menü Datei auf als Quelldateien speichern.

  4. Wählen Sie im Dialogfeld Ordner suchen einen Ordner aus, oder erstellen Sie einen neuen Ordner, in dem die Schemadatei gespeichert werden soll.

Notieren Sie sich den Speicherort des Ordners, in dem alle Quelldateien gespeichert sind, und den Namen der Schemadatei, in diesem Fall MySchema. xsd, die die Schema Definition der Formular-XML-Daten enthält.

Aufgabe 2: Zuordnen der InfoPath-Schemadatei in Excel

  1. Erstellen Sie eine neue Excel-Datei, und speichern Sie Sie dann an einem Speicherort, auf den der Entscheidungsträger zugreifen kann.

  2. Wenn die Registerkarte Entwicklertools in Excel nicht angezeigt wird, führen Sie die folgenden Schritte aus:

    1. Klicken Sie auf die Microsoft Office-Schaltfläche Abbildung der Office-Schaltfläche , und klicken Sie dann auf Excel-Optionen.

    2. Aktivieren Sie in der Kategorie Häufig verwendet unter Die am häufigsten verwendeten Optionen bei der Arbeit mit Excel das Kontrollkästchen Registerkarte "Entwicklertools" in der Multifunktionsleiste anzeigen, und klicken Sie dann auf OK.

      Hinweis: Das Menüband ist Bestandteil der Microsoft Office Fluent-Benutzeroberfläche.

  3. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe XML auf Quelle.

    Gruppe 'XML' im Menüband

    Der Aufgabenbereich XML-Quelle wird angezeigt.

  4. Klicken Sie auf XML-Zuordnungen, und klicken Sie dann im Dialogfeld XML-Zuordnungen auf Hinzufügen.

  5. Auf einem Computer unter Windows Vista   

    1. Klicken Sie in der Adressleiste auf das Laufwerk oder den Ordner mit der Datei "MySchema . xsd ", die Sie in Schritt 2 des Abschnitts, Aufgabe 1: Extrahieren der Schemadatei aus InfoPath, erstellt haben.

      Auf einem Computer, auf dem Microsoft Windows XP ausgeführt wird   

    2. Klicken Sie in der Liste Suchen in auf das Laufwerk oder den Ordner mit der Datei "MySchema . xsd ", die Sie in Schritt 2 des Abschnitts, Aufgabe 1: Extrahieren der Schemadatei aus InfoPath, erstellt haben.

  6. Klicken Sie auf die Datei und dann auf Öffnen.

  7. Wenn das Dialogfeld mehrere Stämme angezeigt wird, klicken Sie auf den assetTracking-Stammknoten, der in der Datei "MySchema. xsd" definiert ist, und klicken Sie dann auf OK.

    Im Aufgabenbereich XML-Quelle wird die XML-Zuordnung angezeigt.

  8. Ziehen Sie das ns1: Asset-Knotenelement, das ein sich wiederholendes XML-Element ist, in das Arbeitsblatt, in dem die Excel-Tabelle angezeigt werden soll.

    Zuordnen der InfoPath-Schemadatei in Excel

Aufgabe 3: Anpassen des Layouts der Excel-Tabelle

Standardmäßig verwendet Excel die XML-Elementnamen als Spaltenüberschriften für die Tabelle. Sie können jedoch die Spaltenüberschriften ändern, indem Sie die Spalten Überschriftenzellen bearbeiten.

  1. Wenn Sie die Standardspalten Überschriften ändern möchten, führen Sie die ausgewählte Excel-Tabelle aus, suchen Sie das folgende Zeichenfolgen Präfix ns1: Asset, und entfernen Sie es. Beispielsweise ändern Sie ns1: Asset-ID in ID.

    Anpassen der Excel-Tabellenüberschriften

  2. Wenn Sie die Spaltenbreite anpassen möchten, klicken Sie auf die Schaltfläche Alles auswählen, und doppelklicken Sie dann auf eine beliebige Spaltenüberschrift.

Seitenanfang

Schritt 3: Erstellen eines PivotTable-und PivotChart-Zusammenfassungsberichts

Entscheidungsträger verwenden PivotTable-und PivotChart-Berichte, um Zusammenfassungsdaten zu analysieren, zu erforschen und zu visualisieren. Wenn Sie die PivotTable-und PivotChart-Berichte, die Sie in diesem Szenario verwenden möchten, vorab einrichten, ist es eine einfache Operation für einen Entscheidungsträger, den Bericht mit den abgeschlossenen Daten zu einem späteren Zeitpunkt auszuführen.

  1. Markieren Sie eine Zelle in der Excel-Tabelle.

  2. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Tabellen auf PivotTable, und klicken Sie dann auf PivotTable.

    Abbildung des Excel-Menübands

    Das Dialogfeld PivotTable erstellen wird in Excel angezeigt.

  3. Wenn Sie den PivotTable-Bericht in einem neuen Arbeitsblatt ab Zelle a1 platzieren möchten, klicken Sie auf Neues Arbeitsblatt, und klicken Sie dann auf OK.

    Excel fügt der angegebenen Position einen leeren PivotTable-Bericht hinzu und zeigt die PivotTable-Feldliste an, sodass Sie Felder hinzufügen, ein Layout erstellen und den PivotTable-Bericht anpassen können.

  4. Um einen tabellarischen Bericht der Daten zu erstellen, ziehen Sie das ID- Feld in den Wertebereich, das Feld " Abteilung " zum Bereich "Spaltenbeschriftungen", das Feld " Kategorie " zum Bereich "Zeilenbeschriftungen" und das Feld " ' ZugewiesenAn ' " in den Berichts Filter Bereich.

  5. Klicken Sie auf den PivotTable-Bericht.

  6. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Diagramme auf den Balken Diagrammtyp.

    Abbildung des Excel-Menübands

  7. Wählen Sie unter 2D-Balken die Option gruppierte Balken aus.

  8. Passen Sie die Größe und den Speicherort des PivotChart-Berichts an Ihre Vorlieben an.

Leere PivotTable- und PivotChart-Berichte

Seitenanfang

Schritt 4: Erfassen von Ressourceninformationen von Benutzern

Damit die Formularvorlage von allen Mitarbeitern ausgefüllt werden kann, müssen Sie das Formular veröffentlichen und an jeden Mitarbeiter senden. Wenn jeder Mitarbeiter das ausgefüllte Formular übermittelt hat, wird er als XML-Datendatei (XML) an eine e-Mail-Nachricht an das e-Mail-Konto des Entscheidungsträgers gesendet. Der Entscheidungsträger kann dann alle Nachrichten in einen dedizierten InfoPath-Ordner in Outlook verschieben. In diesem Szenario wird empfohlen, dass Sie für alle Benutzer einen bestimmten Zeitraum zuweisen, um die Formulare auszufüllen, damit der Entscheidungsträger den Bericht mit allen ausgefüllten Formularen ausführen kann, wenn der Stichtag für die Datenerfassung erreicht wurde.

Eingeben von Daten in die Bestandsnachverfolgungsformular

  1. Öffnen Sie in InfoPath die Formularvorlage (XSN), die Sie in Schritt 1: Entwerfen der Asset Tracker-Beispielformularvorlage gespeichert haben.

  2. Klicken Sie im Menü Extras auf dieses Formular entwerfen.

  3. Klicken Sie im Menü Datei auf veröffentlichen.

  4. Klicken Sie im Veröffentlichungs-Assistenten auf eine Liste der e-Mail-Empfänger, und klicken Sie dann auf weiter.

  5. Geben Sie auf der nächsten Seite des Assistenten im Feld Formularvorlagen Name einen Namen für die Formularvorlage ein, und klicken Sie dann auf weiter. Der Name der Formularvorlage wird in der Betreffzeile der Nachricht angezeigt, die an die Empfänger der e-Mail-Nachricht gesendet wird.

  6. Optional können Sie auf der nächsten Seite des Assistenten Spalten erstellen, die in Ihren Outlook-Ordnern angezeigt werden, um Ihre e-Mail-Nachrichten zu organisieren.

  7. Klicken Sie auf Weiter.

  8. Klicken Sie auf Veröffentlichen.

  9. Nachdem der Veröffentlichungs-Assistent die Veröffentlichung der Formularvorlage abgeschlossen hat, wird eine e-Mail-Nachricht mit dem Formular geöffnet.

  10. Füllen Sie die Nachricht aus, geben Sie die Namen der Mitarbeiter ein, oder verwenden Sie eine Verteilerliste, und senden Sie die Nachricht.

In Outlook kann der Entscheidungsträger alle gesendeten XML-Formulare auf eine von zwei Arten organisieren:

  • Wenn das Meldungsfeld " InfoPath-Formularordner " beim ersten Öffnen der Nachricht angezeigt wird, klicken Sie auf Formularordner erstellen.

  • Erstellen Sie in Outlook eine Regel, um alle zugehörigen InfoPath-Formulare in einen InfoPath-Ordner zu verschieben.

    Weitere Informationen finden Sie unter Verwalten von Nachrichten mithilfe von Regeln.

Seitenanfang

Schritt 5: Importieren von Formularen in Excel

Da Sie die Schritte 2 und 3 der Excel-Arbeitsmappe bereits erstellt haben, ist es eine einfache Angelegenheit für den Entscheidungsträger, die Formulardaten zu exportieren und zu überprüfen. Der Entscheidungsmacher muss einfach die XML-Dateien (. Xml) aus Outlook exportieren, alle Formulardateien (XML) in die Excel-Arbeitsmappe importieren und dann die Daten aktualisieren.

Aufgabe 1: Exportieren der Formulare aus Outlook in einen Windows-Ordner

  1. Wählen Sie in Outlook den Ordner aus, der alle Formulare enthält, die Sie von Mitarbeitern erhalten haben, und drücken Sie dann STRG + A, um alle e-Mail-Nachrichten des Formulars auszuwählen.

  2. Klicken Sie mit der rechten Maustaste auf die Auswahl, zeigen Sie auf InfoPath-Aktionen, und klicken Sie dann auf Formulare exportieren.

  3. Wählen Sie im Dialogfeld Formulare exportieren einen Ordner aus, und drücken Sie OK.

Aufgabe 2: Importieren der Formulare in Excel

  1. Wählen Sie in der Excel-Arbeitsmappe, die Sie in Schritt 2: Zuordnen der Schemadatei und Anpassen des Tabellenlayouts in Excelerstellt haben, eine der zugeordneten Zellen in der Excel-Tabelle aus.

  2. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe XML auf importieren.

    Gruppe 'XML' im Menüband

    Das Dialogfeld XML importieren wird angezeigt.

  3. Auf einem Computer unter Windows Vista   

  4. Führen Sie eine der folgenden Aktionen aus:

    • Wenn die Dateien zusammenhängend sind, drücken Sie die UMSCHALTTASTE, und klicken Sie dann auf die erste und die letzte Datei in der Liste.

    • Wenn die Dateien nicht zusammenhängend sind, drücken Sie STRG, und klicken Sie dann auf jede Datei, die Sie in die Liste importieren möchten.

  5. Klicken Sie auf Importieren.

    Excel-Tabelle mit importierten Daten

Standardmäßig werden in Excel alle vorhandenen Daten in den zugeordneten Zellen überschrieben, was das gewünschte Endergebnis für diese Geschäftslösung ist. Ein Entscheidungsträger könnte beispielsweise die Daten mehrmals importieren, um den Fortschritt vor dem geplanten Stichtag zu messen.

Hinweis: In Excel können Sie die Daten auch anfügen, indem Sie die Option neue Daten an vorhandene XML-Tabellen anfügen (auf der Registerkarte Entwicklertools in der Gruppe XML auf Karteneigenschaften ) klicken, die möglicherweise für andere Lösungen geeignet sind.

Weitere Informationen finden Sie unter Importieren von XML-Daten.

Aufgabe 3: Aktualisieren der PivotTable-und PivotChart-Berichte

  • Klicken Sie auf eine Zelle im PivotTable-Bericht.

  • Klicken Sie auf der Registerkarte Optionen in der Gruppe Daten auf den Pfeil neben Alle aktualisieren, und klicken Sie dann auf Aktualisieren.

    Outlook-Multifunktionsleiste

Endgültiger PivotTable- und PivotChart-Bericht

Die Excel-Arbeitsmappe enthält jetzt alle Daten und Zusammenfassungsberichte, die Sie bei der Zuteilung des Ausstattungs Budgets für das nächste Jahr unterstützen müssen. Selbstverständlich können Sie bei Bedarf weitere Analysen in Ihrer Excel-Arbeitsmappe durchführen, beispielsweise sortieren, Filtern oder bedingtes Formatieren der Daten.

Seitenanfang

Abschließende Gedanken: erwägen der Verwendung einer SharePoint-Liste oder einer Access-Datenbank

Alternativ können Sie eine SharePoint-Liste oder eine Access-Datenbank anstelle von XML verwenden, um Daten zwischen InfoPath und Excel zu übertragen.

Verwenden einer SharePoint-Liste

In InfoPath können Sie eine SharePoint-Liste ganz einfach als schreibgeschützte Datenquelle verwenden. Sie können eine der folgenden Aktionen ausführen:

  • Exportieren Sie die Daten in der SharePoint-Liste nach Excel, wodurch automatisch eine Datenverbindung in Excel erstellt wird.

  • Erstellen Sie in Excel explizit eine Datenverbindung mit der SharePoint-Liste.

Nachdem eine Datenverbindung erstellt wurde, können Sie die Daten in Excel aktualisieren, um aktuelle Daten abzurufen.

Sie können eine SharePoint-Liste zum Hinzufügen und Aktualisieren der Daten verwenden, indem Sie ein InfoPath-Formular verwenden, um ein Element aus der Liste anzuzeigen (beispielsweise ein komplexes oder langes Element, das am besten vertikal angezeigt wird), und dann Excel zum weiteren analysieren der Daten verwenden.

Kombinieren von InfoPath, einer SharePoint-Liste und Excel

1. Anzeigen eines einzelnen Elements zur einfachen Überprüfung in InfoPath

2. HinzuFügen und Aktualisieren von Daten in einer SharePoint-Liste

3. aktualisieren und melden Sie sich mit Excel auf dem neuesten Stand.

Weitere Informationen finden Sie unter Hinzufügen einer Datenverbindung zu einer SharePoint-Dokumentbibliothek oder-Liste .

Verwenden einer Access-Datenbank

In InfoPath können Sie eine Lese-/Schreibzugriff-Verbindung mit einer Access-Datenbank erstellen. In Excel können Sie explizit eine Datenverbindung mit der Access-Datenbank erstellen, die Sie aktualisieren können, um aktuelle Daten abzurufen. Sie können die Verbindung sogar definieren, damit Sie beim Öffnen der Arbeitsmappe automatisch aktualisiert oder periodisch aktualisiert wird, beispielsweise alle 5 Minuten.

Sie können eine Access-Datenbank als Vermittler zwischen InfoPath und Excel verwenden. Wenn Sie ein InfoPath-Formular für Access übermitteln, aktualisieren Sie die Access-Datenbank. Wenn Sie die Datenverbindung in Excel aktualisieren, rufen Sie aktualisierte Daten aus Access ab. Tatsächlich senden Sie Daten indirekt aus InfoPath an eine Excel-Arbeitsmappe.

Kombinieren von InfoPath, Access und Excel

1. anzeigen und Senden eines Formulars an eine Access-Datenbank

2. speichern Sie Daten in einer Access-Datenbank.

3. aktualisieren und melden Sie sich mit Excel auf dem neuesten Stand.

Weitere Informationen finden Sie unter Entwerfen einer Formularvorlage, die auf einer Microsoft Access-Datenbank basiert.

Tipp: Wussten Sie, dass Sie ein InfoPath-Formular direkt aus Access heraus erstellen können? Wenn Ihre Benutzer Outlook 2007 oder 2010 und InfoPath 2007 oder 2010 auf ihren Computern installiert haben, können Sie mithilfe des Assistenten zum Sammeln von Daten aus e-Mail-Nachrichten Daten von unterschiedlichen Benutzern direkt aus Access abrufen. Weitere Informationen finden Sie im Access-Hilfethema, Hinzufügen der per e-Mail erfassten Daten zu Ihrer Access-Datenbank.

Seitenanfang

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×