Zu Hauptinhalt springen

Erste Schritte mit Get #a0 Transform in Excel

Mit Get #a0 Transform in Excel können Sie nach Datenquellen suchen, Verbindungen herstellen und dann die Daten Formen (beispielsweise eine Spalte entfernen, einen Datentyp ändern oder Tabellen zusammenführen), die Ihren Anforderungen entsprechen. Nachdem Sie Ihre Daten modelliert haben, können Sie Ihre Ergebnisse freigeben oder Ihre Abfrage zum Erstellen von Berichten verwenden.

Herstellen einer Verbindung mit und Transformieren von Daten in Excel in 4 Schritten: 1-Connect, 2-Transform, 3-Combine und 4-Manage.

Diese Schritte erfolgen häufig in der folgenden Reihenfolge:

  • Verbinden: Stellen Sie Verbindungen mit Daten her, die sich in der Cloud, in einem Dienst oder in einem lokalen Verzeichnis befinden.

  • Transformieren: Modellieren Sie die Daten gemäß Ihren Anforderungen. Die ursprüngliche Quelle bleibt unverändert.

  • Kombinieren: Erstellen Sie ein Datenmodell aus mehreren Datenquellen, und erhalten Sie einen einzigartigen Einblick in die Daten.

  • Verwalten – sobald Ihre Abfrage abgeschlossen ist, können Sie Sie speichern, kopieren oder für Berichte verwenden.

Wenn Sie eine Verbindung mit Daten herstellen, Sie transformieren oder mit anderen Datenquellen kombinieren, wird für jeden Schritt eine Funktion von Get #a0 Transform mit dem Namen Abfrage-Editor aufgezeichnet, und Sie können Sie ändern, wie Sie möchten. Mit dem Abfrage-Editor können Sie auch rückgängig machen, wiederholen, die Reihenfolge ändern oder einen beliebigen Schritt ändern... alle damit können Sie Ihre Ansicht der verbundenen Daten so gestalten, wie Sie es wünschen.

Mit Abrufen und transformieren können Sie je nach Bedarf einfache oder komplexe Abfragen erstellen. Wenn Sie Schritte zu einer Abfrage hinzufügen, erstellt der Abfrage-Editor im Hintergrund eine Reihe von Einzelanweisungen zum Ausführen Ihrer Befehle. Diese Anweisungen werden in der Sprache M erstellt. Benutzer, die über die Leistungsfähigkeit und Flexibilität von Daten Skripts verfügen, können mithilfe des erweiterten Editors M-sprach Abfragen manuell erstellen oder ändern. Abfrage-Editor und Erweiterter Editor werden weiter unten in diesem Artikel ausführlicher beschrieben.

Sie können eine neue Abfrage über die Registerkarte " Daten " beginnen, #a0 Daten abrufen #a1 eine Datenquelleauswählen. Wenn die Schaltfläche Daten abrufen nicht angezeigt wird, wählen Sie auf der Registerkarte Daten die Schaltfläche neue Abfrage aus. Im folgenden finden Sie ein Beispiel für die Auswahl aus einer Datenbankquelle.

Optionen von Abrufen und transformieren aus einer Datenbank

Hinweis: Power Query steht auch für frühere Versionen von Excel als Add-insowie in Power BIzur Verfügung. Das Verwenden von Power Query in früheren Versionen von Excel wird unter Erste Schritte mit Power Query gezeigt.

Verbinden

Sie können eine Abfrage verwenden, um eine Verbindung mit einer einzelnen Datenquelle herzustellen, beispielsweise mit einer Access -Datenbank, oder Sie können eine Verbindung mit mehreren Dateien, Datenbanken, OData-Feeds oder Websites herstellen. Sie können dann alle diese Quellen mit ihren eigenen eindeutigen Kombinationen zusammenbringen und Einblicke entdecken, die Sie sonst vielleicht nicht gesehen haben.

Wenn Sie auf der Registerkarte Daten im Abschnitt Get #a0 Transform die Option Daten abrufen auswählen (oder neue Abfrage , wenn die Schaltfläche Daten abrufen nicht angezeigt wird), werden viele Datenquellen zur Auswahl angezeigt, einschließlich Dateien wie Excel-Arbeitsmappen. oder Text/CSV-Dateien, Datenbanken wie Access, SQL Server, Oracleund MySQL, Azure -Dienste wie HDInsight oder BLOB-Speichersowie alle möglichen anderen Quellen wie die Web, SharePoint-Listen, Hadoop-Dateien, Facebook, Salesforceund andere.

Hinweis: Informationen zu den verfügbaren Datenquellen in den Excel-Versionen finden Sie hier: wo befindet sich #a0 Transform (Power Query).

Wenn Sie eine Verbindung mit einer Datenquelle herstellen, wird #a0 Transform ein Navigator -Bereich angezeigt, in dem Sie die Daten aus der Quelle bearbeiten können. Wenn Sie im Fenster " Navigator " die Option " Bearbeiten " auswählen, wird mit #a0 Transform der Abfrage-Editorgestartet, bei dem es sich um ein dediziertes Fenster handelt, das Ihre Datenverbindungen und die angewendeten Transformationen vereinfacht und anzeigt. Im nächsten Abschnitt (Transformieren) finden Sie weitere Informationen zum Abfrage-Editor.

Transformieren

Mit Get #a0 Transform können Sie die Daten aus ihren Datenquellen auf eine Weise transformieren, die Sie bei der Analyse unterstützt. Das umwandeln von Daten bedeutet, dass Sie Sie auf eine Art und Weise ändern, um Ihre Anforderungen zu erfüllen – beispielsweise können Sie eine Spalte entfernen, einen Datentyp ändern oder Tabellen zusammenführen, wobei es sich um eine Datentransformation handelt. Während Sie Daten transformieren, übernimmt sie gemeinsam die Form, die Sie benötigen, um Ihre Analyse weiter zu entwickeln. Das Verfahren zum Anwenden von Transformationen auf eine oder mehrere Datensätze wird häufig als Formgebungs Daten bezeichnet.

Excel verwendet einen dedizierten Abfrage-Editor , um Datentransformationen zu vereinfachen und anzuzeigen. Wenn Sie Daten #a0 Daten Abrufenauswählen und dann die Datenquelle wie eine Arbeitsmappe oder eine Datenbank auswählen, wird das Fenster Navigator angezeigt, sodass Sie die Tabelle (oder die Tabellen) auswählen können, die Sie in Ihrer Abfrage verwenden möchten. Wenn Sie eine Tabelle auswählen, wird eine Vorschau der entsprechenden Daten im rechten Bereich des Fensters Navigator angezeigt.

Abrufen #a0 transformieren #a1 Power Query-Navigationsbereich

Wenn Sie Loadauswählen, wird die Datenquelle wie in Excel direkt in Excel importiert. Wenn Sie die Option Daten transformieren auswählen, wird der Abfrage-Editorgestartet.

Bereich "Power Query-Editor"

Der Abfrage-Editor verfolgt alle Schritte, die Sie mit den Daten ausführen. Vom Abfrage-Editor wird jede Transformation (oder jeder Schritt) aufgezeichnet und beschriftet, die (oder den) Sie auf die Daten anwenden. Unabhängig davon, ob es sich bei der Transformation um eine Verbindung mit einer Datenquelle, das Entfernen einer Spalte, eines Seriendrucks oder einer Änderung des Datentyps handelt, verfolgt der Abfrage-Editor jeden Vorgang im Abschnitt " angewandte Schritte " des Bereichs " Abfrageeinstellungen " nach.

Die Transformationen, die Sie auf Ihre Datenverbindungen anwenden, bilden zusammen die Abfrage.

Es ist wichtig zu wissen, dass die im Abfrage-Editor definierten Aktionen die ursprünglichen Quelldaten nicht ändern. Stattdessen zeichnet Excel die einzelnen Schritte auf, die Sie beim Verbinden oder Transformieren der Daten ausführen, und nachdem Sie die Daten geformt haben, wird eine Momentaufnahme des raffinierten Datensatzes erstellt und in die Arbeitsmappe aufgenommen.

Es gibt viele Transformationen, die Sie auf Daten anwenden können. Sie können auch eigene Transformationen mithilfe der Sprache M mit dem erweiterten Editordes Abfrage-Editors schreiben. Sie können den erweiterten Editor über die Registerkarten " Start " oder " Ansicht " des Abfrage-Editors öffnen, in der Sie die M-sprach Schritte ändern können, die mit der vorhandenen Abfrage verknüpft sind, oder eigene erstellen.

Power Query Erweiterter Editor Bereich mit M-sprachbearbeitung

Wenn Sie mit dem Erstellen Ihrer Abfrage fertig sind, können Sie auf der Registerkarte Start#a0 laden auswählen, und die Abfrageergebnisse werden in Excel geladen und auf einer neuen Registerkarte "Arbeitsmappe" verfügbar.

Weitere Informationen zum Transformieren finden Sie hier:

Verwalten

Beim Speichern einer Excel-Arbeitsmappe, die eine Abfrage enthält, wird die Abfrage ebenfalls automatisch gespeichert. Sie können alle Abfragen in einer Excel-Arbeitsmappe anzeigen, indem Sie auf der Registerkarte DatenAbfragen #a0 Verbindungen auswählen.

Power Query-Abfragen und Verbindungen (Bereich)

Wenn Sie im Bereich Abfragen #a0 Verbindungen mit der rechten Maustaste auf einen Abfragenamen klicken, werden verschiedene Optionen angezeigt. So können Sie beispielsweise eine Abfrage duplizieren, mit der Sie einige oder alle Elemente einer Abfrage ändern können, ohne die ursprüngliche Abfrage zu ändern. Es ist wie das Erstellen einer Abfragevorlage, die Sie dann ändern können, um benutzerdefinierte Datasets zu erstellen – wie ein Dataset für den Einzelhandel, ein weiteres für den Großhandel und ein weiteres für das Inventar, das alle auf den gleichen Datenverbindungen basiert.

Sie können auch Abfragen zusammenführen oder anfügen, sodass Sie Abfragen in wiederverwendbare Bausteine umwandeln können.

Abfragen #a0 Verbindungen mit der rechten Maustaste auf Menü Optionen

Sie können Ihre Arbeitsmappe auch in Power BI veröffentlichen und Onlineberichte erstellen, die für Ihre Gruppe freigegeben, automatisch aktualisiert und optimiert werden können. Zum Veröffentlichen einer Arbeitsmappe in Power BI wählen Sie Datei > Veröffentlichen > In Power BI veröffentlichen aus.

Hinweis: Die Arbeitsmappe muss auf OneDrive for Business gespeichert sein, um in Power BI veröffentlicht werden zu können.

Weitere Informationen zum Verwalten von Abfragen:

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Hinweis:  Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Lassen Sie uns bitte wissen, ob diese Informationen hilfreich für Sie waren. Hier finden Sie den englischen Artikel als Referenz.

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden