Entwerfen einer Formularvorlage, die auf einer Microsoft Access-Datenbank basiert

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Sie können eine Microsoft Office InfoPath-Formularvorlage entwerfen, die mit Microsoft Office Access-Datenbank für die beiden Datenabfrage zu Abfragen und Absenden von Daten passt. Entwerfen Sie diese Formularvorlage basierend auf einer Datenbank Microsoft Office Access 2007 (ACCDB) oder einer Access-Datenbank in einer früheren Version (MDB-Format) gespeichert.

Inhalt dieses Artikels

(Übersicht)

Kompatibilität Aspekte

Vorbemerkung

Entwerfen der Formularvorlage

Konfigurieren der Absendeoptionen

Übersicht

Ein Formular kann eine Verbindung von primären Daten, die Datenverbindung Hauptfenster aufgerufen haben, und diese Verbindung kann optional einen oder mehrere sekundäre datenverbindungen haben. Die Verbindung zum Hauptfenster Daten können Sie Abfragen oder Absenden von Formulardaten in einer Access-Datenbank. Sie können auch sekundäre datenverbindungen Abfragen und Senden von Daten an externe Datenquellen, mit einigen Ausnahmen verwenden. Beispielsweise können Sie eine sekundäre Datenquelle mit einer Access-Datenbank, damit es in der Datenbank nur Abfragen. Sie können keine sekundäre Datenquelle zu einem Formular hinzufügen, der Formular-Datenverzeichnis in einer Access-Datenbank.

Beim Entwerfen einer Formularvorlage, die auf einer Access-Datenbank basiert, InfoPath erstellt ein Hauptfenster Datenquelle mit Gruppen, die Abfrage und Datenfelder enthalten, und auch eine Verbindung zum Abfragen von Daten als die Datenverbindung Hauptfenster für die Formularvorlage erstellt. Diese Felder und Gruppen entsprechen der Anzeige von Daten in Tabellen in der Datenbank gespeichert ist.

Abfragefelder enthalten die Daten, die in das Formular, von einem Benutzer eingegeben werden für die Abfrageergebnisse auf Datensätze zu beschränken, die die Daten in den Abfragefeldern entsprechen. Wenn Sie ein Formular, die auf dieser Formularvorlage basieren, ist die Hauptfenster Datenverbindung verwendet, erstellt InfoPath eine Abfrage mit den Daten in den Abfragefeldern ein. InfoPath sendet dann die Abfrage über die Datenverbindung. Die Datenbank gibt die Ergebnisse der Abfrage an das Formular durch die Verbindung von Daten zurück. Die Ergebnisse der Abfrage werden in Datenfelder, setzen Sie die durch die Steuerelemente auf dem Formular bearbeitet werden kann, die an diesen Datenfeldern gebunden sind.

Da die Datenstruktur der Abfrage und der Datenfelder wie übereinstimmen muss Daten in der Datenbank gespeichert ist, können nicht Sie diese Felder oder Gruppen in der primären Datenquelle ändern. Sie können nur Felder oder Gruppen in der primären Datenquelle Stamm zur Gruppe hinzufügen. Finden Sie Links zu weiteren Informationen zu Datenquellen im Abschnitt Siehe auch.

Ein Formular kann Daten in einer Datenbank über main Datenverbindung des Formulars übermitteln, wenn die Formularvorlage, der im Formular auf basiert und die Datenbank die folgenden Anforderungen erfüllt:

  • Die Formularvorlage ist keiner browserkompatible Formularvorlage    InfoPath wird eine Verbindung zum Absenden von Daten nicht in den Hauptfenster Verbindung erstellen, wenn Sie eine browserkompatible Formularvorlage entwerfen. Damit die Benutzer zum Senden von Daten in einem Formular, das auf eine browserkompatible Formularvorlage basiert, verwenden Sie einen Webdienst, der mit der Datenbank arbeitet.

  • In jedem Paar verknüpfter Tabellen in der primären Datenquelle die linke Tabelle enthält einen Primärschlüssel    Mindestens eines der "Beziehungen" für jedes Paar verknüpften Tabellen muss einen Primärschlüssel aus der linken Tabelle enthalten.

  • Keiner der Datenfelder in der primären Datenquelle des Formulars Speichers ein großer binäre Datentyp    InfoPath wird die Verbindung zum Absenden von Daten deaktiviert, wenn die Abfrage Felder enthält, die einen große binäre Datentyp, wie Bilder, Bilder, OLE Objekte, Dateianlagen, die Office Access Memo-Datentyp oder den Text der SQL-Datentyp speichern können.

Wenn InfoPath eine Verbindung zum Absenden von Daten aktiviert, können Benutzer die Daten zu senden, die in die Datenfelder der primären Datenquelle in der Datenbank gespeichert ist. Sie können die Absendeoptionen für die Formulare anpassen, die auf dieser Formularvorlage basieren.

Seitenanfang

Überlegungen zur Kompatibilität

Sie können keine browserkompatible Formularvorlage basierend auf einer Access-Datenbank entwerfen.

Seitenanfang

Vorbemerkung

Bevor Sie erfolgreich eine Formularvorlage, die auf einer Access-Datenbank basiert entwerfen können, benötigen Sie die folgende Informationen über die Access-Datenbank:

  • Der Name und Speicherort der Datenbank.

    Hinweis: Stellen Sie sicher, dass die Datenbank in einen Netzwerkspeicherort ist, der den Benutzern zugänglich.

  • Der Name der Tabelle, die empfangen übermittelt Daten aus, wenn die Formularvorlage Benutzern zum Senden von Formularen in einer Datenbank ermöglicht. Wenn Sie die Verbindung zum Absenden von Daten konfigurieren, verwenden eine dieser Tabelle als die primäre Tabelle.

  • Der Name der Tabelle, die die Ergebnisse der Abfrage an die Datenbank gesendet bereitstellt, wenn die Formularvorlage die Datenbankabfrage nur. Wenn Sie die Verbindung zum Abfragen von Daten konfigurieren, verwenden eine dieser Tabelle als die primäre Tabelle.

  • Die Namen der Tabellen, denen die primäre Tabelle Daten aus erfordern möglicherweise. In den meisten Fällen sind die tabellenbeziehungen in der Datenbank bereits eingerichtet. Wenn Sie die Beziehungen zwischen der primären Tabelle und einer weiteren Tabelle manuell herstellen müssen, benötigen Sie die zugehörigen Feldnamen der beiden Tabellen.

Seitenanfang

Entwerfen der Formularvorlage

Zum Entwerfen einer Formularvorlage mit einer Verbindung zum Abfragen von Daten, müssen Sie zuerst die Formularvorlage zu erstellen. Wenn Sie eine Formularvorlage, die auf einer Datenbank basiert erstellen, erstellt InfoPath eine Verbindung zum Abfragen von Daten als Hauptfenster Datenverbindung zwischen der Formularvorlage und der Datenbank. Dieses Verfahren wird automatisch primären Datenquelle der Formularvorlage erstellt.

Nachdem Sie die Formularvorlage erstellt haben, müssen Sie die Formularvorlage ein Steuerelement hinzu, und klicken Sie dann das Steuerelement an ein Feld in der primären Datenquelle binden. Dadurch wird die Benutzer die Ergebnisse der Abfrage im Formular angezeigt.

Schritt 1: Erstellen der Formularvorlage

  1. Klicken Sie im Menü Datei auf eine Formularvorlage entwerfen.

  2. Klicken Sie im Dialogfeld eine Formularvorlage entwerfen klicken Sie unter Entwerfen einer neuen, auf Formularvorlage.

  3. Klicken Sie in der Liste basierend auf klicken Sie auf die Datenbank, und klicken Sie dann auf OK.

    Der Datenverbindungs-Assistent wird gestartet.

  4. Klicken Sie auf der ersten Seite des Datenverbindungs-Assistenten auf Datenbank auswählen.

  5. Navigieren Sie im Dialogfeld Datenquelle auswählen auf den Speicherort der Datenbank.

    Hinweis: Wenn die Datenbank in einem Speicherort im Netzwerk gespeichert ist, navigieren Sie zu den universal naming Convention (UNC)) Pfad für diesen Speicherort. Nicht zum Netzwerkspeicherort über eine zugeordnete Netzlaufwerk navigieren. Wenn Sie ein zugeordneten Netzlaufwerk verwenden, werden Benutzer, die Erstellen von Formularen, die auf dieser Formularvorlage basieren für die Datenbank aus einem zugeordneten Netzlaufwerk suchen. Wenn der Benutzer nicht mit ein zugeordneten Netzlaufwerk verfügt, wird das Formular die Datenbank nicht finden.

  6. Klicken Sie auf den Namen der Datenbank, und klicken Sie dann auf Öffnen.

  7. Klicken Sie im Dialogfeld Tabelle auswählen klicken Sie auf die primäre Tabelle oder Abfrage, die Sie verwenden möchten, und klicken Sie dann auf OK.

  8. Wählen Sie auf der nächsten Seite des Assistenten das Kontrollkästchen Tabellenspalten anzeigen aus.

  9. Standardmäßig werden alle Felder in der Tabelle der primären Datenquelle der Formularvorlage hinzugefügt werden. Deaktivieren Sie die Kontrollkästchen für die Felder, die Sie nicht in der primären Datenquelle einschließen möchten.

    Fügen Sie weitere Tabellen oder Abfragen, die Sie in der Verbindung zum Abfragen von Daten verwenden möchten.

    So wird's gemacht

    1. Klicken Sie auf Tabelle hinzufügen.

    2. Klicken Sie im Dialogfeld Tabelle oder Abfrage hinzufügen klicken Sie auf den Namen der untergeordneten Tabelle, und klicken Sie dann auf Weiter. InfoPath versucht, die Beziehungen festlegen, indem Sie Feldnamen in beiden Tabellen. Wenn Sie nicht die vorgeschlagenen Beziehung verwenden möchten, wählen Sie die Beziehung aus, und klicken Sie dann auf Beziehung entfernen. Wenn Sie eine Beziehung hinzufügen möchten, klicken Sie auf Beziehung hinzufügen. Klicken Sie im Dialogfeld Beziehung hinzufügen klicken Sie auf den Namen der einzelnen verknüpften Felder in der jeweiligen Spalte, und klicken Sie dann auf OK.

    3. Klicken Sie auf Fertig stellen.

    4. Um weitere untergeordnete Tabellen hinzuzufügen, wiederholen Sie diese Schritte aus.

  10. Klicken Sie auf Weiter.

  11. Geben Sie auf der letzten Seite des Assistenten einen Namen für die Verbindung zum Hauptfenster Daten ein. Dieser Name wird in der Liste Datenquelle im Aufgabenbereich Datenquelle angezeigt.

  12. Wenn Ihre Formularvorlage die im Abschnitt Übersicht erfüllt, gibt im Abschnitt Zusammenfassung auf dieser Seite des Assistenten InfoPath die Verbindung zum Absenden von Daten in das Hauptfenster Datenverbindung aktiviert an.

  13. Um den Namen für die Verbindung zum Übermitteln von Daten zu ändern, geben Sie einen neuen Namen in das entsprechende Feld ein.

  14. Damit Ihre Benutzer übermitteln, dass ihre Formulardaten über einen anderen Datenverbindung Absenden, die Sie in der Formularvorlage später hinzufügen, deaktivieren Sie das Kontrollkästchen Absenden für diese Verbindung aktivieren.

    Hinweis: Wenn Ihre Formularvorlage die Anforderungen im Abschnitt Übersicht nicht erfüllt, InfoPath deaktiviert die Verbindung zum Absenden von Daten und werden im Feld Geben Sie einen Namen für die Verbindung zum Absenden und das Kontrollkästchen Absenden für diese Verbindung aktivieren nicht verfügbar. Wenn die Verbindung zum Absenden von Daten mit InfoPath deaktiviert wird, werden die wichtigsten Datenverbindung für Ihre Formularvorlage nur eine Verbindung zum Abfragen von Daten enthalten.

Schritt 2: Binden eines Steuerelements in das Feld

  1. Wenn der Aufgabenbereich Steuerelemente nicht angezeigt wird, klicken Sie im Menü Einfügen auf Weitere Steuerelemente, oder drücken Sie ALT+I, C.

  2. Ziehen Sie ein Steuerelement auf der Formularvorlage aus.

  3. Wählen Sie das Feld, dem das Steuerelement gebunden werden soll, klicken Sie im Dialogfeld Steuerelement Bindung.

Seitenanfang

Konfigurieren der Absendeoptionen

Wenn Tabellen, die Sie im Datenverbindungs-Assistenten ausgewählt und die Formularvorlage die im Abschnitt Übersicht zu erfüllen, konfiguriert InfoPath Ihrer Formularvorlage, um Daten zu senden, über seine Datenverbindung Hauptfenster aus.

Wenn Sie verwenden diese Datenverbindung übermitteln, InfoPath konfiguriert die Formularvorlage aus, damit Benutzer ihre Formulardaten an die Datenbank senden können, und fügt auch eine Senden-Schaltfläche auf der Standardsymbolleiste und der Befehl Absenden der Datei Menü auf dem Formular. InfoPath konfiguriert auch die Formularvorlage aus, damit beim Benutzer Formulare absenden, das Formular geöffnet bleibt und eine Meldung angezeigt, die angibt, ob das Formular erfolgreich gesendet wurde. Sie können ändern Sie den Text, der auf die Senden-Schaltfläche angezeigt wird, und auch das Verhalten eines Formulars ändern sich nach dem Absenden es.

  1. Klicken Sie im Menü Extras auf Optionen zum Absenden.

    1. Wenn der Name der Senden-Schaltfläche, die angezeigt, klicken Sie auf der Standardsymbolleiste und den Befehl Absenden, der Sie im Menü Datei angezeigt wird wird, wenn Benutzer des Formulars ausfüllen ändern möchten, geben Sie den neuen Namen im Feld Beschriftung die übermitteln Optionen im Dialogfeld.

      Tipp: Wenn Sie diese Schaltfläche und den Befehl eine Tastenkombination zuweisen möchten, geben Sie ein kaufmännisches und-Zeichen (&) vor dem Zeichen, die Sie als Tastenkombination verwenden möchten. Geben Sie beispielsweise ALT + B als die Tastenkombination für die Senden-Schaltfläche und der Befehl zuzuweisen, & bsenden.

  2. Wenn Sie keine anderen Befehl Absenden oder die Senden-Schaltfläche auf der Standardsymbolleiste verwendet, beim Ausfüllen eines Formulars, deaktivieren Sie das Kontrollkästchen anzeigen das Menüelement übermitteln und die Symbolleisten-Schaltfläche Absenden.

    1. Standardmäßig nach dem Senden eines Formulars, InfoPath behält das Formular zu öffnen, und wird eine Meldung angezeigt, um anzugeben, ob das Formular erfolgreich gesendet wurde. Wenn Sie dieses Standardverhalten ändern möchten, klicken Sie auf Erweitert, und führen Sie dann eine der folgenden Aktionen aus:

      • Wenn Sie das Formular schließen, oder erstellen ein neues leeres Formular aus, nach der Benutzer ein ausgefülltes Formular übermittelt, klicken Sie auf die Option, die Sie in der Liste nach dem Senden möchten.

      • Zum Erstellen einer benutzerdefinierten Nachricht, um anzugeben, ob das Formular erfolgreich gesendet wurde, aktivieren Sie das Kontrollkästchen benutzerdefinierte Meldung verwenden, und geben Sie dann Ihre Nachrichten in den Feldern bei Erfolg und bei einem Fehler.

        Tipp: Verwenden Sie eine Nachricht im Feld auf Fehler zu Benutzern mitteilen, was zu tun ist, wenn sie ihr Formular übermitteln können. Beispielsweise können Sie vorschlagen, dass Benutzer Formular zu speichern und Weitere Informationen zum Kontaktieren einer Person.

      • Wenn Sie keine zum Anzeigen einer Meldung, nachdem der Benutzer ein Formular übermittelt, deaktivieren Sie das Kontrollkästchen Erfolg und Fehler Nachrichten anzeigen.

Seitenanfang

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×