Entwerfen einer Formularvorlage basierend auf einer Microsoft SQL Server-Datenbank

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Sie können eine Formularvorlage entwerfen, die Arbeiten mit einer Microsoft SQL Server-Datenbank auf Abfrage oder Abfragen von Daten und Daten übermitteln können.

Inhalt dieses Artikels

(Übersicht)

Kompatibilität Aspekte

Vorbemerkung

Entwerfen der Formularvorlage

Konfigurieren der Absendeoptionen

Übersicht

Ein Formular kann eine Verbindung von primären Daten, die Datenverbindung Hauptfenster aufgerufen haben, und sie können optional eine oder mehrere sekundäre datenverbindungen haben. Je nach Ihren Zielen für das Formular möglicherweise eine Datenverbindung Abfragen oder Senden von Daten aus einer externen Datenquelle, wie etwa Microsoft SQL Server-Datenbank oder einem Webdienst Formular.

Beim Entwerfen einer Formularvorlage, die auf einer Datenbank basiert, erstellt Microsoft Office InfoPath ein Hauptfenster Datenquelle mit Gruppen, die Abfragefelder und Datenfelder und eine Verbindung zum Abfragen von Daten als für die Formularvorlage Datenverbindung Hauptfenster enthalten. Diese Felder und Gruppen entsprechen der Anzeige von Daten in Tabellen in der Datenbank gespeichert ist. Abfragefelder enthalten die Daten, die von einem Benutzer für die Abfrageergebnisse auf Datensätze zu beschränken, die die Daten in den Abfragefeldern entsprechen eingegeben werden. Wenn ein Formular basierend auf dieser Formularvorlage Hauptfenster Datenverbindung verwendet wird, erstellt InfoPath eine Abfrage mit den Daten in den Abfragefeldern ein. InfoPath sendet dann die Abfrage über die Verbindung zum Abfragen von Daten aus. Die Datenbank gibt die Ergebnisse der Abfrage an das Formular durch die Verbindung zum Abfragen von Daten zurück. Die Ergebnisse der Abfrage werden in Datenfelder, setzen Sie die einzelnen Steuerelemente nacheinander bearbeitet werden kann, die an diese Felder gebunden sind.

Da die Datenstruktur der Abfrage und der Datenfelder wie übereinstimmen muss Daten in der Datenbank gespeichert ist, können nicht Sie diese Felder oder Gruppen in der primären Datenquelle ändern. Sie können nur Felder oder Gruppen in der primären Datenquelle Stamm zur Gruppe hinzufügen. Finden Sie Links zu weiteren Informationen zu Datenquellen im Abschnitt Siehe auch.

Ein Formular kann Daten in einer Datenbank über main Datenverbindung des Formulars übermitteln, wenn die Formularvorlage, der im Formular auf basiert und die Datenbank die folgenden Anforderungen erfüllt:

  • Die Formularvorlage ist keiner browserkompatible Formularvorlage    InfoPath wird eine Verbindung zum Absenden von Daten nicht in den Hauptfenster Verbindung erstellen, wenn Sie eine browserkompatible Formularvorlage entwerfen. Damit die Benutzer zum Senden von Daten in einem Formular, das auf eine browserkompatible Formularvorlage basiert, verwenden Sie einen Webdienst, der mit der Datenbank arbeitet.

  • In jedem Paar verknüpfter Tabellen in der primären Datenquelle die linke Tabelle enthält einen Primärschlüssel    Mindestens eines der "Beziehungen" für jedes Paar verknüpften Tabellen muss einen Primärschlüssel aus der linken Tabelle enthalten.

  • Keiner der Datenfelder in der primären Datenquelle des Formulars Speichers ein großer binäre Datentyp    InfoPath wird die Verbindung zum Absenden von Daten deaktiviert, wenn die Abfrage Felder enthält, die einen große binäre Datentyp, wie Bilder, Bilder, OLE Objekte, Dateianlagen, die Office Access Memo-Datentyp oder den Text der SQL-Datentyp speichern können.

Wenn InfoPath die Verbindung zum Absenden von Daten aktiviert, können Benutzer und übermitteln Sie die Daten in die Datenfelder der primären Datenquelle in der Datenbank. Wenn InfoPath die Verbindung zum Absenden von Daten ermöglicht, können Sie die Absendeoptionen für die Formulare anpassen, die auf dieser Formularvorlage basieren.

Seitenanfang

Überlegungen zur Kompatibilität

Beim Entwerfen einer Formularvorlage, die auf einer Datenbank basiert, müssen Sie die Möglichkeit, eine Browserkompatible Formularvorlage entwerfen. InfoPath erstellt eine Verbindung zum Abfragen von Daten als die Datenverbindung Hauptfenster in einer browserkompatible Formularvorlage. Browserkompatible Formularvorlagen können jedoch konfiguriert werden, um Benutzern zum Senden von Daten in einer Datenbank zu ermöglichen. Daher, wenn Sie eine Formularvorlage basierend auf einer SQL Server-Datenbank entwerfen und sollen die Benutzer ihre Formulardaten an die Datenbank durch die Verbindung zum Hauptfenster Daten übermitteln, Sie dieser Formularvorlage browserkompatible nicht möglich.

Seitenanfang

Vorbemerkung

Um die Formularvorlage basierend auf einer SQL Server-Datenbank zu entwerfen, benötigen Sie die folgende Informationen aus Ihren Datenbankadministrator aus:

  • Der Name des Servers, der die Datenbank enthält, der Sie Ihrer Formularvorlage zu verbinden.

  • Der Name der Datenbank, die mit der Formularvorlage soll verwendet werden.

  • Von der Datenbank erforderliche Authentifizierung. Die Datenbank kann entweder Microsoft Windows-Authentifizierung oder SQL Server-Authentifizierung verwenden, um festzustellen, wie Benutzer die Datenbank zugreifen können.

  • Der Name der Tabelle, die die Daten enthält, die Sie auf das Formular oder den, senden möchten, die Daten aus dem Formular erhalten. Dies ist die primäre Tabelle. Wenn Sie mehr als eine Tabelle in der Datenbank verwenden möchten, benötigen Sie die Namen dieser anderen, untergeordneten Tabellen. Sie benötigen ferner die Namen der Felder in der untergeordneten Tabellen mit Beziehungen mit den Feldern in der primären Tabelle.

Seitenanfang

Entwerfen der Formularvorlage

Um eine Formularvorlage mit einer Verbindung zum Abfragen von Daten zu entwerfen, müssen Sie wie folgt vorgehen:

  1. Erstellen der Formularvorlage    Wenn Sie eine Formularvorlage, die auf einer Datenbank basiert erstellen, erstellt InfoPath eine Verbindung zum Abfragen von Daten als Hauptfenster Datenverbindung zwischen der Formularvorlage und der Datenbank. Dieses Verfahren wird automatisch primären Datenquelle der Formularvorlage erstellt.

  2. Fügen Sie eine oder mehrere Steuerelemente zum Anzeigen der Abfrageergebnisse    Damit die Benutzer zum Anzeigen und bearbeiten die Daten in den Feldern in der primären Datenquelle aus, wenn sie das Formular öffnen, können Sie Hinzufügen eines Steuerelements in der Formularvorlage und das Steuerelement dann an ein Feld in der primären Datenquelle binden.

Schritt 1: Erstellen der Formularvorlage

  1. Klicken Sie im Menü Datei auf eine Formularvorlage entwerfen.

  2. Klicken Sie unter neu entwerfen, klicken Sie im Dialogfeld Entwurf einer Formularvorlage auf Formularvorlage.

  3. Klicken Sie in der Liste basierend aufDatenbank ein.

  4. Wenn Sie eine browserkompatible Formularvorlage entwerfen, aktivieren Sie das Kontrollkästchen Nur browserkompatible Features aktivieren.

    Hinweis: Der Datenverbindungs-Assistent wird die Verbindung zum Absenden von Daten in einer browserkompatible Formularvorlage nicht aktivieren. Damit die Benutzer ihre Daten in einer Datenbank von Formularen und übermitteln, die auf einer browserkompatible Formularvorlage basieren, fügen Sie eine sekundäre Datenquelle mit einem Webdienst, der mit der Datenbank arbeitet. Finden Sie Links zu weiteren Informationen zu sekundären Datenquellen im Abschnitt Siehe auch.

  5. Klicken Sie auf OK.

  6. Klicken Sie im Datenverbindungs-Assistenten auf Datenbank auswählen.

  7. Klicken Sie im Dialogfeld Datenquelle auswählen auf Neue Quelle.

  8. Klicken Sie in der Liste welche Art von Datenquelle möchten Sie eine Verbindung mit herstellen klicken Sie auf Microsoft SQL Server, und klicken Sie dann auf Weiter.

  9. Geben Sie im Feld Servername den Namen des Servers mit SQL Server-Datenbank ein.

  10. Führen Sie unter Anmeldeinformationen eine der folgenden Aktionen aus:

    • Wenn die Datenbank bestimmt, wer basierend auf den Anmeldeinformationen, die in einem Microsoft Windows-Netzwerk verwendeten zugreifen kann, klicken Sie auf Windows-Authentifizierung verwenden.

    • Wenn die Datenbank bestimmt, wer Zugriff auf der Basis einer angegebenen Benutzernamen und Ihr Kennwort ein, das Sie von der Datenbankadministrator abrufen kann, klicken Sie auf den folgenden Benutzernamen und das Kennwort verwenden, und geben Sie dann Ihren Benutzernamen und Ihr Kennwort in den Benutzernamen und Kennwort Felder.

  11. Klicken Sie auf Weiter.

  12. Klicken Sie in der Liste Wählen Sie die Datenbank, die die Daten enthält auf den Namen der Datenbank, die Sie verwenden möchten, verwenden, aktivieren das Kontrollkästchen mit einer bestimmten Tabelle verbinden, klicken Sie auf den Namen der primären Tabelle, und klicken Sie dann auf Weiter.

  13. Klicken Sie auf der nächsten Seite des Assistenten geben Sie einen Namen für die Datei, die Verbindungsinformationen in das Feld Dateiname gespeichert, und klicken Sie dann auf Fertig stellen, um diese Einstellungen zu speichern.

    Wenn Sie beabsichtigen, anderen Tabellen in der Verbindung zum Abfragen von Daten verwenden, können Sie die anderen Tabellen auf dieser Seite des Assistenten hinzufügen.

    So wird's gemacht

    1. Klicken Sie auf Tabelle hinzufügen.

    2. Klicken Sie im Dialogfeld Tabelle oder Abfrage hinzufügen klicken Sie auf den Namen der untergeordneten Tabelle, und klicken Sie dann auf Weiter. InfoPath versucht, die Beziehungen festlegen, indem Sie Feldnamen in beiden Tabellen. Wenn Sie nicht die vorgeschlagenen Beziehung verwenden möchten, wählen Sie die Beziehung aus, und klicken Sie dann auf Beziehung entfernen. Wenn Sie eine Beziehung hinzufügen möchten, klicken Sie auf Beziehung hinzufügen. Klicken Sie im Dialogfeld Beziehung hinzufügen klicken Sie auf den Namen der einzelnen verknüpften Felder in der jeweiligen Spalte, und klicken Sie dann auf OK.

    3. Klicken Sie auf Fertig stellen.

    4. Um weitere untergeordnete Tabellen hinzuzufügen, wiederholen Sie diese Schritte aus.

  14. Klicken Sie auf Weiter.

  15. Geben Sie auf der letzten Seite des Assistenten einen Namen für die Verbindung zum Hauptfenster Daten ein. Dieser Name wird in der Liste Datenquelle im Aufgabenbereich Datenquelle angezeigt.

  16. Wenn Ihre Formularvorlage die im Abschnitt Übersicht erfüllt, wird dieser Seite des Assistenten laut InfoPath die Verbindung zum Absenden von Daten in das Hauptfenster Datenverbindung aktiviert. Um den Namen für die Verbindung zum Übermitteln von Daten zu ändern, geben Sie einen neuen Namen in das entsprechende Feld ein. Wenn Ihre Benutzer übermitteln, dass ihre Formulardaten über einen anderen Datenverbindung Absenden, die Sie der Formularvorlage später hinzufügen werden soll, deaktivieren Sie das Kontrollkästchen Absenden für diese Verbindung aktivieren.

    Hinweis: Wenn Ihre Formularvorlage die Anforderungen im Abschnitt Übersicht nicht erfüllt, InfoPath deaktiviert die Verbindung zum Absenden von Daten und werden im Feld Geben Sie einen Namen für die Verbindung zum Absenden und das Kontrollkästchen Absenden für diese Verbindung aktivieren nicht verfügbar (abgeblendet). Wenn die Verbindung zum Absenden von Daten mit InfoPath deaktiviert wird, kann die Hauptfenster Datenverbindung für Ihre Formularvorlage nur eine Verbindung zum Abfragen von Daten sind.

Schritt 2: Hinzufügen eines oder mehrere Steuerelemente zum Anzeigen der Abfrageergebnisse

  1. Wenn der Aufgabenbereich Steuerelemente nicht angezeigt wird, klicken Sie im Menü Einfügen auf Weitere Steuerelemente, oder drücken Sie ALT+I, C.

  2. Ziehen Sie ein Steuerelement auf der Formularvorlage aus.

  3. Wählen Sie im Dialogfeld Steuerelement Bindung die Gruppe oder das Feld, das das Steuerelement gebunden werden soll.

Seitenanfang

Konfigurieren der Absendeoptionen

Wenn Tabellen, die Sie im Datenverbindungs-Assistenten ausgewählt und die Formularvorlage die im Abschnitt Übersicht zu erfüllen, konfiguriert InfoPath Ihrer Formularvorlage, um Daten über die Verbindung zum Hauptfenster Daten zu übermitteln. Wenn Sie verwenden diese Datenverbindung übermitteln, InfoPath konfiguriert die Formularvorlage aus, damit Benutzer ihre Formulardaten an die Datenbank senden können, und fügt die Senden-Schaltfläche auf der Standardsymbolleiste und den Befehl Absenden, um die Datei Menü, wenn Benutzer das Formular ausfüllen. InfoPath konfiguriert auch die Formularvorlage so, dass, wenn die Benutzer ihre Formulare senden, das Formular geöffnet bleibt und eine Meldung für den Benutzer, der angibt, ob das Formular erfolgreich gesendet wurde. Sie können den Text, klicken Sie auf die Schaltfläche Absenden und das Verhalten ändern, nachdem der Benutzer ein Formular übermittelt.

  1. Klicken Sie im Menü Extras auf Optionen zum Absenden.

    1. Wenn der Name der Senden-Schaltfläche, die angezeigt, klicken Sie auf der Standardsymbolleiste und den Befehl Absenden, der Sie im Menü Datei angezeigt wird wird, wenn Benutzer des Formulars ausfüllen ändern möchten, geben Sie den neuen Namen im Feld Beschriftung die übermitteln Optionen im Dialogfeld.

      Tipp: Wenn Sie diese Schaltfläche und den Befehl eine Tastenkombination zuweisen möchten, geben Sie ein kaufmännisches und-Zeichen (&) vor dem Zeichen, die Sie als Tastenkombination verwenden möchten. Geben Sie beispielsweise ALT + B als die Tastenkombination für die Senden-Schaltfläche und der Befehl zuzuweisen, & bsenden.

  2. Wenn Sie keine anderen Befehl Absenden oder die Senden-Schaltfläche auf der Standardsymbolleiste verwendet, beim Ausfüllen eines Formulars, deaktivieren Sie das Kontrollkästchen anzeigen das Menüelement übermitteln und die Symbolleisten-Schaltfläche Absenden.

    1. Standardmäßig nach dem Senden eines Formulars, InfoPath behält das Formular zu öffnen, und wird eine Meldung angezeigt, um anzugeben, ob das Formular erfolgreich gesendet wurde. Wenn Sie dieses Standardverhalten ändern möchten, klicken Sie auf Erweitert, und führen Sie dann eine der folgenden Aktionen aus:

      • Wenn Sie das Formular schließen, oder erstellen ein neues leeres Formular aus, nach der Benutzer ein ausgefülltes Formular übermittelt, klicken Sie auf die Option, die Sie in der Liste nach dem Senden möchten.

      • Zum Erstellen einer benutzerdefinierten Nachricht, um anzugeben, ob das Formular erfolgreich gesendet wurde, aktivieren Sie das Kontrollkästchen benutzerdefinierte Meldung verwenden, und geben Sie dann Ihre Nachrichten in den Feldern bei Erfolg und bei einem Fehler.

        Tipp: Verwenden Sie eine Nachricht im Feld auf Fehler zu Benutzern mitteilen, was zu tun ist, wenn sie ihr Formular übermitteln können. Beispielsweise können Sie vorschlagen, dass Benutzer Formular zu speichern und Weitere Informationen zum Kontaktieren einer Person.

      • Wenn Sie keine zum Anzeigen einer Meldung, nachdem der Benutzer ein Formular übermittelt, deaktivieren Sie das Kontrollkästchen Erfolg und Fehler Nachrichten anzeigen.

Seitenanfang

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×