Entwerfen des Layouts und des Formats einer PivotTable

Nach dem Erstellen einer PivotTable und dem Hinzufügen der zu analysierenden Felder möchten Sie möglicherweise Layout und Formatierungen des Berichts optimieren, um die Daten leichter lesbar und Details besser auffindbar zu machen. Um das Layout einer PivotTable zu ändern, können Sie das PivotTable-Format und die Weise, in der Felder, Spalten, Zeilen, Teilergebnisse, leere Zellen und Linien angezeigt werden, ändern. Um das Format der PivotTable zu ändern, können Sie eine vordefinierte Formatvorlage, gebänderte Zeilen und bedingte Formatierung verwenden.

Wichtig: Die Registerkarte PivotTable-Tools im Menüband umfasst zwei Registerkarten: Analysieren (Excel 2016 und Excel 2013) oder Optionen (Excel 2010 und Excel 2010) und Entwurf. Bei den Vorgehensweisen in diesem Thema werden beide Registerkarten, Analysieren und Optionen, genannt (sofern zutreffend).

Ändern des Layoutformats einer PivotTable

Zum Vornehmen grundlegender Änderungen am Layout einer PivotTable oder ihrer verschiedenen Felder können Sie eins von drei Formaten verwenden:

  • Kurzformat    Zeigt Elemente aus verschiedenen Zeilenbereichsfeldern in einer Spalte an und unterscheidet die Elemente aus verschiedenen Feldern mithilfe von Einzügen. Zeilenbeschriftungen beanspruchen im Kurzformat weniger Platz, wodurch mehr Platz für numerische Daten verbleibt. Erweitern- und Reduzieren-Schaltflächen werden angezeigt, sodass Sie im Kurzformat Details ein- oder ausblenden können. Das Kurzformat spart Platz und verbessert die Übersichtlichkeit von PivotTables; daher ist es als Standardlayoutformat für PivotTables festgelegt.

    PivotTable in Kurzformat

  • Tabellenformat    Hier wird eine Spalte pro Feld angezeigt, und es steht Raum für Feldüberschriften zur Verfügung.

    PivotTable in Tabellenformat

  • Gliederungsformat    Das Gliederungsformat ist dem Tabellenformat ähnlich, jedoch können hier am Kopf jeder Gruppe Teilergebnisse angezeigt werden, da die Elemente in der nächsten Spalte eine Zeile unterhalb des aktuellen Elements angezeigt werden.

    PivotTable in Gliederungsformat

Ändern einer PivotTable in das Kurzformat, das Gliederungs- oder das Tabellenformat

  1. Klicken Sie in der PivotTable auf eine beliebige Stelle.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

  2. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Layout auf Berichtslayout, und führen Sie dann eine der folgenden Aktionen aus:

    • Um die Anzeige von zusammenhängenden Daten außerhalb der horizontalen Bildschirmgrenzen zu verhindern und das Scrollen zu minimieren, klicken Sie auf In Kurzformat anzeigen.

      Im Kurzformat sind die Felder in einer Spalte enthalten und sollen die Schachtelungsbeziehung von Spalten darstellen.

    • Um die Daten im klassischen PivotTable-Format zu gliedern, klicken Sie auf In Gliederungsformat anzeigen.

    • Um alle Daten in einem traditionellen Tabellenformat anzuzeigen und Zellen auf einfache Weise auf andere Arbeitsblätter zu kopieren, klicken Sie auf In Tabellenformat anzeigen.

      Abbildung des Excel-Menübands

Ändern der Darstellungsweise von Elementbeschriftungen in einem Layoutformat

  1. Wählen Sie in der PivotTable ein Zeilenfeld aus.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

    Alternativ können Sie auch im Gliederungs- oder Tabellenformat auf das Zeilenfeld doppelklicken und mit Schritt 3 fortfahren.

  2. Klicken Sie auf der Registerkarte Analysieren oder Optionen in der Gruppe Aktives Feld auf Feldeinstellungen.

    Abbildung des Excel-Menübands

  3. Klicken Sie im Dialogfeld Feldeinstellungen auf die Registerkarte Layout & Drucken, und führen Sie dann unter Layout eine der folgenden Aktionen aus:

    • Klicken Sie zum Anzeigen von Feldelementen in Gliederungsform auf Elementnamen in Gliederungsansicht anzeigen.

    • Wenn Beschriftungen im nächsten Feld in der gleichen Spalte im Kurzformat angezeigt oder ausgeblendet werden sollen, klicken Sie auf Elementnamen in Gliederungsansicht anzeigen, und wählen Sie dann Beschriftungen aus dem nächsten Feld in der gleichen Spalte anzeigen (Kurzformat) aus.

    • Klicken Sie zum Anzeigen von Feldelementen in Tabellenform auf Elementnamen im Tabellenformat anzeigen.

Ändern der Feldanordnung in einer PivotTable

Um im Endeffekt die gewünschten Layoutergebnisse zu erhalten, können Sie Felder mithilfe der PivotTable-Feldliste hinzufügen, neu anordnen und entfernen.

Wenn die PivotTable-Feldliste nicht angezeigt wird, vergewissern Sie sich, dass die PivotTable ausgewählt ist. Wenn die PivotTable-Feldliste trotzdem nicht angezeigt wird, klicken Sie auf der Registerkarte Optionen in der Gruppe Ein-/Ausblenden auf Feldliste.

Werden die gewünschten Felder in der PivotTable-Feldliste nicht angezeigt, müssen Sie möglicherweise die PivotTable aktualisieren, um neue Felder, berechnete Felder, Measures, berechnete Measures oder Dimensionen anzuzeigen, die seit dem letzten Vorgang hinzugefügt wurden. Klicken Sie auf der Registerkarte Optionen in der Gruppe Daten auf Aktualisieren.

Weitere Informationen zum Arbeiten mit der PivotTable-Feldliste finden Sie unter Verwenden der Feldliste, um Felder in einer PivotTable anzuordnen.

Hinzufügen von Feldern zu einer PivotTable

Führen Sie eine oder mehrere der folgenden Aktionen aus:

  • Aktivieren Sie im Feldabschnitt das Kontrollkästchen neben den einzelnen Feldnamen. Das Feld wird in einem Standardbereich des Layoutabschnitts platziert, aber Sie können die Anordnung der Felder bei Bedarf ändern.

    Textfelder werden standardmäßig dem Bereich Zeilenbeschriftungen hinzugefügt, numerische Felder werden dem Bereich Werte hinzugefügt, und OLAP-Datums- und Uhrzeithierarchien (Online Analytical Processing) werden dem Bereich Spaltenbeschriftungen hinzugefügt.

  • Klicken Sie mit der rechten Maustaste auf den Feldnamen, und wählen Sie dann den entsprechenden Befehl aus, um das Feld in einem bestimmten Bereich des Layoutabschnitts zu platzieren: Zum Berichtsfilter hinzufügen, Zu Spaltenbeschriftungen hinzufügen, Zu Zeilenbeschriftungen hinzufügen und Zu Werten hinzufügen.

  • Klicken Sie auf einen Feldnamen, halten Sie die Maustaste gedrückt, und ziehen Sie das Feld zwischen den Feldabschnitt und einen Bereich im Layoutabschnitt.

Kopieren von Feldern in einer PivotTable

In einer PivotTable, die auf Daten in einem Excel-Arbeitsblatt oder auf externen Daten aus Nicht-OLAP-Quelldaten basiert, kann es sinnvoll sein, das gleiche Feld dem Bereich Werte mehr als einmal hinzuzufügen, sodass mithilfe des Features Werte anzeigen als verschiedene Berechnungen angezeigt werden können. Beispielsweise können auf diese Weise Berechnungen Seite an Seite verglichen werden, wie etwa Brutto- und Nettogewinnspannen, Mindest- und Höchstabsatzzahlen oder die Kundenanzahl gegenüber dem Prozentsatz der Gesamtkunden. Weitere Informationen finden Sie unter Anzeigen verschiedener Berechnungen in PivotTable-Wertfeldern.

  1. Klicken Sie im Feldbereich auf einen Feldnamen, halten Sie die Maustaste gedrückt, und ziehen Sie das Feld dann in den Bereich Werte im Layoutabschnitt.

  2. Wiederholen Sie Schritt 1 so oft, wie Sie das Feld kopieren möchten.

  3. Ändern Sie in jedem kopierten Feld die Zusammenfassungsfunktion oder benutzerdefinierte Berechnung in der gewünschten Weise.

    Hinweise: 

    • Wenn Sie im Bereich Werte zwei oder mehr Felder hinzufügen, wird in der Feldliste (unabhängig davon, ob es sich um Kopien desselben Felds oder um unterschiedliche Felder handelt) automatisch die Beschriftung "Wertespalten" im Bereich Werte hinzugefügt. Sie können dieses Feld verwenden, um die Feldpositionen im Bereich Werte nach oben oder unten zu bewegen. Sie können sogar die Wertespaltenbeschriftung in den Bereich Spaltenbeschriftung oder den Bereich Zeilenbeschriftung bewegen. Es ist jedoch nicht möglich, die Wertespaltenbeschriftung in den Bereich "Berichtsfilter" zu bewegen.

    • Sie können ein Feld nur einmal zum Bereich Berichtsfilter, Zeilenbeschriftung oder Spaltenbeschriftung hinzufügen, gleichgültig ob der Datentyp numerisch ist oder nicht. Wenn Sie dasselbe Feld mehr als einmal hinzufügen, z. B. im Bereich Zeilenbeschriftung und im Bereich Spaltenbeschriftung, werden die Felder automatisch aus dem ursprünglichen Bereich entfernt und in den neuen Bereich eingefügt.

    • Das Feld kann im Bereich Werte hinzugefügt werden, indem eine Formel verwendet wird (auch berechnete Spalte genannt), in der das Feld verwendet wird.

    • In einer PivotTable, die auf einer OLAP-Datenquelle basiert, können Sie das gleiche Feld nicht mehr als einmal hinzufügen.

Neuanordnen von Feldern in einer PivotTable

Sie können vorhandene Felder neu anordnen, oder Sie können diese Felder neu positionieren, indem Sie einen der vier Bereiche am unteren Rand des Layoutabschnitts verwenden:

PivotTable-Bericht

Beschreibung

PivotChart

Beschreibung

Werte    

Wird verwendet, um numerische Daten in einer Zusammenfassung anzuzeigen.

Werte    

Wird verwendet, um numerische Daten in einer Zusammenfassung anzuzeigen.

Zeilenbeschriftungen   

Wird verwendet, um Felder als Zeilen auf der Berichtsseite anzuzeigen. Eine Zeile unterhalb dieser Position ist in der direkt darüber liegenden Zeile geschachtelt.

Achsenfelder (Rubriken)   

Wird verwendet, um Felder als Achsen im Diagramm anzuzeigen.

Spaltenbeschriftungen   

Wird verwendet, um Felder als Spalten oben im Bericht anzuzeigen. Eine Spalte unterhalb dieser Position ist in einer direkt darüber liegenden Spalte geschachtelt.

Legendenfelder (Reihen)   

Wird verwendet, um Felder in der Legende des Diagramms anzuzeigen.

Berichtsfilter   

Wird verwendet, um den gesamten Bericht gemäß dem im Berichtsfilter ausgewählten Element zu filtern.

Berichtsfilter   

Wird verwendet, um den gesamten Bericht gemäß dem im Berichtsfilter ausgewählten Element zu filtern.

Wenn Sie Felder neu anordnen möchten, klicken Sie auf den Feldnamen in einem der Bereiche, und wählen Sie dann einen der folgenden Befehle aus:

Auswahl

Zweck

Nach oben   

Verschiebt das Feld im Bereich um eine Position nach oben.

Nach unten   

Verschiebt das Feld im Bereich um eine Position nach unten.

An den Anfang verschieben   

Verschiebt das Feld an den Anfang des Bereichs.

An das Ende verschieben   

Verschiebt das Feld an das Ende des Bereichs.

In Berichtsfilter verschieben   

Verschiebt das Feld in den Berichtsfilterbereich.

In Zeilenbeschriftungen verschieben   

Verschiebt das Feld in den Zeilenbeschriftungsbereich.

In Spaltenbeschriftungen verschieben   

Verschiebt das Feld in den Spaltenbeschriftungsbereich.

In Werte verschieben   

Verschiebt das Feld in den Wertebereich.

Wertfeldeinstellungen, Feldeinstellungen   

Zeigt das Dialogfeld Feldeinstellungen oder Wertfeldeinstellungen an. Weitere Informationen zu den einzelnen Einstellungen erhalten Sie, indem Sie oben im Dialogfeld auf die Schaltfläche "Hilfe" Schaltflächensymbol klicken.

Sie können auch auf einen Feldnamen klicken, die Maustaste gedrückt halten und das Feld aus dem Feldabschnitt in den Layoutabschnitt sowie von einem Bereich in einen anderen ziehen.

Entfernen von Feldern aus einer PivotTable

  1. Klicken Sie auf die PivotTable.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

  2. Um die PivotTable-Feldliste anzuzeigen, falls sie benötigt wird, klicken Sie auf der Registerkarte Analysieren oder Optionen in der Gruppe Anzeigen auf Feldliste.

    Abbildung des Excel-Menübands

  3. Führen Sie eine der folgenden Aktionen aus, um ein Feld aus der PivotTable-Feldliste zu löschen:

    • Deaktivieren Sie in der PivotTable-Feldliste das Kontrollkästchen neben dem Feldnamen.

      Hinweis: Durch Deaktivieren eines Kontrollkästchens in der Feldliste werden alle Instanzen des Felds aus dem Bericht entfernt.

    • Klicken Sie in einem Layoutbereich auf den Feldnamen, und klicken Sie dann auf Feld entfernen.

    • Klicken Sie im Layoutbereich auf einen Feldnamen, halten Sie die Maustaste gedrückt, und ziehen Sie ihn dann aus der PivotTable-Feldliste heraus.

Ändern des Layouts von Spalten, Zeilen und Teilergebnissen

Wenn das Layout der PivotTable noch weiter verfeinert werden soll, können Sie Änderungen vornehmen, die sich auf das Layout von Spalten, Zeilen und Teilergebnissen auswirken, z. B. Teilergebnisse oberhalb der Zeilen anzeigen oder Spaltenüberschriften ausblenden. Außerdem können einzelne Elemente in einer Zeile oder Spalte neu angeordnet werden.

Aktivieren und Deaktivieren von Spalten- und Zeilenfeldüberschriften

  1. Klicken Sie auf die PivotTable.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

  2. Klicken Sie zum Wechseln zwischen dem Anzeigen und Ausblenden von Feldüberschriften auf der Registerkarte Analysieren oder Optionen in der Gruppe Anzeigen auf Feldüberschriften.

    Abbildung des Excel-Menübands

Anzeigen von Teilergebnissen oberhalb oder unterhalb ihrer Zeilen

  1. Wählen Sie in der PivotTable das Zeilenfeld aus, für das Sie Teilergebnisse anzeigen möchten.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

    Tipp: Im Gliederungs- oder Tabellenformat können Sie alternativ auf das Zeilenfeld doppelklicken und dann mit Schritt 3 fortfahren.

  2. Klicken Sie auf der Registerkarte Analysieren oder Optionen in der Gruppe Aktives Feld auf Feldeinstellungen.

    Abbildung des Excel-Menübands

  3. Klicken Sie im Dialogfeld Feldeinstellungen auf der Registerkarte Teilergebnisse & Filter unter Teilergebnisse auf Automatisch oder Benutzerdefiniert.

    Hinweis:  Wenn Keine ausgewählt ist, sind Teilergebnisse deaktiviert.

  4. Klicken Sie auf der Registerkarte Layout & Drucken unter Layout auf Elementnamen in Gliederungsansicht anzeigen, und führen Sie dann einen der folgenden Schritte aus:

    • Wenn Sie die Teilergebnisse oberhalb der betreffenden Zeilen anzeigen möchten, aktivieren Sie das Kontrollkästchen Teilergebnisse oberhalb jeder Gruppe anzeigen. Diese Option ist standardmäßig aktiviert.

    • Wenn Sie die Teilergebnisse unter den betreffenden Zeilen anzeigen möchten, deaktivieren Sie das Kontrollkästchen Teilergebnisse oberhalb jeder Gruppe anzeigen.

Ändern der Reihenfolge von Zeilen- oder Spaltenelementen

Führen Sie eine der folgenden Aktionen aus:

  • Klicken Sie in der PivotTable mit der rechten Maustaste auf die Zeilen- oder Spaltenbeschriftung oder auf das Element in einer Beschriftung, zeigen Sie auf Verschieben, und verwenden Sie dann einen der Befehle im Menü Verschieben, um das Element an eine andere Position zu verschieben.

  • Wählen Sie das zu verschiebende Zeilen- oder Spaltenbeschriftungselement aus, und zeigen Sie dann auf den unteren Rand der Zelle. Wenn der Mauszeiger die Form eines Pfeils mit vier Spitzen annimmt, ziehen Sie das Element an eine neue Position. Die folgende Abbildung zeigt das Verschieben eines Zeilenelements durch Ziehen mit der Maus.

    Beispiel für das Verschieben eines Elements in einem PivotTable-Bericht

Anpassen der Spaltenbreite bei Aktualisierung

  1. Klicken Sie in der PivotTable auf eine beliebige Stelle.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

  2. Klicken Sie auf der Registerkarte Analysieren oder Optionen in der Gruppe PivotTable auf Optionen.

    Abbildung des Excel-Menübands

  3. Führen Sie im Dialogfeld PivotTable-Optionen auf der Registerkarte Layout & Format unter Format einen der folgenden Schritte aus:

    • Wenn die Spalten der PivotTable automatisch an die Größe des breitesten Text- oder Zahlenwerts angepasst werden sollen, aktivieren Sie die Option Spaltenbreiten bei Aktualisierung automatisch anpassen.

    • Wenn Sie die aktuelle Spaltenbreite der PivotTable beibehalten möchten, deaktivieren Sie das Kontrollkästchen Spaltenbreiten bei Aktualisierung automatisch anpassen.

Verschieben einer Spalte in den Zeilenbeschriftungsbereich oder Verschieben einer Zeile in den Spaltenbeschriftungsbereich

Möglicherweise möchten Sie ein Spaltenfeld in den Zeilenbeschriftungsbereich oder ein Zeilenfeld in den Spaltenbeschriftungsbereich verschieben, um das Layout und die Lesbarkeit der PivotTable zu optimieren. Wenn Sie eine Spalte in eine Zeile oder eine Zeile in eine Spalte verschieben, transponieren Sie die vertikale und horizontale Ausrichtung des Felds. Dieser Vorgang wird auch als "Pivotieren" einer Zeile oder Spalte bezeichnet.

Führen Sie eine der folgenden Aktionen aus:

  • Klicken Sie mit der rechten Maustaste auf ein Zeilenfeld, zeigen Sie auf "<Feldname>" verschieben, und klicken Sie dann auf "<Feldname>" in Spalten verschieben.

  • Klicken Sie mit der rechten Maustaste auf ein Spaltenfeld,und klicken Sie dann auf "<Feldname>" in Zeilen verschieben.

  • Ziehen Sie ein Zeilen- oder Spaltenfeld in einen anderen Bereich. In der folgenden Abbildung wird das Verschieben eines Spaltenfelds in den Zeilenbeschriftungsbereich veranschaulicht.

    Beispiel zum Ändern des Layouts eines PivotTable-Berichts

    1. Klicken Sie auf ein Spaltenfeld.

    2. Ziehen Sie es in den Zeilenbereich.

    3. "Sport" wird zu einem Zeilenfeld wie "Region".

Verbinden von Zellen für Elemente in äußeren Zeilen und Spalten oder Aufheben des Verbunds

Sie können Zellen für Elemente in Zeilen und Spalten verbinden, um Elemente horizontal und vertikal zu zentrieren, oder den Verbund aufheben, um die Elemente in äußeren Zeilen- und Spaltenfeldern oben in der Elementgruppe links auszurichten.

  1. Klicken Sie in der PivotTable auf eine beliebige Stelle.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

  2. Klicken Sie auf der Registerkarte Optionen in der Gruppe PivotTable auf Optionen.

    Abbildung des Excel-Menübands

  3. Klicken Sie im Dialogfeld PivotTable-Optionen auf die Registerkarte Layout & Format, und aktivieren oder deaktivieren Sie dann unter Layout das Kontrollkästchen Zellen mit Beschriftungen verbinden und zentrieren.

Hinweis:  Das Kontrollkästchen Zellen verbinden auf der Registerkarte Ausrichtung kann in einer PivotTable nicht verwendet werden.

Ändern der Anzeige von leeren Zellen, leeren Zeilen und Fehlern

Es kann vorkommen, dass in PivotTable-Daten leere Zellen, leere Zeilen oder Fehlerwerte enthalten sind, und Sie ihre Darstellung ändern möchten.

Ändern der Anzeige von Fehlern und leeren Zellen

  1. Klicken Sie in der PivotTable auf eine beliebige Stelle.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

  2. Klicken Sie auf der Registerkarte Analysieren oder Optionen in der Gruppe PivotTable auf Optionen.

    Abbildung des Excel-Menübands

  3. Klicken Sie im Dialogfeld PivotTable-Optionen auf die Registerkarte Layout & Format, und führen Sie dann unter Format eine der folgenden Aktionen aus:

    • Um der Fehleranzeige zu ändern, aktivieren Sie das Kontrollkästchen Fehlerwerte anzeigen als. Geben Sie in das Feld den Wert ein, der anstelle von Fehlern angezeigt werden soll. Wenn bei Fehlern kein Wert angezeigt werden soll, löschen Sie alle Zeichen im Feld.

    • Um die Anzeige von leeren Zellen zu ändern, aktivieren Sie das Kontrollkästchen Leere Zellen anzeigen als, und geben Sie dann den Wert in das Textfeld ein, der in leeren Zellen angezeigt werden soll.

      Tipp:  Wenn kein Wert angezeigt werden soll, löschen Sie alle Zeichen im Feld. Zum Anzeigen von Nullen deaktivieren Sie das Kontrollkästchen.

Ein- oder Ausblenden von leeren Zeilen im Anschluss an Zeilen oder Elemente

Führen Sie für Zeilen den folgenden Schritt aus:

  • Wählen Sie in der PivotTable ein Zeilenfeld aus.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

    Tipp: Im Gliederungs- oder Tabellenformat können Sie alternativ auf das Zeilenfeld doppelklicken und dann mit Schritt 3 fortfahren.

  • Klicken Sie auf der Registerkarte Analysieren oder Optionen in der Gruppe Aktives Feld auf Feldeinstellungen.

    Abbildung des Excel-Menübands

  • Aktivieren oder deaktivieren Sie im Dialogfeld Feldeinstellungen auf der Registerkarte Layout & Drucken unter Layout das Kontrollkästchen Leerzeile nach jedem Elementnamen einfügen.

Führen Sie für Elemente den folgenden Schritt aus:

  • Wählen Sie in der PivotTable das gewünschte Element aus.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

  • Klicken Sie auf der Registerkarte Entwurf in der Gruppe Layout auf Leere Zeilen, und aktivieren Sie dann das Kontrollkästchen Leerzeile nach jedem Elementnamen einfügen oder Leerzeile nach jedem Element entfernen.

    Abbildung des Excel-Menübands

    Hinweis: Auf Leerzeilen können zwar Schrift- und Zellenformatierungen angewendet werden, es können jedoch keine Daten eingegeben werden.

Ändern der Anzeige von Elementen und Beschriftungen ohne Daten

  1. Klicken Sie in der PivotTable auf eine beliebige Stelle.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

  2. Klicken Sie auf der Registerkarte Analysieren oder Optionen in der Gruppe PivotTable auf Optionen.

    Abbildung des Excel-Menübands

  3. Führen Sie auf der Registerkarte Anzeige unter Anzeige eine der folgenden Aktionen aus:

    • Um Elemente ohne Daten in Zeilen anzuzeigen, aktivieren oder deaktivieren Sie das Kontrollkästchen Elemente ohne Daten in den Zeilen anzeigen, um Zeilenelemente, die keine Werte enthalten, anzuzeigen oder auszublenden.

      Hinweis: Diese Einstellung ist nur für OLAP-Datenquellen (Online Analytical Processing) verfügbar.

    • Um Elemente ohne Daten in Spalten anzuzeigen, aktivieren oder deaktivieren Sie das Kontrollkästchen Elemente ohne Daten in den Spalten anzeigen, um Spaltenelemente, die keine Werte enthalten, anzuzeigen oder auszublenden.

      Hinweis: Diese Einstellung ist nur für OLAP-Datenquellen verfügbar.

    • Um Elementbeschriftungen anzuzeigen, wenn sich keine Felder im Wertebereich befinden, aktivieren oder deaktivieren Sie das Kontrollkästchen Elementnamen anzeigen, wenn im Wertbereich keine Felder vorhanden sind, um Elementbeschriftungen anzuzeigen oder auszublenden, wenn der Wertebereich keine Felder enthält.

      Hinweis: Dieses Kontrollkästchen gilt nur für PivotTables, die mit Excel-Versionen vor Office Excel 2007 erstellt wurden.

Ändern oder Entfernen der Formatierung

Im Katalog können Sie aus den unterschiedlichsten PivotTable-Formatvorlagen auswählen. Außerdem können Sie das Verhalten eines Berichts für Bereiche steuern. Durch das Ändern des Zahlenformats in einem Feld lässt sich das Format im Bericht schnell einheitlich anpassen. Sie können auch Bereiche (abwechselnd dunklerer und hellerer Hintergrund) für Zeilen oder Spalten hinzufügen oder entfernen. Durch Bereiche wird die Lesbarkeit und Übersichtlichkeit von Tabellen erhöht.

Anwenden einer Formatvorlage zum Formatieren einer PivotTable

Aussehen und Formatierung einer PivotTable lassen sich mithilfe einer der vielen vordefinierten PivotTable-Formatvorlagen (oder Schnellformatvorlagen) schnell ändern.

  1. Klicken Sie in der PivotTable auf eine beliebige Stelle.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

  2. Führen Sie auf der Registerkarte Entwurf in der Gruppe PivotTable-Formate eine der folgenden Aktionen aus:

    • Klicken Sie auf eine sichtbare PivotTable-Formatvorlage, oder scrollen Sie durch den Katalog, um weitere Formatvorlagen anzuzeigen.

    • Um alle verfügbaren Formatvorlagen anzuzeigen, klicken Sie unten in der Scrollleiste auf die Schaltfläche Mehr.

      Abbildung des Excel-Menübands

      Wenn Sie eine eigene benutzerdefinierte Formatvorlage für PivotTables erstellen möchten, klicken Sie unten im Katalog auf Neues PivotTable-Format, um das Dialogfeld Neues PivotTable-Format anzuzeigen.

Anwenden von Bereichen, um das Format einer PivotTable zu ändern

  1. Klicken Sie in der PivotTable auf eine beliebige Stelle.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

  2. Führen Sie auf der Registerkarte Entwurf in der Gruppe Optionen für PivotTable-Formate eine der folgenden Aktionen aus:

    • Wenn Sie zwischen heller und dunkler formatierten Zeilen abwechseln möchten, klicken Sie auf Verbundene Zeilen.

    • Wenn Sie zwischen heller und dunkler formatierten Spalten abwechseln möchten, klicken Sie auf Verbundene Spalten.

    • Wenn die Zeilenüberschriften beim Banding eingeschlossen werden sollen, klicken Sie auf Zeilenüberschriften.

    • Wenn die Spaltenüberschriften beim Banding eingeschlossen werden sollen, klicken Sie auf Spaltenüberschriften.

      Abbildung des Excel-Menübands

Entfernen einer Formatvorlage oder eines Bereichsformats aus einer PivotTable

  1. Klicken Sie in der PivotTable auf eine beliebige Stelle.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

  2. Klicken Sie auf der Registerkarte Entwurf in der Gruppe PivotTable-Formate am unteren Rand der Bildlaufleiste auf die Schaltfläche Weitere, um alle verfügbaren Formatvorlagen anzuzeigen. Klicken Sie dann unten in der Sammlung auf Löschen.

    Abbildung des Excel-Menübands

Bedingte Formatierung von Daten in einer PivotTable

Verwenden Sie ein bedingtes Format, wenn Sie Daten optisch untersuchen und analysieren, Probleme erkennen sowie Muster und Trends ermitteln möchten. Mithilfe bedingter Formatierungen können Sie bestimmte Fragen zu den Daten beantworten. Beim Anwenden einer bedingten Formatierung auf eine PivotTable sind einige wichtige Unterschiede zu beachten.

  • Wenn Sie das Layout der PivotTable ändern, indem Sie Filter anwenden, Ebenen ausblenden, Ebenen reduzieren oder erweitern oder ein Feld verschieben, bleibt die bedingte Formatierung bestehen, solange die Felder in den zugrunde liegenden Daten nicht entfernt werden.

  • Der Bereich der bedingten Formatierung für Felder im Bereich Werte kann auf der Datenhierarchie basieren und wird durch alle sichtbaren untergeordneten Elemente (die nächst niedrigere Ebene in einer Hierarchie) eines übergeordneten Elements (die nächst höhere Ebene in einer Hierarchie) in Zeilen für eine oder mehrere Spalten oder in Spalten für eine oder mehrere Zeilen bestimmt.

    Hinweis: Innerhalb der Datenhierarchie übernehmen die untergeordneten Elemente nicht die bedingte Formatierung des übergeordneten Elements und auch das übergeordnete Element übernimmt nicht die bedingte Formatierung der untergeordneten Elemente.

  • Es gibt drei Methoden, mit denen der Bereich der bedingten Formatierung für Felder im Wertebereich definiert werden kann: durch Auswahl, durch ein entsprechendes Feld und durch ein Wertfeld.

Weitere Informationen finden Sie unter Anwenden von bedingter Formatierung.

Ändern des Zahlenformats für ein Feld

  1. Wählen Sie in der PivotTable das entsprechende Feld aus.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

  2. Klicken Sie auf der Registerkarte Analysieren oder Optionen in der Gruppe Aktives Feld auf Feldeinstellungen.

    Abbildung des Excel-Menübands

    Im Dialogfeld Feldeinstellungen werden Beschriftungen und Berichtsfilter angezeigt; im Dialogfeld Wertfeldeinstellungen werden Werte angezeigt.

  3. Klicken Sie unten im Dialogfeld auf Zahlenformat.

  4. Klicken Sie im Dialogfeld Zellen formatieren in der Liste Rubrik auf das Zahlenformat, das Sie verwenden möchten.

  5. Wählen Sie die gewünschten Optionen aus, und klicken Sie dann zweimal auf OK.

    Sie können auch mit der rechten Maustaste auf ein Wertfeld und dann auf Zahlenformat klicken.

Einschließen von OLAP-Serverformatierung

Wenn eine Verbindung zu einer Microsoft SQL Server Analysis Services-OLAP-Datenbank (Online Analytical Processing) besteht, können Sie angeben, welche OLAP-Serverformate abgerufen und mit den Daten angezeigt werden sollen.

  1. Klicken Sie in der PivotTable auf eine beliebige Stelle.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

  2. Klicken Sie auf der Registerkarte Analysieren oder Optionen in der Gruppe Daten auf Datenquelle ändern und anschließend auf Verbindungseigenschaften.

    Abbildung des Excel-Menübands

  3. Führen Sie im Dialogfeld Verbindungseigenschaften auf der Registerkarte Verwendung im Abschnitt OLAP-Serverformatierung eine der folgenden Aktionen aus:

    • Mit dem Kontrollkästchen Zahlenformat können Sie die Zahlenformatierung, z. B. Währung, Datum oder Uhrzeit, aktivieren oder deaktivieren.

    • Aktivieren oder deaktivieren Sie das Kontrollkästchen Schriftschnitt, um Schriftschnitte wie fett, kursiv, unterstrichen und durchgestrichen zu aktivieren bzw. zu deaktivieren.

    • Aktivieren oder deaktivieren Sie das Kontrollkästchen Füllfarbe, um Füllfarben zu aktivieren bzw. zu deaktivieren.

    • Aktivieren oder deaktivieren Sie das Kontrollkästchen Textfarbe, um Textfarben zu aktivieren bzw. zu deaktivieren.

Beibehalten und Verwerfen von Formatierungen

  1. Klicken Sie in der PivotTable auf eine beliebige Stelle.

    Dadurch wird die Registerkarte PivotTable-Tools im Menüband angezeigt.

  2. Klicken Sie auf der Registerkarte Analysieren oder Optionen in der Gruppe PivotTable auf Optionen.

    Abbildung des Excel-Menübands

  3. Führen Sie auf die Registerkarte Layout & Format unter Format eine oder mehrere der folgenden Aktionen aus:

    • Wenn Sie Layout und Format der PivotTable speichern möchten, damit sie bei jeder Bearbeitung der PivotTable angewendet werden, aktivieren Sie das Kontrollkästchen Zellformatierung bei Aktualisierung beibehalten.

    • Wenn Sie Layout und Format der PivotTable verwerfen und zum Standardlayout und -format zurückkehren möchten, sobald Sie einen Vorgang in der PivotTable ausführen, deaktivieren Sie das Kontrollkästchen Zellformatierung bei Aktualisierung beibehalten.

    Hinweis: Obwohl diese Option auch Auswirkungen auf die Formatierung des PivotCharts hat, bleiben Trendlinien, Datenbeschriftungen, Fehlerindikatoren und andere Änderungen an bestimmten Datenreihen nicht erhalten.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×