Zu Hauptinhalt springen

Aufzeichnen eines Makros

Wenn Sie eine Aufgabe in Microsoft Office Project wiederholt ausführen, können Sie die Aufgabe mit einem Makro automatisieren. Bei einem Makro handelt es sich um eine Reihe von Befehlen und Funktionen, die in einem Modul gespeichert werden und immer dann ausgeführt werden können, wenn Sie die Aufgabe ausführen müssen.

  1. Wählen Sie auf der Registerkarte Ansicht die Option Makrosaus, und wählen Sie dann Makro aufzeichnenaus.

    (Zeigen Sie in Project 2007 im Menü Extras auf Makro, und wählen Sie dann Neues Makro aufzeichnenaus.)

  2. Geben Sie im Feld Makroname einen Namen für die Makro ein.

    Das erste Zeichen des Makronamens muss ein Buchstabe sein. Andere Zeichen können Buchstaben, Zahlen oder Unterstrichzeichen sein. Leerzeichen sind in einem Makronamen nicht zulässig, der Unterstrich funktioniert aber auch als Word-Trennzeichen.

  3. Um das Makro durch Drücken einer Tastenkombination ausführen zu können, geben Sie im Feld Tastenkombination einen Buchstaben oder eine Tastenkombination ein.

    Sie können Strg + Buchstabe (für Kleinbuchstaben) oder STRG + UMSCHALT + Buchstabe (für Großbuchstaben) verwenden, wobei Buchstabe eine beliebige Buchstabentaste auf der Tastatur, aber keine Zahl oder ein Sonderzeichen ist. Sie können keine Tastenkombination verwenden, die bereits in Microsoft Office Project verwendet wird.

  4. Wählen Sie in der Liste Makro speichern in den Speicherort aus, an dem Sie das Makro speichern möchten:

    • Wenn Sie das Makro bei jeder Verwendung von Project verfügbar machen möchten, wählen Sie globale Dateiaus.

    • Wenn Sie das Makro nur für das aktuelle Projekt verfügbar machen möchten, wählen Sie dieses Projektaus.

  5. Wenn Sie eine Beschreibung des Makros einfügen möchten, geben Sie die Beschreibung in das Feld Beschreibung ein.

  6. Wenn Sie während der Aufzeichnung eines Makros Zellen auswählen, wählt das Makro die gleiche Spalte (das Feld) jedes Mal aus, wenn es ausgeführt wird, unabhängig davon, welche Zelle zuerst ausgewählt wird, da Sie absolute Bezüge auf Spalten aufzeichnet. Wenn ein Makro Spalten unabhängig von der Position der aktiven Zelle auswählen soll, wenn Sie das Makro ausführen, wählen Sie relativ unter Spaltenbezügeaus.

    Umgekehrt wählt das Makro Zeilen unabhängig von der Position der aktiven Zelle aus, wenn Sie das Makro ausführen, da relative Bezüge zu Zeilen aufgezeichnet werden. Wenn ein Makro immer dieselbe Zeile auswählen soll, unabhängig davon, welche Zelle zuerst ausgewählt wird, wählen Sie unter Zeilenbezügedie Option absolut (ID) aus.

    Hinweis: Project verwendet diese Einstellungen während der Aufzeichnung von Makros weiterhin, bis Sie entweder die Einstellungen ändern oder Project schließen.

  7. Wählen Sie OKaus, und führen Sie dann die Aktionen aus, die Sie aufzeichnen möchten.

  8. Wenn Sie alle Aktionen, die Sie aufzeichnen möchten, abgeschlossen haben, wählen Sie auf der Registerkarte Ansicht die Option Makrosaus, und wählen Sie dann Aufzeichnung beendenaus.

    (Zeigen Sie in Project 2007 im Menü Extras auf Makro, und wählen Sie Recorder beendenaus.)

Sicherheitshinweis: Da Makros Viren enthalten können, sollten Sie bei ihrer Ausführung Vorsicht walten lassen. Ergreifen Sie die folgenden Vorsichtsmaßnahmen: Führen Sie Antivirensoftware auf Ihrem Computer aus, die auf dem neuesten Stand ist, legen Sie die Makrosicherheitsstufe auf "Hoch" fest, deaktivieren Sie das Kontrollkästchen Allen installierten Add-Ins und Vorlagen vertrauen, verwenden Sie digitale Signaturen, und verwalten Sie eine Liste der vertrauenswürdigen Herausgeber.

Hinweis:  Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Lassen Sie uns bitte wissen, ob diese Informationen hilfreich für Sie waren. Hier finden Sie den englischen Artikel als Referenz.

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×