Arbeiten mit Offlinecubedateien

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Eine Offlinecubedatei (CUB) speichert Daten in Form eines Cubes (OLAP = Online Analytical Processing). Diese Daten möglicherweise einen Teil einer OLAP-Datenbank aus einem OLAP-Server darzustellen, oder es wurden unabhängig von einem beliebigen OLAP-Datenbank erstellt. Verwenden Sie eine Offlinecubedatei weiterhin mit PivotTable- und PivotChart-Berichten zu arbeiten, wenn der Server nicht verfügbar ist, oder wenn Sie nicht mit dem Netzwerk verbunden sind.

Sicherheitshinweis: Achten Sie darauf verwenden oder Verteilen von Offlinecubedateien, die vertrauliche oder private Informationen enthält. Erwägen Sie statt einer Cubedatei Schutz der Daten in der Arbeitsmappe ein, damit Sie Verwaltung von Informationsrechten zum Steuern des Zugriffs auf die Daten verwenden können. Weitere Informationen finden Sie unter Verwaltung von Informationsrechten in Office.

Beim Arbeiten mit einem PivotTable- oder PivotChart-Bericht, die auf Quelldaten aus einer OLAP-Server basiert, können Sie die Offline-Cube-Assistenten verwenden, um die Quelldaten in einer separaten Offlinecubedatei auf Ihrem Computer zu kopieren. Um diese offline Dateien erstellen zu können, müssen Sie den OLAP-Datenanbieter haben, der diese Funktion, wie z. B. MSOLAP aus Microsoft SQL Server Analysis Services auf Ihrem Computer installiert unterstützt.

Hinweis: Das Erstellen und die Verwendung der Offlinecubedateien aus Microsoft SQL Server Analysis Services unterliegt der Ausdruck und Lizenzierung von Microsoft SQL Server-Installation. Schlagen Sie in den entsprechenden Lizenzinformationen von Ihrer Version von SQL Server.

Mithilfe des Offline-Cube-Assistenten

Zum Erstellen der Offlinecubedatei verwenden Sie den Offline-Cube-Assistenten wählen eine Teilmenge der Daten in der OLAP-Datenbank, und speichern Sie dann auf die Teilmenge an. Der Bericht verfügt nicht über jedes Feld enthalten, die Sie in der Datei enthalten, und Sie können auswählen, von einem beliebigen Dimensionen und Datenfelder, die in der OLAP-Datenbank verfügbar sind. Wenn Sie die Größe der Datei auf ein Minimum beibehalten möchten, können Sie nur die Daten enthalten, die im Bericht angezeigt werden soll. Sie können ganze Dimensionen weglassen und für die meisten Arten von Dimensionen, können Sie auch Low-Level-Details und Elemente, die Sie benötigen, um anzuzeigen, der obersten Ebene auslassen. Für alle Elemente, die Sie einschließen, die Eigenschaftenfelder, die in der Datenbank für diese Elemente sind, auch in Ihrer offline-Datei gespeichert sind.

Offlineschalten der Daten, und klicken Sie dann die Daten eingebunden Onlineschalten

Dazu müssen Sie zuerst einen PivotTable- oder PivotChart-Bericht erstellen, der auf der Serverdatenbank basiert, und dann von diesem Bericht eine Offlinecubedatei erzeugen. Sie können den Bericht jederzeit wahlweise in der Serverdatenbank oder in der Offlinedatei bearbeiten (z. B. bei Verwendung eines Laptops für zu Hause oder unterwegs) und später die Verbindung des Computers zum Netzwerk wiederherstellen.

Im folgenden Verfahren sind die Basisschritte beschrieben, mit denen Daten offline und später wieder online verfügbar gemacht werden können.

  1. Erstellen Sie oder öffnen Sie einer PivotTable oder PivotChart-Bericht, die auf die OLAP Daten basieren, die Sie offline zugreifen möchten.

  2. Erstellen einer Offlinecubedatei auf Ihrem Computer. Finden Sie im Abschnitt Erstellen einer Offlinecubedatei aus einer OLAP-Server-Datenbankaus.

  3. Trennen Sie die Verbindung zum Netzwerk, und arbeiten Sie mit der Offlinecubedatei.

  4. Wiederherstellen der Verbindung zu Ihrem Netzwerk, und schließen Sie den Cube Offlinedatei wieder. Finden Sie im Abschnitt Verbindung Offlinecubedatei zu OLAP-Server-Datenbank wiederherstellenaus.

  5. Aktualisieren der Offlinecubedatei mit neuen Daten und anschließend neu erstellen der Offlinecubedatei. Finden Sie im Abschnitt aktualisieren, und erstellen Sie eine Offlinecubedatei neuaus.

  6. Wiederholen Sie den Vorgang, und beginnen Sie dabei mit Schritt 3.

Hinweis: Wenn Ihre OLAP-Datenbank sehr groß ist und mit der Cubedatei der Zugriff auf eine große Teilmenge der Daten bereitgestellt werden soll, müssen Sie für einen umfangreichen Speicherplatz sorgen, und das Speichern der Datei kann sich als zeitaufwändig erweisen. Zur Steigerung der Leistung sollten Sie das Erstellen der Offlinecubedatei mit einem MDX-Skript erwägen.

  1. Klicken Sie auf den PivotTable-Bericht, für den Sie eine Offlinecubedatei erstellen möchten, oder auf den Zugeordneter PivotTable-Bericht für einen PivotChart-Bericht.

  2. Klicken Sie auf der Registerkarte Analysieren in der Gruppe Berechnungen klicken Sie auf OLAP-Tools, und klicken Sie dann auf Offline OLAP.

    Das Dialogfeld Offline-OLAP-Einstellungen wird angezeigt.

    Hinweis: Wenn Ihr OLAP-Anbieter keine Offlinecubedateien unterstützt, ist der Befehl Offline-OLAP nicht verfügbar. Weitere Informationen erhalten Sie von Ihrem OLAP-Anbieter.

  3. Klicken Sie auf Offlinedatei erstellen oder – falls bereits eine Offlinecubedatei für den Bericht vorhanden ist – auf Offlinedatei bearbeiten.

    Der Offlinecube-Assistent wird angezeigt.

  4. Klicken Sie in Schritt 1 des Assistenten auf Weiter.

  5. Wählen Sie in Schritt 2 des Assistenten jedes Dimension aus dem Servercube, der Daten enthält, die in der Offlinecubedatei enthalten sein sollen. Klicken Sie auf das Plusfeld neben der jeweiligen Dimension, und wählen Sie die Ebenen, die Sie einschließen möchten.

    Hinweise: 

    • Zwischenebenen innerhalb einer Dimension können nicht übersprungen werden.

    • Wenn Sie die Größe der Cubedatei reduzieren möchten, sollten Sie tiefere Ebenen weglassen, die im Bericht nicht angezeigt werden müssen.

    • Nehmen Sie jedoch auf jeden Fall alle Dimensionen auf, in denen Sie Elemente gruppiert haben, damit diese Gruppierungen in Microsoft Office Excel beibehalten werden können, wenn Sie zwischen der Serverdatenbank und der Offlinedatei wechseln.

    • Dimensionen, die nicht über ein Feld Plusfeld verfügen zulassen nicht Ebenen ausgeschlossen. Sie können nur ein- oder ausschließen alle diese Art von Dimensionen.

  6. Klicken Sie in Schritt 3 des Assistenten klicken Sie auf das Plusfeld neben Measures, und wählen Sie die Felder, die Sie als Datenfelder im Bericht verwenden möchten. Sie müssen mindestens ein Element auswählen. Andernfalls werden das Measure zugeordneten Dimensionen keine Daten enthalten. Klicken Sie für jede Dimension unter Measures aufgeführt wird auf das Plusfeld neben der Dimension, und wählen Sie dann auf die Elemente der obersten Ebene in der Offlinecubedatei aufgenommen werden sollen.

    • Wenn Sie die Größe der Cubedatei begrenzen möchten, damit der Speicherplatz nicht knapp wird und die benötigte Zeit zum Speichern der Datei reduziert wird, wählen Sie nur die Elemente aus, die in dem Bericht angezeigt werden müssen. Sämtliche Eigenschaftenfelder, die für die ausgewählten Elemente verfügbar sind, werden automatisch in die Cubedatei aufgenommen.

    • Falls Elemente fehlen, die Sie aufnehmen möchten, haben Sie möglicherweise im vorherigen Schritt die Dimension ausgelassen, die diese Elemente enthält. Klicken Sie im Assistent auf Zurück, wählen Sie die fehlende Dimension in Schritt 2 aus, und kehren Sie dann zu Schritt 3 zurück.

      Hinweis: Im OLAP-Cube-Assistent sind für Datenfelder nur die Funktionen Summe, Anzahl, Minimum und Maximum verfügbar.

  7. Geben Sie in Schritt 4 des Assistenten den Namen und Speicherort für die CUB-Datei ein, und klicken Sie dann auf Fertig stellen.

    Wenn Sie das Speichern der Datei abbrechen möchten, klicken Sie im Dialogfeld Cubedatei erstellen - Fortschritt auf Anhalten.

  8. Nachdem die Offlinecubedatei durch Excel erstellt wurde, klicken Sie im Dialogfeld Offline-OLAP-Einstellungen auf OK.

Problem: Meinem Computer genügend Speicherplatz auf dem Datenträger speichern einen Cube.

OLAP-Datenbanken sind für die Verwaltung sehr großer Datenmengen ausgelegt. Daher benötigt die Serverdatenbank u. U. sehr viel mehr Speicherplatz, als auf der lokalen Festplatte zur Verfügung steht. Wenn Sie eine große Untermenge dieser Daten für die Offlinecubedatei definiert haben, steht auf Ihrer Festplatte möglicherweise nicht genug Speicherplatz zur Verfügung. Die Größe der Offlinecubedatei kann mit Hilfe der folgenden Strategien reduziert werden.

Speicherplatz freigeben oder anderes Laufwerk suchen.    Löschen Sie vor dem Speichern der Cubedatei nicht mehr benötigte Dateien von der Festplatte, oder speichern Sie die Datei auf einem Netzlaufwerk.

Weniger Daten in die Offlinecubedatei einbeziehen.    Überlegen Sie, wie Sie die Datenmenge in der Datei reduzieren können, ohne auf die für den PivotTable- oder PivotChart-Bericht benötigten Daten zu verzichten. Versuchen Sie es mit folgenden Maßnahmen:

  • Dimensionen entfernen.    Wählen Sie in Schritt 2 des Offline-Cube-Assistenten nur die Dimensionen aus, die tatsächlich als Felder im PivotTable- oder PivotChart-Bericht angezeigt werden.

  • Beseitigen Detailebenen     Klicken Sie auf das Plusfeld neben jeder ausgewählten Dimension in Schritt 2 des Assistenten aus, und deaktivieren Sie dann die Kontrollkästchen für Ebenen niedriger als diejenigen, die in Ihrem Bericht angezeigt.

  • Beseitigen von Datenfeldern    Klicken Sie in Schritt 3 des Assistenten klicken Sie auf das Plusfeld neben Measures, und wählen Sie dann im Bericht nur die Datenfelder, die Sie verwenden.

  • Beseitigen von Elementen von Daten    Klicken Sie auf das Plusfeld neben jeder Dimension in Schritt 3, und deaktivieren Sie dann die Kontrollkästchen für Elemente, die Sie benötigen, um in den Bericht anzuzeigen.

  1. Klicken Sie auf den PivotTable-Bericht oder Zugeordneter PivotTable-Bericht für einen PivotChart-Bericht.

  2. Klicken Sie auf der Registerkarte Analysieren in der Gruppe Berechnungen klicken Sie auf OLAP-Tools, und klicken Sie dann auf Offline OLAP.

  3. Klicken Sie auf Online OLAP, und klicken Sie dann auf OK.

  4. Wenn Sie aufgefordert werden, um die Datenquelle zu suchen, klicken Sie auf Durchsuchen, um die Quelle zu suchen, und suchen Sie dann den OLAP-Server in Ihrem Netzwerk.

Das Aktualisieren einer Offlinecubedatei, bei dem die Datei anhand der neuesten Daten von einem Servercube oder einer neuen Offlinecubedatei neu erstellt wird, kann ein zeitaufwändiger Vorgang sein, für den sehr viel temporärer Speicherplatz erforderlich ist. Starten Sie den Vorgang zu einem Zeitpunkt, zu dem kein sofortiger Zugriff auf andere Dateien erforderlich ist. Vergewissern Sie sich außerdem, dass genügend Speicherplatz vorhanden ist, um die Datei erneut zu speichern.

  1. Klicken Sie auf den PivotTable-Bericht, der auf der Offlinecubedatei basiert.

  2. Klicken Sie in Excel 2016: Klicken Sie auf der Registerkarte Daten in der Gruppe Abfragen und Verbindungen auf den Pfeil neben Alle aktualisieren, und klicken Sie dann auf Aktualisieren.

    Klicken Sie in Excel 2013: Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf den Pfeil neben Alle aktualisieren, und klicken Sie dann auf Aktualisieren.

Problem: Neue Daten nicht in meinem Bericht angezeigt, wenn ich aktualisieren.

Vergewissern Sie sich, dass die ursprüngliche Datenbank verfügbar ist.    Möglicherweise kann zwischen der Offlinecubedatei und der ursprünglichen Serverdatenbank keine Verbindung zum Abrufen neuer Daten hergestellt werden. Überprüfen Sie, ob die ursprüngliche Serverdatenbank, aus der die Daten für den Cube stammen, möglicherweise umbenannt oder verschoben wurde. Vergewissern Sie sich, dass der Server verfügbar ist und Sie eine Verbindung zu ihm herstellen können.

Vergewissern Sie sich, dass neue Daten verfügbar sind.    Überprüfen Sie mit dem Datenbankadministrator, ob die Datenbank in den Bereichen, die im Bericht enthalten sind, aktualisiert wurde.

Vergewissern Sie sich, dass die Datenbankorganisation nicht verändert wurde.    Wenn ein OLAP-Servercube neu erstellt wurde, muss möglicherweise der Bericht ebenfalls neu organisiert, eine neue Offlinecubedatei erstellt oder mit dem OLAP-Cube-Assistent ein neuer Cube erzeugt werden, damit Sie auf die geänderten Daten zugreifen können. Klären Sie mit dem Datenbankadministrator, ob Änderungen an der Datenbank vorgenommen wurden.

Das Speichern einer überarbeiteten Offlinecubedatei kann zeitaufwändig sein. Außerdem können Sie nicht in Excel arbeiten, während die Datei gespeichert wird. Starten Sie den Vorgang zu einem Zeitpunkt, zu dem kein sofortiger Zugriff auf andere Dateien erforderlich ist. Vergewissern Sie sich außerdem, dass genügend Speicherplatz zur Verfügung steht, um die Datei erneut zu speichern.

  1. Vergewissern Sie sich, dass Sie eine Verbindung zum Netzwerk besteht und Sie auf die ursprüngliche OLAP-Serverdatenbank zugreifen können, aus der die Daten für die Offlinecubedatei stammen.

  2. Klicken Sie auf einen PivotTable-Bericht, der auf der Offlinecubedatei basiert, oder klicken Sie auf den zugeordneten PivotTable-Bericht für einen PivotChart-Bericht.

  3. Klicken Sie auf der Registerkarte Analysieren in der Gruppe Berechnungen klicken Sie auf OLAP-Tools, und klicken Sie dann auf Offline OLAP.

  4. Klicken Sie auf Offline-OLAP, und klicken Sie dann auf Offlinedatei bearbeiten.

  5. Führen Sie im Offline-Cube-Assistenten die angegebenen Schritte aus, um andere Daten für die Datei auszuwählen. Geben Sie im letzten Schritt den Namen und Speicherort der vorhandenen Datei an, die geändert werden soll.

Hinweis: Wenn Sie das Speichern der Datei abbrechen möchten, klicken Sie im Dialogfeld Cubedatei erstellen - Fortschritt auf Anhalten.

Warnung: Wenn Sie die Offlinecubedatei für einen Bericht löschen, können Sie den Bericht nicht mehr offline verwenden oder eine neue Offlinecubedatei für den Bericht erstellen.

  1. Schließen Sie alle Arbeitsmappen, die Berichte enthalten, für die die Offlinecubedatei verwendet wird, oder vergewissern Sie sich, dass alle entsprechenden Berichte gelöscht wurden.

  2. Suchen Sie in Windows die Offlinecubedatei (*.cub), und löschen Sie sie.

Hinweis: Wenn Ihre OLAP-Datenbank sehr groß ist und mit der Cubedatei der Zugriff auf eine große Teilmenge der Daten bereitgestellt werden soll, müssen Sie für einen umfangreichen Speicherplatz sorgen, und das Speichern der Datei kann sich als zeitaufwändig erweisen. Zur Steigerung der Leistung sollten Sie das Erstellen der Offlinecubedatei mit einem MDX-Skript erwägen.

  1. Klicken Sie auf den PivotTable-Bericht, für den Sie eine Offlinecubedatei erstellen möchten, oder auf den Zugeordneter PivotTable-Bericht für einen PivotChart-Bericht.

  2. Klicken Sie auf der Registerkarte Optionen in der Gruppe Tools klicken Sie auf OLAP-Tools, und klicken Sie dann auf Offline OLAP.

    Abbildung der Outlook-Multifunktionsleise

    Das Dialogfeld Offline-OLAP-Einstellungen wird angezeigt.

    Hinweis: Wenn Ihr OLAP-Anbieter keine Offlinecubedateien unterstützt, ist der Befehl Offline-OLAP nicht verfügbar. Weitere Informationen erhalten Sie von Ihrem OLAP-Anbieter.

  3. Klicken Sie auf Offlinedatei erstellen oder – falls bereits eine Offlinecubedatei für den Bericht vorhanden ist – auf Offlinedatei bearbeiten.

    Der Offlinecube-Assistent wird angezeigt.

  4. Klicken Sie in Schritt 1 des Assistenten auf Weiter.

  5. Wählen Sie in Schritt 2 des Assistenten jedes Dimension aus dem Servercube, der Daten enthält, die in der Offlinecubedatei enthalten sein sollen. Klicken Sie auf das Plusfeld neben der jeweiligen Dimension, und wählen Sie die Ebenen, die Sie einschließen möchten.

    Hinweise: 

    • Zwischenebenen innerhalb einer Dimension können nicht übersprungen werden.

    • Wenn Sie die Größe der Cubedatei reduzieren möchten, sollten Sie tiefere Ebenen weglassen, die im Bericht nicht angezeigt werden müssen.

    • Nehmen Sie jedoch auf jeden Fall alle Dimensionen auf, in denen Sie Elemente gruppiert haben, damit diese Gruppierungen in Microsoft Office Excel beibehalten werden können, wenn Sie zwischen der Serverdatenbank und der Offlinedatei wechseln.

    • Dimensionen, die nicht über ein Feld Plusfeld verfügen zulassen nicht Ebenen ausgeschlossen. Sie können nur ein- oder ausschließen alle diese Art von Dimensionen.

  6. Klicken Sie in Schritt 3 des Assistenten klicken Sie auf das Plusfeld neben Measures, und wählen Sie die Felder, die Sie als Datenfelder im Bericht verwenden möchten. Sie müssen mindestens ein Element auswählen. Andernfalls werden das Measure zugeordneten Dimensionen keine Daten enthalten. Klicken Sie für jede Dimension unter Measures aufgeführt wird auf das Plusfeld neben der Dimension, und wählen Sie dann auf die Elemente der obersten Ebene in der Offlinecubedatei aufgenommen werden sollen.

    • Wenn Sie die Größe der Cubedatei begrenzen möchten, damit der Speicherplatz nicht knapp wird und die benötigte Zeit zum Speichern der Datei reduziert wird, wählen Sie nur die Elemente aus, die in dem Bericht angezeigt werden müssen. Sämtliche Eigenschaftenfelder, die für die ausgewählten Elemente verfügbar sind, werden automatisch in die Cubedatei aufgenommen.

    • Falls Elemente fehlen, die Sie aufnehmen möchten, haben Sie möglicherweise im vorherigen Schritt die Dimension ausgelassen, die diese Elemente enthält. Klicken Sie im Assistent auf Zurück, wählen Sie die fehlende Dimension in Schritt 2 aus, und kehren Sie dann zu Schritt 3 zurück.

      Hinweis: Im OLAP-Cube-Assistent sind für Datenfelder nur die Funktionen Summe, Anzahl, Minimum und Maximum verfügbar.

  7. Geben Sie in Schritt 4 des Assistenten den Namen und Speicherort für die CUB-Datei ein, und klicken Sie dann auf Fertig stellen.

    Wenn Sie das Speichern der Datei abbrechen möchten, klicken Sie im Dialogfeld Cubedatei erstellen - Fortschritt auf Anhalten.

  8. Nachdem die Offlinecubedatei durch Excel erstellt wurde, klicken Sie im Dialogfeld Offline-OLAP-Einstellungen auf OK.

Problem: Meinem Computer genügend Speicherplatz auf dem Datenträger speichern einen Cube.

OLAP-Datenbanken sind für die Verwaltung sehr großer Datenmengen ausgelegt. Daher benötigt die Serverdatenbank u. U. sehr viel mehr Speicherplatz, als auf der lokalen Festplatte zur Verfügung steht. Wenn Sie eine große Untermenge dieser Daten für die Offlinecubedatei definiert haben, steht auf Ihrer Festplatte möglicherweise nicht genug Speicherplatz zur Verfügung. Die Größe der Offlinecubedatei kann mit Hilfe der folgenden Strategien reduziert werden.

Speicherplatz freigeben oder anderes Laufwerk suchen.    Löschen Sie vor dem Speichern der Cubedatei nicht mehr benötigte Dateien von der Festplatte, oder speichern Sie die Datei auf einem Netzlaufwerk.

Weniger Daten in die Offlinecubedatei einbeziehen.    Überlegen Sie, wie Sie die Datenmenge in der Datei reduzieren können, ohne auf die für den PivotTable- oder PivotChart-Bericht benötigten Daten zu verzichten. Versuchen Sie es mit folgenden Maßnahmen:

  • Dimensionen entfernen.    Wählen Sie in Schritt 2 des Offline-Cube-Assistenten nur die Dimensionen aus, die tatsächlich als Felder im PivotTable- oder PivotChart-Bericht angezeigt werden.

  • Beseitigen Detailebenen     Klicken Sie auf das Plusfeld neben jeder ausgewählten Dimension in Schritt 2 des Assistenten aus, und deaktivieren Sie dann die Kontrollkästchen für Ebenen niedriger als diejenigen, die in Ihrem Bericht angezeigt.

  • Beseitigen von Datenfeldern    Klicken Sie in Schritt 3 des Assistenten klicken Sie auf das Plusfeld neben Measures, und wählen Sie dann im Bericht nur die Datenfelder, die Sie verwenden.

  • Beseitigen von Elementen von Daten    Klicken Sie auf das Plusfeld neben jeder Dimension in Schritt 3, und deaktivieren Sie dann die Kontrollkästchen für Elemente, die Sie benötigen, um in den Bericht anzuzeigen.

  1. Klicken Sie auf den PivotTable-Bericht oder Zugeordneter PivotTable-Bericht für einen PivotChart-Bericht.

  2. Klicken Sie auf der Registerkarte Optionen in der Gruppe Tools klicken Sie auf OLAP-Tools, und klicken Sie dann auf Offline OLAP.

    Abbildung der Outlook-Multifunktionsleise

  3. Klicken Sie auf Online OLAP, und klicken Sie dann auf OK.

  4. Wenn Sie aufgefordert werden, um die Datenquelle zu suchen, klicken Sie auf Durchsuchen, um die Quelle zu suchen, und suchen Sie dann den OLAP-Server in Ihrem Netzwerk.

Das Aktualisieren einer Offlinecubedatei, bei dem die Datei anhand der neuesten Daten von einem Servercube oder einer neuen Offlinecubedatei neu erstellt wird, kann ein zeitaufwändiger Vorgang sein, für den sehr viel temporärer Speicherplatz erforderlich ist. Starten Sie den Vorgang zu einem Zeitpunkt, zu dem kein sofortiger Zugriff auf andere Dateien erforderlich ist. Vergewissern Sie sich außerdem, dass genügend Speicherplatz vorhanden ist, um die Datei erneut zu speichern.

  1. Klicken Sie auf den PivotTable-Bericht, der auf der Offlinecubedatei basiert.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen klicken Sie auf den Pfeil neben Alle aktualisieren, und klicken Sie dann auf Aktualisieren.

    Abbildung der Excel-Multifunktionsleiste

Problem: Neue Daten nicht in meinem Bericht angezeigt, wenn ich aktualisieren.

Vergewissern Sie sich, dass die ursprüngliche Datenbank verfügbar ist.    Möglicherweise kann zwischen der Offlinecubedatei und der ursprünglichen Serverdatenbank keine Verbindung zum Abrufen neuer Daten hergestellt werden. Überprüfen Sie, ob die ursprüngliche Serverdatenbank, aus der die Daten für den Cube stammen, möglicherweise umbenannt oder verschoben wurde. Vergewissern Sie sich, dass der Server verfügbar ist und Sie eine Verbindung zu ihm herstellen können.

Vergewissern Sie sich, dass neue Daten verfügbar sind.    Überprüfen Sie mit dem Datenbankadministrator, ob die Datenbank in den Bereichen, die im Bericht enthalten sind, aktualisiert wurde.

Vergewissern Sie sich, dass die Datenbankorganisation nicht verändert wurde.    Wenn ein OLAP-Servercube neu erstellt wurde, muss möglicherweise der Bericht ebenfalls neu organisiert, eine neue Offlinecubedatei erstellt oder mit dem OLAP-Cube-Assistent ein neuer Cube erzeugt werden, damit Sie auf die geänderten Daten zugreifen können. Klären Sie mit dem Datenbankadministrator, ob Änderungen an der Datenbank vorgenommen wurden.

Das Speichern einer überarbeiteten Offlinecubedatei kann zeitaufwändig sein. Außerdem können Sie nicht in Excel arbeiten, während die Datei gespeichert wird. Starten Sie den Vorgang zu einem Zeitpunkt, zu dem kein sofortiger Zugriff auf andere Dateien erforderlich ist. Vergewissern Sie sich außerdem, dass genügend Speicherplatz zur Verfügung steht, um die Datei erneut zu speichern.

  1. Vergewissern Sie sich, dass Sie eine Verbindung zum Netzwerk besteht und Sie auf die ursprüngliche OLAP-Serverdatenbank zugreifen können, aus der die Daten für die Offlinecubedatei stammen.

  2. Klicken Sie auf einen PivotTable-Bericht, der auf der Offlinecubedatei basiert, oder klicken Sie auf den zugeordneten PivotTable-Bericht für einen PivotChart-Bericht.

  3. Klicken Sie auf der Registerkarte Optionen in der Gruppe Tools klicken Sie auf OLAP-Tools, und klicken Sie dann auf Offline OLAP.

  4. Klicken Sie auf Offline-OLAP, und klicken Sie dann auf Offlinedatei bearbeiten.

  5. Führen Sie im Offline-Cube-Assistenten die angegebenen Schritte aus, um andere Daten für die Datei auszuwählen. Geben Sie im letzten Schritt den Namen und Speicherort der vorhandenen Datei an, die geändert werden soll.

Hinweis: Wenn Sie das Speichern der Datei abbrechen möchten, klicken Sie im Dialogfeld Cubedatei erstellen - Fortschritt auf Anhalten.

Warnung: Wenn Sie die Offlinecubedatei für einen Bericht löschen, können Sie den Bericht nicht mehr offline verwenden oder eine neue Offlinecubedatei für den Bericht erstellen.

  1. Schließen Sie alle Arbeitsmappen, die Berichte enthalten, für die die Offlinecubedatei verwendet wird, oder vergewissern Sie sich, dass alle entsprechenden Berichte gelöscht wurden.

  2. Suchen Sie in Windows die Offlinecubedatei (*.cub), und löschen Sie sie.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×