Aktualisieren von PivotTable-Daten

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Sie können jederzeit auf Aktualisieren klicken, um die Daten für die PivotTables in Ihrer Arbeitsmappe zu aktualisieren. Sie können die Daten für PivotTables aktualisieren, die mit externen Daten verbunden sind, die beispielsweise in einer Datenbank (SQL Server, Oracle, Access usw.), in einem Analysis Services-Cube, in einem Datenfeed oder in vielen andere Quellen enthalten sind. Sie können auch Daten aus einer Quelltabelle aktualisieren, die sich in derselben oder in einer anderen Arbeitsmappe befindet. Und Sie können eine Arbeitsmappe so einstellen, dass in ihr enthaltene PivotTable-Daten automatisch aktualisiert werden, wenn Sie die Mappe öffnen.

Standardmäßig werden PivotTables nicht automatisch aktualisiert, aber Sie können angeben, dass die PivotTable automatisch aktualisiert wird, wenn Sie die Arbeitsmappe öffnen, die die PivotTable enthält.

Manuelles Aktualisieren

  1. Klicken Sie auf eine beliebige Stelle in der PivotTable, damit die PivotTable-Tools im Menüband angezeigt werden.

    PivotTable-Tools

  2. Klicken Sie auf Analysieren > Aktualisieren, oder drücken Sie ALT+F5.

    Schaltfläche 'Aktualisieren' auf der Registerkarte 'Analysieren'

    Tipp: Wenn Sie alle PivotTables in einer Arbeitsmappe gleichzeitig aktualisieren möchten, klicken Sie auf analysieren > Alle aktualisieren.

Dauert das Aktualisieren länger als Sie erwartet haben, klicken Sie auf Analysieren > Pfeil unter Aktualisieren > Status aktualisieren, um den Aktualisierungsstatus zu überprüfen.

Wenn Sie das Aktualisieren beenden möchten, Klicken Sie auf Aktualisierung abbrechen.

Verhindern, dass Spaltenbreiten und Zellenformatierung angepasst werden

Werden die Spaltenbreiten und die Zellenformatierung angepasst, wenn Sie die PivotTable-Daten aktualisieren, diese Anpassung von Ihnen aber nicht gewünscht ist, müssen Sie die folgenden Optionen deaktivieren:

  1. Klicken Sie auf Analysieren > Optionen.

    Schaltfläche "Optionen" auf der Registerkarte "Analysieren"

  2. Deaktivieren Sie auf der Registerkarte Layout & Format die Kontrollkästchen Spaltenbreiten bei Aktualisierung automatisch anpassen und Zellformatierung bei Aktualisierung beibehalten.

Automatisches Aktualisieren von Daten, wenn die Arbeitsmappe geöffnet wird

  1. Klicken Sie auf eine beliebige Stelle in der PivotTable, damit die PivotTable-Tools im Menüband angezeigt werden.

    PivotTable-Tools

  2. Klicken Sie auf Analysieren > Optionen.

    Schaltfläche "Optionen" auf der Registerkarte "Analysieren"

  3. Aktivieren Sie auf der Registerkarte Daten das Kontrollkästchen Daten beim Öffnen der Datei aktualisieren .

Manuelles Aktualisieren

  1. Klicken Sie an einer beliebigen Stelle in der PivotTable.

    Dadurch werden die PivotTable-Tools angezeigt, und es werden eine Optionen und eine Registerkarte Entwurf hinzugefügt.

  2. Führen Sie auf der Registerkarte Optionen in der Gruppe Daten eine der folgenden Aktionen aus:

  3. Wenn Sie die Informationen so aktualisieren möchten, dass Sie der Datenquelle entsprechen, klicken Sie auf die Schaltfläche Aktualisieren , oder drücken Sie ALT + F5.

    Sie können auch mit der rechten Maustaste auf die PivotTable und dann auf Aktualisieren klicken.

  4. Wenn Sie alle PivotTables in der Arbeitsmappe aktualisieren möchten, klicken Sie auf den Pfeil der Schaltfläche Aktualisieren , und klicken Sie dann auf Alle aktualisieren.

    Abbildung des Excel-Menübands

    Wenn die Aktualisierung länger dauert als erwartet, klicken Sie auf Optionen > Aktualisieren > Status aktualisieren , um den Aktualisierungsstatus zu übernehmen.

    Wenn Sie das Aktualisieren beenden möchten, Klicken Sie auf Aktualisierung abbrechen.

Verhindern, dass Spaltenbreiten und Zellenformatierung angepasst werden

Werden die Spaltenbreiten und die Zellenformatierung angepasst, wenn Sie die PivotTable-Daten aktualisieren, diese Anpassung von Ihnen aber nicht gewünscht ist, müssen Sie die folgenden Optionen deaktivieren:

  1. Klicken Sie auf Optionen > Optionen.

    Gruppe 'PivotTable' auf der Registerkarte 'Optionen' unter 'PivotTable-Tools'
  2. Deaktivieren Sie auf der Registerkarte Layout & Format die Kontrollkästchen Spaltenbreiten bei Aktualisierung automatisch anpassen und Zellformatierung bei Aktualisierung beibehalten.

Automatisches Aktualisieren von PivotTable-Daten beim Öffnen der Arbeitsmappe

  1. Klicken Sie an einer beliebigen Stelle in der PivotTable.

  2. Klicken Sie in der Gruppe PivotTable auf der Registerkarte Optionen auf Optionen.

    Gruppe 'PivotTable' auf der Registerkarte 'Optionen' unter 'PivotTable-Tools'

  3. Aktivieren Sie im Dialogfeld PivotTable-Optionen auf der Registerkarte Daten das Kontrollkästchen Daten beim Öffnen der Datei aktualisieren .

Wenn Sie Ihrer PivotTable-Datenquelle neue Daten hinzufügen, müssen alle PivotTables, die auf dieser Datenquelle erstellt wurden, aktualisiert werden. Wenn Sie die PivotTable aktualisieren möchten, klicken Sie mit der rechten Maustaste auf eine beliebige Stelle im PivotTable-Bereich, und wählen Sie dann Aktualisieren aus.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×