Zuordnen von XML-Elementen zu Zellen in einer XML-Zuordnung

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Zum Importieren und Exportieren von XML-Daten in Excel ist eine XML-Zuordnung, die zur Erzielung der gewünschten Ergebnisse XML-Elemente mit Daten in Zellen verknüpft, ein hilfreiches Feature. Zur Erstellung einer solchen Zuordnung benötigen Sie eine XML-Schemadatei (XSD) und eine XML-Datendatei (XML). Nach Erstellen der XML-Zuordnung können Sie XML-Elemente auf die gewünschte Weise zuordnen.

Tipp : Weitere Informationen zur Verwendung von XML bei Excel finden Sie in diesem Überblick über XML in Excel.

Suchen nach oder Erstellen von XML-Schema- und XML-Datendateien

Verwenden von XML-Beispielschema- und -Beispieldatendateien

Erstellen einer XML-Zuordnung

Zuordnen von XML-Elementen

Suchen nach oder Erstellen von XML-Schema- und XML-Datendateien

Wenn eine XML-Schema- oder XML-Datendatei in einer anderen Datenbank oder Anwendung erstellt wurde, stehen Ihnen diese Dateien eventuell bereits zur Verfügung. So verfügen Sie beispielsweise über eine Branchenanwendung, die Daten in diese XML-Dateiformate exportiert, eine kommerzielle Website oder einen Webdienst, die bzw. der diese XML-Dateien liefert, oder eine von Ihrer IT-Abteilung entwickelte benutzerdefinierte Anwendung, die diese XML-Dateien automatisch erstellt.

Wenn Sie nicht über die erforderlichen XML-Dateien verfügen, können Sie sie erstellen, indem Sie die zu verwendenden Daten als Textdatei speichern. Diese Textdatei können Sie anschließend sowohl mit Access als auch mit Excel in die benötigten XML-Dateien konvertieren. Gehen Sie dazu folgendermaßen vor:

Access

  1. Importieren Sie die zu konvertierende Textdatei, und verknüpfen Sie sie mit einer neuen Tabelle.

    1. Klicken Sie auf Datei > Öffnen.

    2. Wählen Sie im Dialogfeld Öffnen die Datenbank aus, in der Sie eine neue Tabelle erstellen möchten, und öffnen Sie sie.

    3. Klicken Sie auf Externe Daten > Textdatei, und folgen Sie den Anweisungen für die einzelnen Schritte. Stellen Sie sicher, dass Sie die Tabelle mit der Textdatei verknüpfen.

      Die neue Tabelle wird von Access erstellt und im Navigationsbereich angezeigt.

  2. Exportieren Sie die Daten aus der verknüpften Tabelle in eine XML-Datendatei und eine XML-Schemadatei.

    1. Klicken Sie auf Externe Daten > XML-Datei (in der Gruppe Exportieren).

    2. Geben Sie im Dialogfeld Exportieren - XML-Dateien den Dateinamen und das Dateiformat an, und klicken Sie auf OK.

  3. Beenden Sie Access.

Excel

  1. Erstellen Sie eine XML-Zuordnung, die auf der aus Access exportierten XML-Schemadatei basiert.

    Wenn das Dialogfeld Mehrere Wurzeln angezeigt wird, müssen Sie das Element dataroot auswählen, damit Sie eine XML-Tabelle erstellen können.

  2. Erstellen Sie eine XML-Tabelle, indem Sie das Element dataroot zuordnen. Weitere Informationen hierzu finden Sie unter Zuordnen von XML-Elementen.

  3. Importieren Sie die XML-Datei, die Sie aus Access exportiert haben.

Hinweise : Es gibt verschiedene XML-Schemaelementkonstrukte, die von Excel nicht unterstützt werden. Die folgenden Konstrukte können nicht in Excel importiert werden:

<any>    Dieses Element ermöglicht das Einbeziehen von Elementen, die im Schema nicht deklariert sind.

<anyAttribute>    Dieses Element ermöglicht das Einbeziehen von Attributen, die im Schema nicht deklariert sind.

Rekursive Strukturen    Ein typisches Beispiel für eine rekursive Struktur ist eine Hierarchie von Mitarbeitern und Vorgesetzten, in der dieselben XML-Elemente auf mehreren Ebenen geschachtelt sind. Rekursive Strukturen mit einer Tiefe von mehr als einer Ebene werden in Excel nicht unterstützt.

Abstrakte Elemente    Diese Elemente sollten in dem Schema deklariert sein, jedoch niemals als Elemente verwendet werden. Abstrakte Elemente hängen von anderen Elementen ab, durch die abstrakte Elemente ersetzt werden.

Ersetzungsgruppen    Diese Gruppen ermöglichen den Austausch eines Elements, wenn auf ein anderes Element verwiesen wird. Ein Element gibt durch das Attribut <substitutionGroup> an, dass es Mitglied der Ersetzungsgruppe eines anderen Elements ist.

Gemischter Inhalt    Bei gemischtem Inhalt werden komplexe Datentypen mit mixed="true" deklariert. Einfacher Inhalt mit komplexen Datentypen wird in Excel nicht unterstützt. Unterstützt werden jedoch die für diesen Datentyp definierten untergeordneten Tags und Attribute.

Verwenden von XML-Beispielschema- und -Beispieldatendateien

Wenn Sie über keine XML-Dateien oder Textdateien zum Erstellen der XML-Dateien verfügen, können Sie zum Testen von XML-Zuordnungen die folgenden XML-Beispieldaten verwenden. Sie enthalten XML-Basiselemente und -strukturen. Zum Speichern dieser Beispieldaten in Dateien auf Ihrem Computer führen Sie die folgenden Schritte aus:

  1. Markieren Sie den Beispieltext der Datei, die Sie kopieren möchten, und drücken Sie STRG+C.

  2. Starten Sie den Editor, und drücken Sie STRG+V, um den Beispieltext einzufügen.

  3. Drücken Sie STRG+S, um die Datei unter dem Dateinamen und mit der Erweiterung der kopierten Beispieldaten zu speichern.

  4. Drücken Sie im Editor STRG+N, und wiederholen Sie die Schritte 1 bis 3, um eine Datei für den zweiten Beispieltext zu erstellen.

  5. Beenden Sie Editor.

XML-Beispieldaten (Expenses.xml)

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<Root>
<EmployeeInfo>
<Name>Jane Winston</Name>
<Date>2001-01-01</Date>
<Code>0001</Code>
</EmployeeInfo>
<ExpenseItem>
<Date>2001-01-01</Date>
<Description>Airfare</Description>
<Amount>500.34</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-01</Date>
<Description>Hotel</Description>
<Amount>200</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-01</Date>
<Description>Taxi Fare</Description>
<Amount>100.00</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-01</Date>
<Description>Long Distance Phone Charges</Description>
<Amount>57.89</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-01</Date>
<Description>Food</Description>
<Amount>82.19</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-02</Date>
<Description>Food</Description>
<Amount>17.89</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-02</Date>
<Description>Personal Items</Description>
<Amount>32.54</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-03</Date>
<Description>Taxi Fare</Description>
<Amount>75.00</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-03</Date>
<Description>Food</Description>
<Amount>36.45</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-03</Date>
<Description>New Suit</Description>
<Amount>750.00</Amount>
</ExpenseItem>
</Root>

XML-Beispielschema (Expenses.xsd)

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<xsd:element name="Root">
<xsd:complexType>
<xsd:sequence>
<xsd:element minOccurs="0" maxOccurs="1" name="EmployeeInfo">
<xsd:complexType>
<xsd:all>
<xsd:element minOccurs="0" maxOccurs="1" name="Name" />
<xsd:element minOccurs="0" maxOccurs="1" name="Date" />
<xsd:element minOccurs="0" maxOccurs="1" name="Code" />
</xsd:all>
</xsd:complexType>
</xsd:element>
<xsd:element minOccurs="0" maxOccurs="unbounded" name="ExpenseItem">
<xsd:complexType>
<xsd:sequence>
<xsd:element name="Date" type="xsd:date"/>
<xsd:element name="Description" type="xsd:string"/>
<xsd:element name="Amount" type="xsd:decimal" />
</xsd:sequence>
</xsd:complexType>
</xsd:element>
</xsd:sequence>
</xsd:complexType>
</xsd:element>
</xsd:schema>

Erstellen einer XML-Zuordnung

Eine XML-Zuordnung wird erstellt, indem Sie einer Arbeitsmappe ein XML-Schema hinzufügen. Das Schema kann aus einer XML-Schemadatei (XSD) kopiert oder von Excel aus einer XML-Datendatei (XML) abgeleitet werden.

  1. Klicken Sie auf Entwicklertools > Quelle.

    XML-Befehle auf der Registerkarte 'Entwicklertools'

    Wenn die Registerkarte Entwicklertools nicht angezeigt wird, lesen Sie Anzeigen der Registerkarte "Entwicklertools".

  2. Klicken Sie im Aufgabenbereich XML-Quelle auf XML-Zuordnungen und dann auf Hinzufügen.

  3. Klicken Sie in der Liste Suchen in auf das Laufwerk, den Ordner oder den Internetspeicherort, das bzw. der die zu öffnende Datei enthält.

  4. Klicken Sie auf die Datei und dann auf Öffnen.

    • Wenn Sie eine XML-Schemadatei öffnen, erstellt XML eine XML-Zuordnung auf der Grundlage des XML-Schemas. Wenn das Dialogfeld Mehrere Wurzeln angezeigt wird, wählen Sie einen der Stammknoten aus, der in der XML-Schemadatei definiert ist.

    • Wenn Sie eine XML-Datendatei öffnen, versucht Excel, aus den XML-Daten das XML-Schema abzuleiten, und erstellt dann eine XML-Zuordnung.

  5. Klicken Sie auf OK.

    Die XML-Zuordnung wird im Aufgabenbereich XML-Quelle angezeigt.

Zuordnen von XML-Elementen

XML-Elemente werden in XML-Tabellen einzeln zugeordneten und wiederholten Zellen so zugeordnet, dass eine Beziehung zwischen der Zelle und dem XML-Datenelement im XML-Schema hergestellt wird.

  1. Klicken Sie auf Entwicklertools > Quelle.

    XML-Befehle auf der Registerkarte 'Entwicklertools'

    Wenn die Registerkarte Entwicklertools nicht angezeigt wird, lesen Sie Anzeigen der Registerkarte "Entwicklertools".

  2. Wählen Sie im Aufgabenbereich XML-Quelle die Elemente aus, die Sie zuordnen möchten.

    Zum Auswählen nicht aufeinander folgender Elemente klicken Sie auf ein Element. Halten Sie dann STRG gedrückt, und klicken Sie auf jedes Element, das Sie zuordnen möchten.

  3. Zum Zuordnen der Elemente gehen Sie folgendermaßen vor:

    1. Klicken Sie mit der rechten Maustaste auf die ausgewählten Elemente, und klicken Sie auf Element verknüpfen.

    2. Wählen Sie im Dialogfeld XML-Elemente zuordnen eine Zelle aus, und klicken Sie auf OK.

      Tipp : Sie können die ausgewählten Elemente auch an die Stelle im Arbeitsblatt ziehen, an der sie angezeigt werden sollen.

      Jedes Element wird im Arbeitsbereich XML-Quelle fettgedruckt angezeigt. Dies weist darauf hin, dass das Element zugeordnet ist.

  4. Überlegen Sie, wie Beschriftungen und Spaltenüberschriften behandelt werden sollen:

    • Wenn Sie ein nicht wiederholtes XML-Element in das Arbeitsblatt ziehen und eine einzeln zugeordnete Zelle erstellen, wird ein Smarttag mit drei Befehlen angezeigt, mit denen Sie die Platzierung der Kopfzeile oder Beschriftung steuern können:

      Meine Daten haben bereits eine Kopfzeile    Klicken Sie auf diese Option, um die Kopfzeile des XML-Elements zu ignorieren, da die Zelle bereits über eine Kopfzeile (auf der linken Seite oder oberhalb der Daten) verfügt.

      XML-Kopfzeile links anordnen    Klicken Sie auf diese Option, wenn die Kopfzeile des XML-Elements als Zellenbeschriftung (auf der linken Seite der Daten) verwendet werden soll.

      XML-Kopfzeile oberhalb anordnen    Klicken Sie auf diese Option, wenn die Kopfzeile des XML-Elements als Zellenüberschrift (oberhalb der Daten) verwendet werden soll.

    • Wenn Sie ein wiederholtes XML-Element in das Arbeitsblatt ziehen und in einer XML-Tabelle wiederholte Zellen erstellen, werden die XML-Elementnamen automatisch als Spaltenüberschriften für die Tabelle verwendet. Sie können die Spaltenüberschriften jedoch nach Belieben ändern, indem Sie die zugehörigen Zellen bearbeiten.

      Zur weitergehenden Steuerung des Verhaltens der XML-Tabelle klicken Sie im Arbeitsbereich XML-Quelle auf Optionen:

      Elemente bei Verknüpfung automatisch zusammenführen    Wenn dieses Kontrollkästchen aktiviert ist, werden XML-Tabellen automatisch erweitert, wenn Sie ein Element in eine Zelle neben der XML-Tabelle ziehen.

      Meine Daten haben Überschriften    Wenn dieses Kontrollkästchen aktiviert ist und Sie Ihrem Arbeitsblatt wiederholte Elemente zuordnen, können vorhandene Daten als Spaltenüberschriften verwendet werden.

      Hinweise : 

      • Wenn alle XML-Befehle abgeblendet sind und Sie XML-Elemente keinen Zellen zuordnen können, wurde die Arbeitsmappe möglicherweise freigegeben. Klicken Sie auf Überprüfen > Arbeitsmappe freigeben, um dies zu überprüfen, und die Freigabe der Arbeitsmappe nach Bedarf aufzuheben.

        Wenn Sie XML-Elemente in einer freizugebenden Arbeitsmappe zuordnen möchten, ordnen Sie sie den gewünschten Zellen zu, importieren Sie die XML-Daten, entfernen Sie alle XML-Zuordnungen, und geben Sie die Arbeitsmappe dann frei.

      • Wenn Sie eine XML-Tabelle, die Daten enthält, nicht in eine andere Arbeitsmappe kopieren können, verfügt die Tabelle möglicherweise über eine zugehörige XML-Zuordnung zur Definition der Datenstruktur. Diese XML-Zuordnung ist in der Arbeitsmappe gespeichert, doch wenn Sie die XML-Tabelle in eine neue Arbeitsmappe kopieren, wird die Zuordnung nicht automatisch einbezogen. Statt die XML-Tabelle zu kopieren, erstellt Excel eine eigene Tabelle, die die gleichen Daten enthält. Wenn die neue Tabelle eine XML-Tabelle sein soll, gehen Sie wie folgt vor:

        1. Fügen Sie der neuen Arbeitsmappe eine XML-Zuordnung hinzu, und verwenden Sie dafür die XML- oder XSD-Datei, mit der Sie die ursprüngliche XML-Zuordnung erstellt haben. Wenn Sie XML-Zuordnungen zu weiteren Arbeitsmappen hinzufügen möchten, sollten Sie diese Dateien speichern.

        2. Ordnen Sie der Tabelle die XML-Elemente zu, um die Tabelle in eine XML-Tabelle umzuwandeln.

      • Wenn Sie ein wiederholtes XML-Element einer verbundenen Zelle zuordnen, hebt Excel die Verbindung der Zelle auf. Dies ist ein erwartetes Verhalten, weil wiederholte Elemente nur bei nicht verbundenen Zellen funktionieren sollen.

        Sie können einzelne, nicht wiederholte XML-Elemente einer verbundenen Zelle zuordnen, doch das Zuordnen eines wiederholten XML-Elements (oder eines Elements, das ein wiederholtes Element enthält) zu einer verbundenen Zelle ist nicht zulässig. Die Verbindung der Zelle wird aufgehoben und das Element der Zelle zugeordnet, in der sich der Mauszeiger befindet.

Tipps : Sie können die Zuordnung von XML-Elementen aufheben, die Sie nicht verwenden möchten, oder Sie können mit dieser Aufhebung verhindern, dass die Inhalte von Zellen beim Importieren von XML-Daten überschrieben werden. So könnten Sie beispielsweise die Zuordnung eines XML-Elements bei einer einzelnen Zelle oder bei wiederholten Zellen mit Formeln vorübergehend aufheben, die beim Importieren einer XML-Datei nicht überschrieben werden sollen. Nach Abschluss des Importvorgangs können Sie das XML-Element den Zellen mit Formeln erneut zuordnen, sodass Sie die Ergebnisse der Formeln in die XML-Datendatei exportieren können.

Zum Aufheben der Zuordnung eines XML-Elements klicken Sie mit der rechten Maustaste im Aufgabenbereich XML-Quelle auf dessen Namen, und klicken Sie dann auf Element entfernen.

Anzeigen der Registerkarte "Entwicklertools"

Wenn die Registerkarte Entwicklertools nicht angezeigt wird, führen Sie die folgenden Schritte aus, um sie anzuzeigen:

  • In Excel 2010, 2013 und 2016:

    1. Klicken Sie auf Datei > Optionen.

    2. Klicken Sie auf die Kategorie Menüband anpassen.

    3. Aktivieren Sie unter Hauptregisterkarten das Kontrollkästchen Entwicklertools, und klicken Sie auf OK.

  • In Excel 2007:

    1. Klicken Sie auf die Microsoft Office-Schaltfläche  Abbildung der Office-Schaltfläche > Excel-Optionen.

    2. Klicken Sie auf die Kategorie Beliebt.

    3. Aktivieren Sie unter Die am häufigsten verwendeten Optionen bei der Arbeit mit Excel das Kontrollkästchen Entwicklerregisterkarte in der Multifunktionsleiste anzeigen, und klicken Sie auf OK.

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Siehe auch

Überblick über XML in Excel

Importieren von XML-Daten

Exportieren von XML-Daten

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×