ZÄHLENWENNS (Funktion)

In diesem Artikel werden die Formelsyntax und die Verwendung der Funktion ZÄHLENWENNS in Microsoft Excel beschrieben.

Beschreibung

Wendet Kriterien auf Zellen in mehreren Bereichen an und zählt, wie oft alle Kriterien zutreffen.

Syntax

ZÄHLENWENNS(Kriterienbereich1;Kriterien1;[Kriterienbereich2; Kriterien2]…)

Die Syntax der Funktion ZÄHLENWENNS weist die folgenden Argumente auf:

  • Kriterienbereich1    Erforderlich. Der erste Bereich, in dem die zugehörigen Kriterien ausgewertet werden sollen.

  • Kriterien1    Erforderlich. Die Kriterien in Form einer Zahl, eines Ausdrucks, Zellbezugs oder Texts, mit denen definiert wird, welche Zellen gezählt werden. Kriterien können beispielsweise als 32, ">32", B4, "Äpfel" oder "32" angegeben werden.

  • Kriterienbereich2;Kriterien2; ...    Optional. Zusätzliche Bereiche und deren zugehörige Kriterien. Es sind bis zu 127 Bereich/Kriterien-Paare zulässig.

Wichtig   Jeder zusätzliche Bereich muss dieselbe Anzahl von Zeilen und Spalten wie das Argument Kriterienbereich1 haben. Die Bereiche müssen nicht direkt nebeneinander liegen.

Hinweise

  • Die Kriterien der einzelnen Bereiche werden jeweils auf eine Zelle angewendet. Wenn alle ersten Zellen den zugehörigen Kriterien entsprechen, erhöht sich die Anzahl um 1. Wenn alle zweiten Zellen den zugehörigen Kriterien entsprechen, erhöht sich die Anzahl nochmals um 1 usw. bis alle Zellen ausgewertet sind.

  • Wenn ein Kriterien-Argument ein Bezug auf eine leere Zelle ist, wird die leere Zelle von der Funktion ZÄHLENWENNS als Nullwert (0) behandelt.

  • Eine als Kriterien angegebene Zeichenfolge darf die Platzhalterzeichen Fragezeichen (?) und Sternchen (*) enthalten. Ein Fragezeichen ersetzt ein Zeichen, und ein Sternchen ersetzt eine beliebige Zeichenfolge. Wenn Sie nach einem Fragezeichen oder Sternchen suchen möchten, müssen Sie eine Tilde (~) vor das zu suchende Zeichen setzen.

Beispiele

Kopieren Sie die Beispieldaten in der folgenden Tabelle, und fügen Sie sie in Zelle A1 eines neuen Excel-Arbeitsblatts ein. Um die Ergebnisse der Formeln anzuzeigen, markieren Sie sie, drücken Sie F2 und dann die EINGABETASTE. Im Bedarfsfall können Sie die Breite der Spalten anpassen, damit alle Daten angezeigt werden.

Verkäufer

Überschrittenes Kontingent für Q1

Überschrittenes Kontingent für Q2

Überschrittenes Kontingent für Q3

Derenbach

Ja

Nein

Nein

Burkhard

Ja

Ja

Nein

Söntmann

Ja

Ja

Ja

Lesken

Nein

Ja

Ja

Formel

Beschreibung

Ergebnis

=ZÄHLENWENNS(B2:D2;"=Ja")

Zählt, wie oft Derenbach ein Verkaufskontingent für die Zeiträume Q1, Q2 und Q3 überschritten hat (nur in Q1).

1

=ZÄHLENWENNS(B2:B5;"=Ja";C2:C5;"=Ja")

Zählt, wie viele Verkäufer sowohl das Kontingent für Q1 als auch für Q2 überschritten haben (Burkhard und Söntmann).

2

=ZÄHLENWENNS(B5:D5;"=Ja";B3:D3;"=Ja")

Zählt, wie oft Lesken und Burkhard dasselbe Kontingent für die Zeiträume Q1, Q2 und Q3 überschritten haben (nur in Q2).

1

Beispiel 2

Daten

 

1

01.05.2011

2

02.05.2011

3

03.05.2011

4

04.05.2011

5

05.05.2011

6

06.05.2011

Formel

Beschreibung

Ergebnis

=ZÄHLENWENNS(A2:A7;"<6";A2:A7;">1")

Zählt, wie viele Zahlen zwischen 1 und 6 (1 und 6 nicht eingeschlossen) in den Zellen A2 bis A7 enthalten sind.

4

=ZÄHLENWENNS(A2:A7;"<5";B2:B7;"<03.05.2011")

Zählt, wie viele Zeilen in den Zellen A2 bis A7 Zahlen enthalten, die kleiner sind als 5, und außerdem in den Zellen B2 bis B7 Daten aufweisen, die vor dem 03.05.2011 liegen.

0

=ZÄHLENWENNS(A2:A7;"<"&A6;B2:B7;"<"&B4)

Die gleiche Beschreibung wie beim vorherigen Beispiel, jedoch mit Zellbezügen anstelle von Konstanten in den Kriterien.

2

Gilt für: Excel 2016 Preview, Excel 2010, Excel Starter, Excel 2013, Excel Online, Excel 2016 for Mac, Excel for Mac 2011, Excel 2007



War diese Information hilfreich?

Ja Nein

Wie können wir es verbessern?

255 Zeichen verfügbar

Um Ihre Privatsphäre zu schützen, geben Sie bitte keine Kontaktinformationen in Ihrem Feedback an. Lesen Sie unsere Datenschutzbestimmung.

Vielen Dank für Ihr Feedback!

Supportressourcen

Sprache ändern