Zählen von Zeichen in Zellen mit Excel 2016 für Mac

Zum Zählen von Zeichen in Zellen verwenden Sie die Funktion LÄNGE. Mit dieser Funktion können Sie Buchstaben, Zahlen, Zeichen und alle Leerzeichen zählen. Der Text "Heute ist es 32 Grad warm, und deshalb gehe ich schwimmen." enthält (ohne die Anführungszeichen) 58 Zeichen: 44 Buchstaben, zwei Zahlen, zehn Leerzeichen, ein Komma und einen Punkt.

  • Wenn Sie diese Funktion verwenden möchten, geben Sie =LÄNGE(Zelle) in die Bearbeitungsleiste ein, und drücken Sie die EINGABETASTE. In den folgenden Beispielen gibt Zelle die Zelle an, deren Inhalt Sie zählen möchten (beispielsweise B1).

  • Wenn Sie die Zeichen in mehr als einer Zelle zählen möchten, geben Sie die Formel ein, und kopieren Sie sie dann in die anderen Zellen.

  • Wenn Sie die Gesamtzahl der Zeichen in mehreren Zellen zählen möchten, verwenden Sie neben der Funktion LÄNGE die Funktion SUMME, z. B. =SUMME((LÄNGE(Zelle1);LÄNGE(Zelle2);(LÄNGE(Zelle3)))). In diesem Beispiel zählen Sie mit der Funktion LÄNGE die Zeichen in den einzelnen Zellen und addieren die Werte mit der Funktion SUMME.

  • Wenn Sie bestimmte, spezielle Zeichen in Zellen zählen möchten, verwenden Sie die Funktion LÄNGE in Verbindung mit der Funktion WECHSELN. Wenn Sie beispielsweise wissen möchten, wie viele kleingeschriebenen Zs sich in einer Zelle befinden, verwenden Sie die folgende Formel: =LÄNGE(Zelle1)-LÄNGE(WECHSELN(Zelle1;"z";"")).

Kleiner Test gefällig?

Geben Sie die folgenden Daten in ein neues Excel-Arbeitsblatt ein. Beginnen Sie in Zelle A1.

Textzeichenfolgen

Formeln

Franz jagte

Franz jagte im komplett verwahrlosten Taxi

Franz jagte im komplett verwahrlosten Taxi quer durch Bayern.

Zählen von Zeichen in einer Zelle

  1. Klicken Sie auf Zelle B2.

  2. Geben Sie in der Zelle =LÄNGE(A2) ein, und drücken Sie die EINGABETASTE.

Mit der Formel werden die Zeichen in Zelle A2 gezählt. Der Wert 19 enthält auch alle Leerzeichen. Sind nach dem Punkt am Satzende noch Leerzeichen vorhanden, werden mit der Formel auch diese gezählt.

Zählen von Zeichen in mehreren Zellen

  1. Drücken Sie CTRL+C, um die Zelle B2 zu kopieren.

  2. Drücken Sie CTRL+V, um die Formel in die Zellen B3:B4 einzufügen.

Auf diese Weise wird die Formel in die Zellen B3 und B4 kopiert, und die Zeichen in jeder Zelle werden gezählt (26 und 44).

Zählen einer Gesamtanzahl von Zeichen

  1. Klicken Sie auf Zelle B6.

  2. Geben Sie in der Zelle =SUMME(LÄNGE(A2);LÄNGE(A3);LÄNGE(A4)) ein, und drücken Sie die EINGABETASTE.

Hiermit werden die Zeichen in allen drei Zellen gezählt und addiert (89).

Zählen von bestimmten spezifischen Zeichen in Zellen

  1. Klicken Sie auf die Zelle C4.

  2. Geben Sie in die Zelle =LÄNGE(A4)-LÄNGE(WECHSELN(A4;"z";"")) ein, und drücken Sie die EINGABETASTE.

Kurz gesagt, diese Formel zählt alle kleingeschriebenen Zs in Zelle A4. Das Ergebnis ist 1.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×