Zählen von Zeichen in Zellen

Zum Zählen von Zeichen in Zellen verwenden Sie die Funktion LÄNGE. Mit dieser Funktion können Sie Buchstaben, Zahlen, Zeichen und alle Leerzeichen zählen. Der Text "Heute ist es 32 Grad warm, und deshalb gehe ich schwimmen." enthält (ohne die Anführungszeichen) 58 Zeichen: 44 Buchstaben, zwei Zahlen, zehn Leerzeichen, ein Komma und einen Punkt.

  • Wenn Sie diese Funktion verwenden möchten, geben Sie =LÄNGE(Zelle) in die Bearbeitungsleiste ein, und drücken Sie die EINGABETASTE. In den folgenden Beispielen gibt Zelle die Zelle an, deren Inhalt Sie zählen möchten (beispielsweise B1).

  • Wenn Sie die Zeichen in mehreren Zellen zählen möchten, geben Sie die Formel ein, und ziehen Sie dann das Ausfüllkästchen nach unten oder seitlich über den gewünschten Zellbereich.

Mehrmaliges Eingeben der Funktion LÄNGE in einem Arbeitsblatt

  • Wenn Sie die Gesamtanzahl an Zeichen in mehreren Zellen ermitteln möchten, verwenden Sie die Funktion SUMME. Beispiel: =SUMME((LÄNGE(Zelle1);LÄNGE(Zelle2);(LÄNGE(Zelle3)))). In diesem Beispiel zählen Sie mit der Funktion LÄNGE die Zeichen in den einzelnen Zellen und addieren die Werte mit der Funktion SUMME.

Probieren Sie es aus.

Verwenden Sie die Beispiele in der folgenden Arbeitsmappe, um die Verwendung der Funktion LÄNGE kennenzulernen.

Kopieren Sie die folgende Tabelle, und fügen Sie sie in Zelle A1 eines Excel-Arbeitsblatts ein. Ziehen Sie die Formel aus B2 in B3:B4, um die Länge des Texts in den Zellen in Spalte A anzuzeigen.

Textzeichenfolgen

Formeln

Franz jagte

=LÄNGE(A2)

Franz jagte im komplett verwahrlosten Taxi

Franz jagte im komplett verwahrlosten Taxi quer durch Bayern.

Zählen von Zeichen in einer Zelle

  1. Klicken Sie in Tabelle1 dieser Beispielarbeitsmappe auf die Zelle B2.

  2. Geben Sie in der Zelle =LÄNGE(A2) ein, und drücken Sie die EINGABETASTE.

Mit der Formel werden die Zeichen in Zelle A1 gezählt. Der Wert 61 enthält auch alle Leerzeichen. Sind nach dem Punkt am Satzende noch Leerzeichen vorhanden, werden mit der Formel auch diese gezählt.

Zählen von Zeichen in mehreren Zellen

  1. Klicken Sie in der Beispielarbeitsmappe auf die Zelle B2.

  2. Geben Sie in der Zelle =LÄNGE(A2) ein.

  3. Drücken Sie STRG+C, um Zelle B2 zu kopieren, und drücken Sie STRG+V, um die Formel in die Zellen B3:B4 einzufügen.

Auf diese Weise wird die Formel in die Zellen B3 und B4 kopiert, und die Zeichen in jeder Zelle werden gezählt (11, 42 und 61).

Zählen einer Gesamtsumme von Zeichen

  1. Klicken Sie in der Beispielarbeitsmappe auf die Zelle B6.

  2. Geben Sie in der Zelle =SUMME(LÄNGE(A2);LÄNGE(A3);LÄNGE(A4)) ein, und drücken Sie die EINGABETASTE.

Hiermit werden die Zeichen in allen drei Zellen gezählt und addiert (114).

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×